Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 11/08/2007, à 22:24

BigAce

Re : installation logiciel compta libre phpcompta pas à pas

mise à jour du tuto vers postgesql-8.2

Dernière modification par BigAce (Le 11/08/2007, à 22:25)

Hors ligne

#27 Le 18/08/2007, à 08:32

cindrivani

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour, et bravo pour ce tuto !

Ceci étant dit, comme je peine un peu en informatique, je ne suis pas encore sorti d'affaire :
Lorsque je suis arrivé à l'étape sudo psql -U postgres -d template1psql -U postgres -d template1
J'ai comme résultat :
psql: could not connect to server: Aucun fichier ou répertoire de ce type
        Is the server running locally and accepting
        connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

Le serveur is running, mais pour le reste je ne sais pas comment lui faire accepter les connexions sur le port 5432...

Si quelqu'un pouvait m'aider, ce serait sympa, d'avance merci.

Hors ligne

#28 Le 27/08/2007, à 09:45

BigAce

Re : installation logiciel compta libre phpcompta pas à pas

Hello cindrivani
Avant toute chose, as-tu essayé de tout désinstaller (avec purge, voir méthode décrite) et de tout recommencer ?

Hors ligne

#29 Le 29/08/2007, à 16:57

Feral

Re : installation logiciel compta libre phpcompta pas à pas

Merci beaucoup pour ce tuto!

Je rencontre 2 problèmes:

1-http://localhost/phpcompta/html/admin/setup.php me donne:
(Il semblerait qu'il utilise une base de donnée Template1??)

Info
Vous utilisez le domaine
Php setting
magic_quotes_gpc: Ok
magic_quotes_runtime: Ok
include_path : ok (.:../include:addon)

php.ini est bien configuré
Vos paramètres sont incorrectes :

base de donnée : template1
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

2-Mon http://localhost/ switch automatiquement sur http://localhost/index.php
Et me donne "Not Found"

Ceci est du au fait que je n'ai pas modifié le fichier
"/etc/apache2/sites-available/default" car j'ai besoin d'avoir accès à mes autres sites PHP/MySQL à l'adresse:  http://localhost/ et pas seulement à phpcompta.

Et c'est cassé! SNIF!!
Je suis trop mauvais, je n'arrive pas à réparer!
Une idée SVP????

Merci beaucoup!


ACER 4101WLMi - Centrino - 1.6GHz - 400FSB. Note: 9/10
VAIO VGN-S1XP - Centrino - 1.7GHz - 400FSB. Note: 7/10
VAIO PCG-TR2 - ULV Pentium M - 1GHz - 400FSB. Note: 9/10

Hors ligne

#30 Le 29/08/2007, à 18:20

Feral

Re : installation logiciel compta libre phpcompta pas à pas

Autre petit problème:
Les identification login/mdp ne marchent plus pour SugerCRM/VtigerCRM????
Imossible de les utiliser anymore!

Là je suis un peu perdu???
Qu'est-ce que ces 2 là ont à voir avec les manips de l'install de PHPcompta???
C'est moi qui deviens encore plus bête ou y-a-t-il une explication??

Si quelqu'un a des idées, je suis vraiment dans le flou!
=============
Voilà, ça remarche après avoir bidouiller les modifs de php.ini... je pige pas grand chose... :-(

Dernière modification par Feral (Le 29/08/2007, à 19:08)


ACER 4101WLMi - Centrino - 1.6GHz - 400FSB. Note: 9/10
VAIO VGN-S1XP - Centrino - 1.7GHz - 400FSB. Note: 7/10
VAIO PCG-TR2 - ULV Pentium M - 1GHz - 400FSB. Note: 9/10

Hors ligne

#31 Le 31/08/2007, à 10:00

BigAce

Re : installation logiciel compta libre phpcompta pas à pas

-> Feral
Content que cela remarche.:cool:
Si tu calles trop, tu peux choisir de poster tes questions sur le forum de phpcompta. C'est efficace pour les questions "subtiles".
wink

Hors ligne

#32 Le 01/10/2007, à 01:21

arnoxz

Re : installation logiciel compta libre phpcompta pas à pas

apparement j'ai un probleme similaire lors du login et de l'action admin/setup.php

Vos paramètres sont incorrectes :

base de donnée : account_repository
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

Info
Vous utilisez le domaine
Php setting
magic_quotes_gpc: Ok
magic_quotes_runtime: Ok
include_path : ok (.:../include:addon)

php.ini est bien configuré
Vos paramètres sont incorrectes :

base de donnée : template1
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

--dois-je changer (port) au niveau de apache ou est-ce un probleme directement lie a la DB, quelqu'un peut aider merci ?

Hors ligne

#33 Le 01/10/2007, à 09:38

BigAce

Re : installation logiciel compta libre phpcompta pas à pas

:)Hello !
Disons, dans un premier temps, que la première voie d'amélioration consiste à tout désinstaller avec purge (insistons sur "tout" et "avec purge") et de reprendre toute l'installation depuis le début, sans ommettre les patchs éventuels pouvant exister depuis la version de qui est installée.

Hors ligne

#34 Le 01/10/2007, à 10:29

arnoxz

Re : installation logiciel compta libre phpcompta pas à pas

arnoxz a écrit :

apparement j'ai un probleme similaire lors du login et de l'action admin/setup.php

Vos paramètres sont incorrectes :

base de donnée : account_repository
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

Info
Vous utilisez le domaine
Php setting
magic_quotes_gpc: Ok
magic_quotes_runtime: Ok
include_path : ok (.:../include:addon)

php.ini est bien configuré
Vos paramètres sont incorrectes :

base de donnée : template1
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

--dois-je changer (port) au niveau de apache ou est-ce un probleme directement lie a la DB, quelqu'un peut aider merci ?

Bon enfait il faut decortiquer la doc officielle, la methode expliquee ci-avant est un bon devut mais est incomplete (dans mon cas en tout cas)... voici apparemment cequ'il faut faire pour eviter l'erreur de "connection impossible" !

  Il est impératif que dans le fichier postmaster.conf vous ayez les
  options

  tcpip_socket = true
  port=5432

pas encore teste, j'essaierai ce soir

Hors ligne

#35 Le 02/11/2007, à 22:25

zozoletube

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour, bravo et merci pour ce tuto BigAce !

Je dois avoir presque tout bien fait sauf que à la fin lors du 5.6    Mise à jour et Installation de Phpcompta j'ai le message suivant :

Info
Vous utilisez le domaine
Php setting
magic_quotes_gpc: Ok
magic_quotes_runtime: Ok
include_path : ok (.:../include:addon)

php.ini est bien configuré
Vos paramètres sont incorrectes :

base de donnée : template1
Port 5432
Utilisateur : phpcompta
Connection impossible : vérifiez vos paramètres de base de données

J'ai beau chercher mais comme je dédute sous ubuntu (et linux) je comprends pas tout.
Es-tu en mesuer de m'éclairer un peu ?

Merci

#36 Le 03/11/2007, à 13:10

sparky

Re : installation logiciel compta libre phpcompta pas à pas

Apparemment il n'arrive pas à se connecter à postgresql
Donc
* vérifier que postgresql fonctionne
   psql -U phpcompta -l  (avec le mot de passe que vous avez donné lors de la création de cet utilisateur)
* si cela fonctionne, alors le problème provient du fichier postgresql.conf

Dernière modification par sparky (Le 03/11/2007, à 13:11)

Hors ligne

#37 Le 03/11/2007, à 20:31

patlas

Re : installation logiciel compta libre phpcompta pas à pas

salut,

la nouvelle version est sortie


  une belle présentation sur linuxfr.org :

   http://linuxfr.org/2007/11/03/23297.html


pc 3800 amd 64 1go ram : bubuntu
pc Dell précision 2600 512 mb  : Bubuntu
portable MSI VR600 64 : bubuntu et IBM T23 PIII : opengeu (e17)
tout en un BROTHER DCP-560-CN

Hors ligne

#38 Le 10/11/2007, à 14:52

JCDERCH1

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour,

Je viens d'installer PHPCOMPTA en suivante le tuto et aucun soucis.
Merci à  tous pour le soutien.

a moi de renseigne les données maintenant.

Bon courrage a tous

PS:  Phpcompta 3.0.0, PostGresSql 8.2, Ubuntu 7.10

Dernière modification par JCDERCH1 (Le 10/11/2007, à 14:53)


/dev/sda1 : windows XP (ntfs)
/dev/sda2 : mes documents (windows) (ntfs)
/dev/sdb1 : ubuntu 10.04 (ext4)
/dev/sdb2 : /home (ext3)

Hors ligne

#39 Le 10/11/2007, à 23:57

magicrincevent

Re : installation logiciel compta libre phpcompta pas à pas

merci pour ce tuto, mais il y a 2 erreurs :
dans l'optimisation de postresql, ce n'est pas work_meN, mais work_meM

la dernière instruction pour supprimer le repertoire admin est... étrange, je ferais plutà´t un rm -Rf sur le répertoire, nan? wink

une autre précision : le lien phppgadmin ne semble pas être au bon endroit, mais la suppression du lien symbolique ne dérange pas la bonne marche de l'installation.

Je n'ai pas vu de contre-indication dans l'install qui me permettrait pas d'installer avec un mdp autre que super_mdp_2007. y'a-t-il des choses que je ne sais pas? (un fichier de base de donnée avec toutes les bases de données et ce mdp là  dedans)
Est-ce possible de le changer d'une façon ou d'un autre à  la fin de l'install?

Amicalement

#40 Le 13/11/2007, à 13:34

sparky

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour pour changer le mot de postgres après l'install (ou avant) il suffit de faire

sudo su - postgres
psql template1 -c "alter user postgres password='autre_mot_de_passe'"

Avant de changer  la sécurité de postgresql (le pg_hba.conf) il fallait donner un mot de passe à  postgres (le super user) c'est tout. PhpCompta exigeait cette sécurité, mais votre postgresql est plus sécurisé après :-)

L'utilisateur phpcompta pour postgresql, se définit dans include/constant.php.

define ("phpcompta_password","dany");
define ("phpcompta_psql_port","5432");
define ("phpcompta_user","phpcompta");

Pour changer le mot de passe de phpcompta pour la base de donnée pas pour l'application

sudo su - postgres
psql template1 -c "alter user phpcompta password='autre_mot_de_passe'"

Et changer phpcompta_password dans le fichier include/constant.php, pensez à  mettre ce fichier  en mode 600, owner www-data ( si www-data est l'utilisateur sous lequel fonctionne apache)

Pour mémoire : phpcompta est bien 3 choses différentes
* une application pour la compta
* un utilisateur de l'application
* un utilisateur de postgresql
Le mot de passe "utilisateur de postgresql" n'est utilisé que pour se connecter à  la base de donnée et ne change pas le mot de passe "utilisateur de l'application" ce sont 2 choses différentes, et d'ailleurs dans les prochaines version on va changer "l'utilisateur de l'application" par compta_admin, comptable ou admin si personne ne vote contre.

Dernière modification par sparky (Le 13/11/2007, à 13:49)

Hors ligne

#41 Le 22/11/2007, à 00:02

sparky

Re : installation logiciel compta libre phpcompta pas à pas

Aaha big_smile:D:D tu vas rire : pour installer sous ubuntu en quelques étapes c'était là 
http://www.phpcompta.org/pmwiki.php/Documentation/InstallationRapide

Pour moi, cela a suffit.

Pour te répondre =
1. Pour le backup de la db, c'est avec pg_dump
2. Pour restaurer c'est pg_restore
3. Pour remettre à  zéro, là  je me demande ce que tu veux faire
4. Pour déplacer ta compta sur une autre machine, la nouvelle machine a phpcompta installé, Dans phpcompta : créer dossier, prendre le numéro de dossier (exemple 13) puis dropdb dossier13 puis après avoir restauré le backup (exemple dossier12) faire en tant que postgres psql -c 'alter database dossier12 rename to dossier13'

Enfin c'est l'idée

Hors ligne

#42 Le 09/12/2007, à 01:13

jackx

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour,
J'ai suivi (peut etre pas bien ;-) les etapes de la doc.
Tout fonctionnait jusqu'a l'install de phpcompta. J'ai bien la page d'info. Mais, lorsque je clique sur le bouton "Pret a commencer la mise a jour ou l'installation ? ", :
1/ j'ai le message :

Warning: pg_query() [function.pg-query]: Query failed: ERROR: relation "version" does not exist in /var/www/phpcompta/include/postgres.php on line 136

Fatal error: Uncaught exception 'Exception' with message 'SQL ERROR ::: select val from version' in /var/www/phpcompta/include/postgres.php:138 Stack trace: #0 /var/www/phpcompta/html/admin/setup.php(84): ExecSql(Resource id #20, 'select val from...') #1 /var/www/phpcompta/html/admin/setup.php(173): GetVersion(Resource id #20) #2 /var/www/phpcompta/html/admin/setup.php(477): apply_patch(Resource id #20, '(BE) Basique') #3 {main} thrown in /var/www/phpcompta/include/postgres.php on line 138

2/ lorsque je veux aller dans phppgadmin/ , j'ai le message :

Not Found
The requested URL /phppgadmin/ was not found on this server.

Je vais recommencer l'install, mais pour comprendre, quelqu'au aurait une idee d'ou ca vient ?

Nota: patch http://www.phpcompta.org/download/patch-3.0.4.zip installe

Merci d'avance.
Jackx

Hors ligne

#43 Le 10/12/2007, à 02:34

jackx

Re : installation logiciel compta libre phpcompta pas à pas

Bonsoir,
apres avoir tout reinstalle, juste apres avoir clique sur "Pret a commencer la mise à jour ou l'installation ?, j'ai des messages d'erreur .

Config ubuntu 6.06
phpcompta-3.0.1.tgz
patch-3.0.4.zip


Ci-dessous le debut des messages puis la fin :

#####debut du message :

Info
Vous utilisez le domaine
Php setting
magic_quotes_gpc: Ok
magic_quotes_runtime: Ok
include_path : ok (.:../include:addon)

php.ini est bien configuré
Database version
string(6) "8.1.10"
Database Setting

La base de données est bien configurée
Creation of account_repositoryCreation of Modele1
SET client_encoding = 'LATIN1';
SET check_function_bodies = false;
SET client_min_messages = warning;

SET search_path = public, pg_catalog;

CREATE DOMAIN poste_comptable AS numeric(25,0);

CREATE FUNCTION account_add(p_id poste_comptable, p_name character varying) RETURNS void


#####fin du message (je passe le milieu)

COMMENT ON TABLE action_gestion IS 'Action for Managing';



CREATE SEQUENCE action_gestion_ag_id_seq
START WITH 1
INCREMENT BY 1
NO MAXVALUE
NO MINVALUE
CACHE 1;



ALTER SEQUENCE action_gestion_ag_id_seq OWNED BY action_gestion.ag_id;

Warning: pg_query() [function.pg-query]: Query failed: ERROR: syntax error at or near "OWNED" at character 44 in /var/www/phpcompta/include/postgres.php on line 136

Fatal error: Uncaught exception 'Exception' with message 'SQL ERROR ::: ALTER SEQUENCE action_gestion_ag_id_seq OWNED BY action_gestion.ag_id ' in /var/www/phpcompta/include/postgres.php:138 Stack trace: #0 /var/www/phpcompta/html/admin/setup.php(148): ExecSql(Resource id #99, '???ALTER SEQUEN...', false) #1 /var/www/phpcompta/html/admin/setup.php(415): ExecuteScript(Resource id #99, 'sql/mod1/schema...') #2 {main} thrown in /var/www/phpcompta/include/postgres.php on line 138


############



La seule modif par rapport a la doc est dans la partie 5.2 et 5.3 (teléchargement) ou j'ai fait (car je suis en ligne de commande uniquement) :

>> cd /home/alpha
>> mkdir Desktop
>> cd Desktop
>> wget http://www.phpcompta.org/download/phpcompta-3.0.1.tgz
>> tar -xvzf phpcompta-3.0.1.tgz
>> rm phpcompta-3.0.1.tgz
>> cp -Rf /home/alpha/Desktop/phpcompta /var/www/
>> wget http://www.phpcompta.org/download/patch-3.0.4.zip
>> apt-get install unzip
>> unzip patch-3.0.4.zip
>> cp -Rf /home/alpha/Desktop/html /var/www/phpcompta/
>> cp -Rf /home/alpha/Desktop/include /var/www/phpcompta/
>> rm -rf *


Je suis un peu perdu. Quelqu'un aurait une idee ??
Jack

Hors ligne

#44 Le 10/12/2007, à 10:36

BigAce

Re : installation logiciel compta libre phpcompta pas à pas

2 premières pistes :
1/ quand tu as ré-installé, as-tu tout désinstallé au préalable (en ligne de commande avec l'option --purge + rm du dossier /var/www/phpcompta) ou bien as-tu réinstallé sans désinstaller ? (n'oublies pas de supprimer tous les paquets commençant par apache2 -> remove --purge apache2*)
2/ tu peux aussi tenter une désinstallation complète avec purge et destruction du dossier phpcompta, puis une ré-installation version tuto avec phppgadmin ou une installation rapide comme indiqué ici

dis nous si ça baigne

Hors ligne

#45 Le 10/12/2007, à 11:02

jackx

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour,
Merci de ta reponse.

- J'ai reinstalle le serveur complet version 6.06 (formatage des disques, etc.) avec version tuto avec phppgadmin

- Maintenant que je vois la version rapide, je me dis que c'est peut etre par la qu'il faut faire et pas par le tuto ??

Et donc toujours au meme point... Ca baigne pas ...

Jack

Dernière modification par jackx (Le 10/12/2007, à 15:50)

Hors ligne

#46 Le 17/03/2008, à 16:13

Pierro1er

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour,

J'ai eu exactement le même problème que notre ami jackx avec phpcompta-3.0.1 mais sous debian. En fait il y a un bug dans l'exécution du script de création des bases de données.

Il vaut mieux récupérer les sources sur le site Belge, à ce jour c'est la version 4.0 .

C'est très simple à installer et ça marche au top!

Donc bravo et un énorme MERCI au développeurs de phpcompta. Cela sauve la vie d'un jeune créateur d'entreprise assez pauvre qui ne connaît fichtre rien à la comptabilité et qui ne souhaite en apprendre que le minium légal. Sur ce thème, si quelqu'un connaît des bonnes références de sites ou de livres je suis preneur. Il me faudrait un exemple pratique comme: si tu achète un ordinateur pour ton entreprise tu met XXXeuros dans le compte YYY, ... , ... . Un genre de scénario à difficulté croissante qui me ferait resentir les concepts de la comptabilité courante! (j'écluse de la théorie pathétique et à chaque nouveau concept que je comprends je suis dépité: quinze page de galère là où une simple phrase aurait suffi pour faire comprendre! Sympa l'esprit comptable!!!!!!)


En tout cas merci pour pour le tuto. Je donne toutefois des points qui de mon avis peuvent êtres simplifiés (-) ou complémentés (+) :

(-) Il n'est pas necessaire et je déconseille de modifier le php.ini pour des raisons de sécurités. Un fichier nommé "phpcompta/html/.htaccess" se charge de régler tous les paramètres (merci apache!), y ajouter éventuellement cette ligne:

php_value session.use_trans_sid true

(+) Avant de faire quoi que ce soit il est nécessaire de modifier le login et mot de passe "génériques" qu'utilisera phpcompta pour se connecter au serveur PostGresSQL. C'est dans le fichier /phpcompta/constant.php:

AVANT
define ("phpcompta_password","dany");
define ("phpcompta_psql_port","5432");
define ("phpcompta_user","phpcompta");

APRÈS
define ("phpcompta_password","Put@in_De_Passsssssword_Compliqu&_Non??");
define ("phpcompta_psql_port","5432");
define ("phpcompta_user","TuNeLeSauraPas!");

(+) Puis activer l'encryptage automatique des mots de passe de postgres, c'est plus propre!
Maintenant vous pouvez créer vos utilisateurs de PostGresSQL. N'oubliez pas qu'à la place de l'utilisateur "phpcompta" c'est désormais c'est "TuNeLeSauraPas!" !

(-) Il n'est pas nécessaire de créer une base de données phpcompta.

PS Dans mon cas le script SQL à bugé un peu avant la fin! J'ai fermé la cession* puis renvoyé un "près à commencé...". Réglé, terminé, on va fêté l'évènement.

*fermeture de tous les explorateurs internet


Bonne chance à tous.

#47 Le 26/03/2008, à 12:12

Adra

Re : installation logiciel compta libre phpcompta pas à pas

Bonjour à tous!

Un grand merci pour ce tuto  smile

Installation sans le moindre problème

phpcompta 4.0 + patch 4.0.1 sur Ubuntu 7.10

Y'a plus qu'à apprendre à se servir du logiciel, maintenant... wink

Hors ligne

#48 Le 10/04/2008, à 15:21

sparky

Re : installation logiciel compta libre phpcompta pas à pas

Au fait, il y a du nouveau
* le patch 4.0.2 est là, il suffit de le décompresser dans le répertoire de phpcompta et remplacer les fichiers puis aller sur http://votre_server/votre_phpcompta_html/admin/setup.php
* on peut déjà voir la version en cours de développement sur https://phpcompta.be/prochaine_version il y a même des forums pour en parler wink (ah oui utilisateur/mot de passe : phpcompta/phpcompta)

Hors ligne

#49 Le 17/04/2008, à 11:12

micheld

Re : installation logiciel compta libre phpcompta pas à pas

Avec Gutsy, la version par défaut de Postgres est maintenant la 8.3, qui est configurée en UTF-8. Ceci pose un problème lors de la création initiale de la base par le script admin/setup.php qui veut, lui, du LATIN1.

Voici la procédure que j'ai employée pour forcer postgres en latin1 (j'aurais peut-être pu aussi forcer l'installation d'une 8.2). NB : j'ai aussi tenté latin9 (iso-8859-15) mais ça ne marche pas.

D'abord, il faut créer la "locale" latin1 (iso-8859-1) dans ubuntu :

sudo locale-gen fr_FR

Ensuite on stoppe le serveur et on passe sous l'utilisateur postgres. Et comme je suis prudent, je fais une sauvegarde de l'ancienne base :

sudo /etc/init.d/postgresql-8.3 stop
sudo -u postgres -i
cd /var/lib/postgresql/8.3
mv main main.utf-8

On crée un nouveau cluster LATIN1 :

/usr/lib/postgresql/8.3/bin/initdb -D /var/lib/postgresql/8.3/main --locale=fr_FR

On met à jour les derniers éléments de config :

# Dans postgresql.conf, j'ai retiré utf-8 des variables LC
# Peut-être pas utile...
vi /etc/postgresql/8.3/main/postgresql.conf 
cp -a main.utf-8/root.crt main.utf-8/server.* main

On peut enfin quitter le compte postgres et relancer la base.

exit
sudo /etc/init.d/postgresql-8.3 start

On peut alors reprendre les conseils du tutoriel.

Hors ligne

#50 Le 17/04/2008, à 12:56

sparky

Re : installation logiciel compta libre phpcompta pas à pas

Juste pour dire, la prochaine version de phpcompta sera complètement en Unicode, et en fait, j'ai fait pas mal de test avec Postgresql 8.3 et voici les problèmes que j'ai eu.

select upper ('ééé')

Fonctionne mal...

Hors ligne

Haut de page ↑