Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 13/06/2013, à 10:44

microbulle

Depuis la mise à jour de X-Org

Bonjour,

Depuis la mise à jour de X-Org, j'ai des souci au démarrage. Mes deux cartes graphique GTX580 ne sont plus reconnu.

Pour démarrer il faut que je passe par le mode de dépannage puis démarrage normal.

J'aimerais savoir comment retouner à la précédente version et / ou les améliorations nécessaire pour faire un démarrage normal.

Pour info, voila ce que me retourne le log:
http://www.pasteall.org/43090/text

Dans l'état actuel de mes connaissances, voila quelques screens de la configuration:
http://www.pasteall.org/pic/53454
http://www.pasteall.org/pic/53455

Merci pour votre aide.

Dernière modification par microbulle (Le 13/06/2013, à 10:56)

Hors ligne

#2 Le 13/06/2013, à 15:30

microbulle

Re : Depuis la mise à jour de X-Org

Voila ce qui se passe au démarrage sad

mini_130613033314725054.jpg

Puis :

mini_130613033346504541.jpg

Sur la seconde fenêtre... Pas de souris... Pas de clavier ! Obliger de rebooter ! Sur windows RAS. Donc c'est bien un souci avec Linux sad

Merci de votre aide.

Hors ligne

#3 Le 13/06/2013, à 15:36

Spitfire 95

Re : Depuis la mise à jour de X-Org

Ctrl+Alt+F1
Connectes toi au TTY (avec le même nom d'utilisateur et mot de passe que pour ta session graphique, le pass ne s'affichera pas quand tu le tapera, c'est normal).
Puis fais

sudo dpkg-reconfigure -phigh xserver-xorg-core

Mot de passe encore une fois, qui ne s'affichera toujours pas.
Puis

sudo reboot

Et dis nous ce qu'il en est ensuite.


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#4 Le 13/06/2013, à 15:51

microbulle

Re : Depuis la mise à jour de X-Org

Bon et bien... Il ne se passe... RIEN !
Quand je tape ta ligne de commande, le pc gratte pas, aucun message, on passe de nouveau à l'invite de commande.

Au reboot, même message d'erreur, même souci pour naviguer dans le menu de l'image 2.

Par contre RAS sur la version au header précédent. Mais bon, j'aimerais quand même comprendre ce qui passe.

Hors ligne

#5 Le 13/06/2013, à 17:11

microbulle

Re : Depuis la mise à jour de X-Org

Des questions peut-être bête.

Le TTY, on l'obtiens bien une foisq ue l'on a pu démarrer le PC sous Gnome ? Non ? Ou alors c'est dans une autre phase bien avant d'accéder à la page d'accueil ? Genre une fois que le grub est lancer ?

Est-ce que l'on peut faire la manip directement dans la console ?

Merci.

Hors ligne

#6 Le 13/06/2013, à 17:26

Spitfire 95

Re : Depuis la mise à jour de X-Org

Les TTYs sont les terminaux plein écran, et ils nécessitent pas d'environnement graphique.
Ils sont accessibles après l'écran plymouth (le logo Ubuntu et les points sur fond violet sur Ubuntu, le F de Fedora qui se rempli sous fedora...) je crois.
On va commencer avec les questions moins drole car pas de copier coller wink
Que retourne

sudo dpkg -l |grep -e xserver -e nvidia

Contente toi du nom des paquets pas des ii et des descriptions. Je sais pas si je suis clair, mais n'étant pas sous Ubuntu je peux pas te dire comment filtrer les colonnes à afficher, au risque d'afficher la mauvaise.


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#7 Le 13/06/2013, à 17:31

microbulle

Re : Depuis la mise à jour de X-Org

Ok, à priori j'arrive à avoir des infos sans TTY. Mais je note la manip smile

geeks@PC-Geeks-Graphisme:~$ sudo dpkg -l | grep -e xserver -e nvidia
[sudo] password for geeks: 
ii  nvidia-common                                               1:0.2.44.2                                           Find obsolete NVIDIA drivers
ii  nvidia-current                                              304.88-0ubuntu0.0.2                                  NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-settings                                             304.88-0ubuntu0.0.2                                  Tool of configuring the NVIDIA graphics driver
ii  x11-xserver-utils                                           7.6+3                                                X server utilities
ii  xserver-common                                              2:1.11.4-0ubuntu10.13                                common files used by various X servers
ii  xserver-xorg                                                1:7.6+12ubuntu2                                      X.Org X server
ii  xserver-xorg-core                                           2:1.11.4-0ubuntu10.13                                Xorg X server - core server
ii  xserver-xorg-input-all                                      1:7.6+12ubuntu2                                      X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev                                    1:2.7.0-0ubuntu1.2                                   X.Org X server -- evdev input driver
ii  xserver-xorg-input-mouse                                    1:1.7.1-1build3                                      X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics                                1.6.2-1ubuntu1~precise2                              Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-vmmouse                                  1:12.9.0-0ubuntu0.1                                  X.Org X server -- VMMouse input driver to use with VMWare
ii  xserver-xorg-input-wacom                                    1:0.14.0-0ubuntu2.1                                  X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all                                      1:7.6+12ubuntu2                                      X.Org X server -- output driver metapackage
ii  xserver-xorg-video-ati                                      1:6.99.99~git20120913.8637f772-0ubuntu1~precise~xup2 X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-cirrus                                   1:1.3.2-4build1                                      X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev                                    1:0.4.2-4ubuntu2                                     X.Org X server -- fbdev display driver
ii  xserver-xorg-video-intel                                    2:2.19.0-0ubuntu1~xup1                               X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64                                   6.9.0-1build2                                        X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga                                      1:1.4.13.dfsg-4build2                                X.Org X server -- MGA display driver
ii  xserver-xorg-video-neomagic                                 1:1.2.5-2build2                                      X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau                                  1:1.0.2-0ubuntu3~precise~xup2                        X.Org X server -- Nouveau display driver
ii  xserver-xorg-video-openchrome                               1:0.2.904+svn1050-1ubuntu0.1                         X.Org X server -- VIA display driver
ii  xserver-xorg-video-qxl                                      0.0.16-2ubuntu0.1                                    X.Org X server -- QXL display driver
ii  xserver-xorg-video-r128                                     6.8.1-5build2                                        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                                   1:6.99.99~git20120913.8637f772-0ubuntu1~precise~xup2 X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-s3                                       1:0.6.3-4build2                                      X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-savage                                   1:2.3.3-1ubuntu1                                     X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion                            1:1.7.5-1build2                                      X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis                                      1:0.10.3-3build2                                     X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb                                   1:0.9.4-2build2                                      X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx                                     1:1.4.3-4build2                                      X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident                                  1:1.3.4-2build2                                      X.Org X server -- Trident display driver
ii  xserver-xorg-video-vesa                                     1:2.3.0-7build2                                      X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                                   1:12.0.1-1ubuntu1.1                                  X.Org X server -- VMware display driver

Enfin voila. Je sait maintenant ce qu'est le TTY smile

Remarque je peux refaire au démarrage + plantage.

Merci beaucoup.

Dernière modification par microbulle (Le 13/06/2013, à 17:33)

Hors ligne

#8 Le 13/06/2013, à 18:46

Spitfire 95

Re : Depuis la mise à jour de X-Org

Si tu as une session graphique c'est parfait. Je suppose que tu n'as qu'une fenêtre étant xterm donc smile
À partir d'ici je vais supposer que tu es sous Ubuntu 13.04. Si tu es sous une version antérieure tu n'auras pas l'onglet dont je parle.
Lances

software-properties-gtk

Dans le dernier onglet de la fenêtre tu as les drivers. Regarde si le driver nvidia-304 est bien activé ou pas seulement installé.
S'il ne l'est pas, actives le (ou actives xserver-xorg-video-nouveau ou un autre des drivers privateurs nvidia).


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#9 Le 13/06/2013, à 20:02

microbulle

Re : Depuis la mise à jour de X-Org

Perdu !
Rien de tout ce d'ont tu m'a parlé n'est présent.

C'est peut-être par ce que je suis sous gnome !

M'enfin voila mes écran et onglets.
mini_130613080225280725.jpg

mini_130613080231432115.jpg

mini_130613080235326467.jpg

mini_130613080241312620.jpg

mini_130613080245690684.jpg

Je sait pas si ça peut aider !

Je pense que quand la panne survient, on lance pas les drivers ou que les cartes sont tout bonnement pas reconnu. J'avais jamais eu ce cas en 6 mois que j'ai faite cet installation.

Tu me dira, j'ai la possibilité de démarrer la version antérieur et d'attendre une ultime mise à jour. Mais c'est loin d'être la solution sécur' ni la solution fiable !

Hors ligne

#10 Le 13/06/2013, à 20:11

microbulle

Re : Depuis la mise à jour de X-Org

Oui pour infos :

geeks@PC-Geeks-Graphisme:~$ cat /etc/issue
Ubuntu 12.04.2 LTS \n \l

Donc oui, j'ai pas la version d'ont tu parle en fait !

Hors ligne

#11 Le 13/06/2013, à 20:17

Spitfire 95

Re : Depuis la mise à jour de X-Org

Dans ce cas la commande c'est

jockey-gtk

Et pas de chance pour toi jsais pas comment marche cette interface, ça fait des années que je m'en suis pas servi (depuis la 9.10 je crois).


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#12 Le 13/06/2013, à 20:22

microbulle

Re : Depuis la mise à jour de X-Org

Oh si ça ne tiens qu'à ça, je bascule en mode unity wink

Chu pas réfractère à cette interface, c'est juste que quand je bosse elle m'est totalement pas pratique en production.

Je regarde ton histoire de jockey smile
mini_130613082452248045.jpg

Bon, j'ai bien un drivers activé quand j'arrive à lancer depuis le mode réparation. Mais toujours bloqué dans le mode normal.

J'aurais bien envie de voir et de comparer entre les deux versions, via un cat les deux X-Org. Celui de l'ancien qui marche et l'autre....

Hors ligne

#13 Le 13/06/2013, à 21:16

Spitfire 95

Re : Depuis la mise à jour de X-Org

sudo dpkg-reconfigure nvidia-current

On sait jamais... J'ai plus trop d'idées là. En général les dépannages du serveur X j'y arrive mais un peu part hasard ^^'


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#14 Le 14/06/2013, à 08:05

microbulle

Re : Depuis la mise à jour de X-Org

Hello !

Bon et bien, le mode désespoir de cause à fonctionné ! Je m'explique.

J'ai remarqué qu'au démarrage, c'est comme si:
1/ C'étais devenu lent
2/ On tournais dans le vide puis.
3/ Ecran d'érreur cité tout en haut !

Alors, je suis passé en mode dépannage, et j'ai tenté le DPKG. Pourquoi ?
Et bien par ce que je me suis mis à soupçonner que j'avais un mauvais basculement sur un vieux paquet non mis à jour avec X-ORG. Possible car l'autre jour la mise à jour ne c'est pas accompagné de d'autres mises à jours de paquets.

Résultat :
89 paquets obsolètes supprimés et aucune mise à jour dispo. Le DPKG à été rapide. Un reboot et !!!

Miracle, ça fonctionne de nouveau sans bug sur le header actuel. Le drivers est lancé car je peux switcher sur CUDA avec Blender ! Parfait, j'en demandais pas moins ! Mais je soupçonne autre chose à moyen terme, voir long terme. Et si ça faisait du coup d'autres problèmes cachés ? Alors, je passe en mode "je vais vérifier sur plusieurs jours" et si c'est stable, je concidèrerais que ça à résolu pour le coup la panne.

Néanmoins, je reste convaincu que cette opération est fiable mais pas facile d'accès. Pourquoi donc quand j'avais mes panneaux d'erreur, sur la seconde boite de dialogue je ne pouvais plus utiliser le clavier ? Même pas pour valider l'une des options ? Là c'est un mystère que j'aimerais bien que les développeur élucide. Non pas pour moi ! J'ai résolu mon souci. Mais bel est bien pour les autres users qui auront un jour le même souci que moi.

Voili, voilu, je retourne à mes moutons (en 3D).

Merci quand même de toute ton aide. Je garde le sujet sous le coude au cas ou.

Hors ligne

#15 Le 14/06/2013, à 09:11

microbulle

Re : Depuis la mise à jour de X-Org

Bon, je reviens avec des nouvelles sad
Elles ne sont pas bonne du tout !

Mise à jour du header ce matin vers la 3.2.0-48. Et re patatra... Même écran, même blocage.

Retour au dpkg et bingo ça fonctionne.

Si à chaque mise à jour il faut que je DPKG c'est qu'il y a un sérieux problème sur mon OS.

Bon ben on relance les investigations car c'est pas stable pour moi !

Merci de votre aide.

Hors ligne

#16 Le 14/06/2013, à 09:14

microbulle

Re : Depuis la mise à jour de X-Org

Bon, je viens de tenter le reconfigure:

geeks@PC-Geeks-Graphisme:~$ sudo dpkg-reconfigure nvidia-current
[sudo] password for geeks: 
Removing all DKMS Modules
Done.
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-current
DEBUG:Parsing /usr/share/nvidia-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/nvidia-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/nvidia-common/quirks/dell_latitude
DEBUG:Processing quirk ThinkPad T420s
DEBUG:Failure to match Gigabyte Technology Co., Ltd. with LENOVO
DEBUG:Quirk doesn't match
DEBUG:Processing quirk Latitude E6530
DEBUG:Failure to match Gigabyte Technology Co., Ltd. with Dell Inc.
DEBUG:Quirk doesn't match
Loading new nvidia-current-304.88 DKMS files...
Building only for 3.2.0-48-generic
Building for architecture x86_64
Building initial module for 3.2.0-48-generic
Done.

nvidia_current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-48-generic/updates/dkms/

depmod....

DKMS: install completed.
geeks@PC-Geeks-Graphisme:~$ 

Si ça éclaire un peu !

Là, je tente un reboot !

Hors ligne

#17 Le 14/06/2013, à 09:48

microbulle

Re : Depuis la mise à jour de X-Org

Une rapide recherche sur le net montre que je ne suis pas le seul à galérer sur cette carte:

La preuve... http://forum.ubuntu-fr.org/viewtopic.php?id=1015531

geeks@PC-Geeks-Graphisme:~$ lspci -v | grep -A 12 VGA
02:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 580] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Giga-byte Technology Device 350f
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
	Memory at d0000000 (64-bit, prefetchable) [size=128M]
	Memory at d8000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at fb000000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nvidia_current, nouveau, nvidiafb

02:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)
--
03:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 580] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Giga-byte Technology Device 350f
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f8000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=128M]
	Memory at c8000000 (64-bit, prefetchable) [size=32M]
	I/O ports at d000 [size=128]
	[virtual] Expansion ROM at f9000000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nvidia_current, nouveau, nvidiafb

03:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)
geeks@PC-Geeks-Graphisme:~$ 

Bon si je comprends ce que me retourne cette commande. Mes cartes sont bien driver. Mais pourquoi diable au démarrage j'ai ces soucis depuis 3 jours et avant non ?

Hors ligne

#18 Le 14/06/2013, à 17:09

microbulle

Re : Depuis la mise à jour de X-Org

Des fois que ça puisse aider :
http://www.pasteall.org/43145/text

Merci.

Hors ligne

#19 Le 14/06/2013, à 17:29

Spitfire 95

Re : Depuis la mise à jour de X-Org

Je ne comprend pas pourquoi à chaque mise à jour ça saute...
Enfin si çe remarche c'est déjà ça...


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#20 Le 14/06/2013, à 17:33

microbulle

Re : Depuis la mise à jour de X-Org

Oui, moi non plus je ne comprends pas pourquoi ça saute !

Donc en même temps, pour ma culture générale linuxienne. S'a fait la commande au dessus ?
geeks@PC-Geeks-Graphisme:~$ sudo dpkg-reconfigure nvidia-current

Par ce que je crois comprendre qu'avant il manquais un truc et qu'il en a reconstruit un...

Autre chose, on m'a parler de retirer le quiet du grub. J'ai pas su ce que c'étais j'y ai pas touché hein !

Hors ligne

#21 Le 14/06/2013, à 17:50

Spitfire 95

Re : Depuis la mise à jour de X-Org

Oui pourquoi pas, au démarrage quand je GRUB s'affiche (s'il ne s'affiche pas maintiens la touche Shift enfoncée une fois passé le BIOS et relâche quand le GRUB s'affiche, ou quand tu vois Plymouth s'il refuse de s'afficher ^^). Sur le choix par défaut appuis sur... euh... X je crois, enfin regarde c'est affiché en bas du GRUB, pour entrer en mode édition. Changes quiet splash en text (là ça va pas être gênant mais je précise quand même : tu vas être en qwerty). Après fais F10 pour valider et continuer de démarrer.
Avec ça tu verra tout ce qu'il se passe pendant la phase de boot, y compris les erreurs éventuelles.
Tu peux faire la manipulation sans risque, la manipulation n'est pas persistante et sera oubliée dès le prochain boot.

dpkg-reconfigure, comme son nom l'indique, reconfigure un paquet Debian (D=Debian PKG=Package wink) avec ses fichiers de configuration par défaut.

Dernière modification par Spitfire 95 (Le 14/06/2013, à 17:52)


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#22 Le 14/06/2013, à 18:00

microbulle

Re : Depuis la mise à jour de X-Org

Ok, maintenant je comprends !

Rah, suis fâché avec le qwerty ! Alors ça ne sera pas fait hein wink

Sinon, ben tant pis je tournerais comme ça et si ça me le refais, je passerais en mode débug pour prendre la main et refaire un nvidia-reconf enfin la manip d'en haut quoi smile

De toute façon, c'est pas gênant tant que ça explose pas le reste mais je reste attentif à un fix car bon je veux pas dire que ça m'embête mais j'ai pas envie de refaire une installation pour un truc que j'ai pas commis. Si je puis m'exprimé ainsi.

Maintenant, c'est sûr, il existe la solution de formater mais bon, ça sent le windadeuxballes. sad

Hors ligne

#23 Le 14/06/2013, à 18:15

Spitfire 95

Re : Depuis la mise à jour de X-Org

Autre solution mais celle ci permanente donc faudra la faire deux fois, une pour mettre ça, et une pour retirer ça :

sudo nano /etc/default/grub

Chercher quiet splash, remplacer par text
Ctrl+O, Entrée, Ctrl+X

sudo update-grub
sudo reboot

Même chose pour remettre le comportement précédent, mais manip inverse, changer text en quiet splash


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#24 Le 14/06/2013, à 18:17

microbulle

Re : Depuis la mise à jour de X-Org

Ok.

Bon, remarque j'utilise grub customizer vue que j'ai deux OS sur mon DD.

J'ai pas vue de mise à jour récente de celui-ci. Faudrais pas qu'il soit la source des ennuis actuels...

Hors ligne

#25 Le 14/06/2013, à 19:45

microbulle

Re : Depuis la mise à jour de X-Org

Tien, à propos de ce bug,

J'espère que les devs regarde le forum et qu'ils sont en train de corriger le bug.
De la même façon, si un pro d'ubuntu à un fix ou un corectif hein, qu'il n'hésite pas.
Idem pour la suite; je veux dire par là que si un patch est à appliquer, je suis preneur.

N'est il pas nécessaire, du coup de mettre à jour le drivers ?
Si oui, lequel prendre ? Quelle méthode pour retirer l'ancien proprement ? Est-ce que je ne vais pas me retrouver bloquer si je bascule d'un driver à un autre ? Autant de questions que je me pose finalement.

Hors ligne

Haut de page ↑