Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 15/07/2013, à 18:47

manu___

partage de connexion avec network manager

Bonjour,

J'ai essayé de partager ma connexion wifi avec network manager via deux cartes wifi : tp-link WN722N et la carte wifi intel N-2230 mais impossible...
Sous network manager je vais dans "sans fil" puis je sélectionne la connexion (en fait, une deux deux vu que les deux se connectent), je fais "modifier"..
Dans l'ongle ipv4 je coche 'partage de connexion" (je crois) dans ipv6 je mets ignorer...
Je renomme le nom du point d'accès..

Dans les icônes d'ubuntu en haut, je ne vois pas de point d'accès "hotspot", celui que j'ai créé.
J'ai deux menu, 1 par carte wifi..
Mais les points d'accès sont ceux donnés usuellement.

Je suis sous ubuntu studio 12.04 (ou 12.10)

Merci d'avance pour votre aide :-)

Hors ligne

#2 Le 16/07/2013, à 17:02

toutafai

Re : partage de connexion avec network manager

Salut

2 cartes connecté sur le meme réseaux ? si oui, et si tu n'as pas configuré le noyau pour utilisé les 2 conjointement, une seul n'est en réalité utilisée !
que dit un

route -n

Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 17/07/2013, à 12:05

manu___

Re : partage de connexion avec network manager

Bonjour,
Voici ce que me dit cette commande après avoir configuré le partage de connexion dans network manager sur la clé Tp-link.


Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
0.0.0.0         10.29.1.193     0.0.0.0         UG    0      0        0 wlan0
10.29.1.192     0.0.0.0         255.255.255.192 U     9      0        0 wlan1
10.29.1.192     0.0.0.0         255.255.255.192 U     9      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0


Merci

Hors ligne

#4 Le 17/07/2013, à 12:07

manu___

Re : partage de connexion avec network manager

Je précise que je passe déjà par un hotspot, dont le signal est faible mais que je souhaite diffuser dans mon lieu d'habitation !

Hors ligne

#5 Le 03/08/2013, à 16:53

manu___

Re : partage de connexion avec network manager

hmm ...

Hors ligne

#6 Le 03/08/2013, à 17:36

navtex

Re : partage de connexion avec network manager

salut
pour creer le hotspot ,il faut absolument que la carte soit dispo donc non connectée à un reseau.

indépendant de network-managerpour ceusse que ça interesse : un script que voici

Creer un hotspot

]-1------copier dans un terminal :

sudo apt-get install hostapd dnsmasq
sudo service hostapd stop
sudo service dnsmasq stop
sudo update-rc.d hostapd disable
sudo update-rc.d dnsmasq disable

2-------editer le fichier :

--------sudo gedit /etc/dnsmasq.conf
------et ajouter ces lignes:

# Bind to only one interface
bind-interfaces
# Choose interface for binding
interface=wlan0
# Specify range of IP addresses for DHCP leasses
dhcp-range=192.168.150.2,192.168.150.10

enregistrer et fermer

3------editer le fichier :

------sudo gedit /etc/hostapd.conf
-------et ajouter ces lignes:

# Define interface
interface=wlan0
# Select driver
driver=nl80211
# Set access point name
ssid=monhotspot
# Set access point harware mode to 802.11g
hw_mode=g
# Set WIFI channel (can be easily changed)
channel=6
# Enable WPA2 only (1 for WPA, 2 for WPA2, 3 for WPA + WPA2)
wpa=2
wpa_passphrase=mon motdepasse


#------personnaliser monhotspot et mon motdepasse
#------personnaliser wlan0 ou ,wlan1, wlan2 c'est ton hotspot

4--------creer un fichier vide  ,ou tu veux
--------qui s'appellera start.sh et copier dedans:

#!/bin/bash
# Start
# Configure IP address for WLAN
sudo ifconfig wlan0 192.168.150.1
# Start DHCP/DNS server
sudo service dnsmasq restart
# Enable routing
sudo sysctl net.ipv4.ip_forward=1
# Enable NAT
sudo iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
# Run access point daemon
sudo hostapd /etc/hostapd.conf
# Stop
# Disable NAT
sudo iptables -D POSTROUTING -t nat -o ppp0 -j MASQUERADE
# Disable routing
sudo sysctl net.ipv4.ip_forward=0
# Disable DHCP/DNS server
sudo service dnsmasq stop
sudo service hostapd stop


--------personnaliser ppp0 :  ,c'est ta source internet à définir : eth0, wlan1 etc..

--------proprietes/permissions/autoriser


TERMINE
pour mettre en route,tu ouvres un terminal dans le repertoire du fichier  ,glisses le fichier dans le terminal
enter ,mot depasse et c'est parti!
plus difficile
pour l' arreter ,fermer le terminal ou la session


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

Haut de page ↑