Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 01/08/2013, à 14:48

Franck67

environnement X qui ne se lance pas

Bonjour,

J'avais un serveur Ubuntu qui tournait bien, que j'ai tenté de mettre à jour en version 12.10
Depuis la mise à jour, l'environnement X, ne se lance plus au démarrage de la machine.
Avant il démarrait directement sur la mire de login.
Résultat, je ne peux l'accéder qu'en SSH, puisqu'il est dans une salle serveur et si je tente une connexion VNC, celle ci plante, puisque le serveur X ne tourne pas.

Je peux lancer un startX en SSH, puis me connecter en VNC, mais j'arrive alors, sur le bureau du root, vierge, aucune barre d'outils, alors que dans le fonctionnement avant l'upgrade, ma session vnc, arrivait sur la mire de login...

J'avoue être un peu perdu.
Quelqu'un sait d'ou peut venir le souci ?

Merci pour votre aide

Hors ligne

#2 Le 01/08/2013, à 21:23

J5012

Re : environnement X qui ne se lance pas

tu as du heriter d'un X minimal, cela arrive apres une maj losque des paquets auparavant disponibles pour un certain environnement graphique, sont declares obsoletes, et donc supprimes par l'installeur automatique ...

sur quel environnement s'ouvrait le login graphique, ou de quel login graphique s'agissait-il ?
sous u12.04 en gnome tu as gdm2 mais sous u12.10 c'est gdm3 qui s'impose par ex ...

Hors ligne

#3 Le 02/08/2013, à 00:10

Franck67

Re : environnement X qui ne se lance pas

honnetement, je ne sais plus de quelle version je venais... mais j'ai upgradé car je recevais un message comme quoi l'autre version n'etait plus supportée.
J'ai tenté de réinstaller l'environnement graphique sudo apt-get remove ubuntu-desktop puis sudo apt-get install ubuntu-desktop
l'install se passe bien, mais s'il devait  avoir un souci de paquets il devrait les corriger a ce moment la, non ?
ou alors je dois faire la meme chose pour gdm ?

Hors ligne

#4 Le 02/08/2013, à 03:53

J5012

Re : environnement X qui ne se lance pas

tu ne devrais pas requerir l'install de ubuntu.desktop qui est un paquet de paquets (meta-paquet) puisque tu es en mode serveur ... en effet si tu installais tout l'environnement standard d'un ubuntu normal, tu perdrais tout l'interet du mode serveur ...

cependant quel est ton objectif ? un serveur ou une station de travail ?

Hors ligne

#5 Le 02/08/2013, à 08:19

Franck67

Re : environnement X qui ne se lance pas

Un serveur qui heberge des machines virtuelles...
L'interface graphique, c'est juste pour superviser ces machines...

Hors ligne

#6 Le 02/08/2013, à 13:57

Franck67

Re : environnement X qui ne se lance pas

problème résolu.
Je ne sais pourquoi, mais j'avais lightdm en serveur X par défaut, au lieu de gdm.

Hors ligne

#7 Le 02/08/2013, à 20:08

J5012

Re : environnement X qui ne se lance pas

lightdm est le gestionnaire de sessions par defaut depuis un certain nombre de ubuntu : http://doc.ubuntu-fr.org/lightdm

si tu as installe l'ensemble des composants manquants en faisant "betement" l'install de ubuntu.desktop, lightdm est donc installe.

si tu ne voulais qu'un minimum eu egard a l'usage serveur, tu pouvais tres bien n'installer que le gdm/gnome ...

Hors ligne

Haut de page ↑