Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 03/08/2013, à 20:24

friedmann

Openvpn connecté mais pas de ping

Bonjour à tous,

J'ai installer openvpn sur un serveur Ubuntu.

J'ai ensuite installer la version PC sur Windows 8 en client.

Après des heures de recherches, j'arrive enfin à me connecter au vpn.

Seulement je n'accède pas au réseau. j'ai tenter un ping depuis le server ainsi que depuis le PC mais aucun n'à abouti.

Voilà mes paramètres server :

port 1194

proto udp

dev tun

ca ca.crt

cert server.crt

key server.key  # This file should be kept secret
 
dh dh1024.pem

server 10.8.0.0 255.255.255.0

ifconfig-pool-persist ipp.txt

keepalive 10 120

comp-lzo

persist-key

persist-tun

status openvpn-status.log

verb 3

Le client :

client

dev tun

proto udp

remote **.***.***.* 1194

resolv-retry infinite

nobind

persist-key

persist-tun

mute-replay-warnings

ca ca.crt

cert client1.crt

key client1.key

cipher AES-128-CBC

comp-lzo

verb 5

route-method exe 

route-delay 2 

ET le log :

OpenVPN CLIENT LIST
Updated,Sat Aug  3 14:40:39 2013
Common Name,Real Address,Bytes Received,Bytes Sent,Connected Since
client1,90.48.94.208:60192,4911,6085,Sat Aug  3 14:39:26 2013
ROUTING TABLE
Virtual Address,Common Name,Real Address,Last Ref
10.8.0.6,client1,90.48.94.208:60192,Sat Aug  3 14:39:27 2013
GLOBAL STATS
Max bcast/mcast queue length,0
END

Si quelqu'un à une idée du soucis ça m'aiderais beaucoup.

Édit , j'ai recréé un nouveau post dans cette section qui me semble plus adapté.

Hors ligne

#2 Le 18/10/2013, à 18:57

Morion

Re : Openvpn connecté mais pas de ping

Bonjour,

Un problème comparable pour ma part.

La machine ubuntu tourne avec la version 13.04 et utilise le client openvpn.

Je précise :

- le vpn est fonctionnelle avec toutes les autres machines sauf ubuntu !

- les autres machines (windows, backtrack...) fonctionnent sans souci avec ce même serveur et les mêmes certificats

- je n'arrive pas à pinger l'autre extrémité du vpn depuis cette machine ubuntu...

J'ai testé par mal de choses :

- Forward autorisé
- régles iptables
- j'ai viré avahi et les annonces de route 169.254.0.0...
- j'ai comparé les routes avec une machine-client fonctionnelle et celle qui ne fonctionne pas : aucune différence..

Bref...toute aide sera appréciée !

Merci

Hors ligne

Haut de page ↑