Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#26 Le 10/08/2013, à 09:43

abecidofugy

Re : Erreur d'upgrade

$ mysqld --console
130810 10:42:37 [Warning] Can't create test file /var/lib/mysql/bibliotheca.lower-test
130810 10:42:37 [Warning] Can't create test file /var/lib/mysql/bibliotheca.lower-test
mysqld: Can't change dir to '/var/lib/mysql/' (Errcode: 13)
130810 10:42:37 [ERROR] Aborting

130810 10:42:37 [Note] mysqld: Shutdown complete

Je regarde les logs dans quel fichier stp ?

Dernière modification par abecidofugy (Le 10/08/2013, à 09:43)


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#27 Le 10/08/2013, à 09:46

tiramiseb

Re : Erreur d'upgrade

Oh ben tiens, tu as exactement le même problème que nam1962 en #11.

As-tu lu ma réponse en #12 ?
As-tu vérifié de ce côté-là ?

Sinon, que donne la commande mount ? /var/lib/mysql est-il accessible en écriture ?
Que donnent les commandes suivantes ?

touch /var/lib/mysql/la-tete-a-toto
rm /var/lib/mysql/la-tete-a-toto

Je regarde les logs dans quel fichier stp ?

/var/log/mysql...quelque-chose


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#28 Le 10/08/2013, à 09:54

abecidofugy

Re : Erreur d'upgrade

$ dmesg | tail -n 50
[   14.746619] init: failsafe main process (1223) killed by TERM signal
[   14.764981] RPC: Registered named UNIX socket transport module.
[   14.764984] RPC: Registered udp transport module.
[   14.764986] RPC: Registered tcp transport module.
[   14.764987] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   14.861264] init: statd-mounting (/mnt/sauvegarde) main process (1080) killed by TERM signal
[   14.861478] init: statd-mounting (/mnt/homepoussiere) main process (1084) killed by TERM signal
[   14.861662] init: statd-mounting (/mnt/diskstation) main process (1091) killed by TERM signal
[   14.861844] init: statd-mounting (/mnt/Download) main process (1095) killed by TERM signal
[   15.104841] FS-Cache: Netfs 'nfs' registered for caching
[   15.376896] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[   15.532671] type=1400 audit(1376123335.320:8): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=1340 comm="apparmor_parser"
[   15.533018] type=1400 audit(1376123335.320:9): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=1340 comm="apparmor_parser"
[   15.533209] type=1400 audit(1376123335.320:10): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=1340 comm="apparmor_parser"
[   15.786790] init: idmapd-mounting (/mnt/homepoussiere) main process (1083) killed by TERM signal
[   15.787010] init: idmapd-mounting (/mnt/diskstation) main process (1090) killed by TERM signal
[   15.787382] init: idmapd-mounting (/mnt/sauvegarde) main process (1079) killed by TERM signal
[   15.787960] init: idmapd-mounting (/mnt/Download) main process (1094) killed by TERM signal
[   15.865739] type=1400 audit(1376123335.652:11): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=1339 comm="apparmor_parser"
[   15.970937] NFS: Registering the id_resolver key type
[   15.970948] Key type id_resolver registered
[   15.970950] Key type id_legacy registered
[   17.300625] audit_printk_skb: 39 callbacks suppressed
[   17.300629] type=1400 audit(1376123337.088:25): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=1485 comm="apparmor_parser"
[   17.303686] init: mysql pre-start process (1441) terminated with status 127
[   17.438132] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[   17.495486] NFSD: starting 90-second grace period (net ffffffff81cbb100)
[   18.274329] vboxdrv: Found 2 processor cores.
[   18.274423] vboxdrv: fAsync=0 offMin=0x258 offMax=0x2080
[   18.274486] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[   18.274487] vboxdrv: Successfully loaded version 4.2.10_Ubuntu (interface 0x001a0004).
[   18.500167] vboxpci: IOMMU not found (not registered)
[   18.913347] init: kdm main process (1582) killed by TERM signal
[   19.314789] Bluetooth: Core ver 2.16
[   19.314807] NET: Registered protocol family 31
[   19.314809] Bluetooth: HCI device and connection manager initialized
[   19.314818] Bluetooth: HCI socket layer initialized
[   19.314820] Bluetooth: L2CAP socket layer initialized
[   19.314826] Bluetooth: SCO socket layer initialized
[   19.466336] Bluetooth: RFCOMM TTY layer initialized
[   19.466349] Bluetooth: RFCOMM socket layer initialized
[   19.466350] Bluetooth: RFCOMM ver 1.11
[   19.486336] init: avahi-cups-reload main process (1642) terminated with status 1
[   19.546724] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   19.546728] Bluetooth: BNEP filters: protocol multicast
[   19.546737] Bluetooth: BNEP socket layer initialized
[   19.690450] ppdev: user-space parallel port driver
[   19.744801] type=1400 audit(1376123339.532:26): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=1673 comm="apparmor_parser"
[   19.745214] type=1400 audit(1376123339.532:27): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=1673 comm="apparmor_parser"
[   26.590288] init: plymouth-upstart-bridge main process (1583) killed by TERM signal
$ sudo touch /var/lib/mysql/la-tete-a-toto
$ sudo rm /var/lib/mysql/la-tete-a-toto
$ cat /var/log/mysql/error.log
130810  9:37:24 [Note] Plugin 'FEDERATED' is disabled.
130810  9:37:24 InnoDB: The InnoDB memory heap is disabled
130810  9:37:24 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130810  9:37:24 InnoDB: Compressed tables use zlib 1.2.7
130810  9:37:24 InnoDB: Using Linux native AIO
130810  9:37:24 InnoDB: Initializing buffer pool, size = 128.0M
130810  9:37:24 InnoDB: Completed initialization of buffer pool
130810  9:37:24 InnoDB: highest supported file format is Barracuda.
130810  9:37:25  InnoDB: Waiting for the background threads to start
130810  9:37:26 InnoDB: 5.5.32 started; log sequence number 1921561155
130810  9:37:26 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130810  9:37:26 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
130810  9:37:26 [Note] Server socket created on IP: '127.0.0.1'.
130810  9:37:27 [Note] Event Scheduler: Loaded 0 events
130810  9:37:27 [Note] mysqld: ready for connections.
Version: '5.5.32-0ubuntu0.13.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
130810  9:41:50 [Note] mysqld: Normal shutdown

130810  9:41:50 [Note] Event Scheduler: Purging the queue. 0 events
130810  9:41:50  InnoDB: Starting shutdown...
130810  9:41:51  InnoDB: Shutdown completed; log sequence number 1921561155
130810  9:41:51 [Note] mysqld: Shutdown complete

130810 10:09:27 [Note] Plugin 'FEDERATED' is disabled.
130810 10:09:27 InnoDB: The InnoDB memory heap is disabled
130810 10:09:27 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130810 10:09:27 InnoDB: Compressed tables use zlib 1.2.7
130810 10:09:27 InnoDB: Using Linux native AIO
130810 10:09:27 InnoDB: Initializing buffer pool, size = 128.0M
130810 10:09:27 InnoDB: Completed initialization of buffer pool
130810 10:09:28 InnoDB: highest supported file format is Barracuda.
130810 10:09:29  InnoDB: Waiting for the background threads to start
130810 10:09:30 InnoDB: 5.5.32 started; log sequence number 1921561155
130810 10:09:30 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130810 10:09:30 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
130810 10:09:30 [Note] Server socket created on IP: '127.0.0.1'.
130810 10:09:30 [Note] Event Scheduler: Loaded 0 events
130810 10:09:30 [Note] mysqld: ready for connections.
Version: '5.5.32-0ubuntu0.13.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
130810 10:11:08 [Note] mysqld: Normal shutdown

130810 10:11:08 [Note] Event Scheduler: Purging the queue. 0 events
130810 10:11:08  InnoDB: Starting shutdown...
130810 10:11:09  InnoDB: Shutdown completed; log sequence number 1921561155
130810 10:11:09 [Note] mysqld: Shutdown complete

Je fais quoi avec la commande mount ?

Dernière modification par abecidofugy (Le 10/08/2013, à 09:55)


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#29 Le 10/08/2013, à 10:00

tiramiseb

Re : Erreur d'upgrade

Je fais quoi avec la commande mount ?

Dans la mesure où le "touch" et le "rm" semblent avoir réussi, je n'ai pas besoin du retour de "mount" (que tu aurais simplement exécuté comme ça sans argument).

Le log de MySQL que tu montres dit qu'à 10:09 MySQL s'est correctement lancé et qu'à 10:11 il s'est correctement arrêté.
Est-ce que ton horloge est décalée ? Si oui, ça peut correspondre à tes derniers démarrages. Si ton PC est à l'heure, cela veut dire qu'il y a 45 minutes ça avait fonctionné.

Refais pkill mysqld pour tout arrêter et exécute :

mysqld_safe

Puis, dans un autre terminal :

tail -n 20 /var/log/mysql/error.log

Qu'est-ce que ça donne ?

(mysqld_safe, tu devrais pouvoir l'arrêter avec Ctrl-C, il met juste un peu de temps à confirmer qu'il s'arrête)

Dernière modification par tiramiseb (Le 10/08/2013, à 10:01)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#30 Le 10/08/2013, à 10:04

abecidofugy

Re : Erreur d'upgrade

$ mysqld_safe
130810 11:03:14 mysqld_safe Can't log to error log and syslog at the same time.  Remove all --log-error configuration options for --syslog to take effect.
130810 11:03:14 mysqld_safe Logging to '/var/log/mysql/error.log'.
130810 11:03:14 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
/usr/bin/mysqld_safe: 126: /usr/bin/mysqld_safe: cannot create /var/log/mysql/error.log: Permission denied
/usr/bin/mysqld_safe: 1: eval: cannot create /var/log/mysql/error.log: Permission denied
130810 11:03:14 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
/usr/bin/mysqld_safe: 126: /usr/bin/mysqld_safe: cannot create /var/log/mysql/error.log: Permission denied

Et en root :

# mysqld_safe
130810 11:05:05 mysqld_safe Can't log to error log and syslog at the same time.  Remove all --log-error configuration options for --syslog to take effect.
130810 11:05:05 mysqld_safe Logging to '/var/log/mysql/error.log'.
130810 11:05:05 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
$ tail -n 20 /var/log/mysql/error.log
130810 10:11:09  InnoDB: Shutdown completed; log sequence number 1921561155
130810 10:11:09 [Note] mysqld: Shutdown complete

130810 11:05:05 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
130810 11:05:05 [Note] Plugin 'FEDERATED' is disabled.
130810 11:05:05 InnoDB: The InnoDB memory heap is disabled
130810 11:05:05 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130810 11:05:05 InnoDB: Compressed tables use zlib 1.2.7
130810 11:05:05 InnoDB: Using Linux native AIO
130810 11:05:05 InnoDB: Initializing buffer pool, size = 128.0M
130810 11:05:05 InnoDB: Completed initialization of buffer pool
130810 11:05:05 InnoDB: highest supported file format is Barracuda.
130810 11:05:06  InnoDB: Waiting for the background threads to start
130810 11:05:07 InnoDB: 5.5.32 started; log sequence number 1921561155
130810 11:05:07 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
130810 11:05:07 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
130810 11:05:07 [Note] Server socket created on IP: '127.0.0.1'.
130810 11:05:08 [Note] Event Scheduler: Loaded 0 events
130810 11:05:08 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.5.32-0ubuntu0.13.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)

Dernière modification par abecidofugy (Le 10/08/2013, à 10:07)


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#31 Le 10/08/2013, à 10:06

tiramiseb

Re : Erreur d'upgrade

OK, ça ça vient peut-être du fait que je t'ai fait lancer mysqld en root.

chown -R mysql /var/log/mysql

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#32 Le 10/08/2013, à 10:09

abecidofugy

Re : Erreur d'upgrade

$ chown -R mysql /var/log/mysql
chown: modification du propriétaire de «/var/log/mysql/error.log.1.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.7.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.5.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.4.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.6.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.3.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql/error.log.2.gz»: Opération non permise
chown: modification du propriétaire de «/var/log/mysql»: Opération non permise

PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#33 Le 10/08/2013, à 10:10

tiramiseb

Re : Erreur d'upgrade

Houla désolé, je n'avais pas fait gaffe, tu fais tout en utilisateur simple !
Désolé, moi sur mes serveurs je suis toujours root.

Il faut alors utiliser sudo :

sudo mysqld_safe

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#34 Le 10/08/2013, à 10:14

abecidofugy

Re : Erreur d'upgrade

sudo mysqld_safe
[sudo] password for patrice: 
130810 11:13:58 mysqld_safe Can't log to error log and syslog at the same time.  Remove all --log-error configuration options for --syslog to take effect.
130810 11:13:58 mysqld_safe Logging to '/var/log/mysql/error.log'.
130810 11:13:59 mysqld_safe A mysqld process already exists

PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#35 Le 10/08/2013, à 10:16

agensbur

Re : Erreur d'upgrade

Idem de mon coté aussi (Xubuntu - 12.10 64b) - tout en root

root@xxxxxxx:/home/xxxxx# ps auxw | grep mysqld
root      3758  0.0  0.0  13632   928 pts/4    S+   11:09   0:00 grep --color=auto mysqld

puis

root@xxxxxx:/home/xxxxx# mysqld

Grand silence (et je reprends la main en tuant le process)
--
Sur launchpad, le "bug" semble passer à confirmé (mais si la confirmation vient de nous?), je n'ai rien vu par contre du coté forum anglophone.

Dernière modification par agensbur (Le 10/08/2013, à 11:54)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#36 Le 10/08/2013, à 10:16

abecidofugy

Re : Erreur d'upgrade

Je n'ai rien vu non plus sur le forum anglophone. Gardons l'œil ouvert.


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#37 Le 10/08/2013, à 10:17

nam1962

Re : Erreur d'upgrade

Chez moi :

~$ sudo service mysql start
start: Job failed to start

Et dans synaptic, les 2 trucs qui ont loupé l'upgrade apparaissent comme installés, mais la réinstall est grisée

Dernière modification par nam1962 (Le 10/08/2013, à 10:19)


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.10 sur portable, 14.04 sur fixe, 14.04 chez mes amis.
Score : 50 convertis IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, qui fait du T-shirt la nouvelle élégance ...bio en plus : http://goudronblanc.com

Hors ligne

#38 Le 10/08/2013, à 10:20

abecidofugy

Re : Erreur d'upgrade

nam1962 a écrit :

Chez moi :

~$ sudo service mysql start
start: Job failed to start

Pareil.

Le serveur Mysql est partiellement installé… normal qu'il ne se lance pas je suppose.


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#39 Le 10/08/2013, à 11:52

agensbur

Re : Erreur d'upgrade

idem

Dernière modification par agensbur (Le 10/08/2013, à 11:55)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#40 Le 11/08/2013, à 09:58

agensbur

Re : Erreur d'upgrade

Installation décrite comme partielle, j'ai fini par désinstaller - ré-installer mysql (en demandant conservation des bases - option proposée lors de l'effacement - et en prenant soin de reparamétrer l'accès sur le même mot de passe initial à la réinstallation)

Apparemment le problème est pour le moment résolu, j'accède correctement à mes petites réplications de site et semble jusqu'ici ne plus  avoir de difficultés de mise à jour.

La solution est rapide mais brutale et surtout je n'ai rien compris à cette histoire - donc un remède de cosaque rien d'une médecine savante.

Dernière modification par agensbur (Le 11/08/2013, à 09:58)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#41 Le 11/08/2013, à 10:56

abecidofugy

Re : Erreur d'upgrade

Quel idiot, j'ai essayé de faire comme tu dis et je n'arrive plus à installer MySql à présent :

	

    sudo apt-get install mysql-server-5.5
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances      
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation :
     
    Les paquets suivants contiennent des dépendances non satisfaites :
     mysql-server-5.5 : Dépend: mysql-server-core-5.5 (= 5.5.32-0ubuntu0.13.04.1) mais 5.5.32-0ubuntu0.13.04.2 devra être installé
    E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

//edit : j'ai commenté les dépôts proposed et j'ai réussi à downgrader ! Ouf ! Ma réinstallation de Mysql marche.

Dernière modification par abecidofugy (Le 11/08/2013, à 11:48)


PC 1 : Kubuntu 14.10 virtualisé dans Windows 8.1 (24 Go de ram) / PC2 & 3 : Kubuntu en double-boot avec Seven, PC4 : Ubuntu 14.04 serveur sur machine dédiée

Hors ligne

#42 Le 11/08/2013, à 12:00

agensbur

Re : Erreur d'upgrade

 sudo apt-get install mysql-server 

via le dépot de ma distrib (quantal 12.10) et j'ai obtenu cette version : mysql-server.5-5 5.5.32-0 ubuntu0.12.10.1

Chez moi après avoir désinstallé complètement mysql-server via synaptic et réinstallation (bien penser à réintroduire le même mot de passe : les choses sont rentrées dans l'ordre sans avoir à réparamétrer quoique ce soit (j'avais pris quelques précautions sur le dossier www/ au cas où mais tout cela a été inutile) mais je répête : méthode de cosaque et il serait mieux que se soit commenté par quelqu'un de plus patient et plus compétent que moi.
(des manipulations plus sélectives sur les seuls composants signalés defectueux suffisent peut-être amplement).

Dernière modification par agensbur (Le 11/08/2013, à 12:18)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#43 Le 11/08/2013, à 12:06

nam1962

Re : Erreur d'upgrade

Uhhh, je ne sais déjà pas pourquoi mysql est installé chez moi, alors le mdp ???


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.10 sur portable, 14.04 sur fixe, 14.04 chez mes amis.
Score : 50 convertis IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, qui fait du T-shirt la nouvelle élégance ...bio en plus : http://goudronblanc.com

Hors ligne

#44 Le 11/08/2013, à 13:21

VieuxMotard2

Re : Erreur d'upgrade

Bonjour à tous,
Le topic http://forum.ubuntu-fr.org/viewtopic.php?id=1097151 relate le même problème soulevé dans ce topic concernant la dernière mise à jour de mysql-server-5.5.
Il semble que xavier4811, dans son message #5, en explique la cause.
Alors pourrait-on suivre la démarche décrite sans supprimer les bases non sauvegardées.
Merci de vos lumières

Hors ligne

#45 Le 11/08/2013, à 20:13

agensbur

Re : Erreur d'upgrade

Quand j'ai effacé mysql-server via synaptic j'ai obtenu un dialogue de demande de conservation des bases.

Je les ai retrouvées après réinstal (le mot de passe initial d'accès au serveur de bases a seul été ressaisi, je n'ai rien fait d'autre).

J'avais effacé progressivement les composants de mysql via synaptic en y allant au flair et ne saurais pas dire exactement dans quel ordre je m'y suis pris. Je sais pas quand ce dialogue est apparu (sans doutes au début - j'ai commencé par le plus récent : mysql-server -5.5). Je ne suis même pas certain que ce petit miracle soit lié à la validation du dialogue.

En fait je m'attendais à un dump en le validant, donc à devoir recharger le serveur après coup. Je soupçonne quelque chose de plus simple : le dossier des bases ne serait pas effacé - cf plus bas -  avec par dessus une bonne gestion du rétablissement du mot de passe et on change la nappe sans toucher aux assiettes - mais la porcelaine c'est précieux donc prudence.

A lire les instructions de xavier4811, je l'interrogerai sur le dossier /var/lib/mysql/ afin de définir avec lui une démarche reproductible qui assurerait à tout coup la survie du service en vieux Sevres. Ce dossier semble contenir les bases mais c'est peut-être simpliste.

Un dump préalable serait sage, seulement voilà sur un serveur planté... (de mon coté le localhot tournant en réplication j'avais les bases distantes en recours : récupérer directement mes réplications a été une heureuse surprise, pas le fruit d'un geste savant).

Dernière modification par agensbur (Le 11/08/2013, à 20:18)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#46 Le 12/08/2013, à 05:10

J5012

Re : Erreur d'upgrade

hmm ... on dirait un conflit sur les dependances a partir de depots tiers :

- qqsoit votre distribution, vous devez desactiver les backports (ou retroportes) et les proposed, et ne les activer que le temps d'installer un paquet particulier que vous ne pouvez pas avoir avec les depots officiels; ces depots ne doivent pas etre actives lors des mises a jour ...

- lorsque vous ajoutez des depots tiers comme les ppa ou les extras, faites attention aux possibles dependances s'y trouvant , et le conseil ci-dessus vaut pour eux aussi ...

Hors ligne

#47 Le 12/08/2013, à 09:59

agensbur

Re : Erreur d'upgrade

hmm ... on dirait un conflit sur les dépendances à partir de dépôts tiers :

C'est l'hypothèse que je retiens sans exclure une "fragilité"  d'apt-get telle qu'elle est décrite dans la doc .
Rien sur le forum anglais, une petite dizaine de personnes concernées ici, même autour du 15 août, un vrai 'bug' sur mysql aurait déclenché une émeute planétaire.
J'étais en train de faire la chasse a des outils 'multimedia' introuvables en dépôts distrib ces deniers temps : beaucoup d'install 'pour test', beaucoup d'effacement en "purge", d'autoremove, avant de trouver exactement ce que je cherchais.
Par-dessus le marché, quelques sources compilés en allant à la pèche à des dépendances exotiques, bref pas mal de chahut dans les libraires et trop de dépôts ouverts que j'ai laissé trainer en "résiduels".
Dont acte et je remets de l'ordre.

Dernière modification par agensbur (Le 12/08/2013, à 10:19)


Dell Inspirion 620 - Intel(R) Core(TM) i5- 3.00GHz - 6 Go mémoire - Xubuntu 14.04-64 bits
NetBook Samsung NC -10 - Lubuntu 14.04-32 bits

Hors ligne

#48 Le 12/08/2013, à 12:22

VieuxMotard2

Re : Erreur d'upgrade

Bonjour et merci à tous, problème résolu pour moi,
Pour éviter des conflits de ce genre, je viens en effet de désactiver les MAJ backports et proposed.
Ensuite avec Synaptic, j'ai supprimé mysql-server qui a retourné une fenêtre message "mysql-server-5.5: le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1". Puis dans la foulée j'ai désinstallé mysql-server-core-5.5 et mysql-server-5.5. Je n'ai eu en revanche aucune notification pour la conservation des bases.
Puis, sur les conseils de xavier4811 concernant un problème similaire :

 sudo apt-get purge mysql-server && sudo apt-get autoremove && sudo apt-get install mysql-server

En allant sur 127.0.0.1/phpmyadmin/index.php je n'ai eu qu'à remettre les anciens login et mot de passe pour retrouver toutes les bases intactes sans avoir à reconfigurer.
Bravo et merci.

Hors ligne

#49 Le 12/08/2013, à 12:50

fabiensc

Re : Erreur d'upgrade

Bonjour,

Pour ma part, j'ai supprimé les références à "mysqld_get_param" : cf mail-archive.

À partir de là, plus de problème pour lancer le service.
Il doit bien s'agir d'un imbroglio dans les versions (je n'ai pas de référence mysqld_get_param).

Fabien

Hors ligne

#50 Le 12/08/2013, à 13:45

nam1962

Re : Erreur d'upgrade

Pas tout pigé.
Comment as tu supprimé ces références ?

(un peu newbee moâ)


Mon tuto pour optimiser / finaliser une install : http://forum.ubuntu-fr.org/viewtopic.ph … #p15041961
Xubuntu 14.10 sur portable, 14.04 sur fixe, 14.04 chez mes amis.
Score : 50 convertis IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, qui fait du T-shirt la nouvelle élégance ...bio en plus : http://goudronblanc.com

Hors ligne

Haut de page ↑