Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 14/08/2013, à 10:58

Philip Masse

Squidguard + Google Chrome

Bonjour tout le monde,

J'ai mis en place un proxy squid + squidguard (le tout fonctionne après beaucoup de sueur smile )
Mais j'ai un soucis, les termes ne fonctionnent pas sur Chrome.

Par exemple, si on tape

Sexe

sur Internet explorer ou Firefox, automatiquement la personne est redirigée vers la page d'erreur.
Mais sur Chrome cela ne fait absolument rien ... (Par contre le blocage des pages fonctionne).

Auriez-vous une idée ?

J'ai trouvé un semblant d'information sur google :

squidGuard.conf:
s @ (google \ .. * / search?. * q =. *) @ \ 1 \ & safe = actifs @ i
s @ (google \ .. * / images. * q =. *) @ \ 1 \ & safe = actifs @ i
s @ (google \ .. * / groupes. * q =. *) @ \ 1 \ & safe = actifs @ i
s @ (google \ .. * / nouvelles. * q =. *) @ \ 1 \ & safe = actifs @ i

Mais je ne sais pas du tout si c'est un bout de solution ou si c'est hors sujet ...

Merci d'avance

Philip Masse

Hors ligne

#2 Le 18/08/2013, à 11:15

tiramiseb

Re : Squidguard + Google Chrome

Salut,

Qu'appelles-tu "absolument rien" ?
Le "rien" n'existe pas : il y a forcément une réaction. Quelle est la réaction sous Chrome.

Si on tape "Sexe" où ça ?
Quel est l'URL présenté dans la barre d'adresse du navigateur après avoir tapé "Sexe" je-ne-sais-pas-où ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 27/08/2013, à 06:12

Philip Masse

Re : Squidguard + Google Chrome

Désoler, j'ai complètement "Zappé" !!!! J'ai du passer à autre chose pour un temps !

Alors je pense que "rien" est le mot juste car ce phénomène existe aussi avec les contrôles parentaux installés en local.
Effectivement, je m'en étais rendu compte en installant le CP de Orange (le temps de mettre en place un serveur) et les recherches d'image de Google dans Chrome n'était absolument pas perturbé ! Alors que Google image dans Firefox et IE était bien impacté.
La recherche d'image de google dans Chrome ne tient absolument pas compte du blocage. Dans la barre d'adresse, il y a un lien "normal" ...

Philip Masse

PS : encore désolé pour le retard ....

Hors ligne

#4 Le 27/08/2013, à 07:19

tiramiseb

Re : Squidguard + Google Chrome

Peux-tu donner un/des exemple(s) concret(s) s'il-te-plaît ?

Chrome utilise-t-il bien le proxy ?
Qu'est-ce que tu vois dans les logs de Squid ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#5 Le 27/08/2013, à 13:51

Philip Masse

Re : Squidguard + Google Chrome

Il n'y a pas de configuration de proxy directement dans Chrome (contrairement à Firefox) il utilise la configuration du poste (poste windows : Options Internet/Connexions/Paramètres réseau). Le proxy fonctionne pour les recherches !

Voici les logs quand je recherche "sexe" sur google image :
1377607578.655  10113 192.168.0.9 TCP_MISS/200 226 CONNECT ssl.gstatic.com:443 - DIRECT/74.125.195.120 -
1377607590.286  10116 192.168.0.9 TCP_MISS/200 226 CONNECT apis.google.com:443 - DIRECT/74.125.195.100 -


et c'est tout rien d'autre.

Hors ligne

#6 Le 27/08/2013, à 14:03

tiramiseb

Re : Squidguard + Google Chrome

Voici les logs quand je recherche "sexe" sur google image :
1377607578.655  10113 192.168.0.9 TCP_MISS/200 226 CONNECT ssl.gstatic.com:443 - DIRECT/74.125.195.120 -
1377607590.286  10116 192.168.0.9 TCP_MISS/200 226 CONNECT apis.google.com:443 - DIRECT/74.125.195.100 -

Chromium se connecte en SSL. Un proxy n'est pas capable de filtrer le contenu des requêtes SSL (vu qu'elles sont chiffrées, la communication n'est "lisible" que par le serveur (Google) et le poste de travail).

Si, avec Firefox ou Internet Explorer, tu te connectes en HTTPS (SSL) sur Google, tu auras le même résultat.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#7 Le 27/08/2013, à 14:53

Philip Masse

Re : Squidguard + Google Chrome

Effectivement, et bloquer le port ne change rien (appart à l'ouverture de ladite photo ...)
Y a-t-il un moyen de "surveiller" ces communication ?

Hors ligne

#8 Le 27/08/2013, à 15:16

tiramiseb

Re : Squidguard + Google Chrome

Philip Masse a écrit :

Y a-t-il un moyen de "surveiller" ces communication ?

Aucun moyen "propre", non.

- soit tu "casses" le chiffrement (auquel cas il te faut un cluster de plein de PC super balaises pour faire ça en live)
- soit tu interceptes la communication et tu intercales un certificat SSL propre au proxy (auquel cas le PC donnera systématiquement une alerte pour cause de certificat SSL invalide).

bloquer le port ne change rien

Si tu configures Squid pour refuser les accès vers le port 443, alors ça bloquera les communications SSL. Toutes les communications SSL (ce qui n'est probablement pas ce que tu souhaites).


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#9 Le 27/08/2013, à 15:22

Philip Masse

Re : Squidguard + Google Chrome

tiramiseb a écrit :
Philip Masse a écrit :

bloquer le port ne change rien

Si tu configures Squid pour refuser les accès vers le port 443, alors ça bloquera les communications SSL. Toutes les communications SSL (ce qui n'est probablement pas ce que tu souhaites).

Exacte, c'est vraiment embêtant ! A la limite faudrait bloquer l'url https://www.google.fr/*
Au moins on est sûr que tout passera pas le site normal...

Hors ligne

#10 Le 27/08/2013, à 15:34

tiramiseb

Re : Squidguard + Google Chrome

Sauf que, rien que sur les deux lignes que tu as donné, aucune des deux ne correspond à "www.google.fr/*" : on voit soit "ssl.gstatic.com" soit "apis.google.com". Et il y en a certainement des dizaines d'autres comme ça...


Par contre j'ai lu récemment (il y a quelques semaines), sur ce forum, une discussion où un gars avait trouvé une solution à ça, il s'agit d'ajouter des entrées dans /etc/hosts pour certaines adresses particulières. Il avait trouvé ça dans la doc de Google je crois. Si tu fouilles un peu dans le forum tu peux ptet le retrouver...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 28/08/2013, à 07:31

Philip Masse

Re : Squidguard + Google Chrome

tiramiseb a écrit :

Sauf que, rien que sur les deux lignes que tu as donné, aucune des deux ne correspond à "www.google.fr/*" : on voit soit "ssl.gstatic.com" soit "apis.google.com". Et il y en a certainement des dizaines d'autres comme ça...

Pas faux ...

tiramiseb a écrit :

Par contre j'ai lu récemment (il y a quelques semaines), sur ce forum, une discussion où un gars avait trouvé une solution à ça, il s'agit d'ajouter des entrées dans /etc/hosts pour certaines adresses particulières. Il avait trouvé ça dans la doc de Google je crois. Si tu fouilles un peu dans le forum tu peux ptet le retrouver...

Ok je vais regarder ça ! Merci beaucoup en tout cas !

Hors ligne

Haut de page ↑