Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 30/08/2013, à 10:11

papy44

[résolu] virtualbox : ping vers invité impossible

Bonjour,

Après 3 heures de recherche sur ce sujet je demande de l'aide sad

Je souhaite installer un serveur web dans une virtualbox (sous debian)
L'installation s'est bien passé et ma machine virtuelle (10.0.2.15) fonctionne bien: accès internet et à l’hôte (192.168.0.6)

J'ai suivi ce tuto :
http://www.diije.fr/installer-serveur-d … tu-server/
donc 2 cartes virtuelles : NAT et réseau hôte privé
J'ai exactement la même config que le tuto

ifconfig machine vituelle
eth0 : 10.0.2.15
eth1 : inexistante

Problèmes :
- J'ai une erreur lors du redémarrage du réseau (/etc/init.d/networking restart) ou même de la machine

Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
Reconfiguring network interfaces...Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/08:00:27:4b:1b:c6
Sending on   LPF/eth0/08:00:27:4b:1b:c6
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 10.0.2.2 port 67
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/08:00:27:4b:1b:c6
Sending on   LPF/eth0/08:00:27:4b:1b:c6
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPOFFER from 10.0.2.2
DHCPACK from 10.0.2.2
bound to 10.0.2.15 -- renewal in 42014 seconds.
Missing required variable: address
Missing required configuration variables for interface eth1/inet.
Failed to bring up eth1.
done.

-  impossible de pinger ma machine virtuelle depuis mon hôte : normal ! pas de eth1

Donc comment résoudre ce problème qui ne devait pas exister en avril 2012 = date du tuto

Merci par avance à tous.

Dernière modification par papy44 (Le 30/08/2013, à 13:47)


Intel® Xeon(R) CPU X3430 @ 2.40GHz × 4  * 12 Go
Quadro FX 580/PCIe/SSE2 * 2 écrans 22''
SSD 64Gb G.SKILL FALCON * DD 500Gb WDC

Hors ligne

#2 Le 30/08/2013, à 12:29

jplemoine

Re : [résolu] virtualbox : ping vers invité impossible

Une méthode qui fonctionne :
- coté machine virtuelle : 1 seule carte réseau en mode Pont et en DHCP.

Au lieu d'avoir un réseau en 10.a.b.c, tu auras une machine de plus en 192.168.x.y, tous les PC du réseau local pourront y accéder.

Je pense que la 2eme carte en réseau privé sert juste pour avoir le localhost (127.0.0.1). à vérifier.

Jean-Philippe.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes il n'en reste plus qu'un) & server (1 poste)

En ligne

#3 Le 30/08/2013, à 12:32

Flambaz

Re : [résolu] virtualbox : ping vers invité impossible

Salut,

Quand j'installais un serveur à l'aide de VirtualBox, je sélectionnais pont (ou brigde) sur la carte 1 dans les modes d'accès réseau.
En gros, cela donnait une ip local à ton serveur. Mais il faut que ta box soit configuré en routeur.

Plus simple ^^


Asus CG8250
i7-2600
12 Go de RAM
Voyager 13.04 64 bits

Hors ligne

#4 Le 30/08/2013, à 13:47

papy44

Re : [résolu] virtualbox : ping vers invité impossible

Merci de vos réponses rapides et correctes.
La solution d'une carte en mode pont fonctionne parfaitement
Certainement des problèmes de sécurité ... mais comme ce n'est pas de la production et dans mon réseau local tout va bien.


Intel® Xeon(R) CPU X3430 @ 2.40GHz × 4  * 12 Go
Quadro FX 580/PCIe/SSE2 * 2 écrans 22''
SSD 64Gb G.SKILL FALCON * DD 500Gb WDC

Hors ligne

Haut de page ↑