Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 08/09/2013, à 14:30

R a M u S

|RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Bonjour à tous,

tout d'abord je précise que je suis sous xubuntu 13.04

Chez moi j'ai 3 pc : 2 sous xubuntu 13.04 (un portable et un pc de bureau) et un portable sous windows 7.
J'ai créé un petit réseau (partage de dossiers) qui fonctionne très bien sauf sur mon portable.
En effet quand je vais dans Thunar et parcourir le réseau, je clique sur le nom d'un de mes pc et j'obtiens ce message :

L'obtention de la liste des partages du serveur a échoué : Connexion refusée.

Je n'arrive donc pas avec mon portable à accéder aux dossiers partagé des deux autres pc et ces deux autres pc n'arrivent pas à se connecter à mon portable (alors qu'entre eux tout va bien dans les deux sens).

J'ai fait ce qui est préconisé dans la doc mais rien n'y fait.

Si vous avez une idée...
Merci d'avance.

Dernière modification par R a M u S (Le 14/09/2013, à 20:27)


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#2 Le 09/09/2013, à 01:00

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

salut,

que donne

sudo ufw status
sudo iptables -L
sudo smbtree
cat /etc/samba/smb.conf
sudo status smbd
sudo status nmbd

Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 09/09/2013, à 09:15

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

sudo ufw status :

État : inactif

Pas normal j'imagine...

sudo iptables -L :

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

sudo smbtree :

WORKGROUP
	\\SALON          		Salon server (Samba, Ubuntu)
	\\RAMUS          		ramus server (Samba, Ubuntu)
	\\HUBERT         		Hubert
	\\FREEBOX        		Freebox Server
		\\FREEBOX\IPC$           	IPC Service (Freebox Server)
		\\FREEBOX\Disque dur     	AutoShare of fbxhdiskd partition 2

cat /etc/samba/smb.conf :

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which 
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic 
# errors. 
# A well-established practice is to name the original file
# "smb.conf.master" and create the "real" config file with
# testparm -s smb.conf.master >smb.conf
# This minimizes the size of the really used smb.conf file
# which, according to the Samba Team, impacts performance
# However, use this with caution if your smb.conf file contains nested
# "include" statements. See Debian bug #483187 for a case
# where using a master file is not a good idea.
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
	workgroup = workgroup

# server string is the equivalent of the NT Description field
	server string = %h server (Samba, Ubuntu)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
#   wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
;   wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
	dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
;   name resolve order = lmhosts host wins bcast

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
;   interfaces = 127.0.0.0/8 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
;   bind interfaces only = yes



#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
	log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
	max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#   syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
	syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
	panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
#   security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
;	encrypt passwords = yes

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.  
;	passdb backend = tdbsam

	obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
	unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
	passwd program = /usr/bin/passwd %u
	passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
	pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
	map to guest = bad user

########## Domains ###########

# Is this machine able to authenticate users. Both PDC and BDC
# must have this setting enabled. If you are the BDC you must
# change the 'domain master' setting to no
#
;   domain logons = yes
#
# The following setting only takes effect if 'domain logons' is set
# It specifies the location of the user's profile directory
# from the client point of view)
# The following required a [profiles] share to be setup on the
# samba server (see below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the 
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
#   load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;	printing = cups
;   printcap name = cups

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

# The following was the default behaviour in sarge,
# but samba upstream reverted the default because it might induce
# performance issues in large organizations.
# See Debian bug #368251 for some of the consequences of *not*
# having this setting and smb.conf(5) for details.
;   winbind enum groups = yes
;   winbind enum users = yes

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 (default) means that usershare is disabled.
;	usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
	usershare allow guests = yes
	security = share
	guest ok = yes
	guest account = ramus

#======================= Share Definitions =======================

# Un-comment the following (and tweak the other settings below to suit)
# to enable the default home directory shares. This will share each 
# user's home director as \\server\username
;[homes]
;   comment = Home Directories
;   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server. Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# The following parameter makes sure that only "username" can connect
#
# This might need tweaking when using external authentication schemes
;   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

;	wins support = yes
wins support = yes
[printers]
	comment = All Printers
	browseable = no
	path = /var/spool/samba
	printable = yes
;	guest ok = no
;	read only = yes
	create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
	comment = Printer Drivers
	path = /var/lib/samba/printers
;	browseable = yes
;	read only = yes
;	guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#	cdrom share is accesed. For this to work /etc/fstab must contain
#	an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
#	is mounted on /cdrom
#
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

[Musique]
	path = /home/ramus/Musique

;	browseable = yes
	available = yes
	guest ok = yes
	
browsable = yes
public = yes
writable = yes

sudo status smbd :

smbd start/running, process 933

sudo status nmbd :

nmbd start/running, process 1760

Merci !


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#4 Le 09/09/2013, à 09:55

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Si ufw "non-actif" n'est pas grave ; par contre iptables confirme que les ports pour le partage ne sont pas configurés : C'est pourtant c'est bien spécifiée dans la doc que tu cite cite (voir la partie : Ports liés au partage de fichiers par les protocoles SMB et CIFS)

Ensuite le nom du workgroup, peut tu vérifié qu'il est bien orthographié sur tous tes différents pc, pour rappel workgroup n'est pas la même chose que WORKGROUP...attention donc au majiscules/minuscules

Enfin on ne voit pas de partages sur tes autres pc dans le retour de la commande "sudo smbtree" et dans ton smb.conf, il n'y a pas de partages de définis ??? d'ou la question, comment a tu créer tes partages ?


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#5 Le 09/09/2013, à 10:58

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Suite à tes conseils j'ai modifié les ports en ajoutant à /etc/default/ufw :

# extra connection tracking modules to load \\
# ajout de nf_conntrack_netbios_ns pour Samba \\
IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"

J'ai aussi modifié WORKGROUP qui était en minuscules dans /etc/samba/smb.conf.
Ca ne change rien.

J'ai fait mon partage à l'aide de l'outil dossier partagé de xubuntu. Je précise que mon partage est protégé par mot de passe. C'est peut-être pour cela qu'il n’apparaît pas dans sudo smbtree (mais l'ordinateur apparait : "salon")


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#6 Le 09/09/2013, à 23:23

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Ok, je pense pas que que la modif que tu cite soit utile...
Attention aussi a bien redemarrer les services smbd et nmbd apres chaque modif et attendre au moins 3 bonnes minutes avant de retester (redemarrer est plus rapide a moins d'avoir un pc lent ...)

sinon ok pour la façon de créer le partage, j'aime pas trop comme cela....et quoiqu'il en soit il devrait quand même être listé par le smbtree....tu peux aussi utiliser cette commande pour voir les partages

sudo smbclient -L IP_DU_PC #remplace IP_DU_PC par la vrai adresse ip :-)

donne aussi le retour de

sudo iptables -L

Dernière modification par toutafai (Le 09/09/2013, à 23:26)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#7 Le 10/09/2013, à 22:57

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

re,

ramus@ramus:~$ sudo smbclient -L 192.168.1.36
WARNING: The security=share option is deprecated
Enter root's password: 
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.9]
Server requested LANMAN password (share-level security) but 'client lanman auth = no' or 'client ntlmv2 auth = yes'
tree connect failed: NT_STATUS_ACCESS_DENIED
ramus@ramus:~$ 
ramus@ramus:~$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination 

█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#8 Le 11/09/2013, à 08:53

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Le pare feu !!!! Les ports ne sont pas ouverts ! (voir la doc).


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#9 Le 11/09/2013, à 19:28

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Pourtant j'ai fais ce qui est expliqué ici.

Dernière modification par R a M u S (Le 11/09/2013, à 19:29)


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#10 Le 11/09/2013, à 19:42

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Bon je comprends pas comment on modifie le pare feu.Si tu peux m'aider...


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#11 Le 11/09/2013, à 22:16

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

R a M u S a écrit :

Pourtant j'ai fais ce qui est expliqué ici.

Si c'est la 2 em partie (de modifier le fichier /etc/default/ufw) ce n'est pas suffisant (je sais même pas si cette manipulation est encore utile ou pas, cela marche sans chez moi...)

Par contre il faut ouvrir les ports du pare feu, fait cela avec gufw


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#12 Le 11/09/2013, à 22:25

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

J'ai essayé mais je ne dois pas être très doué...
Déjà lorsque je lance gufw le pare feu est désactivé. Je l'active et lorsque je veux ajouter une règle (allow/in/service/samba) et que je valide, j'ai le message "erreurs lors de l’exécution de l'opération".


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#13 Le 12/09/2013, à 01:47

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

as tu cliqué sur déverrouiller/unlock ? je te conseille plutot des créer une regle en mode avancé : il faut juste en plus precisé le port, le protocole et qu'elle adresse sont autorisé (192.168.0/24 ou 192.168.1/24)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#14 Le 14/09/2013, à 16:20

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

re,
désolé je dois pas être doué mais j'ai toujours le même message : "erreurs lors de l’exécution de l'opération". Pourtant j'ai bien déverrouillé le pare-feu.

Merci !


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#15 Le 14/09/2013, à 20:27

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Finalement je ne suis pas si boulet que ça, ça fonctionne parfaitement.
Merci !


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

#16 Le 14/09/2013, à 22:08

toutafai

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

ok et tant mieux, je commencais a nager dans le potage :-)

Ps : c'etait quoi qui allait pas ?


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#17 Le 14/09/2013, à 22:09

R a M u S

Re : |RESOLU| impossible d'accéder à mon réseau local |RESOLU|

Le pare-feu. et j'ai réussi à le configurer...


█▀ █▀█ █▀█▀█ █▄█ ▄█▀

Hors ligne

Haut de page ↑