Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 03/10/2013, à 11:09

alexxcool

Mise à jour des plugins Firefox sous Ubuntu 13.4

Bonjour,

J'ai des problèmes de prise en compte de la mise à jopur de 2 plugins sous Firefox. Les documentations fournient par lAdobe semble bien imcomplètes et on dirait bien que c'est volontaire de leur part par ailleurs. Enfin bref je suis pas la pour polémiquer.

Je vais sur http://www.mozilla.org/fr/plugincheck/ qui me dit que les plugins Java Plug-in 1.7.0_21 et Shockwave Flash sont vulnérable.

Je clique sur le bouton mettre à jour maintenant du premier on va commencer donc par Java.
J'atterris sur Java Downloads et je télécharge donc la version tar.gz x64 ayant un système 64 bits. Donc Linux x64.
Je clique sur Instructions qui me mène ici http://www.java.com/en/download/help/li … nstall.xml
Alors là ça dit en anglais les étapes suivantes :
1 Aller dans le répertoire où vous voulez installer Java. Je choisis donc /usr/java/
2 Je déplace le fichier tar.gz dans ce dossier
3 Je tape tar zxvf jre-7u40... tout se passe à merveille
4 Effacer le tar.gz pour gagner de l'espace. Voyant que ça me semble bien imcomplet comme procédure j'efface rien du tout je sens que je vais encore en avoir besoin.

Selon laDobe de Oracle c'est bon ça serait à jour. Bein voyons et la marmotte ... vous connaissez la suite.
Un OS qui verrait seul qu'on viens de le mettre à jour en copiant des fichiers dans un répertoire de notre choix. Bienvenu dans le monde des Bisounors mais non ça marche pas dans la vrai vie. ^^

Donc j'ai bien mon archive décompresser mais comment aller dire à Firefox que les fichiers à jour sont dans /usr/java/jre1.7.0_40 et non plus dans jre1.7.0_25 ?

----------------------------------------------------------
Ensuite l'histoire se répète pour Shockwave Flash
Je clique sur mettre à jour maintenant.
Étape 1 sur 3 : je télécharge la version tar.gz
Étape 2 sur 3 : ça télécharge tout est bon pour le moment
Étape 3 sur 3 : tout est gris sans rien d'écrit ça commence à sentir le poulet grillé.

Je me laisse pas abattre et file dans l'archive téléchargée. JE vois un fichier readme.txt  cool en général c'est bon signe ce truc là.
Le truc raconte en anglais qu'il faut :
- Dézipper et copiez les fichiers dans un lieu approprié. Je choisis /usr/flash à côté de Java ça me semble être un bon endroit. (Choix arbitraire rien n''est indiqué).
- Sauver le plugin tar.gz localement et noter son emplacement.
- Lancer un terminal. En fait j'y suis déjà dans un terminal enfin bref.
- il demande de dézipper les fichiers libflashplayer.so et le dossier /usr mais en réalité c'est déjà fait avant.
- Indentifier le répertoire des plugins de firefox. Si je me trompe pas c'est dans /usr/lib/firefox-addons/plugins mais j'ai du me tromper car vous le devinez ça marchera pas.
- Je copie le fichier liflashplayer.so dans /usr/lib/firefox-addons/plugins
- Je tape la commande sudo cp -r usr/* /usr (Je comprends pas exactement ce qu'elle va faire mais bon je suis pas à ça prêt je fonce)

Soit disant après ça c'est terminé.

Les Bisounours ne sont pas encore arrivés et ça marche pas.

Donc seriez-vous faire ses mises à jour de façon que ça fonctionne ?
Il doit sûrement allez mettre les mains dans le cambouis de firefox mais où ?


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#2 Le 03/10/2013, à 11:45

Bob49

Re : Mise à jour des plugins Firefox sous Ubuntu 13.4

Bonjour

Je vois pas pourquoi tu t'ennuies à effectuer de telles manipulations ! Alors qu'en mettant ce qu'il faut comme dépôt, ça pose aucun problème ! surtout pour Java...  https://launchpad.net/~webupd8team/+archive/java

Et que Flash s'installe sans problème à partir du gestionnaire de paquets (flashplugin-installer) ou de la bibliothèque (chercher adobe flash, puis choisir Adobe flash plugin)
Pour son bon fonctionnement sur certains pc, c'est une autre histoire !..

Et de préférence, effectuer les installations, navigateur(s) fermé(s).

Dernière modification par Bob49 (Le 03/10/2013, à 11:53)


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

#3 Le 03/10/2013, à 21:48

alexxcool

Re : Mise à jour des plugins Firefox sous Ubuntu 13.4

C'est pas simple de deviner tout ça en fait. Vous me dites cela comme si ça couler de source mais faudrait que java donner la procédure clairement dans sa documentation. Je vois mal un novice se dire ah oui mais si j'allais rajouter un nouveau dépôt pour Java tout marcherais. La logique des non geek ne va pas jusque là. Des progrés restent à faire de ce côté là dans Ubuntu si un développeur me lit espérons que l'idée fasse son chemin.

Quand à Adobe Flash plugin dans mon gestionnaire de paquets il s'appelle Extensions Adobe Flash et est déjà installé. Mais pour ce dernier je pense ça va dépendre de Adobe qui ne veut plus de Linux dans ses clients. On doit pas être assez rentable pour eux.

Je verrais au prochain redémarrage si la mise à jour s'effectue ou pas pour Java.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#4 Le 03/10/2013, à 22:23

Ubuntu1988

Re : Mise à jour des plugins Firefox sous Ubuntu 13.4

Pour Java, le mieux est de désactiver le plug in, pas vraiment nécessaire


J'ai perdu ! :(

Hors ligne

#5 Le 04/10/2013, à 09:46

alexxcool

Re : Mise à jour des plugins Firefox sous Ubuntu 13.4

Petite parenthèse mon mail de suivi me renvoyé sur xubuntu-fr.org et non ubuntu ! C'est louche je trouve mais bon pas trop génant. Mais ça laisse interrogatif.

Bref ...

Personnellement je croise encore pas mal de site qui utilise Java et sans ça je devrais changer de crèmerie. Je laisse Java pour le moment. On est pas encore dans le monde des Bisounours sans Java. C'est encore beaucoup trop tôt ou trop tard à méditer.


Ubuntu 13.10 CG : nVidia 9800GT RAM : 8 Go
Ubuntu jamais de bug ils disaient ! Ah bein pas chez moi.

Hors ligne

#6 Le 04/10/2013, à 10:14

Bob49

Re : Mise à jour des plugins Firefox sous Ubuntu 13.4

Bonjour

alexxcool a écrit :

Vous me dites cela comme si ça couler de source mais faudrait que java donner la procédure clairement dans sa documentation.

Ajouter un dépôt, c'est expliqué clairement dans la documentation ! Même si c'est dans les solutions alternatives (ce qui est normal sous Linux), la solution pour ajouter le Java d'Oracle s'y trouve : http://doc.ubuntu-fr.org/java#depuis_le_ppa

Et pour un novice qui aura lu toute la page concernant Java (pour ce cas), aura plus de facilité en ajoutant le dépôt. Dans ce cas, pas de téléchargement à effectuer et simplement 3 lignes à taper (ou coller) une par une dans le terminal, sans oublier qu'en suite les mises à jour sont automatiques...donc plus besoin de s'en occuper. smile

******************************************

Actuellement, je suis pas sous la 12.04 LTS et ne peux vérifier le nom du plugin de Flash que j'ai installé, mais je confirme qu'il fonctionne bien avec Firefox 24. 
Mais comme je l'ai évoqué dans mon précédent message, Flash peut ne pas fonctionner sur certains pc...Sujet soulevé maintes fois sur ce forum. Dont encore une fois sur un fil en dessous du tient : http://forum.ubuntu-fr.org/viewtopic.ph … #p14345901
Sans oublier les sites qui bloquent la lecture des vidéos, parce que la version Flash sous Linux et pour Firefox, n'a pas le bon n° !... mad

Dernière modification par Bob49 (Le 04/10/2013, à 10:16)


AMD Athlon 64X2  3800+ 2 GHz / XP et Ubuntu 10.04
Ram +2Go /DD principal..Seagate SATA2 HDD / NVIDIA Quadro NVS 285
La patience est une vertu qui consiste à bien supporter des inconvénients sans pour cela se détourner d'une fin poursuivie.
%NOINDEX%

Hors ligne

Haut de page ↑