Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 07/10/2013, à 00:39

RoaxDunkHeldos

Processeur 64-bits, OS 64 bits... Impossible de démarrer une VM 64-bit

Bonsoir à tous,

Je suis développeur web, concernant les VM je ne suis pas expert la matière, mais je me débrouille pas mal, en général je trouve toujours une solution à mes problèmes... Mais là, je ne comprend pas...

J'ai un serveur IBM X3200 - 4362E3G ( détails ici ) avec un processeur Intel® Pentium® D Processor 820 détails ici
(2M Cache, 2.80 GHz, 800 MHz FSB)
.
J'utilise VMWare workstation 9.0.2, j'ai installé le paquet "linux-headers-3.2.0-4-amd64" détails ici

Au moment de la configuration de la VM, j'ai : "64-bit guest operating systems are not supported by this host and will not run" ( ce problème est tout même bien étrange non ).
Donc je fais comme si j'avais pas vu le message, et je lance la VM... Et là j'ai "this virtual machine is configured for 64 bit guest. however 64 bit operation is not possible" et "this host does not support intel vt-x"...

Alors pour la petite histoire... Ces VM ont été créé sur un autre PC qui supporte l'intel VT-X, en les transférant sur ce serveur, j'ai désactivé cette fonctionnalité dans chacune d'elle... Donc normalement l'intel VT-X n'as plus rien à voir dans l'histoire... sad

Après quelques recherches, je me suis rendu sur cette page de VMWare détails ici... Mais je ne vois pas ce qui cloche...

P.S : Les VM en 32-bit se lancent bien !

En tout cas, merci d'avance à tout ceux qui veulent bien m'aider wink

Hors ligne

#2 Le 07/10/2013, à 10:50

slasher-fun

Re : Processeur 64-bits, OS 64 bits... Impossible de démarrer une VM 64-bit

Bonjour,

Est-ce que les instructions VT-x sont bien activées dans le BIOS/EFI ?

Hors ligne

#3 Le 07/10/2013, à 11:00

genma

Re : Processeur 64-bits, OS 64 bits... Impossible de démarrer une VM 64-bit

@slasher-fun : l'option n'est pas active dans le BIOS vu que le processeur ne supporte pas cette instruction.

@RoaxDunkHeldos : une recherche rapide sur google montre que la version 5 de VMware nécessitait les accélérations matérielles (les fameuses instructions intel VT-X) pour le support d'un invité/guest en 64 bits. Je ne sais pas ce qu'il en est avec la version 9 que tu utilises, mais si ça n'a pas changé, même si ton OS hôte est en 64 bits, tu ne "pourrais" que faire tourner des machines virtuelles en 32 bits. A valider/vérifier.

Ce que le message "this host does not support intel vt-x" confirmerait. Il n'est pas lié à la case cochée ou pas dans la configuration de la machine virtuelle mais bel et bien lié au fait que le processeur ne supporte pas intel vt-x.

Dernière modification par genma (Le 07/10/2013, à 11:02)


"Lorsque tu as découvert le libre, tu sais que tu ne pourras plus jamais revenir en arrière".
Utilisateur d'Ubuntu depuis la version 4.10 !
Mon blog ?      http://genma.free.fr
Mon twitter?     http://twitter.com/genma

Hors ligne

#4 Le 07/10/2013, à 19:22

RoaxDunkHeldos

Re : Processeur 64-bits, OS 64 bits... Impossible de démarrer une VM 64-bit

Merci @genma pour cette piste je vais trouver un processeur Intel VT-x compatible... Je reviendrais pour confirmer que cela fonctionne...

Hors ligne

#5 Le 08/10/2013, à 07:56

src

Re : Processeur 64-bits, OS 64 bits... Impossible de démarrer une VM 64-bit

Je pense pouvoir dire sans me tromper que c'est pareil pour les autres (VirtualBox et KVM)
Pas de VT-x, pas de chocolat....

Par contre si tu veux virtualiser du Linux, tu as d'autres solutions.

Proxmox te permet de gérer facilement des "VM" Linux avec OpenVZ (qui n'utilise pas VT-x).


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

Haut de page ↑