Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/10/2013, à 16:49

benwa666

[RÉSOLU] Dpkg/apt cassés.

Hello,

comme tous les 6 mois je fais ma mise à niveau un peu en avance. Mais cette fois ci ça ne s'est pas très bien passé …

# dpkg --configure -a
dpkg : avertissement : « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg : erreur : 1 programme attendu non trouvé dans la variable PATH ou non exécutable
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 apparmor : Dépend: initramfs-tools mais il n'est pas installé
 console-setup : Dépend: initramfs-tools (>= 0.85eubuntu12) mais il n'est pas installé
 cryptsetup : Dépend: initramfs-tools (>= 0.91) mais il n'est pas installé ou
                       linux-initramfs-tool
 cups : Dépend: libc-bin (>= 2.13)
        Recommande: colord
 dmsetup : Dépend: initramfs-tools mais il n'est pas installé
 kbd : Dépend: initramfs-tools mais il n'est pas installé
 linux-image-3.11.0-11-generic : Dépend: initramfs-tools (>= 0.36ubuntu6) mais il n'est pas installé
 linux-image-3.8.0-30-generic : Dépend: initramfs-tools (>= 0.36ubuntu6) mais il n'est pas installé
 linux-image-3.8.0-31-generic : Dépend: initramfs-tools (>= 0.36ubuntu6) mais il n'est pas installé
 plymouth : Dépend: initramfs-tools mais il n'est pas installé
 ubuntu-minimal : Dépend: initramfs-tools mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
# dpkg-reconfigure -phigh -a
Can't exec "locale": Aucun fichier ou dossier de ce type at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
/var/lib/dpkg/info/ace-of-penguins.postinst: 10: /var/lib/dpkg/info/ace-of-penguins.postinst: ldconfig: not found
# apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  g++-4.7 gcc-4.7-base:i386 gir1.2-polkit-1.0 libaccounts-qt1 libboost-date-time1.49.0
  libboost-iostreams1.49.0 libboost-python1.49.0 libboost-signals1.49.0
  libboost-system1.49.0 libboost-thread1.49.0 libdvbpsi7 libgnome-desktop-3-4
  libgnome-keyring0:i386 libgtkdatabox-0.9.1-1 libgusb2 libhsqldb-java libibus-1.0-0:i386
  libllvm3.2 libllvm3.2:i386 libmpc2 libpolkit-qt-1-1 libpoppler28 librhythmbox-core6
  libsignon-extension1 libsignon-plugins-common1 libsignon-qt1 libstdc++6-4.7-dev
  linux-headers-3.8.0-30 linux-headers-3.8.0-30-generic linux-image-3.8.0-30-generic
  linux-image-extra-3.8.0-30-generic python-enchant python-gtkspell python-zeitgeist
  session-migration signon-keyring-extension signon-ui signond
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : # apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  g++-4.7 gcc-4.7-base:i386 gir1.2-polkit-1.0 libaccounts-qt1 libboost-date-time1.49.0
  libboost-iostreams1.49.0 libboost-python1.49.0 libboost-signals1.49.0
  libboost-system1.49.0 libboost-thread1.49.0 libdvbpsi7 libgnome-desktop-3-4
  libgnome-keyring0:i386 libgtkdatabox-0.9.1-1 libgusb2 libhsqldb-java libibus-1.0-0:i386
  libllvm3.2 libllvm3.2:i386 libmpc2 libpolkit-qt-1-1 libpoppler28 librhythmbox-core6
  libsignon-extension1 libsignon-plugins-common1 libsignon-qt1 libstdc++6-4.7-dev
  linux-headers-3.8.0-30 linux-headers-3.8.0-30-generic linux-image-3.8.0-30-generic
  linux-image-extra-3.8.0-30-generic python-enchant python-gtkspell python-zeitgeist
  session-migration signon-keyring-extension signon-ui signond
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  initramfs-tools libc-bin
Les NOUVEAUX paquets suivants seront installés :
  initramfs-tools libc-bin
0 mis à jour, 2 nouvellement installés, 0 à enlever et 118 non mis à jour.
Il est nécessaire de prendre 0 o/1.226 ko dans les archives.
Après cette opération, 3.915 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Can't exec "locale": Aucun fichier ou dossier de ce type at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
dpkg : avertissement : « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg : erreur : 1 programme attendu non trouvé dans la variable PATH ou non exécutable
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

  initramfs-tools libc-bin
Les NOUVEAUX paquets suivants seront installés :
  initramfs-tools libc-bin
0 mis à jour, 2 nouvellement installés, 0 à enlever et 118 non mis à jour.
Il est nécessaire de prendre 0 o/1.226 ko dans les archives.
Après cette opération, 3.915 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Can't exec "locale": Aucun fichier ou dossier de ce type at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
dpkg : avertissement : « ldconfig » introuvable dans la variable PATH ou non exécutable
dpkg : erreur : 1 programme attendu non trouvé dans la variable PATH ou non exécutable
Note : la variable PATH du superutilisateur doit normalement contenir /usr/local/sbin, /usr/sbin et /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

Pas mal hein tongue
J'ose même pas redémarrer …

Si vous avez une piste je suis preneur  …

Merci d'avance.

Dernière modification par benwa666 (Le 08/10/2013, à 17:16)


** J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source.

Hors ligne

#2 Le 08/10/2013, à 17:11

jeanjd63

Re : [RÉSOLU] Dpkg/apt cassés.

Salut

Que donne un :
set | grep "PATH"
Tu devrais avoir une ligne de type :
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Si ce n'est pas le cas il faut initialiser ainsi :
export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:$PATH"

@+

Hors ligne

#3 Le 08/10/2013, à 17:16

benwa666

Re : [RÉSOLU] Dpkg/apt cassés.

Hello,

ouais j'allais justement paste mon path et mon sudoers mais je me suis fait aider sur irc (#ubuntu-fr-testing) par Snarf, que je re-remercie au passage.
En gros le problème était surtout celui ci :

« ldconfig » introuvable dans la variable PATH ou non exécutable

J'ai donc fait ça :

touch /sbin/ldconfig
echo exit 0 > /sbin/ldconfig
chmod +x /sbin/ldconfig

Je suis allé dans /etc/apt/archives
Et j'ai fait :

dpkg -i libc-bin_2.17-93ubuntu1_amd64.deb

Ça a marché, j'ai pu ensuite faire mes dpkg et apt en toute tranquilité \o/


** J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source.

Hors ligne

#4 Le 09/10/2013, à 13:30

"-"

Re : [RÉSOLU] Dpkg/apt cassés.

Idem, j'ai eu un gros pb avec libc6 sur cette release lors de mon dist-upgrade, et j'ai fini la màj avec un liveCD...

Hors ligne

Haut de page ↑