Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 09/10/2013, à 14:15

loja

League of Legend sous Wine (encore et toujours...)

Bonjours à tous,

J'ai suivi ce tutoriel http://forums.na.leagueoflegends.com/bo … ?t=1946188 pour installer Lol avec Wine (pas avec PlayOnLinux, pour éviter de télécharger 7Go..).
J'ai suivi le tuto à la lettre mais je n'ai pas réussi à installer internet explorer 6. (j'ai essayé divers moyen mais je n'y arrive pas..)

Le jeu se lance tout de même mais quand j'essaye de me connecter une fenêtre apparaît disant que : "Le certificat pour ce site pose problème. Voulez-vous tout de même continuer ? Oui Non" Je pense que cela vient de IE6.
Pour que Je me puisse me connecter je suis obliger d'appuyer sur oui, une bonne dizaine de fois.

Mon principal problème est que lorsque que je lance une partie, l'écran de chargement (en plein écran) apparaît, mais mon chargement reste à 0% et n’affiche pas mes sorts d'invocateurs. Rien ne se passe, donc je dois quitter le jeu manuellement.
J'ai cherché dans les lignes du terminal pour trouver une erreur et je suis tombé sur ça:

 (  ERROR)[13:23:19.015] RADS::Common::HTTPConnection::GetFile: Failed on /rest/getToken?format=xml&ClientID=PMB_Client 
 (  ERROR)[13:23:19.027] RADS::Common::HTTPConnection::GetFile: perform request failed with code 7 
 (  ERROR)[13:23:19.027] RADS::Common::HTTPConnection::GetFile: Failed on /rest/shutdown?format=xml&netToken= 

J'espère avoir été clair sur mes problèmes(installer IE6, faire partir la fenêtre avec le certificat et débloquer mon chargement qui reste à 0%).

Merci de vos réponses en espérant que vous puissiez m'aider ! big_smile

Hors ligne

#2 Le 13/10/2013, à 17:49

loja

Re : League of Legend sous Wine (encore et toujours...)

Je viens de remarquer que ma version de wine n'était pas la plus récente, j'ai donc installé la 1.7.4.
Grâce à cette version, la fenêtre avec le certificat ne s'affiche plus smile
et je suppose que internet explorer 6, je n'ai pas besoin de le télécharger car il ne sert pas à grand chose.

Mais le problème le plus important, avec l’écran de chargement persistent et les erreurs aussi !!

J’espère (encore une fois) qu'un génie passera par là pour m'aider... tongue

Hors ligne

#3 Le 20/10/2013, à 13:31

loja

Re : League of Legend sous Wine (encore et toujours...)

Quoi de nouveau depuis le dernier post ?

Et bien, maintenant le jeu fonctionne à peu près normalement mais j'ai que 10 fps avec tout au minimum.. tongue
Pour que tout marche, il me faut lancer le jeu avec ce launcher: lol.launcher.admin.exe . Qui de trouve dans le dossier League of Legends
Et non avec la commande :

 WINEDEBUG=+ntdll wine "rads_user_kernel.exe" run lol_launcher $(ls ../projects/lol_launcher/releases/) LoLLauncher.exe 

Ce que je voudrais faire maintenant, c'est de lancer le jeu avec une commande qui ressemble à celle ci-dessus car je suppose qu'elle devrait me faire gagner quelque fps.
Et donc, je chercherai aussi des moyens pour gagner des fps...

Merci de vos réponses en espérant que vous puissiez m'aider ! cool

Hors ligne

#4 Le 20/10/2013, à 14:10

Fnux.fr

Re : League of Legend sous Wine (encore et toujours...)

Pour ma part j'ai déjà réussi à lancer Lol avec wine il y a quelques mois, mais ce n'était pas très très joyeux niveau fps dès qu'il commençait à avoir du mouvement et je n'ai pas cherché à creuser.
Quel erreur est renvoyée avec la commande en question ?

Hors ligne

#5 Le 20/10/2013, à 14:15

loja

Re : League of Legend sous Wine (encore et toujours...)

Avec la commande il y n'a pas vraiment d'erreur à part que le chargement reste à 0%...

Hors ligne

#6 Le 22/10/2013, à 15:10

loja

Re : League of Legend sous Wine (encore et toujours...)

J'ai découvert un bug étrange, la 1ier partie que je fais sur lol je suis au alentour de 7fps, et puis à la 2ième vers les 17fps. Il m'a sembler aussi que à chaque partie d'affilé après le 2ième mon nombre de fps augmente encore mais de pas beaucoup... J'ai même atteint les 30fps en début de partie à la 4ième !!! smile

Je cherche toujours des solutions pour avoir au moins 24fps tout au long d'une partie mais dès la première game et pas après...

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » League of Legend sous Wine (encore et toujours...)

Haut de page ↑