Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/10/2013, à 22:58

pilou254

[RÉSOLU] Xubuntu 13.04 inutilisable

Bonsoir à tous,
je viens de mettre à niveau mon install vers la 13.04 et je suis confronté à de sérieuses difficultés.
Le démarrage est très très lent ... mais vraiment très très lent !
Une fois démarré tout va bien, la machine est un avion et puis d'un coup ça devient à nouveau très très lent pendant plusieurs minutes pour revenir à la normale et recommencer ansi de suite ...ma machine en devient inutilisable.

Voilà ce que j'ai pu trouver dans dmesg (je crois comprendre qu'il y a une cacahouète dans le système de fichier et également quelquechose avec apparmor) :

[    2.844105] firewire_core 0000:02:0a.0: created device fw0: GUID 00000ae6ff73e643, S400
[    9.158106] EXT3-fs (sda1): recovery required on readonly filesystem
[    9.158110] EXT3-fs (sda1): write access will be enabled during recovery
[  589.500646] kjournald starting.  Commit interval 5 seconds
[  589.500770] EXT3-fs (sda1): orphan cleanup on readonly fs
[  591.303280] ext3_orphan_cleanup: deleting unreferenced inode 25518082
[  594.903627] ext3_orphan_cleanup: deleting unreferenced inode 26911819
[  596.746779] ext3_orphan_cleanup: deleting unreferenced inode 27141529
[  596.746795] ext3_orphan_cleanup: deleting unreferenced inode 1679364
[  602.209533] EXT3-fs (sda1): 4 orphan inodes deleted
[  616.768115] EXT3-fs (sda1): recovery complete
[  616.768117] EXT3-fs (sda1): mounted filesystem with ordered data mode
[  647.461959] Adding 2048280k swap on /dev/sda2.  Priority:-1 extents:1 across:2048280k 
[  650.075405] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  650.075412] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[  650.745447] udevd[470]: starting version 175
[  655.192300] lp: driver loaded but no devices found
[  657.305481] EXT3-fs (sda1): using internal journal
[  658.722595] parport_pc 00:0a: reported by Plug and Play ACPI
[  658.722679] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[  658.820125] lp0: using parport0 (interrupt-driven).
[  659.199434] ppdev: user-space parallel port driver
[  659.651260] MCE: In-kernel MCE decoding enabled.
[  659.756831] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
[  659.759248] i2c i2c-0: nForce2 SMBus adapter at 0x1c00
[  659.759267] i2c i2c-1: nForce2 SMBus adapter at 0x1c40
[  659.859186] microcode: AMD CPU family 0xf not supported
[  659.860305] microcode: AMD CPU family 0xf not supported
[  660.123315] EDAC MC: Ver: 2.1.0
[  660.456920] nv_tco: NV TCO WatchDog Timer Driver v0.01
[  660.457007] nv_tco: Watchdog reboot not detected
[  660.457052] nv_tco: initialized (0x1440). heartbeat=30 sec (nowayout=0)
[  660.694388] AMD64 EDAC driver v3.4.0
[  660.694434] EDAC amd64: DRAM ECC disabled.
[  660.694447] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
[  660.694447]  Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
[  660.694447]  (Note that use of the override may cause unknown side effects.)
[  661.336558] input: ImExPS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input3
[  661.717535] kvm: Nested Virtualization enabled
[  663.947076] ACPI: PCI Interrupt Link [AAZA] enabled at IRQ 20
[  663.947081] hda_intel: Disabling MSI
[  663.947110] snd_hda_intel 0000:00:0e.1: setting latency timer to 64
[  665.557187] nvidia: module license 'NVIDIA' taints kernel.
[  665.557193] Disabling lock debugging due to kernel taint
[  665.817020] ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
[  665.817041] nvidia 0000:02:07.0: setting latency timer to 64
[  665.817046] vgaarb: device changed decodes: PCI:0000:02:07.0,olddecodes=io+mem,decodes=none:owns=io+mem
[  665.817274] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.37  Wed Mar  6 18:37:51 PST 2013
[  666.304092] input: HDA NVidia Line as /devices/pci0000:00/0000:00:0e.1/sound/card0/input4
[  666.304186] input: HDA NVidia Front Mic as /devices/pci0000:00/0000:00:0e.1/sound/card0/input5
[  666.304251] input: HDA NVidia Rear Mic as /devices/pci0000:00/0000:00:0e.1/sound/card0/input6
[  666.304317] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:0e.1/sound/card0/input7
[  666.304380] input: HDA NVidia Line Out Side as /devices/pci0000:00/0000:00:0e.1/sound/card0/input8
[  666.304424] input: HDA NVidia Line Out CLFE as /devices/pci0000:00/0000:00:0e.1/sound/card0/input9
[  666.304496] input: HDA NVidia Line Out Surround as /devices/pci0000:00/0000:00:0e.1/sound/card0/input10
[  666.304558] input: HDA NVidia Line Out Front as /devices/pci0000:00/0000:00:0e.1/sound/card0/input11
[  666.909967] type=1400 audit(1381884320.798:2): apparmor="STATUS" operation="profile_load" name="/sbin/dhclient" pid=890 comm="apparmor_parser"
[  666.909982] type=1400 audit(1381884320.798:3): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=888 comm="apparmor_parser"
[  666.910320] type=1400 audit(1381884320.798:4): apparmor="STATUS" operation="profile_load" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=890 comm="apparmor_parser"
[  666.910336] type=1400 audit(1381884320.798:5): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=888 comm="apparmor_parser"
[  666.910513] type=1400 audit(1381884320.798:6): apparmor="STATUS" operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" pid=890 comm="apparmor_parser"
[  666.910534] type=1400 audit(1381884320.798:7): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=888 comm="apparmor_parser"
[  666.911072] type=1400 audit(1381884320.798:8): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=889 comm="apparmor_parser"
[  666.911422] type=1400 audit(1381884320.798:9): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=889 comm="apparmor_parser"
[  666.911616] type=1400 audit(1381884320.798:10): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=889 comm="apparmor_parser"
[  667.443664] type=1400 audit(1381884321.334:11): apparmor="STATUS" operation="profile_load" name="/usr/sbin/ntpd" pid=930 comm="apparmor_parser"
[  670.000357] init: failsafe main process (945) killed by TERM signal
[  671.824539] init: udev-fallback-graphics main process (1019) terminated with status 1
[  673.435782] Bluetooth: Core ver 2.16
[  673.435804] NET: Registered protocol family 31
[  673.435806] Bluetooth: HCI device and connection manager initialized
[  673.435808] Bluetooth: HCI socket layer initialized
[  673.435809] Bluetooth: L2CAP socket layer initialized
[  673.435812] Bluetooth: SCO socket layer initialized
[  673.499330] audit_printk_skb: 6 callbacks suppressed
[  673.499334] type=1400 audit(1381884327.390:14): apparmor="STATUS" operation="profile_load" name="/usr/share/gdm/guest-session/Xsession" pid=1124 comm="apparmor_parser"
[  673.501610] type=1400 audit(1381884327.390:15): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=1152 comm="apparmor_parser"
[  673.501978] type=1400 audit(1381884327.390:16): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=1152 comm="apparmor_parser"
[  673.502173] type=1400 audit(1381884327.390:17): apparmor="STATUS" operation="profile_replace" name="/usr/lib/connman/scripts/dhclient-script" pid=1152 comm="apparmor_parser"
[  673.701559] Bluetooth: RFCOMM TTY layer initialized
[  673.701565] Bluetooth: RFCOMM socket layer initialized
[  673.701567] Bluetooth: RFCOMM ver 1.11
[  673.780908] type=1400 audit(1381884327.670:18): apparmor="STATUS" operation="profile_load" name="/usr/bin/freshclam" pid=1154 comm="apparmor_parser"
[  673.931094] type=1400 audit(1381884327.818:19): apparmor="STATUS" operation="profile_load" name="/usr/lib/cups/backend/cups-pdf" pid=1146 comm="apparmor_parser"
[  673.931216] type=1400 audit(1381884327.818:20): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=1158 comm="apparmor_parser"
[  673.931615] type=1400 audit(1381884327.818:21): apparmor="STATUS" operation="profile_load" name="/usr/sbin/cupsd" pid=1158 comm="apparmor_parser"
[  673.932839] type=1400 audit(1381884327.822:22): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=1146 comm="apparmor_parser"
[  673.937724] type=1400 audit(1381884327.826:23): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/ntpd" pid=1163 comm="apparmor_parser"
[  674.257093] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  674.257097] Bluetooth: BNEP filters: protocol multicast
[  674.534198] init: cups main process (1164) killed by HUP signal
[  674.534221] init: cups main process ended, respawning
[  680.402309] init: gdm main process (1330) killed by TERM signal

Si une bonne âme pouvait me filer un coup de main, j'apprécierai grandement.
Bien à vous,
Pilou.

Dernière modification par pilou254 (Le 25/10/2013, à 13:49)

Hors ligne

#2 Le 16/10/2013, à 23:23

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Salut,

As-tu essayé de redémarrer ? La même erreur est-elle rencontrée après un redémarrage ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#3 Le 17/10/2013, à 00:18

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Salut,

oui j'ai essayé de redémarrer et j'ai toujours la même erreur.
Parfois c'est seulement un peu moins long et une fois complétement démarré j'ai toujours ces gels intempestifs.
D'autre part, j'ai oublié de le préciser, quand la machine gèle je n'arrive pas à commaître le process responsable.
Grâce à "top" je vois qu'un des deux processeurs est à fond et que l'autre est quasiment pas chargé.
Pour autant, top ne m'affiche pas le ou les processus responsables ... je ne sais pas comment les trouver.
Ou bien, c'est peut être à cause du système de fichier qui bat de l'aile ?

Dernière modification par pilou254 (Le 17/10/2013, à 00:36)

Hors ligne

#4 Le 17/10/2013, à 00:22

melXero

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonsoir,

Surveiller mes TOP processus en cours et leurs consommation CPU est ce que je ferais en premier dans votre cas.
Si ton système devient lent, que donne Moniteur Système > onglet Processus > trier par %CPU ?

PS. Avoir un Conky, desklet, xfce4-plugin ou même applet pour dock pour surveiller ton système est toujours utile dans ce genre de situation.

Hors ligne

#5 Le 17/10/2013, à 00:40

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonsoir melXero,

et bien justement, que ce soit avec top ou bien un utilitaire graphique, ni l'un ni l'autre ne m'affiche de processus consommant autant de ressources système.
Ça ne tient pas la route cette histoire, je devrais voir quelque chose pourtant.

Hors ligne

#6 Le 17/10/2013, à 01:40

melXero

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Ton problème semble plutôt infamous... J'ai fait un peut de recherche et je peux affirmer que même si ton cas est plutôt courante les réponses divergent trop souvent o_O
Je te propose alors d'ouvrir une nouvelle discussion libellé "Aide pour analyser dmsg et/ou bootchart". une interversion d'un pro du matière sera plus qu'indispensable alos.

PS. une désactivation du support IPv6 semble supprimer ton problème mais je ne peux pas d'assurer des résultats d'avance.

Bonne Chance

Hors ligne

#7 Le 17/10/2013, à 08:13

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Moi çe qui me fait tiquer, c'est ça :

[    9.158106] EXT3-fs (sda1): recovery required on readonly filesystem
[    9.158110] EXT3-fs (sda1): write access will be enabled during recovery
[  589.500646] kjournald starting.  Commit interval 5 seconds
[  589.500770] EXT3-fs (sda1): orphan cleanup on readonly fs
[  591.303280] ext3_orphan_cleanup: deleting unreferenced inode 25518082
[  594.903627] ext3_orphan_cleanup: deleting unreferenced inode 26911819
[  596.746779] ext3_orphan_cleanup: deleting unreferenced inode 27141529
[  596.746795] ext3_orphan_cleanup: deleting unreferenced inode 1679364
[  602.209533] EXT3-fs (sda1): 4 orphan inodes deleted
[  616.768115] EXT3-fs (sda1): recovery complete
[  616.768117] EXT3-fs (sda1): mounted filesystem with ordered data mode

Comme tu le pressens, ça me semble être un problème de système de fichiers.

Chez moi, ça donne ça :

[    2.565796] EXT4-fs (sda2): INFO: recovery required on readonly filesystem
[    2.565800] EXT4-fs (sda2): write access will be enabled during recovery
[    3.731394] EXT4-fs (sda2): orphan cleanup on readonly fs
[    3.743174] EXT4-fs (sda2): ext4_orphan_cleanup: deleting unreferenced inode 941737
[    3.743242] EXT4-fs (sda2): 1 orphan inode deleted
[    3.743243] EXT4-fs (sda2): recovery complete
[    3.822141] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)

Deux secondes pour faire un recovery (que ce soit en ext3 ou en ext4), c'est raisonnable.

10 minutes (600 secondes !) comme chez toi ce n'est pas normal.


Es-tu sûr que ton disque dur n'est pas en train de défaillir ?
As-tu regardé ses infos avec smartctl ?
As-tu regardé dans le dmesg s'il y a des messages d'erreur parlant du disque, pendant l'utilisation ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#8 Le 17/10/2013, à 14:56

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

melXero a écrit :

Ton problème semble plutôt infamous... J'ai fait un peut de recherche et je peux affirmer que même si ton cas est plutôt courante les réponses divergent trop souvent o_O ..........................................;Bonne Chance

Bonjour,

merci d'avoir fait des recherches, tu n'était pas obligé.
Cordialement.

Hors ligne

#9 Le 17/10/2013, à 16:47

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonjour tiramiseb,

depuis hier je ne fais plus tourner ma machine avec la mise à niveau 13.04.
Je tourne sur une distro en live.

tiramiseb a écrit :

Es-tu sûr que ton disque dur n'est pas en train de défaillir ? As-tu regardé ses infos avec smartctl ?

Apparemment, les tests effectué avec Palimpsest sont tous bons.

tiramiseb a écrit :

As-tu regardé dans le dmesg s'il y a des messages d'erreur parlant du disque, pendant l'utilisation ?

Oui, j'ai cherché mais je n'ai rien trouvé.

Autre chose, qui à mon avis confirme que le système de fichier commence à déconner sérieusement :
lorsque je veux accéder à certain répertoires (volumineux) du disque en question, j'observe exactement le même comportement !
→ des accès très courts et répétés au disque pendant plusieurs minutes pour m'afficher le contenu d'un gros répertoire.
Quand la machine démarre c'est bel et bien ce qui se passe .

Quelles sont les commandes à utiliser pour « soigner » mon système de fichiers à ton avis ?

Cordialement.

Hors ligne

#10 Le 17/10/2013, à 18:38

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Pour "soigner" le système de fichiers, je ne saurais pas te dire. Je ne connais pas trop cet aspect-là.

À la limite, le plus sûr serait peut-être de copier toutes les données et refaire complètement le système de fichiers...


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#11 Le 18/10/2013, à 14:52

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonjour tiramiseb,

quand je pense "soigner", je veux dire en fait, à part fsck quels sont les outils pour investiguer au mieux le système de fichiers.
J'aimerai bien me sortir de ce mauvais pas avec quelques utilitaires en ligne de commande parce que je ne peux pas immédiatement copier toutes les données sur un autre disque, il y a plus de 400 Gio à copier et je n'ai pas d'autre disque pour ce faire.

Hors ligne

#12 Le 18/10/2013, à 15:05

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Malheureusement là je n'ai pas d'idée qui me vienne... à part fsck, comme tu dis.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#13 Le 19/10/2013, à 16:42

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

melXero a écrit :

Ton problème semble plutôt infamous... J'ai fait un peut de recherche et je peux affirmer que même si ton cas est plutôt courante les réponses divergent trop souvent o_O
Je te propose alors d'ouvrir une nouvelle discussion libellé "Aide pour analyser dmsg et/ou bootchart". une interversion d'un pro du matière sera plus qu'indispensable alos.
PS. une désactivation du support IPv6 semble supprimer ton problème mais je ne peux pas d'assurer des résultats d'avance.Bonne Chance

Bonjour melXero,

si tu pouvais me donner quelques précisions pour la modification de mon "/etc/sysctl.conf".
Actuellement, voilà son état:

#
# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
#net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1


###################################################################
# Additional settings - these settings can improve the network
# security of the host and prevent against some network attacks
# including spoofing attacks and man in the middle attacks through
# redirection. Some network environments, however, require that these
# settings are disabled so review and enable them as needed.
#
# Do not accept ICMP redirects (prevent MITM attacks)
#net.ipv4.conf.all.accept_redirects = 0
#net.ipv6.conf.all.accept_redirects = 0
# _or_
# Accept ICMP redirects only for gateways listed in our default
# gateway list (enabled by default)
# net.ipv4.conf.all.secure_redirects = 1
#
# Do not send ICMP redirects (we are not a router)
#net.ipv4.conf.all.send_redirects = 0
#
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
# Log Martian Packets
#net.ipv4.conf.all.log_martians = 1
#

D'aprés ton lien, il faut rajouter ceci :

net.ipv6.conf.all.disable_ipv6=1   
net.ipv6.conf.default.disable_ipv6=1   
net.ipv6.conf.lo.disable_ipv6=1

À quel niveau faut-il que je modifie le fichier, n'importe où, à la fin du fichier ?
Les "#" devant les lignes de config ipv4, faut-il les supprimer ?

Faut-il également ajouter ceci ? :

gksu gedit /etc/modprobe.d/blacklist.conf
Ajoutez à la fin de ce fichier la ligne:
blacklist ipv6

Par avance, merci.
Cordialement.

Hors ligne

#14 Le 20/10/2013, à 09:34

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

pilou254 a écrit :

À quel niveau faut-il que je modifie le fichier, n'importe où, à la fin du fichier ?

N'importe où.

pilou254 a écrit :

Les "#" devant les lignes de config ipv4, faut-il les supprimer ?

Ça dépend, où as-tu lu qu'il faudrait supprimer ces "#" ?

Ou alors tu te dis que ce serait joli de supprimer ces "#" en complément d'ajouter des lignes ? big_smile

pilou254 a écrit :

Faut-il également ajouter ceci ? :
[...]
blacklist ipv6

Tu as le choix entre l'un et l'autre.

Les lignes "...ipv6..." dans le fichier sysctl.conf disent au pilote IPv6 de ne pas configurer l'IPv6.

La ligne "blacklist ipv6" dans blacklist.conf dit au noyau de ne pas charger le pilote IPv6.

Dans le premier cas, le pilote sera chargé mais l'IPv6 non configuré.
Dan le second cas, le pilote ne sera même pas chargé.

Cela étant dit, je ne vois pas en quoi ton problème de système de fichiers serait lié à l'IPv6... Je ne comprends pas pourquoi melXero évoque ça.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#15 Le 20/10/2013, à 16:33

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonjour tiramiseb,

merci pour ta réponse.

tiramiseb a écrit :

Ça dépend, où as-tu lu qu'il faudrait supprimer ces "#" ?
Ou alors tu te dis que ce serait joli de supprimer ces "#" en complément d'ajouter des lignes ? big_smile

Joli, c'est bien ça, comment as-tu fait pour deviner ?

tiramiseb a écrit :

Cela étant dit, je ne vois pas en quoi ton problème de système de fichiers serait lié à l'IPv6... Je ne comprends pas pourquoi melXero évoque ça.

J'ai modifié mon fstab qui décrivait une partition de swap sur un disque qui n'existe pas sur ma machine, ça a un peu amélioré les choses, ça donne ça :

[    2.820099] firewire_core 0000:02:0a.0: created device fw0: GUID 00000ae6ff73e643, S400
[   42.728758] EXT3-fs (sda1): recovery required on readonly filesystem
[   42.728762] EXT3-fs (sda1): write access will be enabled during recovery
[   51.936659] kjournald starting.  Commit interval 5 seconds
[   53.749458] EXT3-fs (sda1): recovery complete
[   53.749460] EXT3-fs (sda1): mounted filesystem with ordered data mode
[  679.744767] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Donc, 51 secondes pour monter le fs, à chaque démarrage il y a un recovery alors que j'arrête la machine proprement, va comprendre ...
et un saut de 53 s à 679 s pour atterrir à une mauvaise config IPV6.
Apparemment, mais je peux me tromper, ça ne mange pas de pain de supprimer l'IPV6 pour le moment, ça semble justifié dans ce cas précis.

Cdlt.

Hors ligne

#16 Le 20/10/2013, à 17:35

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

pilou254 a écrit :

Joli, c'est bien ça, comment as-tu fait pour deviner ?

big_smile
Plus sérieusement, non, tant que tu ne veux pas activer (ou désactiver) telle ou telle fonctionnalité, ne change pas d'autre ligne.

pilou254 a écrit :

ça a un peu amélioré les choses, ça donne ça
[...]

[...]
[   53.749460] EXT3-fs (sda1): mounted filesystem with ordered data mode
[  679.744767] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Ce que j'ai cru comprendre c'est qu'il y a un délai chez à peu près tout le monde, qu'il s'y passe quelque chose mais je n'ai toujours pas réussi à comprendre quoi. En changeant telle ou telle chose au démarrage ça change le timing en effet, mais je n'ai toujours pas compris comment identifier précisément sa source : ce n'est pas obligatoirement lié au timing des différents messages du noyau.


Tu peux toujours tenter de désactiver l'IPv6, en effet ça ne mange pas de pain. Pour maximiser les chances d'avoir un impact sur le démarrage, je te conseille d'utiliser la solution "blacklist" plutôt que la solution "sysctl"...

Dernière modification par tiramiseb (Le 20/10/2013, à 17:43)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#17 Le 21/10/2013, à 17:06

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Bonjour tiramiseb,

tiramiseb a écrit :

Tu peux toujours tenter de désactiver l'IPv6, en effet ça ne mange pas de pain. Pour maximiser les chances d'avoir un impact sur le démarrage, je te conseille d'utiliser la solution "blacklist" plutôt que la solution "sysctl"...

la solution "blacklist" ne fonctionne pas, le module ipv6 est toujours lancé au boot.
Je vais donc passer à la solution "sysctl" -> affaire à suivre.

À partir de la distrib live j'ai cherché à accéder au disque récalcitrant avec nautilus en mode root et il m'est apparu quelques messages qui pourraient peut être nous mettre sur la voie concernanat cette lenteur d'accés aux fichiers :

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ gksu nautilus

** (nautilus:5409): WARNING **: Unable to add monitor: Operation not supported
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.


--- Hash table keys for warning below:
--> file:///var/run/motd
--> file:///media/disk-2/run/resolvconf/resolv.conf
--> file:///etc/alternatives/vtrgb
--> file:///var/run/cups/printcap
--> file:///dev/.blkid.tab

(nautilus:5409): Eel-WARNING **: "nautilus-file.c: symbolic_links" hash table still has 5 elements at quit time (keys above)

--- Hash table keys for warning below:
--> file:///media/disk-2/home
--> file:///media/disk-2/etc
--> file:///media
--> file:///media/disk
--> file:///root
--> file:///media/disk-2
--> file:///media/disk-2/var/log
--> file:///media/disk-1
--> file:///media/disk-2/var
--> file:///media/disk-2/proc

(nautilus:5409): Eel-WARNING **: "nautilus-metafile.c: metafiles" hash table still has 10 elements at quit time (keys above)

(nautilus:5409): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 10 elements at quit time
ubuntu@ubuntu:~$ 

Je me trompe peut être mais "hash table still has 5 elements at quit time" ... ce serait pas un début de réponse ?

Cdlt.

Hors ligne

#18 Le 21/10/2013, à 21:33

fcn50

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Salut,

Juste une suggestion, pourquoi buntu 13.04 en ext3 et pas en ext4?


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#19 Le 21/10/2013, à 22:17

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

fcn50 a écrit :

Salut, Juste une suggestion, pourquoi buntu 13.04 en ext3 et pas en ext4?

Salut,
je n'ai pas choisis lors de la mise à niveau et franchement je ne me suis pas posé la question.
Mais maintenant que tu en parles y aurait-il un moyen de faire la manip pour passer mon fs de ext3 -> ext4 ?
Peut être que ca pourrait corriger un problème dans le fs, si ça vient de là, je suis prêt à tout essayer !

Par contre, il y a du changement au démarrage, dans le bon sens, après avoir modifié la config ipv6.
À présent la machine démarre en 40 s, c'est une très importante amélioration !
Par contre, ce qui m'interroge c'est que malgré la modif "blacklist" + "sysctl" le noyau appelle toujours le module ipv6 !
Voilà le code :

[    2.592087] ata11: SATA link down (SStatus 0 SControl 300)
[    8.724144] EXT3-fs (sda1): recovery required on readonly filesystem
[    8.724148] EXT3-fs (sda1): write access will be enabled during recovery
[   10.532276] kjournald starting.  Commit interval 5 seconds
[   10.580473] EXT3-fs (sda1): recovery complete
[   10.580475] EXT3-fs (sda1): mounted filesystem with ordered data mode
[   35.599580] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

Ce que je comprends c'est qu'une fois sda1 monté il y a une tentative de configurer un accès réseau sur eth0 (ça prend 25 s).
Problème :
- je pense avoir viré la config ipv6
- je n'ai pas d'interface eth0, seule eth2 est configuré pour l'accès réseau et il n'y a pas d'autre interfaces réseau physiques sur ma machine, étrange quand même, non ?

À chaque démarrage, je vois un recovery sur sda1, à présent ça ne prend plus que 8 s, c'est beaucoup plus rapide mais je ne vois pas pourquoi le recovery s'impose à chaque démarrage alors que j'ai arrêté la machine proprement ...

Enfin, à chaque extinction de la machine j'ai une succession de "lignes de commandes" qui s'affichent les unes après les autres (en pagaille) et j'aimerai bien y jeter un coup d'œil.
Est-ce qu'il existe un "journal" de l'extinction de la machine que l'on peut consulter.

Merci pour vos réponses et votre soutien, ça avance, ça avance !

Cdlt.

Hors ligne

#20 Le 21/10/2013, à 23:06

fcn50

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Je ne sais pas concernant ext3 > ext4, je vais regarder mais je doute...

Pourquoi eth2 et pas eth0, tu as plusieurs ethernet? Poste le contenu du fichier /etc/network/interfaces, des commandes ifconfig -a et route -n.

L'ipv6 c'est normal concernant le noyau, j'ai vu l'option pour le désactiver, je dois chercher mais c'est pas important. Pour ce faire il faut rajouter cette option dans /etc/default/grub: ipv6.disable=1

Pour les journaux: /var/log/syslog est le plus complet.

Malgré tout y'a du mieux!

Dernière modification par fcn50 (Le 22/10/2013, à 11:13)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#21 Le 22/10/2013, à 16:20

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Salut,

fcn50 a écrit :

Pourquoi eth2 et pas eth0, tu as plusieurs ethernet?

Je ne sais pas pourquoi, comme je te l'écrivais je n'ai qu'une interface réseau (eth2, carte réseau séparée sur le bus pci), les deux interfaces ethernet de la carte mère sont désactivées dans le bios.
Je n'ai pas choisis non plus le nom de l'interface, c'est le système qui lui a collé eth2.

Merci pour ta réponse.

Cdlt.

Hors ligne

#22 Le 22/10/2013, à 16:25

pilou254

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Le contenu de /etc/network/interfaces :

auto lo
iface lo inet loopback

#auto eth2
#iface eth2 inet dhcp
#auto eth0
#iface eth0 inet static
#	netmask 255.255.255.0
#	gateway 192.168.0.254

Hors ligne

#23 Le 22/10/2013, à 16:27

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Le système a probablement réservé eth0 et eth1 pour les deux interfaces de la carte mère...


Que donne la commande suivante ?

cat /etc/udev/rules.d/70-persistent-net.rules

Dernière modification par tiramiseb (Le 22/10/2013, à 16:28)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#24 Le 22/10/2013, à 21:44

fcn50

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

Mais pourquoi tu n'utilises pas la carte réseau de la carte mère? Donne aussi le retour de ifconfig -a et route -n puis regarde si tu as un dossier /etc/resolvconf.

@ tiramiseb: Tu fais bien comme moi "à l'ancienne" les nameserver dans /etc/resolv.conf et le reste dans /etc//network/interfaces sans le paquet resolvconf installé, il me semble qu'on en avaient déjà parlé?


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#25 Le 22/10/2013, à 21:48

tiramiseb

Re : [RÉSOLU] Xubuntu 13.04 inutilisable

@ tiramiseb: Tu fais bien comme moi "à l'ancienne" les nameserver dans /etc/resolv.conf et le reste dans /etc//network/interfaces sans le paquet resolvconf installé, il me semble qu'on en avaient déjà parlé?

Sur mon PC sous Ubuntu, je laisse le système faire comme il a été configuré.

Sur mon serveur sous Debian, je le fais à l'ancienne.


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

Haut de page ↑