Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/08/2007, à 20:49

sdumasp

Compiz-fusion lent

Bonjour,
J'ai fraichement installé Compiz-fusion complètement (via les dépôts Trevino) sur cet ordinateur avec Emerald en décorateur de fenêtre.
Il est parfaitement installé (je n'avais aucun Beryl ou Compiz précédent) et se lance au démarrage de l'ordinateur.
Mais je le trouve plutôt lent dans les effets visuels : lenteur dans la diminution d'une fenêtre, saccades parfois dans le déplacement d'une fenêtre etc...
Pourtant j'ai une config capable de faire tourner tout ça : Core2Duo E6600, 2Go DDR2, 8800GTS 640Mo...
Et j'ai les dernier pilotes nVidia (grâve à Envy) et un xorg.conf bien rempli :

Section "Device"
    Identifier     "GeForce 8800 GTS"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "TripleBuffer" "true"
    Option         "AddARGBGLXVisuals" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "DisableGLXRootClipping" "True"
    Option         "BackStoring" "True"
EndSection

et

Section "Extensions"
    Option         "RENDER" "Enable"
    Option         "Composite" "Enable"
EndSection

Merci d'avance!
sdumasp

Dernière modification par sdumasp (Le 27/08/2007, à 21:35)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#2 Le 23/08/2007, à 20:54

Sir Na Kraïou

Re : Compiz-fusion lent

que donnent les commandes

glxinfo | grep rendering

et

glxgears

?

Dernière modification par la 'tite gogole (Le 23/08/2007, à 20:54)


Hey, t’as vu, j’ai changé de signature ?!

Hors ligne

#3 Le 23/08/2007, à 20:57

sdumasp

Re : Compiz-fusion lent

glxinfo | grep rendering
direct rendering: Yes

et

glxgears
43932 frames in 5.0 seconds = 8786.359 FPS
41274 frames in 5.0 seconds = 8254.746 FPS
34154 frames in 5.0 seconds = 6830.758 FPS

avec Compiz-fusion et Emerald activés.

Dernière modification par sdumasp (Le 23/08/2007, à 20:59)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#4 Le 24/08/2007, à 00:48

tartifletteman

Re : Compiz-fusion lent

sdumasp a écrit :

Bonjour,
J'ai fraichement installé Compiz-fusion complètement (via les dépôts Trevino) sur cet ordinateur avec Emerald en décorateur de fenêtre.
Il est parfaitement installé (je n'avais aucun Beryl ou Compiz précédent) et se lance au démarrage de l'ordinateur.
Mais je le trouve plutôt lent dans les effets visuels : lenteur dans la diminution d'une fenêtre, saccades parfois dans le déplacement d'une fenêtre etc...
Pourtant j'ai une config capable de faire tourner tout ça : Core2Duo E6600, 2Go DDR2, 8800GTS 640Mo...
Et j'ai les dernier pilotes nVidia (grâve à Envy) et un xorg.conf bien rempli :

Section "Device"
    Identifier     "GeForce 8800 GTS"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "TripleBuffer" "true"
    Option         "AddARGBGLXVisuals" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "DisableGLXRootClipping" "True"
    Option         "BackStoring" "True"
EndSection

et

Section "Extensions"
    Option         "RENDER" "Enable"
    Option         "Composite" "Enable"
EndSection

Merci d'avance!
sdumasp

Je sais que ça ne se fait pas et que je ne vais aucunement t'aider, mais juste pour chambrer, avec mon athlon 1,4ghz, 768 Mo de RAM et une geforce FX 5200, c'est fluide ! A la limite, si tu veux, on échange nos pc, si c'est juste un compiz fusion fluide que tu veux avoir...


-moi, fou ? non, je suis juste déviant, comme l'eau...(jeu de mots minable inside)

Hors ligne

#5 Le 24/08/2007, à 09:44

sdumasp

Re : Compiz-fusion lent

lol j'avais une config quasi indentique il y a peu et je faisais aussi tourner Beryl sans problème avec les mêmes pilotes nVidia (des moins récents même) et le xorg.conf c'est celui que j'utilisais auparavant...


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#6 Le 24/08/2007, à 14:03

Sir Na Kraïou

Re : Compiz-fusion lent

T'as pas quelque chose qui bouffe du CPU à côté?


Hey, t’as vu, j’ai changé de signature ?!

Hors ligne

#7 Le 24/08/2007, à 16:52

TraxX

Re : Compiz-fusion lent

Moi aussi j'avais un compiz-fusion qui été lent cad, les animations légérement saccadées, j'ai installer XGL et la franchement c'est vraiment top!!!

Voila pour ma part, je ne sais pas si cela pourra t'aider!
@+

Hors ligne

#8 Le 24/08/2007, à 19:06

sdumasp

Re : Compiz-fusion lent

ma charge cpu est minimum en utilisation normale de l'ordinateur, je ne pense pas que ça vienne de là parce que l'ordinateur est plutôt réactif, je pencherai pour des problèmes graphiques?!

XGL c'est un moteur pour faire tourner Compiz-fusion non? je n'ai pas changé les options graphiques de Compiz-fusion donc je ne fonctionne peut-être pas sur XGL? peut-être sur nVidia? peut-être pas? pourtant nVidia est le plus approprié (d'après mes précédentes expériences avec Beryl)
comment tu installes XGL?

Dernière modification par sdumasp (Le 24/08/2007, à 19:11)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#9 Le 24/08/2007, à 19:47

Fl4t

Re : Compiz-fusion lent

Essaie cette commande :

compiz --replace  --loose-binding

Et test si c'est fluide wink


My blog : http://fl4t.blogspot.com/
Fichier Hosts : http://doc.ubuntu-fr.org/fichier_hosts_brouillon
Deviant : http://fl4t.deviantart.com/

Hors ligne

#10 Le 24/08/2007, à 19:51

sdumasp

Re : Compiz-fusion lent

ah! c'est plus fluide oui mais ça saccade toujours à certains moments...
à quoi sert cette option --loose-binding ?

EDIT : ça marche bien sur les petites fenêtres mais les grand fenêtres sont plus récalcitrantes, les effets saccadent une fois sur deux ou n'apparaissent même pas (pour la diminution par exemple) en ce qui concerne le cube, aucun problème depuis le début

Dernière modification par sdumasp (Le 24/08/2007, à 19:53)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#11 Le 24/08/2007, à 19:56

Fl4t

Re : Compiz-fusion lent

sdumasp a écrit :

ah! c'est plus fluide oui mais ça saccade toujours à certains moments...
à quoi sert cette option --loose-binding ?

EDIT : ça marche bien sur les petites fenêtres mais les grand fenêtres sont plus récalcitrantes, les effets saccadent une fois sur deux ou n'apparaissent même pas (pour la diminution par exemple) en ce qui concerne le cube, aucun problème depuis le début

A vrai dire j'en c'est rien, depuis une certaine mise a jour sa lagai chez pas mal de monde et une personne a poster sa donc j'ai essayer et maintenant c'est très fluide, mais noublie pas que c'est une beta donc il se peu qu'il y a des problèmes.
Chez moi quand je veux redimensionner à la main sa lagg très fortement et quand je fais une séléction avec le carré de séléction de la souris (je sais pas si c'est très clair..)

Dernière modification par Fl4t (Le 24/08/2007, à 19:58)


My blog : http://fl4t.blogspot.com/
Fichier Hosts : http://doc.ubuntu-fr.org/fichier_hosts_brouillon
Deviant : http://fl4t.deviantart.com/

Hors ligne

#12 Le 24/08/2007, à 21:16

sdumasp

Re : Compiz-fusion lent

sisi c'est clair smile
oui c'est une beta mais beaucoup de gens font tourner ça sans problème avec des configs moins importantes que ce que j'ai donc je pense pouvoir faire tourner ça correctement...

merci pour l'astuce, c'est toujours mieux en attendant la solution à mon problème wink


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#13 Le 25/08/2007, à 14:01

sdumasp

Re : Compiz-fusion lent

comment je fais pour avoir accès aux options graphiques de Compiz-fusion (celles auxquelles j'avais accès par le menu de Beryl-manager)?
voir si je peux changer nVidia ou XGL et voir le changement!
merci


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#14 Le 25/08/2007, à 16:51

Sir Na Kraïou

Re : Compiz-fusion lent

Ben faut installer carrément Compiz fusion, je pense


Hey, t’as vu, j’ai changé de signature ?!

Hors ligne

#15 Le 25/08/2007, à 16:58

Astier

Re : Compiz-fusion lent

XGL est une surcouche graphique au même titre que AIGLX.

Pour accéder aux options de compiz-fusion :

ccsm

Par contre il ne me semble pas que l'on puisse passer sur XGL avec un simple clic. Il faut au préalable l'installer et créer un menu de pour accéder à la session XGL dans GDM. Regarde la doc pour plus d'infos. De mémoire le paquet à installer est xserver-xgl ou un truc dans le genre.

L'utilisation d'XGL est quand même source de problèmes (vois la doc pour plus de détails).

A+

Hors ligne

#16 Le 26/08/2007, à 12:39

sdumasp

Re : Compiz-fusion lent

j'ai trouvé ça dans la doc oui effectivement
ccsm je connais mais il n'y a pas autant d'options graphiques (type nVidia ou XGL) que dans le menu de Beryl-manager précédemment, comment je fais pour trouver ce genre d'options?

Ben faut installer carrément Compiz fusion, je pense

ben j'ai tout installé de Compiz-fusion...


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#17 Le 26/08/2007, à 14:21

sdumasp

Re : Compiz-fusion lent

ok en suivant la doc et un utilisant XGL ça m'a l'air nickel
merci beaucoup
mais au démarrage de KDE il y a quelques petits problèmes graphiques genre l'écran devient marron quadrillé enfin c'est bizarre même s'il démarre correctement.

mais comment expliquer qu'il tourne mieux en XGL? il tournait en nVidia précédemment?

EDIT : Compiz-fusion fonctionne parfaitement mais au bout de 3mn, le bureau disparait puis la barre des têches (remplacés par du blanc) et il faut que je redémarre le server X...

Dernière modification par sdumasp (Le 26/08/2007, à 14:40)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#18 Le 27/08/2007, à 10:10

TraxX

Re : Compiz-fusion lent

Pour ma part XGL à résolu tous mes soucis de ralentissement.

Pour ma part j'ai aussi cette page cadrillé et je ne sais pas encore comment la supprimer, peut qu'on ne peux pas!!!Je sais pas!!!

Sinon après tout fonctionne très bien pas de problème de barre et autres.

Dsl de ne pas pouvoir t'aider plus que cela.

Bonne journée.

Hors ligne

#19 Le 28/08/2007, à 18:28

jlbiasini

Re : Compiz-fusion lent

Bonjour,

Moi je suis repassé à beryl et bien c'est pareil j'ai le même problème (mais avec un geforce fx5500)
voici mon xorg.conf

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "oss"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/input/wacom"
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "DELL E771p"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation NV34 [GeForce FX 5500]"
    Driver         "nvidia"
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "true"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "TripleBuffer" "true"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "nVidia Corporation NV34 [GeForce FX 5500]"
    Monitor        "DELL E771p"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    SubSection     "Display"
        Depth       1
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

Comme avec beryl on peut choisir j'ai essayé de mettre xgl et beng! c'est pas mieux ça plante carrement !

ce qui est drôle c'est que je peut déplacer le cube avec le plugins flou et ça tourne à fond par contre le moindre effet de fenêtre sacade...:lol:

euh je précise je n'ai pas la config indiqué en signature mais un atlhon 1.2 ghz avec la geforce fx 5500
c'est plutot vieux comme matos mais ça devrait suffir je pense...:rolleyes:

Dernière modification par jlbiasini (Le 28/08/2007, à 18:31)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#20 Le 28/08/2007, à 22:02

sdumasp

Re : Compiz-fusion lent

jlbiasini a écrit :

ce qui est drôle c'est que je peut déplacer le cube avec le plugins flou et ça tourne à fond par contre le moindre effet de fenêtre sacade...lol

mêmes symptomes manifestement, c'est vrai que c'est bizarre que le problème ne réside que dans les effets de fenêtres...


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#21 Le 30/08/2007, à 16:16

jlbiasini

Re : Compiz-fusion lent

Hihi big_smile marrant sur mon portable avec une intel 945gm ça tourne 10 fois plus vite selon glxgears !!

Je note que le même problème se pose avec metacity l'affichage des fenêtre est lent et saccadé. C'est un problème qui concerne l'affichage 2D donc.. quelqu'un à une idée ?

au secours !!! lol:lol:

edit : je viens d'essayer divers mode graphiques (résolution / color depth) mais pas mieux neutralroll

Dernière modification par jlbiasini (Le 30/08/2007, à 16:55)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#22 Le 30/08/2007, à 23:05

jlbiasini

Re : Compiz-fusion lent

A la découverte de la galère...

Bon alors pourrais-tu me dire si c'est pareil chez toi, car moi il semblerais que beryl n'y soit pour rien et je penche de plus en plus pour un problème drivers de rendu 2d.:mad:

En effet glxgears me donne sous beryl 160fps, bon mais seulement si je suis un gentil garçon big_smile

Si je commence à maltraiter (mais vraiment violent) une fenêtre, avec un peu d'entraînement j'arrive à le faire descendre à ... 0 !!! lol:lol::rolleyes::(

Mais attenttion, maintenant encore plus fort :
j'éteins beryl et je m'attaque à metacity (gestionnaire fenêtre par défaut de gnome). Là mon adversaire me nargue narquoisement avec un glxgears à 4500fps. Et ben, je prend ma sourie dans une main et un fenêtre dans l'autre et là encore je tombe le fps à 0 big_smile:D:D ouais !! big_smile cool je suis le meilleur ! MERDE !:(:( ça veux dire que ma 2D est absolument nulle !!!:(:(:(
Détail intéressant : la fenêtre utilisé sous metacity pour le noyer n'est pas la fenêtre glx mais la fenêtre terminal dans lequel j'ai tapé ma commande. Car sinon c'est impossible de le coulé ce que je m'explique justement parce que le contenu de la fenêtre glx est précisément 3D et non 2D

Je précise que metacity quand on lui met la tête sous les 20 fps commence à faire bien moins le malin et même franchement la gueule (genre Windows avec problème de rafraîchissement image...)

Bon est-ce que quelqu'un il y comprend quelque chose ou est-ce que je peux direct faire un rapport de bug à Nvidia ? lol:lol::lol:


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#23 Le 31/08/2007, à 01:55

Xinox

Re : Compiz-fusion lent

Moi aussi j'ai ce genre de ralentissement, et je pense que sa vient du driver nvidia. Il y a sûrement un bug avec l'accélération graphique et c'est le processeur qui fait tout le travail, ce qui entraîne des ralentissement.

Dans mon cas par contre, j'ai remarqué que certains effets sont fluides et d'autres au contraire le sont pas du tout. Le cube par exemple est fluide, sidestick ou dream vont a peut pret, par contre magic lamp est inutilisable smile

Hors ligne

#24 Le 31/08/2007, à 07:28

sk8glad

Re : Compiz-fusion lent

J'avais exactement le même problème de ralentissement avec en particulier le plugin animation jusqu'à ce que je change de distrib. Sous debian testing, tout est beaucoup plus fluide, plus rapide que cela n'a jamais été auparavant. Le portable de ma femme avait aussi le même problème et le passage à debian a également tout réglé. Une raison de plus (parmi de nombreuses) de passer à Debian.

Dernière modification par sk8glad (Le 31/08/2007, à 07:29)

Hors ligne

#25 Le 31/08/2007, à 09:49

jeanvalery

Re : Compiz-fusion lent

ouais bah là je dis stop! Déjà sous debian testing, paye ta recompilation de noyau pour enlever l'option de paravirtualisation pour installer les drivers nvidia... du bonheur. Ensuite, je suis curieux de savoir quelle est ta carte graphique, parce que sous debian testing j'ai aussi des pb de ralentissement, bien améliorés grace à 

compiz --replace  --loose-binding

. Sous ubuntu je reste sous beryl pour le moment, mais j'ai aussi le meme genre de pb avec beryl. Le probleme viendrait il des drivers nvidia?


Membre du club des beaux Ubunteros

Hors ligne