Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/11/2013, à 02:21

TisseFlac

[Résolu] Audacity plante constamment et périphérique de lecture change

Bien le bonjour ! smile

Je suis tout nouveau sur ce site et c'est la première fois donc que je poste un message. Soyez donc intransigeant s'il vous plaît si je n'arrive pas à vous exposer convenablement mon problème, je n'ai pas l'habitude !

Alors je suis sous Linux Mint 14, et depuis plusieurs mois, sans connaître la raison, le logiciel Audacity ne fait que planter. Généralement au bout de 5 ou 10 minutes (avec beaucoup de chances) d'utilisation pour faire mes montages son (pas d'enregistrement ici, seulement du montage) le logiciel se met à faire son Windows et ne répond plus, je ne peux plus rien faire, les boutons ne marchent plus, et quand je réduis la fenêtre et l'agrandit l'interface disparaît et une seule couleur remplit la fenêtre (à la Windows je vous dis), je suis obligé de le fermer de force.

Mais les quelques minutes où j'arrive à faire mon montage son à peu près convenablement (car le logiciel n'est pas très réactif je trouve), c'est quand la configuration reste sur "default" en périphérique de lecture et d'enregistrement (ça ne marche que sous cette configuration), car là aussi vient un autre problème : 9 fois sur 10 le choix "default" n'apparaît pas dans la liste des périphériques de lecture et d'enregistrement ! Je suis parfois obliger de redémarrer mon ordinateur 10 000 fois, fermer Audacity sous une certaine configuration pour, par pur hasard, réussir à retrouver le choix "default" qui disparaît sans cesse de la liste. Sous d'autres configurations, le son soit ne marche pas, soit est très saccadé.

Autre chose aussi, je suis obligé d'ouvrir Audacity via le terminal car je ne le trouve absolument pas dans les menus !

Alors je précise que j'ai déjà consulté pleins de forums et cherché pendant des heures des solutions. J'ai déjà désinstallé et réinstallé Audacity : sans succès. J'ai déjà supprimé complètement le dossier de configuration d'Audacity : sans succès. J'ai déjà même essayé de l'installer et l'utiliser avec le logiciel Wine : sans succès non plus ! Je ne trouve aucun sujet de forum qui ne corresponde à mon problème, et je ne comprends vraiment pas pourquoi je ne peux pas utiliser convenablement ce logiciel alors qu'il y a quelques mois de cela je le pouvais sans aucun soucis (je suis toujours rester sous le même Linux pourtant, je n'ai rien changé).

Peut-être que cette information vous sera utile, juste au cas où : ma carte son est une M-Audio Delta Audiophile 24/96 (que j'avais déjà au temps où le logiciel marchait parfaitement).

Merci d'avance d'avoir pris le temps de lire mon message et j'espère que vous pourrez me venir en aide car je suis vraiment très embêté, je dois commencer un montage son mais c'est carrément pas du tout envisageable sous ces conditions.

Merci ! big_smile

Dernière modification par TisseFlac (Le 20/11/2013, à 00:37)


C'est pas parce que ok que voilà.

Hors ligne

#2 Le 19/11/2013, à 02:42

Alfe noir

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Salut,

C'est peut-être dû à une mise à jour d'Audacity. As-tu essayé avec une version antérieur du logiciel ? Même si ça ne résout pas forcément le problème, ça permettrait de pouvoir bosser en attendant.

Hors ligne

#3 Le 19/11/2013, à 02:44

Alfe noir

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

PS : La page de téléchargement :

http://packages.ubuntu.com/search?keywo … ection=all

Hors ligne

#4 Le 19/11/2013, à 11:40

TisseFlac

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Merci pour ta solution. Je viens de voir en effet que j'ai la version 2.0.1 d'Audacity alors qu'il existe la version 2.0.5.

J'ai télécharger le fichier mais là autre problème je n'arrive pas à l'installer ! J'ai bien extrait le dossier de l'archive "audacity_2.0.5.orig.tar.xz", ouvert le terminal, mis en su-, déplacer dans le répertoire spécifique avec la commande "cd", mais après lorsque je lance la commande "./install-sh" il me sort "install: no input file specified". Je ne comprends pas, j'ai bien cherché sur internet et c'est bien la solution pour installer ce type de fichier sous Linux. Comment faire pour l'installer ? sad

En attendant de corriger le problème, je vous fais part de ce qui est écrit dans le terminal lorsque je lance Audacity :

ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Erreur d'entrée/sortie(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Erreur d'entrée/sortie(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Erreur d'entrée/sortie(5)
ALSA lib audio/pcm_bluetooth.c:1614:(audioservice_expect) BT_GET_CAPABILITIES failed : Erreur d'entrée/sortie(5)
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'ret' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1670
Expression 'AlsaOpen( &alsaApi->baseHostApiRep, params, streamDir, &self->pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1830
Expression 'PaAlsaStreamComponent_Initialize( &self->capture, alsaApi, inParams, StreamDirection_In, NULL != callback )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2092
Expression 'PaAlsaStream_Initialize( stream, alsaHostApi, inputParameters, outputParameters, sampleRate, framesPerBuffer, callback, streamFlags, userData )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2764
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541
Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4541

Je vois bien qu'il y a pleins d'erreurs au lancement, mais je ne saisis pas vraiment lesquels...

Merci encore de m'aider.

Dernière modification par TisseFlac (Le 19/11/2013, à 11:42)


C'est pas parce que ok que voilà.

Hors ligne

#5 Le 19/11/2013, à 12:28

Alfe noir

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Arf, tu peux pas le télécharger en .deb ?

Choisis le fichier en fonction de ton architecture amd64 ou i386 (si ton système est en 32 bits).

Hors ligne

#6 Le 19/11/2013, à 13:18

TisseFlac

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Merci pour le lien. J'ai essayé, j'ai téléchargé le "amd64" mais quand je veux installer le paquet (que je double-clic sur le fichier téléchargé) il me met :

Erreur : La dépendance ne peut être satisfaite : audacity-data (=2.0.5-1ubuntu3)

Je ne peux donc l'installer ! Mais mince ya quelque chose sur mon ordi qui est contre Audacity ou quoi ? ><

Help please sad

Dernière modification par TisseFlac (Le 19/11/2013, à 13:19)


C'est pas parce que ok que voilà.

Hors ligne

#7 Le 19/11/2013, à 13:42

Alfe noir

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

J'ai la même erreur en essayant d'installer le paquet 2.0.5 par contre pas de soucis pour le 2.0.3.

Hors ligne

#8 Le 19/11/2013, à 18:57

TisseFlac

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Je viens d'essayer avec la 2.0.3, et même avec d'autre versions plus anciennes mais aucune ne marche ! Il m'affiche toujours le même message lorsque je veux installer le paquet :

Erreur : La dépendance ne peut être satisfaite : audacity-data

Vraiment je ne comprends pas ! sad
Je suis en train de me prendre la tête pour trouver une solution, rien ne marche pour l'instant !

Help please sad


C'est pas parce que ok que voilà.

Hors ligne

#9 Le 19/11/2013, à 19:24

TisseFlac

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

C'est bon j'ai enfin réussi à installer Audacity 2.0.5 ! En fait j'ai à chaque fois installé le paquet (via http://packages.ubuntu.com) dont la dépendance ne pouvait être satisfaite. J'ai dû installer en tout 5 paquets à jour nécessaire pour pouvoir enfin arriver à installer la version 2.0.5 d'Audacity qui avait toujours un problème de dépendance.

Je viens de lancer Audacity et pour l'instant ça n'a pas l'air de planter, c'est même très réactif.

J'attends de voir si ça continue comme ça ou si ça plantera comme avant.

Je tiens au courant. big_smile

Dernière modification par TisseFlac (Le 19/11/2013, à 19:25)


C'est pas parce que ok que voilà.

Hors ligne

#10 Le 20/11/2013, à 00:26

TisseFlac

Re : [Résolu] Audacity plante constamment et périphérique de lecture change

Problème résolu ! big_smile

Depuis que j'ai installé la version 2.0.5 d'Audacity j'arrive enfin à faire mon montage son sans soucis. Je n'ai eu qu'un plantage au bout de 2h30 (ce qui est carrément mieux qu'avant !).

Pour pouvoir installer la dernière version d'Audacity il faut d'abord installer les paquets suivants :

libsoxr0 (0.1.1-1)
libsoundtouch0 (1.7.1-4)
libflac8 (1.3.0-2)
libflac++6 (1.3.0-2)
audacity-data (2.0.5-1ubuntu3)
(et ensuite pour terminer le logiciel lui-même) audacity (2.0.5-1ubuntu3)

Par contre pour le lancer je suis obligé de passer par le terminal et taper "audacity", il n'apparaît pas dans le menu. Mais ça c'est un détail. cool

Merci beaucoup unicorne pour ton aide qui m'a bien servi ! smile

Dernière modification par TisseFlac (Le 20/11/2013, à 00:39)


C'est pas parce que ok que voilà.

Hors ligne

Haut de page ↑