Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 20/11/2013, à 20:56

Moskito7

[RESOLU] Erreur 500 - depuis ISPConfig !

Bonsoir,

Voilà, depuis quelques temps j'héberge un serveur web et tout fonctionne correctement.
Voulant peaufiner la gestion du serveur, des services etc. je décide d'installer ISPConfig.
Mais depuis cette installation impossible de retrouver mon site il n'y a qu'une erreur 500.
A vrai dire, mon site est derrière une "page d'accueil" qui elle s'affiche correctement mais quand je clique sur le "Entrer" qui doit m'amener au site à proprement parler...
ERROR 500 - Internal Server Error! The following error occurred: The requested URL caused an internal server error. If you get this message repeatedly please contact the webmaster.

POUR INFO : Les fichiers de mon site sont déportés via un lien vers un répertoire situé dans le HOME.

Quelqu'un peut-il m'aider ? Si je désinstalle ISPConfig, est-ce que je vais retrouver ma configuration précédente ?

Merci de votre aide... C'est la panique !

Dernière modification par Moskito7 (Le 23/11/2013, à 20:58)


Asus R500VD SX666 - Ubuntu 14.04

Hors ligne

#2 Le 21/11/2013, à 09:37

mazarini

Re : [RESOLU] Erreur 500 - depuis ISPConfig !

Essayes d'afficher une page html simple dans le répertoire ou sont tes scripts pour voir si c'est un problème d'accès au fichiers ou un plantage du script.
Si c'est un plantage du script, essayes de voir les log et/ou d'activer les messages d'erreurs. Pour PHP voir error_reporting et display_error du fichier php.ini. Pour un problème similaire, j'avais fait un script php qui utilisait une variable non initialisée pour trouver comment afficher le warning avant de règler le problème de mon script. 

Il est possible qu'ispconfig modifie le paramétrage d'apache ou de PHP et provoque ainsi des erreurs. Le plus probable étant le remplacement des erreurs de script par une page "500" avec log des erreurs (configuration normale en production).


Macronite : Trouble de l'équilibre qui se manifeste par une tendance à pencher à droite

Hors ligne

#3 Le 23/11/2013, à 20:57

Moskito7

Re : [RESOLU] Erreur 500 - depuis ISPConfig !

Merci de ton aide mais ne trouvant pas ce qui clochait et vu l'urgence de la situation j'ai restauré une sauvegarde d'avant installation d'ISPconfig qui visiblement avait modifié la configuration d'apache et notamment le répertoire de stockage des fichiers de mon site Internet.

Encore merci.


Asus R500VD SX666 - Ubuntu 14.04

Hors ligne

#4 Le 23/11/2013, à 22:30

Titouan

Re : [RESOLU] Erreur 500 - depuis ISPConfig !

probablement un conflit htaccess et directives apache vhost

Hors ligne

#5 Le 26/10/2014, à 13:31

Systo

Re : [RESOLU] Erreur 500 - depuis ISPConfig !

Bonjour à tous,

Je remonte ce vieux topic car je rencontre le même problème et j'avoue être complêtement perdu.

Pour info, apache, mysql et php sont bien installés et fonctionels. (php -a fonctionne).
J'accède bien a l'interface d'ispconfig. Un fichier html s'affiche bien mais un fichier php me donne une erreur 500 dans mon browser.
Je n'ai aucune erreur dans error.log.
Je n'ai pas d'htaccess, il n'y a que deux fichiers à la racine de /var/www/html => index.html et phpinfo.php

mazarini disait que ispconfig peut modifier des config, avez-vous plus d'infos à ce sujet?

Merci d'avance

Dernière modification par Systo (Le 26/10/2014, à 13:35)

Hors ligne

#6 Le 27/10/2014, à 03:06

chefdelegion

Re : [RESOLU] Erreur 500 - depuis ISPConfig !

ISPCONFIG a des problemes avec apache de la version de ubuntu 14.04 j'ai recu pas mal de merde depuis la mise a jour. Utilise une Debian ou comme moi une Centos et depuis aucun soucis.

Tu peux en revenche utiliser Vesta Control Panel qui est une sorte de ISPConfig egalement.


Xubuntu  14.04 LTS sur tous les postes.
Debian/FreeBSD pour les serveurs.
OMV/FreeNAS pour les serveurs NAS/SAN
Windows server 2008 R2 Virtualise pour (Adobe ...)

Hors ligne

Haut de page ↑