Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 28/10/2007, à 21:18

jajax pas connecté

Re : Problème droit disque dur externe ntfs auto-alimenté

hello

je passe rapido...

ça me donne sur mon portable (car ça marche pas non plus) :

groups
jajax adm disk dialout cdrom floppy audio dip video plugdev lpadmin scanner fuse admin vboxusers

j'ai essayé de rajouter comme groupes =>

- fuse => idem
- disk => idem

j'ai le message suivant :

hal-storage-removable-mount-all-options refused uid 1000

j'essaierais sur mon fixe tout à l'heure mais à mon avis...

note : seule différence sur mon PC portable => il n'y a pas d'entrée pour ce disque USB dans fstab.

#27 Le 29/10/2007, à 01:17

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

encore moi

sur PC fixe, ça marche pas plus pourtant =>

jaja@athlon64:~$ groups
jaja adm disk dialout cdrom floppy audio dip video plugdev scanner netdev lpadmin powerdev admin fuse vboxusers

@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#28 Le 29/10/2007, à 12:17

scholi

Re : Problème droit disque dur externe ntfs auto-alimenté

Il me semble que je t'ai déjà donné la solution...

Un disque NTFS ayant des erreurs (mais fonctionnant parfaitement bien sous windows ou en root sous Linux) ne se montera pas automatiquement!!!! Pour ça il faut faire un scan disque et après tout est ok.

Vu que t'as pas windows, copie tes données (en le montant en root) et format le en autre chose que NTFS. Je vois pas vraiment l'intérêt de garder du NTFS si on a pas windows. Ext3 c'est tellement mieux.

Dernière modification par scholi (Le 29/10/2007, à 12:19)


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#29 Le 29/10/2007, à 12:20

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

et moi je te répète :

- que je ne monte ce disque que sous linux
- que si je le monte via disk & filesystem, ça marche...


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#30 Le 29/10/2007, à 12:57

bruno

Re : Problème droit disque dur externe ntfs auto-alimenté

jajax peux-tu essayer ceci :

sudo cp "/etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi" "/usr/share/hal/fdi/policy/10osvendor/"

Si ce fichier existe chez toi. (voir ce bug : https://bugs.launchpad.net/ubuntu/+source/hal/+bug/115768)

Dernière modification par bruno (Le 29/10/2007, à 13:01)

Hors ligne

#31 Le 29/10/2007, à 15:41

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

sur le PC fixe => aucune sortie !

jaja@athlon64:~$ sudo cp "/etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi" "/usr/share/hal/fdi/policy/10osvendor/"
[sudo] password for jaja:
jaja@athlon64:~$

@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#32 Le 29/10/2007, à 16:11

scholi

Re : Problème droit disque dur externe ntfs auto-alimenté

jajaX a écrit :

et moi je te répète :

- que je ne monte ce disque que sous linux
- que si je le monte via disk & filesystem, ça marche...

primo je vois pas le rapport avec le faite que tu le montes seulement sous Linux. Du NTFS reste du NTFS. Donc monté que sous Linux ça change rien. Des erreurs de disque ça arrive.... Oui ça marche peut-être sous disk & filesystem, mais c'est comme si root le montait (non?).

Pourquoi as-tu besoin de NTFS si c'est pour Linux???? Je pige vraiment pas l'intérêt à part avoir plein de problèmes (merci bilou).


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#33 Le 29/10/2007, à 16:20

amkoolgarst

Re : Problème droit disque dur externe ntfs auto-alimenté

jajaX a écrit :

sur le PC fixe => aucune sortie !

jaja@athlon64:~$ sudo cp "/etc/hal/fdi/policy/20-ntfs-config-write-policy.fdi" "/usr/share/hal/fdi/policy/10osvendor/"
[sudo] password for jaja:
jaja@athlon64:~$

Comment aucune sortie? Qu'entends-tu? ça me parait normale pour une copie...Qu'en est-il des erreurs que tu avais auparavant?


Jifya moja haliinjiki chungu.
In girum imus nocte, ecce, et consumimur igni.

Hors ligne

#34 Le 29/10/2007, à 17:24

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

scholi : il est formaté en ntfs car je l'utilise personnellement et professionnellement.

pour le montage, c'est en root effectivement quand je passe par disk&filesytem. j'ai redis ça pour confirmer que comme le montage se fait "bien" c'est que le disque (et son système de fichier) sont propre. je n'ai aucun message d'erreur et je peux naviguer dans le disque sans erreur.
c'est donc bien un problème droit concernant mon compte utilisateur.

amkoolgarst : oups j'ai copier/coller la ligne ans faire attention. je pensais que je devais avoir "une sortie" ou confirmation. je te dirais plus tard, là le PC est pas dispo.

edit : le problème ne date pas d'hier => http://forum.ubuntu-fr.org/viewtopic.php?id=136832&p=1

Dernière modification par jajaX (Le 29/10/2007, à 17:58)


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#35 Le 29/10/2007, à 19:46

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

bon j'ai enfin eu accés au PC et ça n'a rien changé hmm


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#36 Le 29/10/2007, à 21:03

urashima82

Re : Problème droit disque dur externe ntfs auto-alimenté

Salut jajaX,
As-tu essayé de monter ton disque dur selon ma méthode à la page 1, j'ai aussi décrit une méthode "bourrine" pour ajouter ton user aux group.
Car selon moi tu es revenue a ton problème de départ.

Hors ligne

#37 Le 29/10/2007, à 21:37

scholi

Re : Problème droit disque dur externe ntfs auto-alimenté

si tu fais:

sudo mount /dev/xxx /media/yyy

où xxx est ton périphérique et yyy un dossier valable, il te sort quoi comme message?


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Hors ligne

#38 Le 29/10/2007, à 22:28

jajax pas connecté

Re : Problème droit disque dur externe ntfs auto-alimenté

alors, j'allume mon rack. j'annule la fenêtre car de toute façon...

dans un terminal, si je tapes

sudo mount /dev/sdb1 /media/sdb1

ça marche...

#39 Le 29/10/2007, à 22:30

urashima82

Re : Problème droit disque dur externe ntfs auto-alimenté

Yop,
Le problème c'est que tu ne devrais pouvoir y acceder qu'en root et que même si tu peux lister les fichiers ne peux faire aucune opération je me trompe?

Dernière modification par urashima82 (Le 29/10/2007, à 22:33)

Hors ligne

#40 Le 29/10/2007, à 23:32

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

si je tape la commande plus haut avec mon rack allumé => le disque se monte et je peux faire ce que je veux.

si j'essaie de "l'enlever en toute sécurité" via l'icone sur le bureau =>

Malheureusement, le répertoire system:/media/sdb1 (/dev/sdb1) nommé nouveau nom et actuellement monté dans /media/sdb1 n'a pu être démonté.

le démontage a échoué en raison de l'erreur suivante :

Device tu unmount is not in /media/.hal-mtab so it is not mounted by HAL

contenu de mon mtab (rack allumé) :

/dev/hda2 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda6 /home ext2 rw 0 0
/dev/sda5 /media/sda5 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sda1 /media/sda1 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/hdc1 /media/hdc1 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/hdb1 /media/hdb1 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
/dev/sdb1 /media/sdb1 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0

@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#41 Le 29/10/2007, à 23:39

urashima82

Re : Problème droit disque dur externe ntfs auto-alimenté

Yop,
Je ne saurais te dire si l'erreur vient de là mais essaye de le monter avec l'option ntfs-3g au lieu de fuseblk.
Sinon fait un

sudo umout /media/sdb1

pour le démonter.
Si ça ne marche toujours pas et qu'il te renvoit une erreur comme quoi le disque est toujours occuper je te renvois au ntfs-3g qui te permet de bien gérer le ntfs à le difference de fuseblk.

Hors ligne

#42 Le 30/10/2007, à 00:53

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

hello

si je change cette valeur dans mtab, le disque veut plus se démonter.

si je regarde le dernier post du lien que bruno a donné sur le launchpad, j'ai regardé aussi mon fichier .xsession-errors

kded: ERROR: mount failed for /org/freedesktop/Hal/devices/volume_uuid_FCDC38B3DC386A52: org.freedesktop.Hal.Device.Volume.PermissionDenied - Device /dev/sdb1 is listed in /etc/fstab. Refusing to mount.
kded: ERROR: mounting /org/freedesktop/Hal/devices/volume_uuid_FCDC38B3DC386A52 returned Autorisations refusées

@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#43 Le 30/10/2007, à 03:41

urashima82

Re : Problème droit disque dur externe ntfs auto-alimenté

Bon ce n'est plus un secret, Hal a du mal à gérer certains disque dur externe ntfs en usb. Mais il suffit de l'aider un peu.

Bon voilà ce que je ferais si j'étais à ta place :

- Commente la ligne(ajouter # au début de la ligne) dans ton fstab du device sdb1.
- Arrete ton pc.
- Débranche ton rack.
- Démarre ton pc.
- Lorsque tu as ouvert ta session kde rebranche ton disque, une icone de clef usb devrait apparaître.
- Ouvre un terminal et fais :

sudo mount -a -o ntfs-3g /dev/sdb1 /media/sdb1

Une petite fleche verte sur le coin droit de l'icone devrait apparaître.

- Teste ton disque dur (lecture, ecriture)
- Si pb fais un nouveau post, sinon teste le démontage :

sudo umount /media/sdb1

Voilà, c'est la seule solution fiable que j'ai à t'apporter.
Préviens moi si tu as des problèmes lors de cette démarche.

Et si tout marche mais que tu trouve ça long, fais-toi un petit bash script à lancer en sudo.

Hors ligne

#44 Le 30/10/2007, à 09:31

bruno

Re : Problème droit disque dur externe ntfs auto-alimenté

Je n'ai pas de DD en NTFS pour tester cela, mais en suivant la procédure indiquée dans le rapport de bug que j'ai cité, on doit pouvoir créer un fichier texte contenant ceci :

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">

<!-- file created by ntfs-config -->
<!-- mount ntfs volume with the ntfs-3g driver to enable write support -->

    <device>
        <match key="volume.fstype" string="ntfs">
                    <match key="@block.storage_device:storage.hotpluggable" bool="true">
                            <merge key="volume.fstype" type="string">ntfs-3g</merge>
                <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
                            <append key="volume.mount.valid_options" type="strlist">locale=</append>
                </match>
            </match>
    </device>

</deviceinfo>

et l'enregistrer sous (en tant que root) :

/usr/share/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi

ou installer ntfs-config et copier ce fichier comme je l'ai indiqué.

Dernière modification par bruno (Le 30/10/2007, à 09:33)

Hors ligne

#45 Le 30/10/2007, à 14:52

jajaX

Re : Problème droit disque dur externe ntfs auto-alimenté

urashima82 => j'ai pas redémarré vu les soucis que certains ont en ce moment (avec les freezes) que j'ai aussi sur mon PC portable. mon PC (fixe) marche nikel et je préfère pas pour le moment.

mais j'ai quand même essayer ta ligne de commande, ça donne :

jaja@athlon64:~$ sudo mount -a -o ntfs-3g /dev/sdb1 /media/sdb1
mount: according to mtab, /dev/sdb1 is already mounted on /media/sdb1

FUSE mount point creation failed
Unmounting /dev/sdb1 (Nouveau nom)

hier, j'ai réessayer la ligne de commande concernant le bug sur launchpad. (j'ai pourtant rien fumé mais) il y a du changement. dès que je fais "ouvrir dans une nouvelle fenêtre", j'ai ce message (au bout d'un certains temps) :

did not receive a reply. Possible cause include : the remote application did not send a reply, the message bus security policy blocked the reply, the replys timout the reply, or the netwrok connection is broken.

j'ai aussi ça dans .xsessionerrors :

kded: ERROR: mount failed for /org/freedesktop/Hal/devices/volume_uuid_FCDC38B3DC386A52: org.freedesktop.DBus.Error.NoReply - Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
kded: ERROR: mounting /org/freedesktop/Hal/devices/volume_uuid_FCDC38B3DC386A52 returned Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

bruno : ntfs-config est déjà installer et fonctionne wink


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8
HP dv7 2230f et HP Compaq NX6310 sous Kubuntu Precise Pangolin 12.04 (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#46 Le 30/10/2007, à 19:02

urashima82

Re : Problème droit disque dur externe ntfs auto-alimenté

Yop,
Concernant ma ligne de commande ça ne sert à rien si ton device est déjà monté part défaut.
Essaye d'abord de faire un

sudo umount /media/sdb1

Et ensuite retape mes ligne de commande plus haut.

Hors ligne

#47 Le 01/11/2007, à 15:50

compte supprimé

Re : Problème droit disque dur externe ntfs auto-alimenté

bruno a écrit :
urashima82 a écrit :

On peut regarder les droits d'accès aux périphériques dans /dev (avec une commande ls -l par exemple). Par exemple les périphériques de type bloc /dev/hd* ou /dev/sd* sont accessibles en lecture écriture au groupe disk. Dans certaines circonstances il peut donc être utile d'ajouter l'utilisateur au groupe disk pour obtenir ces droits.

$ ls -l /dev/ | grep "\ sd."
brw-rw---- 1 root   disk        8,   0 2007-10-29 21:38 sda
brw-rw---- 1 root   disk        8,   1 2007-10-29 21:38 sda1
brw-rw---- 1 root   disk        8,  10 2007-10-29 20:40 sda10
brw-rw---- 1 root   disk        8,  11 2007-10-29 21:38 sda11
brw-rw---- 1 root   disk        8,  12 2007-10-29 20:40 sda12
brw-rw---- 1 root   disk        8,   2 2007-10-29 21:38 sda2
brw-rw---- 1 root   disk        8,   5 2007-10-29 20:40 sda5
brw-rw---- 1 root   disk        8,   6 2007-10-29 21:38 sda6
brw-rw---- 1 root   disk        8,   7 2007-10-29 20:40 sda7
brw-rw---- 1 root   disk        8,   8 2007-10-29 20:40 sda8
brw-rw---- 1 root   disk        8,   9 2007-10-29 20:39 sda9
brw-rw---- 1 root   disk        8,  16 2007-10-29 21:38 sdb
brw-rw---- 1 root   disk        8,  17 2007-10-29 21:38 sdb1
brw-rw---- 1 root   plugdev     8,  32 2007-10-29 21:38 sdc
brw-rw---- 1 root   plugdev     8,  33 2007-10-29 21:38 sdc1
brw-rw---- 1 root   plugdev     8,  48 2007-10-29 20:38 sdd
brw-rw---- 1 root   plugdev     8,  49 2007-10-29 20:39 sdd1
brw-rw---- 1 root   plugdev     8,  53 2007-10-29 20:39 sdd5
brw-rw---- 1 root   plugdev     8,  64 2007-10-29 20:38 sde
brw-rw---- 1 root   plugdev     8,  65 2007-10-29 20:39 sde1
brw-rw---- 1 root   plugdev     8,  69 2007-10-29 20:39 sde5
brw-rw---- 1 root   plugdev     8,  80 2007-10-29 22:07 sdf
brw-rw---- 1 root   plugdev     8,  81 2007-10-29 22:07 sdf1

Je suppose donc que c'est pas bon le root   plugdev ?

sudo chown root:disk /dev/sd*

?

#48 Le 01/11/2007, à 16:22

bruno

Re : Problème droit disque dur externe ntfs auto-alimenté

Si c'est bon ! De toute façon tes périphériques seront récréés au prochain démarrage/branchement comme appartenant à root et au groupe plugdev.

Pour info :
- les fichiers de périphériques pur les disques durs fixes sont créés au démarrage (par udev) comme appartenant à root et au groupe disk. En principe l'utilisateur n'a pas à appartenir au groupe disk car ces disques sont probablement montés automatiquement grâce aux entrées correspondante dans /etc/fstab

- les fichiers de périphériques pour les médias amovibles sont créés lors du branchement du périphérique (par hal) comme appartenant à root et au groupe plugdev. En principe l'utilisateur appartient au groupe plugdev (voir avec la commande groups) ce qui lui permet de monter ceux-ci sans les privilèges super-utilisateur.

(merci de corriger si je dis des bêtises smile)

Encore une fois les problèmes de montage des périphériques amovibles (en NTFS tout du moins) semblent venir des fichiers policy de hal. Les messages d'erreurs semblent l'indiquer clairement, pourquoi je l'ignore ... d'autant que les fichiers dans /usr/share/hal/fdi/policy/10osvendor semblent contenir toutes les options nécessaires.

Hors ligne

#49 Le 02/11/2007, à 13:26

jajax pas connecté

Re : Problème droit disque dur externe ntfs auto-alimenté

hello

je passe rapido pour dire que cela fonctionne big_smile

apparement notre ami HAL n'est pas en cause mais c'est fuse qui pose problème (merci google smile). une petit problème de droits...

il suffit d'ouvrir le fichier /etc/fuse.conf et de décommenter la ligne

user_allow_other

note : il faut enlever toutes les lignes concernant le disque dans mtab et fstab (media usb éteint)
je ne sais pas si les manips d'avant sont à prendre en compte ou pas.
j'essaierai d'aller sur le launghpad pour donner la solution. mais si quelqu'un veut le faire avant moi, je n'y vois aucun inconvénients wink

#50 Le 02/11/2007, à 20:36

bruno

Re : Problème droit disque dur externe ntfs auto-alimenté

Merci jajax voilà une info qui va être bien utile smile

Hors ligne

Haut de page ↑