Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 13/12/2013, à 22:50

Elyis

Problème d'installation (Game Develop)

Bonsoir toute la communauté,

Je viens de commencer à utiliser ubuntu (donc j'ai la dernière version 13.10) car j'en avais assez de windows ^^.
Bref c'est ma vie XD (je l'ai fait entre deux khôlles maths spé oblige ^^).

Je souhaitais créer mon "jeux vidéo" tout en ne sachant pas coder ni même utiliser le terminal (que ce soit sur windows ou ubuntu).
J'ai donc choisi Game Develop qui est disponible en français et téléchargeable pour la 13.10 de ubuntu.
Je le télécharge, *le temps passe*, je le dézip vu que c'est un .tar.bz2 et que je ne connais pas la moindre ligne commande et que j'y comprend (pour l'instant j'éspère) rien du tout, la je vois un fichier .sh, je le met en "can be run like a program" je le lance, et la directement une erreur : ./GDEditor: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory.
Pouvez vous m'aider ? (tout en sachant que je sais strictement rien faire à  part rajouter des app via le software laucher, et tapper mon mot de passe XD.

Merci à vous ^^.
Elyis.

Hors ligne

#2 Le 14/12/2013, à 00:06

abelthorne

Re : Problème d'installation (Game Develop)

Il lui manque des bibliothèques de fonctions. Il y a probablement un bout de doc avec ton soft qui liste les différentes dépendances (les autres logiciels dont il a besoin).
Je ne sais pas s'il veut les biblis de développement ou celles pour une utilisation normale donc dans un premier temps, tente d'installer le paquet libopenal1 (sudo apt-get install libopenal1 dans un terminal). S'il te remet le même message après, essaie d'installer le paquet de développement (sudo apt-get install libopenal-dev).

Il y aura certainement d'autres paquets à installer...

EDIT : je vois qu'il y a un "Game Develop" disponible dans la Logithèque. C'est le soft en question ? Si c'est le cas, tu devrais l'installer depuis là (paquet gamedevelop dans la Logithèque ou sudo apt-get install gamedevelop) plutôt que manuellement, il installera normalement toutes les dépendances nécessaires.

Dernière modification par abelthorne (Le 14/12/2013, à 00:08)

Hors ligne

#3 Le 14/12/2013, à 00:15

Elyis

Re : Problème d'installation (Game Develop)

Bonsoir ^^
Maintenant j'ai un nouveau message d'erreur --' (heureusement que me dit souvent du bien de ubuntu sinon j'aurais jamais tenté l'aventure XD, en prépa on fait pas beaucoup d'info ^^)
./GDIDE: error while loading shared libraries: libgailutil.so.18: cannot open shared object file: No such file or directory

Oui j'ai vu aussi ce packet, je clique sur le lien qui est en bas et ça ne marche pas --' ça me met "not found" et pour le terminal voici ce que ça me marque : "E: Unable to locate package gamedevelop
" (j'ai essayer avec le Terminal de base et Terminology qui est beaucoup plus joli ^^)

Hors ligne

#4 Le 14/12/2013, à 00:32

abelthorne

Re : Problème d'installation (Game Develop)

Elyis a écrit :

Maintenant j'ai un nouveau message d'erreur --' (heureusement que me dit souvent du bien de ubuntu sinon j'aurais jamais tenté l'aventure XD, en prépa on fait pas beaucoup d'info ^^)
./GDIDE: error while loading shared libraries: libgailutil.so.18: cannot open shared object file: No such file or directory

sudo apt-get install libgail18
Mais ce serait bien de regarder dans ton dossier ou sur le site du soft s'il y a la liste des biblis dont il a besoin, parce que s'il y en a 50, on a pas fini...

Oui j'ai vu aussi ce packet, je clique sur le lien qui est en bas et ça ne marche pas --' ça me met "not found" et pour le terminal voici ce que ça me marque : "E: Unable to locate package gamedevelop
" (j'ai essayer avec le Terminal de base et Terminology qui est beaucoup plus joli ^^)

Ah, effectivement, il n'y a apparemment pas de paquet gamedevelop dans les dépôts. Bizarre.

Hors ligne

#5 Le 14/12/2013, à 16:55

Elyis

Re : Problème d'installation (Game Develop)

Rebonjour,

J'ai ouvert le fichier .sh pour mieux connaitre les dépendances :

Veuillez installer les paquetages <b>\"ia32-libs\"</b>, \"libc6-dev-i386\" et \"g++-multilib\" avant de lancer Game Develop: Cherchez les dans la <i>logithèque</i>
Veuillez installer les paquetages <b>\"libc6-dev-i386\"</b> et \"libc6-dev-i386\" avant de lancer Game Develop: Cherchez les dans la <i>logithèque</i>
Veuillez installer le paquetage <b>\"g++-multilib\"</b> avant de lancer Game Develop: Cherchez le dans la <i>logithèque
Voila les différents type d'erreur préenregistrer dans le fichier d'initialisation ^^.

J'ai également essayer de le lancer sur un autre pc voilà ce que ça me dit  :
/home/elyis/Downloads/Game Develop/StartGameDevelop.sh: 37: /home/elyis/Downloads/Game Develop/StartGameDevelop.sh: ./GDIDE: not found
(j'ai bien sur autorisé le lancement en tant que programme pour GDIDE et pour le .sh)

Hors ligne

#6 Le 14/12/2013, à 17:16

abelthorne

Re : Problème d'installation (Game Develop)

Si je comprends bien ce que tu fais à la fin, le message d'erreur vient du fait que tu n'es pas dans le bon dossier : tu lances le script en indiquant le chemin complet et il cherche GDIDE dans le dossier courant (.) et comme le dossier courant n'est pas celui du soft, il ne le trouve pas...
C'est une erreur assez courante et quand on lance un logiciel en ligne de commande/par script, il vaut mieux toujours se placer dans son dossier avant (pas besoin pour tout ce qui est commandes et softs installés par le système : ils le font déjà proprement). Donc cd /home/elyis/Downloads/Game Develop puis ./StartGameDevelop.sh

Pour ce qui est des autres paquets dont tu parles, ça risque de se compliquer un petit peu : ils sont en rapport avec multiarch, le système qui permet de lancer des logiciels 32 bits sur un environnement 64 bits (et de charger les bonnes biblis). Mais le fonctionnement de multiarch a changé avec Ubuntu 13.10 et ia32-libs n'existe plus (c'était un "faux" paquet qui installait simplement les paquets de toutes les biblis courantes en versions 32 bits).

Donc essaie de lancer ton soft pour voir s'il te dit encore qu'il manque des biblis.

Hors ligne

#7 Le 14/12/2013, à 18:04

Elyis

Re : Problème d'installation (Game Develop)

Bon bin c'est fini, en gros XD,
voila ce que mon deuxième ordi me dit : Veuillez installer les paquetages "ia32-libs", "libc6-dev-i386" et "g++-multilib" avant de lancer Game Develop: Cherchez les dans la logithèque.
voila --'.

Merci de m'avoir appris comment naviguer dans les dossiers, et comment résoudre ce problème ^^.

Hors ligne

#8 Le 14/12/2013, à 18:05

Elyis

Re : Problème d'installation (Game Develop)

Désolé pour le double post, le premier ordi est toujours bloqué aussi ^^ mais à libgailutil.so.18: cannot open shared object file: No such file or directory.
Pourquoi des bugs (enfin ça c'est pas grave ^^), mais pourquoi a deux endroits différents ? Oo

Hors ligne

#9 Le 14/12/2013, à 18:43

abelthorne

Re : Problème d'installation (Game Develop)

Est-ce que les deux ordis ont la même version d'Ubuntu ? dans la même archi (32 ou 64 bits) ?

Pour celui qui te dit d'installer ia32-libs, etc. essaie sudo apt-get install libc6-dev-i386 g++-multilib
Pour celui qui te parle de libgaiutil.so.18 : sudo apt-get install libgail18 ou sudo apt-get install libgail18:i386 si tu es en 64 bits et que ton soft veut des biblis 32 bits.

Ce ne sont pas des bugs, simplement tu as un logiciel qui a besoin de bibliothèques de fonctions (comme à peu près n'importe quel soft) et comme tu l'as téléchargé tel quel, il faut tout installer à la main. Et dans la bonne archi.

Dernière modification par abelthorne (Le 14/12/2013, à 18:44)

Hors ligne

#10 Le 14/12/2013, à 18:53

Elyis

Re : Problème d'installation (Game Develop)

Les deux sont sur un ubuntu 13.10 avec une archi 64bits provenant de la même clé ^^.
Euh l'ordi qui me dit d'installer la ia32-libs il continue de me la demander.
Et pour l'autre bin je l'ai pas sous la main dsl ^^

Hors ligne

#11 Le 14/12/2013, à 19:37

Elyis

Re : Problème d'installation (Game Develop)

Si c'est compiler pour ubuntu 12.10 alors je peux pas l'utiliser en 13.10 ?

Hors ligne

#12 Le 14/12/2013, à 20:32

abelthorne

Re : Problème d'installation (Game Develop)

Elyis a écrit :

Euh l'ordi qui me dit d'installer la ia32-libs il continue de me la demander.

Le problème, c'est que le paquet ia32-libs n'existe plus dans les dépôts d'Ubuntu 13.10. Si ton soft vérifie les paquets (et pas seulement la présence de ce dont il a besoin), non seulement il est mal foutu mais ça va compliquer les choses...

Elyis a écrit :

Si c'est compiler pour ubuntu 12.10 alors je peux pas l'utiliser en 13.10 ?

Qu'est-ce que tu appelles "compilé pour Ubuntu 12.10" ?

Dernière modification par abelthorne (Le 14/12/2013, à 20:33)

Hors ligne

#13 Le 14/12/2013, à 20:59

Elyis

Re : Problème d'installation (Game Develop)

Je voulais dire par là que l'éditeur du soft propose uniquement un téléchargement pour la 12.10 de ubuntu ^^

Hors ligne

#14 Le 14/12/2013, à 21:05

Elyis

Re : Problème d'installation (Game Develop)

je viens de trouver un topic peut être interressant :
"You could open the "Start Game Develop" script and delete all the checks made.
You basically just need the "export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:." line and then "./GDIDE"." (écrit par le créateur du soft en parlant de StartGameDevelop.sh
Je viens de la faire sur mon ordi j'obtiens désormais :
"
./GDIDE: error while loading shared libraries: libSM.so.6: cannot open shared object file: No such file or directory"

Hors ligne

#15 Le 14/12/2013, à 21:25

abelthorne

Re : Problème d'installation (Game Develop)

Alors attention à bien faire la commande export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. dans le dossier du jeu. Ça implique vraisemblablement que les biblis dont il a besoin sont dans son dossier : la commande en question ajoute le dossier courant à la liste des dossiers dans lesquels le système va chercher les biblis avant de dire "je les trouve pas, il faut les installer".

Si tu as tapé la commande en étant au bon endroit et que tu as le message d'erreur dont tu parles, il y a un paquet libsm6 dans les dépôts. Je ne sais pas du tout si c'est la bibli dont il a besoin mais tu peux tenter de l'installer avec sudo apt-get install libsm6 pour voir.

Hors ligne

#16 Le 14/12/2013, à 21:32

Elyis

Re : Problème d'installation (Game Develop)

Je viens de faire sudo apt-get install libsm6, mais il m'affiche toujours le même message d'erreur --'.
Je me demande si je dois abandonner ou pas là ^^

Hors ligne

#17 Le 14/12/2013, à 22:19

abelthorne

Re : Problème d'installation (Game Develop)

Le plus important : quand tu as tapé la commande export, tu étais bien dans le dossier du jeu ? Tu n'as pas fermé/rouvert le terminal entre temps ?

Hors ligne

#18 Le 14/12/2013, à 22:21

Elyis

Re : Problème d'installation (Game Develop)

non j'étais toujours dans le dossier du soft, mais en fait le .sh on peut le faire en ligne commande nan ?

Hors ligne

#19 Le 14/12/2013, à 22:24

Elyis

Re : Problème d'installation (Game Develop)

bon changement d'erreur (pourtant j'ai fais exactement la même chose --') :
"./GDIDE: error while loading shared libraries: libgailutil.so.18: cannot open shared object file: No such file or directory"

Hors ligne

#20 Le 14/12/2013, à 22:31

abelthorne

Re : Problème d'installation (Game Develop)

On est d'accord que tu fais ça ?

cd /home/elyis/Downloads/Game\ Develop
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
./StartGameDevelop.sh

Dernière modification par abelthorne (Le 14/12/2013, à 22:31)

Hors ligne

#21 Le 14/12/2013, à 22:35

Elyis

Re : Problème d'installation (Game Develop)

tout à fait d'accord ^^

Hors ligne

#22 Le 14/12/2013, à 22:44

abelthorne

Re : Problème d'installation (Game Develop)

Qu'est-ce qu'il y a dans le dossier de Game Develop (/home/elyis/Downloads/Game Develop) ?

Hors ligne

#23 Le 14/12/2013, à 22:48

Elyis

Re : Problème d'installation (Game Develop)

euh il y a une commande pour faire une liste ? ^^

Hors ligne

#24 Le 14/12/2013, à 23:25

abelthorne

Re : Problème d'installation (Game Develop)

ls /home/elyis/Downloads/Game\ Develop

(ou tu fais une capture d'écran)

Hors ligne

#25 Le 14/12/2013, à 23:26

Elyis

Re : Problème d'installation (Game Develop)

7zS.sfx                        libsfml-system.so.2
config.txt                     libsfml-window.a
CppPlatform                    libsfml-window.so.2
errorMsgWhileLoadingGD.txt     libsndfile.so.1
Examples                       libwebkitgtk-1.0.so.0
GDIDE                          libwx_baseu-2.9.so.5
icon.ico                       libwx_baseu_net-2.9.so.5
Informations-en.rtf            libwx_baseu_xml-2.9.so.5
Informations-fr.rtf            libwx_gtk2u_adv-2.9.so.5
JsPlatform                     libwx_gtk2u_aui-2.9.so.5
libenchant.so.1                libwx_gtk2u_core-2.9.so.5
libFLAC.so.8                   libwx_gtk2u_gl-2.9.so.5
libfreetype.so.6               libwx_gtk2u_html-2.9.so.5
libGDCore.so                   libwx_gtk2u_propgrid-2.9.so.5
libGDCpp.so                    libwx_gtk2u_qa-2.9.so.5
libgeoclue.so.0                libwx_gtk2u_ribbon-2.9.so.5
libGLEW.so.1.8                 libwx_gtk2u_richtext-2.9.so.5
libicudata.so.48               libwx_gtk2u_stc-2.9.so.5
libicui18n.so.48               libwx_gtk2u_webview-2.9.so.5
libicuuc.so.48                 libwx_gtk2u_xrc-2.9.so.5
libjavascriptcoregtk-1.0.so.0  License-en.rtf
libopenal.so.1                 License-fr.rtf
libsfml-audio.a                locale
libsfml-audio.so.2             res
libsfml-graphics.a             Ressources
libsfml-graphics.so.2          SelectLanguage-en.cfg
libsfml-main.a                 SelectLanguage-fr.cfg
libsfml-network.a              StartGameDevelop.sh
libsfml-network.so.2           StartGameDevelop.sh~
libsfml-system.a               Templates

Hors ligne

Haut de page ↑