Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/09/2007, à 23:16

Enayem

[Résolu] Problème avec libasound2 pour l'installation de wine

Bonjour,
J'ai envie d'essayer wine, après lecture du tuto sur ce site, j'ai compris qu'il suffisait d'un apt-get install wine mais la message d'erreur :

sudo apt-get install wine
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Reading state information... Fait       
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  wine: Dépend: lib32asound2 (> 1.0.12) mais ne sera pas installé
E: Paquets défectueux

Problème de dépendances !! pas de problème sous ubuntu tout se règle par apt-get, donc j'essaye apt-get install lib32asound2

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Reading state information... Fait       
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  lib32asound2: Dépend: libasound2 (= 1.0.13-1ubuntu5) mais 1.0.14-1ubuntu6 devra être installé
E: Paquets défectueux

La c'est de plus en plus bizarre, mais bon le point bloquant c'est apt-get install libasound2 :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Reading state information... Fait       
libasound2 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Quel est la solution ?


Ma config : proc AMD 64x2 + carte Nvidia F8
Merci, Enayem.

Dernière modification par Enayem (Le 12/09/2007, à 08:33)

Hors ligne

#2 Le 11/09/2007, à 06:20

csat18

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

Bonjour

Fait
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get clean all
sudo apt-get update
sudo aptitude dist-upgrade (si aptitude en fonctionne pas : sudo apt-get install aptitude et recommence)
et la il devrait te proposer de résoudre tes dépendances

Hors ligne

#3 Le 11/09/2007, à 16:19

Enayem

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

csat18 a écrit :

Bonjour

Fait
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get clean all
sudo apt-get update
sudo aptitude dist-upgrade (si aptitude en fonctionne pas : sudo apt-get install aptitude et recommence)
et la il devrait te proposer de résoudre tes dépendances

J'ai effectué tout ce que tu m'as recommandé de faire, tout c'est passé sans problème.
Il ne m'a pas proposer de résoudre mes dépendances


Résultat pour aptitude dist-upgrade

sudo aptitude dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Reading state information... Fait       
Reading extended state information      
Initializing package states... Fait
Building tag database... Fait      
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.

Et toujours la même réponse pour apt-get install wine




Edit : en cherchant sur le forum j'ai trouvé une approche de réponse :

kallagane a écrit :

en faite , il fallait que je force la version  1.0.13-1ubuntu5 de libasound2

Comment faire comme notre chère kallagane et forcé la version de libasound2 ?!!!

Dernière modification par Enayem (Le 11/09/2007, à 16:34)

Hors ligne

#4 Le 11/09/2007, à 17:10

brakbabord

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

Houla, c'est un peu risqué ce bidouillage.

Mais bon en fait tu recherche le paquet dans Synaptic, tu clic dessus, et tu ouvres le menu "Paquet" -> "Forcer la version"

Hors ligne

#5 Le 12/09/2007, à 08:33

Enayem

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

ça fonctionne, l'installation s'est effectué avec succès, merci brakbabord.

Par contre configurer correctement wine est une autre histoire.

Merci encore de m'avoir indiqué la façon de forcer une version, même si j'aurais préféré une méthode en ligne de commande.

Hors ligne

#6 Le 31/12/2007, à 14:32

oseres

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

bonjour,
pourquoi faut il "forcer la version" ?
Cette option est grisée chez moi, je ne peux pas le faire.
Bizzare cette tendance de libasound2 à  rester sous version 1.0.11...
Je suis sous Edgy sur ce PC


Mon blog : http://oseres.com

Hors ligne

#7 Le 23/04/2009, à 06:02

lifala

Re : [Résolu] Problème avec libasound2 pour l'installation de wine

salut j'ai le meme probleme et la methode qui vien d'etre citer ne fonctionne pas de mon coter

byebye


conky 1 --- conky 2 --- conkyForecast 2.09 --- Tuto Finch
Lucid minimal + openbox

Hors ligne

  • Accueil
  • » Forum
  • » Archives
  • » [Résolu] Problème avec libasound2 pour l'installation de wine

Haut de page ↑