Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/10/2005, à 12:35

EcliptuX

[Résolu] Apt-get cassé

Hello,

J'ai voulu installer le package ltmodem pour mon winmodem et visiblement je my suis mal pris car mon système de package est sacrément mal au point sad
Voilà ce que donne apt-get check :

root@Narayan:~ # apt-get check
Reading package lists... Done
Building dependency tree... Done
E: The package ltmodem-2.6.8-2-386 needs to be reinstalled, but I can't find an archive for it.
root@Narayan:~ #

La réinstallation du package ou sa suppression pose problème :

root@Narayan:/home/ecliptux/Download # dpkg -r ltmodem-2.6.8-2-386
dpkg: error processing ltmodem-2.6.8-2-386 (--remove):
Package is in a very bad inconsistent state - you should
reinstall it before attempting a removal.
Errors were encountered while processing:
ltmodem-2.6.8-2-386
root@Narayan:/home/ecliptux/Download #

root@Narayan:/home/ecliptux/Download # dpkg -i ltmodem-2.6.8-2-386_8.31a11_i386.deb
Selecting previously deselected package ltmodem-2.6.8-2-386.
(Reading database ... 95730 files and directories currently installed.)
Preparing to replace ltmodem-2.6.8-2-386 8.31a11 (using ltmodem-2.6.8-2-386_8.31a11_i386.deb) ...
Unpacking replacement ltmodem-2.6.8-2-386 ...
find: warning: you have specified the -mindepth option after a non-option argument -name, but options are not positional (-mindepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

find: warning: you have specified the -maxdepth option after a non-option argument -name, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.


Could not identify your distribution's way of automatically loading modules,
Exiting.

dpkg: warning - old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
find: warning: you have specified the -mindepth option after a non-option argument -name, but options are not positional (-mindepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

find: warning: you have specified the -maxdepth option after a non-option argument -name, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.


Could not identify your distribution's way of automatically loading modules,
Exiting.

dpkg: error processing ltmodem-2.6.8-2-386_8.31a11_i386.deb (--install):
subprocess new post-removal script returned error exit status 1
find: warning: you have specified the -mindepth option after a non-option argument -name, but options are not positional (-mindepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

find: warning: you have specified the -maxdepth option after a non-option argument -name, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.


Could not identify your distribution's way of automatically loading modules,
Exiting.

dpkg: error while cleaning up:
subprocess post-removal script returned error exit status 1
Errors were encountered while processing:
ltmodem-2.6.8-2-386_8.31a11_i386.deb
root@Narayan:/home/ecliptux/Download #

Vous n'auriez pas une piste pour me sortir de là ?

Dernière modification par EcliptuX (Le 12/10/2005, à 19:13)

Hors ligne

#2 Le 12/10/2005, à 12:36

laurent

Re : [Résolu] Apt-get cassé

sudo apt-get install --reinstall ltmodem ?


Laurent, petit belge explorant la banquise

Hors ligne

#3 Le 12/10/2005, à 12:43

EcliptuX

Re : [Résolu] Apt-get cassé

Hummm pas concluant : roll

root@Narayan:/home/ecliptux/Download # apt-get install --reinstall ltmodem-2.6.8-2-386_8.31a11_i386.deb
Reading package lists... Done
Building dependency tree... Done
E: The package ltmodem-2.6.8-2-386 needs to be reinstalled, but I can't find an archive for it.
root@Narayan:/home/ecliptux/Download #

Hors ligne

#4 Le 12/10/2005, à 12:44

laurent

Re : [Résolu] Apt-get cassé

sudo apt-get remove ltmodem

(inutile d'écrire à chaque fois toute la suite wink )

ou sudo apt-get install -f


Laurent, petit belge explorant la banquise

Hors ligne

#5 Le 12/10/2005, à 12:53

EcliptuX

Re : [Résolu] Apt-get cassé

même topo sad

Hors ligne

#6 Le 12/10/2005, à 14:08

EcliptuX

Re : [Résolu] Apt-get cassé

Ca m'embêterai de devoir réinstaller Ubuntu pour ce genre de truc sad sad

Qd je lance synaptic, voici ce que j'obtiens :

E: The package ltmodem-2.6.8-2-386 needs to be reinstalled, but I can't find an archive for it.
E: Internal error opening cache (1). Please report.

Dernière modification par EcliptuX (Le 12/10/2005, à 14:11)

Hors ligne

#7 Le 12/10/2005, à 19:13

EcliptuX

Re : [Résolu] Apt-get cassé

Je viens de réparer mes bêtises avec ceci :

dpkg -r ltmodem-2.6.8-2-386
mv /var/lib/dpkg/info/ltmodem-2.6.8-2-386.* /tmp
apt-get install -f

Dès fois que ça serve à d'autres wink

Hors ligne