Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/02/2014, à 08:47

Tan Phi

Impossible de démarrer avec Cinnamon

Bonjour,

Il y a quelques jours, alors que j'étais sous Cinnamon, mon PC a planté (tout était figé, impossible même de bouger la souris). A ce moment précis, seuls Nemo et Firefox étaient ouverts. Impossible de savoir qui a planté précisément. J'ai éteint et redémarré violemment (via le bouton d'alim) mon PC. Depuis à chaque fois que je lance ma session sous cinnamon, impossible de faire quoi que ce soit : cinnamon occupe 90 % de la mémoire du système (sur 6 Go, c'est pas mal quand-même). La seul solution est de changer de tty, puis faire un sudo kill `pgrep cinnamon`.

Ce problème ne se produit que sous ma session, un autre utilisateur peut travailler normalement. Il ne se produit également qu'avec cinnamon, quand je me log avec unity, tout est normal.

J'ai tenté une suppression/réinstallation, ça n'a pas fonctionné. Comme ça fonctionne avec un autre utilisateur, je me suis dit que ça venait de mes fichiers de configuration. Donc sudo apt-get purge, puis réinstallation. Ça n'a pas fonctionné (d'ailleurs, ça n'a pas tout supprimé puisqu'à la connexion, j'avais le même fond d'écran que d'habitude, ainsi que les mêmes raccourcis).

J'ai supprimé manuellement tous les fichiers avec "cinnamon" dedans dans mon répertoire home (oui c'est violent), mais ça n'a pas fonctionné non plus.

Je ne sais plus quoi faire. Quelqu'un aurait-il une idée pour m'aider ?

Merci à vous.

Edit : j'oublie de préciser ma config : Ubuntu 13.10 64 bits avec Cinnamon 2.0.14 (pas Cubuntu, cinnamon a été installé après)

Dernière modification par Tan Phi (Le 10/02/2014, à 13:37)

Hors ligne

#2 Le 12/02/2014, à 07:00

Tan Phi

Re : Impossible de démarrer avec Cinnamon

Il semble que j'ai réussi à résoudre mon problème. J'ai fait la même chose que ce qui est décrit dans mon message initial, mais cette fois-ci, j'ai ajouté nemo en plus de cinnamon (ce qui laisse penser que c'était lui le coupable).
Donc pour faire simple :

sudo apt-get purge --auto-remove cinnamon nemo

Puis j'ai supprimé de mon répertoire utilisateur tous les fichiers dont le nom comportait "cinnamon" ou "nemo". J'ai redémarré (peut-être par excès de prudence, mais sait-on jamais).
Ensuite j'ai réinstallé le tout :

sudo apt-get install cinnamon nemo

A la connexion sous l'environnement, tout fonctionnait à nouveau.

Au final, je n'ai toujours pas compris la raison exacte de mon problème, mais je vais me contenter du fait que c'est réparé. Il reste néanmoins une question que je me pose : pourquoi la purge et la suppression de tout fichier ou dossier faisant référence à cinnamon de mon répertoire personnel n'a pas "tout purgé" ? Comme annoncé dans mon premier message, j'ai retrouvé tel quel mon fond d'écran, mes raccourcis dans le tableau de bord et tous mes réglages de thème et autres préférences. Il y a des informations liées à l'utilisateur stockées ailleurs que dans le répertoire de celui-ci ?

Hors ligne

#3 Le 12/02/2014, à 07:52

Tan Phi

Re : Impossible de démarrer avec Cinnamon

Je viens de reproduire le problème involontairement, et j'ai compris ce qu'il se passe. Tout a planté à nouveau alors que j'effectuais exactement la même action que la première fois, à savoir télécharger une image au format jpeg2000. Il y un bug déjà reporté à ce sujet ici ou ici. Je ne connais pas bien le lien entre nemo et nautilus, mais c'est sans aucun doute le même bug.

La solution décrite dans le premier lien fonctionne, et pour résumer, il suffit d'empêcher la création de l'aperçu dans nemo en faisant :

gsettings set org.gnome.desktop.thumbnailers disable "['image/jp2','image/jpeg2000']"

(normalement seul le premier type MIME est bon, mais j'ai trouvé le 2è à divers endroits, je l'ai mis par prudence)

S'il est déjà trop tard et que tout a déjà planté, pas la peine de tout désinstaller comme je l'ai fait dans mon message précédent. Il suffit de passer sur un autre tty (CTRL+ALT+F1), se connecter et supprimer les fichiers jp2 qui posent problème, puis lancer la ligne de commande que je viens de donner.

Hors ligne

Haut de page ↑