Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 16/02/2014, à 15:34

weedykangaroo

[Résolu]Le swap ne s'active pas au démarrage

Bonjour,
Je ne suis pas sur de poster dans la bonne section, mais je n'en ai pas trouvé d'autres.
Je suis sur Ubuntu 13.10 et j'utilise gnome-shell comme interface graphique.

A chaque démarrage de mon PC, je suis obligé d'utiliser la commande

swapon /dev/sda5

afin de faire reconnaître l'utilisation de ma partition swap (que j'ai créé au moment de l'installation d'Ubuntu). J'aurais aimé savoir s'il existe une technique pour que cela se passe automatiquement. Je pense que c'est possible de le faire en écrivant un script à faire exécuter au démarrage, mais je n'en ai jamais utilisé ou créé et je préférerais ne pas passer par cette option si c'est possible.

Merci pour vos réponses

weedykangaroo

Dernière modification par weedykangaroo (Le 17/02/2014, à 11:35)

Hors ligne

#2 Le 16/02/2014, à 15:52

Korak

Re : [Résolu]Le swap ne s'active pas au démarrage

Bonjour,

As-tu laissé l'installeur créer les partitions automatiquement ou as-tu fait un partitionnement manuel?


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#3 Le 16/02/2014, à 16:44

weedykangaroo

Re : [Résolu]Le swap ne s'active pas au démarrage

Je l'ai fait manuellement à partir de l'installeur : j'ai créé une partition swap de ~4Go et une autre partition ext4 de ~50Go (je suis en dual boot avec Windows et ses partitions ntfs) avec pour point de montage "/".

L'installeur a donc créé une partition étendue de ~54Go regroupant les 2 partitions (swap et ext4).
GParted m'indique donc que j'ai /dev/sda3 en système de fichiers "extended", et dedans /dev/sda5 en système de fichiers "linux-swap" et /dev/sda6 en système de fichiers "ext4".

Voilà deux captures d'écra, la première de Gparted :

438075Capturedcrande20140216164024.png

et la deuxième de disk-manager :

125249Capturedcrande20140216164054.png

Je ne sais pas si ç vous seras utile, mais si vous avez besoin de quoique ce soit d'autre, demandez moi smile

Hors ligne

#4 Le 16/02/2014, à 16:57

Korak

Re : [Résolu]Le swap ne s'active pas au démarrage

Dans tes captures d'écran, on ne vois nul part que la partition swap n'est pas active.

Je me trompe?


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#5 Le 16/02/2014, à 17:04

vikin712

Re : [Résolu]Le swap ne s'active pas au démarrage

Bonjour.

Le swap est activé. Si il ne l'était pas il n'y aurait pas de clé devant la partition dans Gparted.

#6 Le 16/02/2014, à 17:05

f.x0

Re : [Résolu]Le swap ne s'active pas au démarrage

Bonjour weedykangaroo,

ouvres un terminal
tapes

sudo blkid

et postes le résultat de la commande


ensuite
tapes

cat /etc/fstab

et postes le résultat de la commande


SOPI

Hors ligne

#7 Le 16/02/2014, à 17:28

PPdM

Re : [Résolu]Le swap ne s'active pas au démarrage

vikin712 a écrit :

Bonjour.

Le swap est activé. Si il ne l'était pas il n'y aurait pas de clé devant la partition dans Gparted.

Je plussoie, je ne vois pas ou est le souci, la partition de swap est invisible en fonctionnement normal, et de plus si tu as plus de 1 GO de ram, elle ne  sert quasiment a rien.

Dernière modification par PPdM (Le 16/02/2014, à 17:28)


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#8 Le 16/02/2014, à 17:33

Korak

Re : [Résolu]Le swap ne s'active pas au démarrage

PPdM a écrit :

Je plussoie, je ne vois pas ou est le souci, la partition de swap est invisible en fonctionnement normal, et de plus si tu as plus de 1 GO de ram, elle ne  sert quasiment a rien.

Sur mon PC avec 6 Go de RAM et Ubuntu 12.04.3 64 bits:

1392568283.png

Le swap n'est pas utilisé (ou alors très peu).


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#9 Le 16/02/2014, à 19:07

erresse

Re : [Résolu]Le swap ne s'active pas au démarrage

Bonsoir,
Avec les tailles de mémoire vive actuelle, c'est vrai que le swap n'est pas utilisé pendant la session de travail. En revanche, il est encore nécessaire pour l'hibernation (veille de longue durée) car le système y copie le contenu de la mémoir pour ne pas le perdre lorsque l'alimentation est coupée.
A part ça, je me pose la question : Pourquoi penses-tu que le swap n'est pas activé au démarrage, et comment le sais-tu ???
(Pour ma part, je rejoins vikin712 sur le fait que la partition est bien montée, donc active pour autant qu'on en ait besoin).


Plus de 40 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !

Hors ligne

#10 Le 16/02/2014, à 19:49

weedykangaroo

Re : [Résolu]Le swap ne s'active pas au démarrage

Pour répondre à vos questions, oui le swap est activé (effectivement, j'aurais du prendre les captures d'écran sans l'avoir activé tongue ), c'est moi qui l'active manuellement à chaque démarrage avec la commande :

swapon /dev/sda5

Lorsque je ne le fais pas, je sais que le swap n'est pas activé car la commande

swapon -s

ne me retourne que cela :

[Filename				Type		Size	Used	Priority

au lieu de cette réponse (une fois que j'ai /dev/sda5 manuellement) :

Filename				Type		Size	Used	Priority
/dev/sda5                               partition	3905532	0	-1

De plus, le moniteur système indique non disponible au lieu de la taille et de l'utilisation au niveau du swap.


-------------------------------------------------------- Réponse pour f.x0
En ayant le swap désactivé, voilà la réponse de sudo blkid :

/dev/sda1: LABEL="RECOVERY" UUID="4CE5-3ACB" TYPE="vfat" 
/dev/sda2: LABEL="OS" UUID="A810EABE10EA929C" TYPE="ntfs" 
/dev/sda4: LABEL="Data" UUID="5410A30F10A2F6E0" TYPE="ntfs" 
/dev/sda5: UUID="30299996-f913-44b3-a5a4-cfd5d8336d4c" TYPE="swap" 
/dev/sda6: UUID="06254479-ff50-44cc-939e-9992b8dd3107" TYPE="ext4" 

et cat /etc/fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=06254479-ff50-44cc-939e-9992b8dd3107 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=334a32b2-ccc4-4ddb-88d7-30133ac24464 none            swap    sw              0       0
/dev/disk/by-uuid/5410A30F10A2F6E0 /mnt/5410A30F10A2F6E0 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/A810EABE10EA929C /mnt/A810EABE10EA929C auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
/dev/disk/by-uuid/4CE5-3ACB /mnt/4CE5-3ACB auto nosuid,nodev,nofail,noauto 0 0
/dev/disk/by-id/wwn-0x5000c50028196508-part1 /mnt/wwn-0x5000c50028196508-part1 auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
/dev/disk/by-id/usb-TOSHIBA_External_USB_3.0_222238191AD1-0:0-part1 /mnt/usb-TOSHIBA_External_USB_3.0_222238191AD1-0:0-part1 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0
/dev/disk/by-id/usb-Verbatim_STORE_N_GO_1262000000000239-0:0-part1 /mnt/usb-Verbatim_STORE_N_GO_1262000000000239-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
/dev/disk/by-id/wwn-0x5000c5002818b559-part1 /mnt/wwn-0x5000c5002818b559-part1 auto nosuid,nodev,nofail,noauto,x-gvfs-show 0 0

Hors ligne

#11 Le 16/02/2014, à 20:06

f.x0

Re : [Résolu]Le swap ne s'active pas au démarrage

C'est bien ce que je pensais, ton n° UUID du swap ne correspond pas à celui désigné dans le fstab.
Tu as sûrement dû reformater ton swap depuis l'installation.

Du coup, il faut taper

gksudo gedit /etc/fstab

et modifier cette ligne

UUID=334a32b2-ccc4-4ddb-88d7-30133ac24464 none            swap    sw              0       0

pour qu'elle devienne

UUID=30299996-f913-44b3-a5a4-cfd5d8336d4c     none            swap    sw              0       0

enregistrer le fichier
quitter gedit
et redémarrer

normalement, tout devrait être OK.


SOPI

Hors ligne

#12 Le 17/02/2014, à 11:36

weedykangaroo

Re : [Résolu]Le swap ne s'active pas au démarrage

Ca a fonctionné, merci beaucoup pour votre aide cool

Hors ligne

Haut de page ↑