Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 24/02/2014, à 23:40

AlexxelA

[Abandon] Problème de partage de connexion

Bonsoir,

je suis connecté en ethernet à l'hôtel et je voudrais faire un partage de connexion depuis mon PC pour utiliser ma tablette en wifi.
Je suis régulièrement dans cet hôtel et j'ai déjà cherché sur le forum et essayé ce qui est écrit .

En faisant tout ça, je vois bien le réseau depuis ma tablette (et aussi mon téléphone d'ailleurs) et je peux m'y connecter... par contre ça ne me demande pas la clé WEP pour m'y connecter et je n'ai aucune connexion internet avec ce réseau (sur les appareils mobiles connectés en wifi).

Vous savez comment je peux corriger ça ?

Merci !

AlexxelA

Dernière modification par AlexxelA (Le 02/03/2014, à 14:19)

Hors ligne

#2 Le 26/02/2014, à 17:05

mytux

Re : [Abandon] Problème de partage de connexion

Le bridge ne fonctionne pas avec les interfaces Wifi, parcontre tu peux faire du NAT avec iptables.

Hors ligne

#3 Le 26/02/2014, à 22:36

AlexxelA

Re : [Abandon] Problème de partage de connexion

J''ai essayé en suivant la méthode du transfert d'IP décrite sur cette page http://doc.ubuntu-fr.org/partage_de_con … ont_reseau, je crois que c'est celle d'iptables mais je n'ai vu aucune différence.
Le réseau est tjrs visible mais pas de connexion internet.

En faisant ifconfig j'ai :

alexandre@HP ~ $ ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:1b:24:e6:40:5c  
          inet adr:10.44.205.71  Bcast:10.44.205.255  Masque:255.255.255.0
          adr inet6: fe80::21b:24ff:fee6:405c/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:5845 erreurs:0 :0 overruns:0 frame:0
          TX packets:4512 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:5308504 (5.3 MB) Octets transmis:351983 (351.9 KB)

eth1      Link encap:Ethernet  HWaddr 00:1a:73:d6:cd:d2  
          inet adr:10.42.0.1  Bcast:10.42.0.255  Masque:255.255.255.0
          adr inet6: fe80::21a:73ff:fed6:cdd2/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:24
          TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:0 (0.0 B) Octets transmis:21212 (21.2 KB)
          Interruption:19 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:118 erreurs:0 :0 overruns:0 frame:0
          TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:13095 (13.0 KB) Octets transmis:13095 (13.0 KB)

Il y a bien le partage de connexion avec très peu de données transférées.

J'ai aussi testé la méthode de bridge-utils citée un peu peu plus bas mais sans plus de succès...

Hors ligne

#4 Le 26/02/2014, à 22:59

mytux

Re : [Abandon] Problème de partage de connexion

Il y a bien le partage de connexion avec très peu de données transférées.

Donc c'est bon ?

Dernière modification par mytux (Le 26/02/2014, à 23:00)

Hors ligne

#5 Le 27/02/2014, à 00:04

AlexxelA

Re : [Abandon] Problème de partage de connexion

Pardon, je n'ai pas été clair mais non, ça ne fonctionne pas.

Je pense que le peu de données transférées vient de la connexion de mon mobile en wifi, mais je n'ai toujours pas internet.

J'ai continué d'essayer mais en mode graphique parce que je ne comprends pas ce que j'ai fait avant.
Je crée un pont entre mes cartes ethernet et wifi avant d'activer l'utilisation de ma connexion wifi comme point d'accès (avec network-manager).
Mais jusqu'à présent je suis toujours bloqué sad

Hors ligne

#6 Le 27/02/2014, à 00:29

navtex

Re : [Abandon] Problème de partage de connexion

salut
l'app. " ap-hotspot"  avec PPA
https://launchpad.net/~nilarimogard/+archive/webupd8


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#7 Le 27/02/2014, à 00:37

mytux

Re : [Abandon] Problème de partage de connexion

http://olivieraj.free.fr/fr/linux/information/firewall/
http://axel.buob.free.fr/memento-un.php

Le pont de fonctionne pas avec les cartesWifi il faut que tu utilises iptables, pour faire du NAT.
Désactive network-manager il te posera problème.

/etc/init.d/network-manager stop

Configure tes interfaces eth0 et wlan0.

auto eth0 
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet static 
wpa-ssid ****
wpa-psk ***************************
address 192.168.2.1
netmask 255.255.255.0

Ensuite install un serveur DHCP en écoute sur wlan0, pour fournir desaddres ip a tes clients. La passrelle c'est ton interface wlan0.

Enfin translate les adrresses privés du réseau wifi en addresses publics :

iptables -t nat -A POSTROUTING -s 192.168.2.0/24 -o eth0 -j MASQUERADE

Et en effet comme le suggère navtex tu auras besoin d'installer un hotspot en plus du nat pour diffuser le signal à tes clients.

Dernière modification par mytux (Le 27/02/2014, à 10:37)

Hors ligne

#8 Le 02/03/2014, à 14:19

AlexxelA

Re : [Abandon] Problème de partage de connexion

Bonjour,

j''ai essayé de suivre vos instructions.
@ mytux : ta méthode est un peu compliquée pour moi et je n'ai pas réussi à la faire fonctionner.
@ navtex : j'ai installé ap-hotspot mais ma carte graphique ne semble pas supporter, voici le message :

Your wireless card or driver does not support Access Point mode

La solution doit être la méthode donnée par mytux mais c'est un peu trop compliqué pour moi donc je laisse tomber...

Merci de votre aide wink

Dernière modification par AlexxelA (Le 02/03/2014, à 14:20)

Hors ligne

Haut de page ↑