Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/10/2005, à 15:51

avr

[Résolu]Comment régler Synaptic qd proxy avec .pac?

Bonjour,

Il me semble que je suis sous proxy. J'ai réglé dans "Système>Préférences>Proxy réseau" la "configuration automatique du réseau" avec une URL d'autoconfiguration (http://www/proxyconf.pac). Dans Firefox >Préférences>Connexion Settings, j'ai coché "Automatic proxy configuration URL" et j'ai rentré dans le champ le même http://(...).pac .
Dans les préférences de Synaptic, j'ai essayé:
-connexion directe à internet;
-configuration manuelle du mandataire
   -avec les champs libres;
   -avec mandataire http rempli par: http://(...).pac
J'obtiens, quels que soient les réglages, le même problème:

Je voudrais régler les dépôts pour Synaptic. Dans Catégories>Dépôts, j'ai choisi tous les dépôts possibles en configuration "automatique", ie Ubuntu5.10 "Breezy Badger", "Security Updates" et "Updates" et pour chacun en supporté, restreint, universe et multiverse.
Mais quand je recharge mes dépôts, j'obtiens le message d'erreur:
"Le dépôt ne semple plus être disponible ou ne peut être contacté à cause de problèmes réseau. S'il existe un fichier d'index plus ancien il sera utilisé. Sinon, le dépôt sera ignoré. Vérifiez votre connexion réseau et corrigez l'adresse du dépôt dans les préférences."

J'ai essayé de créer un fichier /etc/apt/apt.conf avec dedans la ligne:
acquire::http::proxy "http://I(...).pac";
mais ça ne marche pas mieux (même message d'erreur). Je précise que nul part je ne rentre un port, ni un login, ni même un mot de passe (c'est pourquoi je n'ai pas écrit dans le apt.conf une ligne du type:
acquire::http::proxy "http://IP:PORT";

help. je ne sais plus quoi faire.
Voici mon source.list:

## Uncomment the following two lines to fetch updated software from the network

## Uncomment the following two lines to fetch major bug fix updates produced
## after the final release of the distribution.

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://fr.archive.ubuntu.com/ubuntu breezy-backports main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu breezy-backports main restricted



## Ajout des depots multiverse

## Ubuntu breezy-backports
deb http://archive.ubuntu.com/ubuntu/ breezy main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ breezy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ breezy-updates main restricted universe multiverse
#breezy-extras

PS: je peux aller sur internet sans problème.

Dernière modification par avr (Le 19/10/2005, à 14:59)

Hors ligne

#2 Le 18/10/2005, à 16:52

avr

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

Personne n'a d'idée? Je commence à m'embrouiller, mais j'ai enlevé tous les dépôts, puis remis: toujours ce problème de connexion. Je ne sais pas si ça peut aider, mais avec un apt-get update, j'obtiens:

lohan@pavasseur:~$ sudo apt-get update
Password:
Err http://security.ubuntu.com breezy-security Release.gpg
  Connexion à security.ubuntu.com: 80 (82.211.81.138) impossible, délai de connexion dépassé
0% [Connexion à archive.ubuntu.com (82.211.81.193)]
lohan@pavasseur:~$

(j'ai fait un ctrl-c pour arrêter tout).
Merci d'avance pour votre aide.

Hors ligne

#3 Le 18/10/2005, à 17:23

avr

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

Personne ne peut m'indiquer comment faire? Car là, je suis carrément bloqué, et je ne peux faire aucune mise à jour...

Hors ligne

#4 Le 18/10/2005, à 18:49

bobydu63

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

change ton fichier sources.list, et mais le à jour ...

Hors ligne

#5 Le 19/10/2005, à 14:58

avr

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

Bon, c'était effectivement un paramétrage du apt.conf que je ne pouvais pas deviner. Résolu!

Hors ligne

#6 Le 12/09/2006, à 12:03

sprint95

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

avr a écrit :

Bon, c'était effectivement un paramétrage du apt.conf que je ne pouvais pas deviner. Résolu!

Bonjour,
Je ne trouve pas l'option pour apt.conf permetant d'utiliser une configuration de proxy automatique (adresse type URL/proxy.pac).
Sachant qu'en plus, il y a de l'authentification avec login password.
Quelle est l'astuce ?
Merci
Sprint

Hors ligne

#7 Le 12/09/2006, à 17:39

avr

Re : [Résolu]Comment régler Synaptic qd proxy avec .pac?

Il existe un man pour apt.conf. Regardez dessus (section "groupe acquire") et vous devriez trouver votre bonheur. A priori, il devrait se présenter comme ça:

Acquire::http::Proxy "http://[[user][:pass]@]host[:port]/";

Il y a aussi /usr/share/doc/apt/examples/configure-index.gz qui est pas mal détaillé.

Si j'ai pu aidé...
++

Hors ligne