Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/05/2014, à 22:02

camox

https écrit en rouge et barre

bonjour a tous

je viens d'installé xampp sur ubuntu 14.04, quand je suis sur localhost j'ai le https qui et écrit en rouge et barré, sur php / Myadmin y a deux messages en bas de page 1 qui me conseil de faire la mise à jour, comment procéder pour la faire ? smile et un qui me dit que php n'est pas complètement configuré et que certaines fonctionnalités sont désactivée comment procéder pour les réactivées smile

capture pour le https
ici

les message sur php/myadmin
ici

merci bonne soirée ou bonne journée smile smile


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#2 Le 12/05/2014, à 22:14

toutafai

Re : https écrit en rouge et barre

Bsr,

Vite fait quelques pistes :
le https doit etre désactive ou mal activé dans un fichier de conf
voir aussi le port et la regle de  parefeu qui va bien
enfin, si il dit qu'il y a des maj a faire, t'as plus qu'a xD


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#3 Le 12/05/2014, à 22:21

lool_lauris

Re : https écrit en rouge et barre

Salut,

En fait, xampp est un truc qui peut paraître facile et pratique quand on débute mais comme c'est un bundle, tu n'as pas forcément les derniers outils à jour et comme cela ne passe pas par les dépôts les mises à jour ne se feront pas.
De plus, en terme de sécurité, c'est plutôt léger.

Il vaut mieux que tu installes Lamp via les dépôts officiels.

Vois ce tuto qui est très bien => http://forum.ubuntu-fr.org/viewtopic.ph … #p15181681


Je complète ce tuto par ceci :

CRÉER DES RÉPERTOIRES DE TRAVAIL

Présentation

L'erreur de beaucoup de personnes arrivant sur Ubuntu et/ou GNU/Linux est de créer des pages internet avec des droits d'administration ou d'affecter le répertoire /var/www à un utilisateur. En contrepartie, beaucoup d'utilisateurs trouvent également peu pratique de devoir travailler dans un répertoire qu'ils n'ont pas choisi.
/var/www est un répertoire sous droits root. Il est donc contre indiqué de travailler dans ce répertoire.

Ici nous allons exposer comment créer ses propres répertoires de travail avec des droits spécifiques à une utilisation à la fois 'publique' (serveur web personnel) et 'privée' (serveur de développement).

Nous allons aussi faire en sorte de rendre /var/www inaccessible de l'extérieur ou du moins accessible de façon ponctuelle.
Mise en place
Protection de /var/www

Dans un premier temps nous allons donc rendre le dossier /var/www inaccessible. Pour cela, on édite en super utilisateur le fichier : /etc/apache2/sites-available/default et dans la section <Directory /var/www> on va modifier les accès . Depuis la version 2.4 d'apache le fichier 000-default.conf n'a plus de section <Directory /var/www>, il faut la rajouter en dessous de la ligne DocumentRoot /var/www.
Changez :

<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

en :
A partir de ubuntu 13.10 et apache 2.4

<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    <RequireAny>
        Require ip 127.0.0.1
        Require ip 192.168.1
    </RequireAny>
</Directory>

Pour les versions précédentes à ubuntu 13.10 et apache 2.4

<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1        # local
    Allow from 192.168.1.0/24    # reseau
</Directory>

Cette modification va faire en sorte que seule votre machine (127.0.0.1) et celles de votre réseau local (à condition que celui-ci utilise l'adresse 192.168.1.0) auront accès aux pages web situées dans le dossier /var/www/.
Création des répertoires de travail

Ici nous allons placer nos répertoires dans la zone /media (en prévision d'une installation sur une clé usb, un disque externe, une partition séparée, etc. Libre à vous de choisir le lieu … qu'il reste cohérent quand même :-P

sudo mkdir /media/www-dev
sudo mkdir /media/www-dev/public
sudo mkdir /media/www-dev/private

Donner les droits utilisateur aux répertoires de travail

Attention : la variable '$USER' est une variable pour l'utilisateur en cours. si vous voulez affecter ces répertoires à un autre utilisateur, donnez le nom réel de l'utilisateur.
Le 'users' par contre est un nom de group (normalement déjà présent sur votre installation). Soit vous utilisez nom_user:nom_user, soit nom_user:users.
'users' étant souvent le group utilisé sur de l'hébergement mutualisé, ce qui vous permet de simuler votre hébergeur au plus près.

sudo chown -R $USER:users /media/www-dev

Si vous n'utilisez pas /media/www/ mais un dossier personnalisé, attention :

    Vous ne pouvez pas utiliser des partitions NTFS et FAT, car elles ne gèrent pas les droits utilisateurs. il faut donc impérativement que votre dossier figure sur une partition Linux.
    Si votre dossier figure sur un autre disque dur (clef USB, etc…), toutes les permissions doivent être favorables, sur chacun des dossiers, depuis le disque lui même.

Exemple : votre site se situe sous /media/votre_disque/vos_sites/votre_site, il vous faut exécuter :

sudo chown $USER:users /media/votre_disque

sudo chown $USER:users /media/votre_disque/vos_sites

sudo chown -R $USER:users /media/votre_disque/vos_sites/votre_site

Configuration d'alias dans apache

Pour pouvoir accéder à ces répertoires, apache a besoin d'une *redirection*.
Cette *redirection* se présente sous la forme : http://nom_de_domaine.tld/nom_de_redirection
Ces *redirections* s'appellent des Alias.
Il nous faut donc ajouter deux alias, un pour public et un pour private.

Éditez en super utilisateur le fichier : /etc/apache2/sites-available/default et ajoutez à la suite de <Directory /var/www>….</Directory> :

Dans le cas ci-dessous on accorde un accès au W3C (validateur html) et à l'espace dédié aux développeurs d'application utilisant Paypal

A partir de ubuntu 13.10 et apache 2.4

## ZONE PUBLIQUE
Alias /public /media/www-dev/public
<Directory /media/www-dev/public>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
</Directory>

## ZONE PRIVEE
Alias /private /media/www-dev/private
<Directory /media/www-dev/private>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    <RequireAny>
        Require ip 127.0.0.1
        Require ip 192.168.1
        Require host .w3.org
        Require host sandbox.paypal.com
    </RequireAny>
</Directory>

Pour les versions précédentes à ubuntu 13.10 et apache 2.4

## ZONE PUBLIQUE
Alias /public /media/www-dev/public
<Directory /media/www-dev/public>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

## ZONE PRIVEE
Alias /private /media/www-dev/private
<Directory /media/www-dev/private>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1            # Local
    Allow from 192.168.1.0/24       # Réseau
    Allow from .w3.org              # W3C
    Allow from sandbox.paypal.com   # Paypal
</Directory>

Ajout de liens symboliques

A présent les espaces sont valides, mais non visible depuis la racine de votre serveur (c.f.: http://localhost). Il serait donc judicieux et pratique d'y avoir accès directement, plutôt que de devoir taper manuellement 'http://localhost/public' ou 'http://localhost/private'.
Il suffit tout simplement de créer un lien symbolique dans /var/www

Attention: Ne jamais faire un 'rm -rf' sur un lien symbolique … cette commande aura pour effet de supprimer le contenu réel de destination du lien symbolique. Utilisez juste 'rm /dossier/nom_symbolique' comme s'il s'agissait d'un simple fichier.
les liens symboliques dans /var/www se font via 'sudo' et donc sont en root:root. Ne changez pas ces droits !

sudo ln -s /media/www-dev/public /var/www/public
sudo ln -s /media/www-dev/private /var/www/private

Il vous faudra également effacer le fichier index.html pour que cela prenne effet :

sudo rm /var/www/index.html

Éviter le 403

Les répertoires /var/www et /media/www-dev/private (/var/www/private) étant interdit de l'extérieur, un visiteur tapant votre adresse (ip / no-ip , DynDNS / nom de domaine) directement sans préciser le dossier 'public', se verra accueilli par une belle page en 403 (ou si il tente d'accéder *par miracle* ←- faut le savoir :-P à votre répertoire 'private')

Si vous n'avez pas de domaine (domain.tld est un exemple générique), il faudra utiliser votre IP réelle (ex : http://checkip.dyndns.org/ ).

On va donc remédier à cela en redirigeant les visiteurs automatiquement vers le répertoire 'public' en cas d'erreur 403.
Il suffit d'ajouter la ligne :

ErrorDocument 403 "http://domain.tld/public"

à la suite de :

<Directory /var/www>

et :

<Directory /media/www-dev/private>

Dans certains cas une erreur 403 peut également se produire lorsque vous demandez l'affichage de localhost alors que 127.0.0.1 fonctionne (et que vous avez d'ores et déjà réglé les problèmes de ServerName dans /etc/hosts et /etc/apache2/apache2.conf). Dans ce cas, dans le fichier : /etc/apache2/sites-available/default, ajouter à la suite de <Directory /var/www> la ligne :

Allow from localhost            # Local

après

Allow from 127.0.0.1            # Local

Finalisation

Voilà c'est fini. À présent il vous suffit de recharger la configuration d'apache pour rendre tout cela opérationnel.

sudo /etc/init.d/apache2 force-reload

Problèmes

* Cas d'une erreur sur ServerName au rechargement d'apache
Erreur ServerName

* Renvoi vers votre 'livebox/neufbox/ClubInternet Box' avec un nom de domaine.
Éditez en super utilisateur le fichier : /etc/hosts et ajouter une ligne avec :

127.0.0.1 domain.dnsalias.net

* Erreur sur le localhost
Éditez en super utilisateur le fichier : /etc/hosts et remplacer les lignes :

127.0.0.1 localhost
127.0.1.1 <hostname>

par :

127.0.0.1 localhost <hostname>


Enfin, afin de bien comprendre ce que tu fais, je te conseille de lire cette page => http://www.linux-france.org/prj/edu/arc … 16s02.html


Ne rien lâcher, les utopies d'aujourd'hui seront la réalité de demain !
------------------------------------------------------------------------------------------------
Soutenez le Libre => http://www.april.org/

Hors ligne

#4 Le 13/05/2014, à 06:32

camox

Re : https écrit en rouge et barre

Salut lool_lauris

Pour installé lamp je peux suivre le lien que tu me donne à la fin de ta réponse et après je vois pour lier les dossiers. 

Comment faire pour désinstallé xamp complètement ?

Merci bonne journée smile


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#5 Le 13/05/2014, à 07:32

lool_lauris

Re : https écrit en rouge et barre

camox a écrit :

Comment faire pour désinstallé xamp complètement ?

1/ Assure toi que le serveur est bien arrêté. Pour ceci :

sudo /opt/lampp/lampp stop

2/ Pour supprimer la totalité de xampp :

sudo rm -rf /opt/lampp

3/ Si tu te rends à : /opt il ne doit plus y avoir trace de xampp


Ne rien lâcher, les utopies d'aujourd'hui seront la réalité de demain !
------------------------------------------------------------------------------------------------
Soutenez le Libre => http://www.april.org/

Hors ligne

#6 Le 13/05/2014, à 20:34

camox

Re : https écrit en rouge et barre

L'installation de lamp ces bien passé j'ai la page qui indique il fonctionne smile

par contre pour ce qui est de phpmyadmin a l'adresse http://localhost/phpmyadmin il ne la trouve pas
e.png

pour info quand je vais dans ordinateur/ var/ www j'ai un dossier HTML un phpmyadmin qui est typé lien vers Dossier.

et quand je vais dans ordinateur/ usr/ share/ phpmyadmin.

je ne comprend ou et l'erreur car j'ai juste installé les paquets des liens suivant

Alternative 2 : Installation des paquets (méthode recommandée)

phpMyadmin

ps : pour ce qui de la désinstallation de xampp le dossier opt et bien vide smile

merci smile


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#7 Le 13/05/2014, à 20:55

casperfr

Re : https écrit en rouge et barre

Bonjour,

en faite, le dossier de travail d'apache par défaut sur un ubuntu 14.04 est /var/www/html et non plus /var/www comme c'étais le cas dans les éditions précédente,
le lien symbolique créé par apache n'est donc plus bon, vu que celui ci c'est retrouvé dans /www/var
pour placer le lien symbolique au bonne endroit tu as juste a faire un :

sudo ln -s /usr/share/phpmyadmin /var/www/html

le lien symbolique ce trouvant dans le dossier /var/www est obsolète il peut donc etre supprimé

Dernière modification par casperfr (Le 13/05/2014, à 20:56)

Hors ligne

#8 Le 13/05/2014, à 21:40

camox

Re : https écrit en rouge et barre

slt casperfr

bon pour phpMyadmin ça marche j'ais juste ce petit message en bas de page

t.png

comment avoir les droit pour créé /déplacé un fichier  dans le dossier HTML.

qu'an j'étais sur windows wamp et que j'étais sur la page 127.0.0.1 y avais tous mes dossiers de site qui avait dans le www, la qu'an je suis sur 127.0.0.1  il me met page inaccessible pourtant quand je clique sur les liens de la page de la documentations j'ai bien la page il fonctionne sad


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#9 Le 13/05/2014, à 21:50

casperfr

Re : https écrit en rouge et barre

pour l'avertissement, celui ci n'est pas bloquant, si tu veux utilisé les options de cryptage au seins de phpmyadmin il devront etre rajouter en installent le module mcrypt.
j'ai pas bien compris ce que tu as dis,
apache fonctionne sur ton ordinateur, tu dois avoir une version 14.04 d'ubuntu,
dans cette version le dossier par défaut d'apache est /var/www/html tous tes dossiers de travail web doivent donc ce trouvé a cette emplacement pour que tu puisses y avoir accès en faisant un http://localhost/ dans ton explorateur internet,
soit effectivement tu déplaces tes dossiers, dans /var/www/html, soit on modifie la directive pour les site par défaut d'apache pour lui dire que le dossier par défaut est /var/www
pour avoir les droits pour déplacer tes fichierser dossiers , il sufit de faire un sudo devant ta commande le déplacement ce faisant par la commande mv
tu as donc,

sudo mv /le_dossier_ou_se_trouve_tes_fichiers/* /var/www/html/

Dernière modification par casperfr (Le 13/05/2014, à 21:53)

Hors ligne

#10 Le 14/05/2014, à 07:45

camox

Re : https écrit en rouge et barre

le dossiers qui contiens mes site sont dans Documents/site, j'ai taper la commande suivante :

camox@camox-K55VM:~/Documents$ sudo mv /Documents/site/* /var/www/html

le retour est

mv: impossible d'évaluer «/Documents/site/*»: Aucun fichier ou dossier de ce type

smile


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#11 Le 14/05/2014, à 09:41

casperfr

Re : https écrit en rouge et barre

es tu sur du chemin que ton dossier documents se trouve a la racine ?
je vois que tu te trouve dans un dossier qui s'appel document, si c'est celui la tu n'as pas mis la bonne adresse,
il y a un ~ devant ton document cela veux dire que tu te trouve dans le dossier home/nom_de_ton_compte/
ressait donc soit donné le chemin complet

sudo mv /home/nom_de_ton_compte/Documents/site/* /var/www/html/

ou utilise le raccourci de ton home :

sudo mv ~/Documents/site/* /var/www/html/

Hors ligne

#12 Le 14/05/2014, à 11:36

camox

Re : https écrit en rouge et barre

ça a l'air d'avoir marché

camox@camox-K55VM:~$ sudo mv /home/camox/Documents/site/* /var/www/html
[sudo] password for camox:camox@camox-K55VM:~$ 

par contre ce que je comprend pas ces comment ouvrir  un index.php qui et a la racine de tous les dossiers qui compose mes sites, exemple:

dans mon dossier site, j'ai un dossier 'velo' qui et un site, à l’intérieur y à les dossiers qui compose le site img/css/les pages html... et donc a la racine du dossier 'velo' y à un fichier index.php    comment ouvrir cet index.php ?

l’arborescence ça donne

home/camox/Documents/site/velo/dossier images/dossier css/ dossier js/ fichier index.php

smile


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#13 Le 14/05/2014, à 11:47

casperfr

Re : https écrit en rouge et barre

le fichier dont tu as donné le chemin, ce trouve dans tes documents, l'ouverture est donc faite par un éditeur de texte dans ton système,
un fichier php est un code qui doit etre interprété puis le résultat est renvoyé au destinataire,
c'est apache qui va ce chargé de cette étape,
apache par défaut lit certain fichier dans un certaine ordre quand tu ne lui indique pas dans ta barre d'adresse de ton explorateur internet,
dans le cas présant, le fichier ne peut pas etre interprété par apache puisque celui ci ce trouve dans ton dossier home alors que apache ne va lire par défaut que les fichiers ce trouvant dans /var/www/html/
si tu as réussi a déplacer tes fichiers via la commande que je t'ai fournis, tu devrais donc avoir tes fichiers
dans le dossier :
/var/www/html/velo/dossier images/dossier css/ dossier js/ fichier index.php
si tu cherches a les ouvrirs il faut que tu  aille a cette endroit pour pouvoir éditer ton fichier
si tu cherche a voir le résultat
il faut que tu écrive dans la barre d'adresse de ton explorateur internet :
http://localhost/velo/dossier images/dossier css/ dossier js/ fichier index.php
ou
http://127.0.0.1/velo/dossier images/dossier css/ dossier js/ fichier index.php
ou encore
http://adresse_ip_de_ta_machine/velo/dossier images/dossier css/ dossier js/ fichier index.php
la on a écrit les fichiers,
mais comme apache ouvre automatiquement un fichier index quand ne précise pas le nom du fichier
(attention 'index.php' et non 'fichier index.php')
tu peut donc écrire directement:
http://localhost/velo/dossier images/dossier css/ dossier js/
ou
http://127.0.0.1/velo/dossier images/dossier css/ dossier js/
ou encore
http://adresse_ip_de_ta_machine/velo/dossier images/dossier css/ dossier js/
apache dois donc executer le code php et te renvoyé le résultat, si cela n'est pas le cas (si tu vois le contenu du php plutot que le résultat de celui ci) c'est que les modules php pour apache n'ont pas été installé
j'espère avoir été clair dans mon explication

Hors ligne

#14 Le 14/05/2014, à 22:27

camox

Re : https écrit en rouge et barre

casperfr a écrit :

j'espère avoir été clair dans mon explication]

tu ais bien clair dans tes explications ces moi qui débute avec lamp et le ligne de commande et le php donc je me perd un peut avec tout ça smile

mes je crois qu'on y arrive voici la capture

cap_velo.png

maintenant le problème ces que quand je clique sur le fichier index.php (le dernier tout en bas) ça me le télécharge au lieux de lancé le site:(

merci de ton suivi.


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#15 Le 14/05/2014, à 22:50

casperfr

Re : https écrit en rouge et barre

c'est beaucoup plus claire avec une copie d'écran,
en faite, tu ne visionne pas du tout une page internet,
dans ta barre d'adresse en haut il est écris file://
en faite tu utilise ton navigateur internet (firefox ?) pour te permettre de naviguer sur ton ordinateur comme s'il était un explorateur de fichier.

je vais essayé d'etre clair :
un fichiers internet est en faite un fichier comportant des balises a l'interrieur, ton navigateur interprete ses balise pour mettre en page et afficher une page de texte avec des image, des animations et tout autre de choses, pour cela, ton navigateur reçoit les informations du serveur web qui lui envois toutes ces balises, c'est le boulo d'apache d'envoyé toutes ces balises pour qu'elle soit utilisé par ton navigateur,
tout cela est normalisé, la norme utilisé est le http (hyper text transport protocol) c'est pour cela qu'une page web possède une adresse http://
toi dans l'usage de ton explorateur, tu n'utilises pas du tout ce protocole puisque tu utilise le file:// le file est donc simplement l'affichage des fichiers et dossier se trouvant sur ton disque (c'est normalement le boulo de l'exploreur de fichier sur linux c'est nautilus) normalement ton navigateur ne doit pas faire ce genre de chose, mais pour facilité l'usage on peut lui faire faire un maximum de chose,

donc dans la barre d'adresse tu dois écrire
http://localhost/
localhost étant ton ordinateur comme je te l'ai dis dans mes poste précédant,
d'après le paramétrage par défaut d'apache, localhost ouvre les fichiers (index) qui se trouve dans le dossier /var/www/html
dans cette emplacement il doit y avoir un fichier index.html (celui installé par apache lors de son installation) a moins que tu l'ai retiré,
donc quand tu ecris cette ligne apache execute index.html qui t'affiche une page contenant l'information "it's work !!!!"
toi tu as mis tes fichiers dans un dossier supplémentaire velo
donc l'accès a velo ce fait par
http://localhost/velo
étant donné que dans le dossier ce trouve un fichier index apache va donc l'executer par defaut
si tu veux que ce soit un autre fichier qui s'affiche il faut que tu précise ce fichier
exemple :
http://localhost/velo/monfichiertest.html

Hors ligne

#16 Le 15/05/2014, à 07:38

camox

Re : https écrit en rouge et barre

casperfr a écrit :

quand tu ecris cette ligne apache execute index.html qui t'affiche une page contenant l'information "it's work !!!!"

pour ça c ok

il_fonctionne.png

casperfr a écrit :

l'accès a velo ce fait par
http://localhost/velo

pour ça c pas ok

localhost_velo.png

une capture de la ou ce trouve le dossier velo

chemin_fichier.png


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#17 Le 15/05/2014, à 08:06

casperfr

Re : https écrit en rouge et barre

pourrait tu me montré ce que te donne en ligne de commande,

ls -l /var/www/html/

et

ls -l /var/www/html/velo

Hors ligne

#18 Le 15/05/2014, à 08:10

casperfr

Re : https écrit en rouge et barre

en faite je penses savoir le résultat de la commande,
c'est a dire, que apache n'étant pas le propriétaire du dossier puisque c'est toi le propriétaire, il refuse donc d'affiché ce dossier,
il faudrait que tu fasses la commande suivant,

sudo chown www-data:www-data -R /var/www/html/velo

la on change le groupe et le propriétaire du dossier velo en lui disant que le nouveau propriétaire est apache, celui ci a donc le droit de voir les fichiers qui ce trouve dedans et te les renvoyés dans ton explorateur internet

Hors ligne

#19 Le 15/05/2014, à 08:12

camox

Re : https écrit en rouge et barre

ls -l /var/www/html/

résulta

camox@camox-K55VM:~$ ls -l /var/www/html/
total 16
-rw-r--r-- 1 root  root  11510 mai   13 19:39 index.html
lrwxrwxrwx 1 root  root     21 mai   13 21:21 phpmyadmin -> /usr/share/phpmyadmin
drwx------ 7 camox camox  4096 mai   14 07:33 velo
ls -l /var/www/html/velo

resulta

camox@camox-K55VM:~$ ls -l /var/www/html/velo
total 108
drwx------ 2 camox camox  4096 oct.  30  2013 css
drwx------ 2 camox camox  4096 oct.  21  2013 img
drwx------ 2 camox camox  4096 oct.  17  2013 img_articles
drwx------ 2 camox camox  4096 oct.  30  2013 img_promo
-rw------- 1 camox camox 42547 mai    8 13:29 index.html~
-rw------- 1 camox camox 42547 mai    8 13:29 index.php
drwx------ 2 camox camox  4096 oct.  14  2013 js
camox@camox-K55VM:~$ 

"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#20 Le 15/05/2014, à 08:26

casperfr

Re : https écrit en rouge et barre

comme je te l'ai écris juste après
quand tu fais la commande tu as ceci
drwx------ 7 camox camox  4096 mai   14 07:33 velo
                     ^           ^groupe
                      |propriétaire
le propriétaire et le groupe est camox,
mais quand on regarde le début de la ligne,
d<- désigne que ce que tu vois est un dossier (directory)
ensuite tu as un groupe de 3 lettre
r w x (r voulant dire autorisation de lire, w autorisation d'écrire et x autorisation d'executer)
tu vois donc que le premier groupe de 3 lettres a le droit de lire ecrire et executer,
ce premier groupe de 3 represante ce que le propriétaire a le droit de faire, c'est a dire camox dans ton cas
ensuite il y a un autre groupe de 3 lettre qui représente le groupe d'autorisation de se dossier (il ce trouve que dans ton cas c'est le meme camox)
et le troizieme groupe de 3 représante tous les autres, ceux qui ne fond pas partis du propriétaire ou du groupe
apache est l'utilisateur www-data
il n'est ni le propriétaire du dossier, ni faisant parti du groupe, il n'a donc pas le droit d'affiché le dossier puisqu'il fait partit des autres et que les autre sont configuré pour n'avoir aucun droit.
la commande que je t'ai donné

sudo chown www-data:www-data -R /var/www/html/velo

te permet de changer le propriétaire et le groupe pour que ce soit apache,
pour donné les droits (écriture lecture et execution)
la commande est
pour l'utilisateur

sudo chmod u+rwx -R /var/www/html/velo

pour le groupe

sudo chmod g+rwx -R /var/www/html/velo

pour tous le monde d'un coup

sudo chmod a+rwx -R /var/www/html/velo

avec + on rajoute les droit r (read =lecture) w (write = ecriture) et x (eXecution)
on peut utilisé une autre métode par des chiffres,

sudo chmod 777 -R /var/www/html/velo

rajoute tous les droit a tout le monde

sudo chmod 755 -R /var/www/html/velo

c'est le plus courant, celui que je te conseil,
le propriétaire a le droit de tout faire et les autres n'on que le droit de lire et d'executer les fichiers,
pour les fichier internet c'est celui qu'on utilise par défaut.
je pourrais rentré dans les détails si tu veux, mais je t'embrouille déja peut etre suffisament

Dernière modification par casperfr (Le 15/05/2014, à 08:28)

Hors ligne

#21 Le 15/05/2014, à 08:46

camox

Re : https écrit en rouge et barre

caspertfr a écrit :

je pourrais rentré dans les détails si tu veux, mais je t'embrouille déja peut etre suffisament

c clair je suis un peux pommé smile

si j'ais bien compris je tape site ligne dans la console et ça devrais marcher smile

sudo chmod 755 -R /var/www/html/velo

"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

#22 Le 15/05/2014, à 10:31

casperfr

Re : https écrit en rouge et barre

oui si tu veux donné les droits,
tu as deux choses a prendre en compte,
a qui appartient le fichier (ou dossier) et ce qu'il a le droit de faire,
a chaque fois cela marche par trois,

un fichier ou un dossier possède

un propriétaire, un groupe et les autres (ni propriétaire ni groupe)
cela ce fait avec l'instruction chown
on met donc a ce fichier a qui il appartient, et les autres sont ceux qui ne font pas partis du groupe et qui ne sont pas le propriétaire
quand tu créé un fichier sur ta machine, le fichier est créé au nom d'un utilisateur ce fichier a donc comme carractéristique (propriétaire) celui qui l'a créé c'est a dire toi avec ton nom utilisé pour ouvrir ta session


ensuite a ces informations on rajoute ce qu'il peuvent faire
la lecture, l'écriture et l'execution
voici un tableau récapitulatif,

pour le propriétaire
--------------------------------------
| lecture | ecriture | execution |     <--      ce que c'est
|      r     |       w     |      x          |     <--     comment on l'écrit
|      4     |      2      |     1          |     <--     la valeur en chiffre (on additionne les nombres)
--------------------------------------              auccun droit = 0  uniquement l'execution = 1 uniquement la lecture = 4 tout les droit = 7

pour le groupe
--------------------------------------
| lecture | ecriture | execution |     <--      ce que c'est
|      r     |       w     |      x          |     <--     comment on l'écrit
|      4     |      2      |     1          |     <--     la valeur en chiffre (on additionne les nombres)
--------------------------------------              auccun droit = 0  uniquement l'execution = 1 uniquement la lecture = 4 tout les droit = 7

pour les autres
--------------------------------------
| lecture | ecriture | execution |     <--      ce que c'est
|      r     |       w     |      x          |     <--     comment on l'écrit
|      4     |      2      |     1          |     <--     la valeur en chiffre (on additionne les nombres)
--------------------------------------              auccun droit = 0  uniquement l'execution = 1 uniquement la lecture = 4 tout les droit = 7

quand on écrit chmod 744 sur un dossier ou fichier, celui ci a donc
1er chiffre le droit de tout faire et c'est le propriétaire
2eme chiffre 5 : 4+1 ce qui représente le droit en lecteur et en execution mais pas en écriture pour le groupe du fichier
3eme chiffre 5 : 4+1 ce qui représente le droit en lecteur et en execution mais pas en écriture pour tous les autres
voila ce sont les droits que l'on donne au fichier,
cela ce fait avec l'instruction chmod

alors je peux comprendre que la réflexion est complexe mais cela te permet de tout faire et ne pas avoir de limite


pour résumé,
tu changes le propriétaire de ton dossier

sudo chown www-data:www-data -R /var/www/html/velo

tu donnes les droit a ton dossier

sudo chmod 755 -R /var/www/html/velo

le -R permet de dire, que l'on fait la meme chose a tous les dossiers et fichiers contenu dans le dossier velo

pas trop pompeux mon explication ?

EDIT sous windows, les droits sont géré différement, ce qui fait qu'ayant plus de droit par défaut, les fichiers sont moins sécurisé, la stratégie de linux se base principalement sur la sécurité d'ou la complexité aparante de ce que je t'ai expliquer, mais une fois que tu as pigé le truc tu t'apperçois que ce n'est pas si complexe que ça et sa va devenir un reflexe.

Dernière modification par casperfr (Le 15/05/2014, à 10:33)

Hors ligne

#23 Le 15/05/2014, à 20:58

camox

Re : https écrit en rouge et barre

là tu ma complètement pommé smile

du coup j'ai fais quelque recherche pour trouvé des tutos sur les commandes linux et apache, je suis tombé sur ce site et j'ai commande ces deux magazine hors séries

pour le serveur apache

pour les lignes de commande

je vais mettre le php de coté, me concentre sur les commandes de linux je pense que ces importent quand on veux ce servir correctement de linux smile

j'ai mis le site en favoris car il vont sortir un 2èm HS sur le commande pour personne intermédiaire et confirmé ( je sais ces pas pour de suite smile )

++


"L'homme est moins fidèle à lui-même lorsqu'il s'exprime à découvert. Donnez-lui un masque et il vous dira la vérité."

Oscar Wilde

Hors ligne

Haut de page ↑