Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 23/10/2007, à 20:03

Gentoo

VSFTPD - fichiers uploadés chmodé en 0600

Bonjour à tous.

Voilà : mes fichiers que j'uploade sont automatiquement chmodés en 0600, je suis obligé de passer après avec un chmod 0666 pour pouvoir le rendre accessible …voilà ma config :
#/etc/xinetd.conf

service ftp
{
	socket_type             = stream
	protocol                = tcp
	wait                    = no
	user                    = root
	server                  = /usr/sbin/vsftpd
}

#/etc/vsftpd.conf

# Ceci configure vsFTPd en mode "standalone"
listen=NO

# Petit nom du serveur
ftpd_banner=Bienvenue sur le FTP du Clan Fantome.

# On active les connexions anonymes pour rendre le contenu accessible
# et on active les non-anonymes(c'est le cas des utilisateurs virtuels):
anonymous_enable=YES
local_enable=YES

# Pour des raisons de sécurité on interdit toute action d'écriture:
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO

# 'guest_enable' est très important: cela active les utilisateurs virtuels!
# 'guest_username' fait correspondre tous les utilisateurs virtuels à
# l'utilisateur 'virtual' que nous avons défini plus haut, et au home
# correspondant: '~virtual/'.
guest_enable=YES
guest_username=virtual

# On veut que les utilisateurs virtuels restent chez eux: '~virtual/'
# (attends, on leur a fait un toît, c'est pas pour rien!)
chroot_local_user=YES
user_config_dir=/etc/vsftpd_user_conf/

# On défini le nombre maximum de sessions à 200(les nouveaux clients recevront
# un message du genre: "erreur: serveur occupé").
# On défini le nombre maximum de sessions par IP à 4
max_clients=200
max_per_ip=4
local_umask=002

####################################
# Debian customization             #
# (ou adoptons la debian attitude) #
####################################
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default.  These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem

ensuite j'utilise PAM pour logguer mes utilisateurs ayant un accès en écriture, çà marche très bien
et je le créer un espace à chacun et un fichier de conf à chacun (le même pour tous)
#user

#son fichier d'écriture
local_root=ellaume
anon_world_readable_only=NO
#peut uploader
anon_upload_enable=YES
#peut écrire
write_enable=YES
#peut créer des dossiers
anon_mkdir_write_enable=YES
# Masque qui normalement fais que c'est chmodé en 0766 je crois
local_umask=022

Merci d'avance pour votre aide

Hors ligne

#2 Le 23/10/2007, à 20:34

NP

Re : VSFTPD - fichiers uploadés chmodé en 0600

man umask

Edit : copié/coller raté

# Masque qui normalement fais que c'est chmodé en 0766 je crois
local_umask=022

A changer selon tes besoins

Dernière modification par NP (Le 23/10/2007, à 20:36)

Hors ligne

#3 Le 23/10/2007, à 20:37

redback

Re : VSFTPD - fichiers uploadés chmodé en 0600

slt,

essaye avec ca puis redemarre vsftp

local_umask=022
file_open_mode=0777
virtual_use_local_privs=NO

cela me permet d' avoir un chmod 755 sur mon serveur avec vsftp

Dernière modification par redback (Le 23/10/2007, à 20:38)

Hors ligne

#4 Le 23/10/2007, à 21:17

Gentoo

Re : VSFTPD - fichiers uploadés chmodé en 0600

çà ne marche pas ta solution redback, juste mon chmod qui devient 0700 …

Hors ligne

#5 Le 04/11/2007, à 22:39

Gentoo

Re : VSFTPD - fichiers uploadés chmodé en 0600

Bon je suis passé à Xubuntu 7.10 et j'ai réinstallé vsftpd … toujours le même problème : çà doit venir forcement de la config. À la ubuntu party de Paris j'ai demandé et il parait que c'est parce que je le lance avec root ; je me demandais comment faire car j'utilise xinetd pour gérer vsftpd et si je lance xinetd avec l'user normal mon ftp marche pas …
Pouvez-vous m'aider siou-plait.

Hors ligne

#6 Le 10/12/2007, à 12:37

LeCaméléon

Re : VSFTPD - fichiers uploadés chmodé en 0600

en 7.10 au taf j'avais oublié de mettre la bone config pour le mask et j'avais le même soucis que toi.

j'ai mis :
local_umask=022
au lieu de 077

redémarrer VSFTPD et ça fonctionne !

Hors ligne