Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 05/06/2014, à 23:04

Bougron

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Ubunter0 a écrit :

Bonjour,
* Petite précision au sujet du BIOS : le PC en question est tout récent, son BIOS est donc un UEFI ; par souci de simplicité, j'avais installé Ubuntu en mode non-UEFI.

Tu boote en node normal et non EFI  voir le tuto d'installation. http://forum.ubuntu-fr.org/viewtopic.php?id=986671

Dernière modification par Bougron (Le 05/06/2014, à 23:11)

Hors ligne

#27 Le 05/06/2014, à 23:18

Ubunter0

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

J'ai installé Ubuntu en suivant la procédure "Installer rapidement Ubuntu sur un PC récent (sans se soucier de l'EFI)" décrite ici : http://doc.ubuntu-fr.org/uefi#installer … r_de_l_efi

Le Windows installé au départ n'est pas un Windows 8 préinstallé, mais un Windows XP installé par mes soins. Je peux aller vérifier dans le BIOS, mais normalement j'ai désactivé le QuickBoot ou FastBoot propre au mode EFI avant d'installer UBuntu.

Je ne trouve pas de répertoire /EFI/boot ni /EFI/ubuntu, mais j'ai un fichier grub.cfg dans le répertoire /boot/grub. Je tape les deux commandes que tu me proposes et je compare les numéros UUID.

Hors ligne

#28 Le 05/06/2014, à 23:29

Bougron

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Bonsoir, Non c'est inutile, tu as un demarrage classique et non EFI, le fichier est totalement différant

Hors ligne

#29 Le 05/06/2014, à 23:33

Ubunter0

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Tiens, la commande 'sudo blkid' a renvoyé un truc bizarre à propos de ma partition Ubuntu (sda5 en l'occurence) :

/dev/sda5: UUID="0162fa94-3703-4ccb-8bf2-d4c6c8558574" UUID_SUB="def99e55-d719-4621-ad70-f98d73ba20c3" TYPE="btrfs"

La première série de caractère (UUID) correspond à celui renseigné dans mon fichier /boot/grub/grub.cfg. En revanche, j'ignore à quoi se rapporte le second (UUID_SUB).

Hors ligne

#30 Le 06/06/2014, à 00:34

Bougron

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Le grub-cfg indique un identifiant unique (dans le monde) de la partition sur laquelle booter, qui te renvoie sur l'adresse d'un disque  (/dev/sda5) qui doit avoir ubuntu..
l'autre  est aussi un identifiant, Comme toi je ne connais pas, Il y a encore la possibilité d'identifier la partition par son label (que tu peux fournir) pour par son id constructeur
=> voir   sous  /dev/disk

Dernière modification par Bougron (Le 06/06/2014, à 00:34)

Hors ligne

#31 Le 06/06/2014, à 15:20

bishop.sad.clown

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

mount -t proc /proc /U/proc

puis la suite...


@++ , Rob'
Xubuntu TRUSTY sur laptop Asus X54H ( usage server ), Xubuntu TRUSTY sur laptop  Asus eeepc 1215N ( usage laptop ), et Xubuntu TRUSTY / Debian JESSIE  sur laptop HP Envy M6 ( usage desktop )
Xubuntu PRECISE sur desktop Fujitsu-Siemens
Je n'ai pas toujours les réponses mais je les cherche en même temps que vous... =· þ

Hors ligne

#32 Le 06/06/2014, à 16:34

Ubunter0

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Je n'aurais pas l'occasion d'essayer cette dernière commande, je suis en train de finaliser la réinstallation d'Ubuntu... Faut dire, il s'agit du PC familial, et mes parents me mettent un peu la pression pour que tout rentre dans l'ordre.^^
Je vous donne quelques informations au passage :
- Le répertoire /dev/disk/by-label ne contenait qu'un seul et unique fichier nommé Ubuntu\x2014.04\x20LTS\x20amd64. Après un clic droit sur "Propriétés" et dans la fenêtre qui s'ouvre on pouvait lire notamment : Link target: ../../sr0 (ce "sr0" me fait dire que ce fichier ne se rapportait qu'au Live-CD dans le lecteur DVD ; sinon, aucune trace du label de la partition où était installé Ubuntu...).
- J'ai réinstallé en choisissant l'option "Autre chose" afin de supprimer la partition Windows et recréer totalement une nouvelle partition pour Ubuntu, beaucoup plus grande (40 Go sur les 500 Go du disque dur) et formatée cette fois-ci en ext4.
- L'installateur d'Ubuntu a détecté la présence de Windows sur mon disque, mais pas celle d'Ubuntu, j'aurais donc tendance à penser qu'en touchant à sa partition, j'ai dû bousillé mon Ubuntu, bien que ses fichiers apparaissent toujours. Ca expliquerait qu'aucune tentative pour le redémarrer n'ait abouti.
- Probablement parce que ma nouvelle installation d'Ubuntu se trouve désormais sur une partition ext4 et non Btrfs comme précédemment, je n'ai pas eu droit au fameux bug et j'ai donc pu installer grub sans problème sur /dev/sda.

Bref, j'ai désormais un Ubuntu tout neuf sur lequel je m'occupe de remettre les pilotes (imprimante, scanner...).

Un point de détail pour finir : j'ai installé smartmontools que j'utilisais déjà précédemment, et il me semble bien que quelque chose a changé depuis la précédente installation qui date de la mi-avril : lorsqu'on arrive à l'étape "Traduire l'alerte" ici : http://doc.ubuntu-fr.org/smartmontools# … e_l_alerte
la commande : sudo gedit /usr/share/smart-notifier/smart_notifier/smart-notifier.glade
n'ouvre qu'un nouveau document vide, car le fichier smart-notifier.glade n'existe plus dans smart-notifier (en tout cas sous Ubuntu 14.04, je ne saurais dire ce qu'il en est pour les autres versions). La bonne commande à taper pour éditer le message d'alerte et le traduire en français est :
sudo gedit /usr/share/smart-notifier/smart_notifier/smart-notifier.xml

Hors ligne

#33 Le 07/06/2014, à 18:14

Ubunter0

Re : Ubuntu 14.04 ne démarre plus suite à une modif des partitions [Résolu]

Conclusion : je termine ma réinstallation d'Ubuntu, c'est pas encore tout à fait fini parce que mon scanner me fait quelques misères (ça devrait rentrer dans l'ordre).
Merci à tous ceux qui se sont penchés sur mon problème.

Hors ligne

Haut de page ↑