Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 23/06/2014, à 19:01

Domeee

GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour,
à une époque, j'avais téléchargé la version beta de GeoGebra 3D sur les bons conseils de michcauch, ça devait être la version 249 ou 250, sur une Lubuntu 13.04 et ça marchait très bien.
Je viens de retenter la chose avec la version 275 sur une Lubuntu 14.04, ça marche, le logiciel se charge, la partie classique semble fonctionnelle (mais je n'ai pas trop investigué), par contre, la fenêtre 3D affiche des zébrures n'importe quoi (genre carte vidéo plantée) : inutilisable...
Quelqu'un a été confronté au pb ?
Domeee

Dernière modification par Domeee (Le 07/10/2014, à 22:20)

Hors ligne

#2 Le 23/06/2014, à 23:04

mikedafunk

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Salut wink
Tu as essayé d'autres softs 3D sur ta distrib ? ça se trouve tu as un problème de pilote ?
Quelle carte vidéo ?
Donne nous le résultat de la commande : lspci | grep VGA


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#3 Le 24/06/2014, à 13:49

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Salut mikedafunk,
merci de te pencher sur mon pb smile
Je n'avais pas pensé à ça...
Réponse à ta 1e question : à priori non...
Réponse à ta 2e question :

domeee@domeee-desktop:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation NV44A [GeForce 6200] (rev a1)

Jusque là, tout va bien, j'ai effectivement une geforce 6200 (sur un port AGP : j'ai bon, ça a existé ces trucs là ?!!), en plus d'une puce intel GMA 900 ou truc du genre sur la carte mère, mais visiblement, c'est la nvidia qui est prise en compte.
Je n'ai pas fait d'install des pilotes nvidia (ça m'avait mis le binz sur ma 13.04), j'ai vérifié dans synaptic, y'a rien de nvidia qui soit installé.

Sinon, des infos qui peuvent peut-être t'aider à m'aider :
- j'ai pas de fichier etc/X11/xorg.conf : c'est grave docteur ?
- j'ai eu par 2 fois (enfin, deux salves de plusieurs fois) des soucis au boot : j'avais un message d'erreur, et visiblement ça concernait un truc de l'affichage (je ne me rappelle plus trop si c'était un fichier en xorg ou x11  qui déconnait). A chaque fois, je cliquais sur 'laisse tomber' et mon système marchait comme il faut. Ca a disparu la 1e fois après une mise à jour du système, et tout récemment après un boot sous win wxp (??)

Faudrait que je trouve un soft 3D pour voir ce que ça donne, c'est une bonne piste.
Domeee

[edit] : je viens de tester le même sur la même machine mais avec une mint lmde : pareil.
idem, j'ai le pilote "nouveau", pas de nvidia

Dernière modification par Domeee (Le 24/06/2014, à 20:56)

Hors ligne

#4 Le 24/06/2014, à 22:11

mikedafunk

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Oui c'est normal qu'il n'y a plus de fichier X11, le paramétrage se fait à la volée
"À partir de la version 7.4 de X.org (soit à partir d'Ubuntu 8.10 Intrepid), le serveur X se configure automatiquement au démarrage.

Tu as essayé d'enlever ta carte vidéo pour voir comment gérait la carte interne ?
Sinon installe le pilote recommandé de ta carte, va dans le gestionnaire de pilotes propriétaires
http://doc.ubuntu-fr.org/gestionnaire_d … prietaires

Tiens nous au jus


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#5 Le 24/06/2014, à 22:31

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

alors en fait, tant pis pour geogebra 5, mon pc marche bien comme ça, je ne vais pas démonter la carte ni remettre une 3e fois des pilotes nvidia (première fois j'ai vautré ma mint => à réinstaller, deuxième fois, j'ai abimé ma Lubuntu 13.04 => un boot sur deux, ça plantait, fallait rebooter une 2e fois (ça s'appelle le dual boot lol))
Et quand même, avec la 13.04 et la version 4.9.250 (environ) de geogebra 5, ça marchait très bien...

Hors ligne

#6 Le 25/06/2014, à 12:57

mikedafunk

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Ouai sinon il faut faire un ghost de ton disque au cas où...
http://doc.ubuntu-fr.org/clonezilla


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#7 Le 07/10/2014, à 22:19

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Suite de l'épisode précédent...
J'avais essayé d'autres versions beta de ggb5 sur la même machine avec la 14.04 => même pb de zébrures dans la zone d'affichage 3D (et que celle là, le graphique 2D marche sans pb)

Plus casse pied : j'ai chargé le .deb de la version 5.0.13 (donc la version officielle nouvellement sortie), j'ai d'abord désinstallé complètement ma version 4.4 pour éviter les embrouilles, et installé la 5. Tout marche, sauf le même problème de zébrure en zone 3D.

Ensuite, j'ai voulu tester la version "portable", histoire de l'essayer sur mon eeepc qui tourne sous Lubuntu 13.04, et dont la version ggb 5 beta 250 marche très bien depuis longtemps (la même marchait très bien sur mon pc de bureau quand il était en 13.04 ceci dit en passant...)
Et là, le fichier geogebra-portable qui est normalement un exécutable ne veut pas s'exécuter... Si j'ouvre pcmanfm en root, dans les propriétés, je change les droits d'exécution de ce fichier à "tout le monde" (c'est à "personne" par défaut : pas étonnant que le fichier ne s'exécute pas), je valide => modife pas prise en compte.
Je passe en console en root (grrr...), et ni "chmod o+x geogebra-portable", ni "chmod 777 geogebra-portable" ne sont pris en compte !!!
un ls -l ne montre aucun changement.
J'ai merdé quoi ?
Pour le coup, geogebra m'agace un peu...
Qq'un a eu les mêmes soucis ?

Hors ligne

#8 Le 07/10/2014, à 22:38

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

J'ai fait une autre manip : j'ai décompressé les fichiers de la version portable dans mon home : cette fois, on peut exécuter l'exécutable : super. Mais bon, toujours le même bug d'affichage sur la 14.04.
Pour une version portable, ça la fout mal, pas moyen de mettre ça sur un disque quelconque ou une clé usb !

Hors ligne

#9 Le 07/10/2014, à 23:00

temps

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour,
Peut-être qu'avec un peu d'espace disque la solution est dans l'installation d'un bureau plus léger.
Un petit coup de live, gparted puis l'install faible ressource.
ensuite penser à faire un update-grub dans la version actuelle
Cordialement


Parce que l'USB bootable est le support des systèmes experts,
Parce que l'USB bootable contient sa propre image au démarrage.
L'USB bootable permet de créer un monde à la dimension de son imagination

Hors ligne

#10 Le 08/10/2014, à 09:42

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour,
non, j'ai une installation récente, légère (Lubuntu) faite après formatage (clean, pas upgrade d'une vieille bouse), j'ai une partition système de 15Go dont 6 occupés. Et j'ai une beta qui marche très bien sur mon eeepc (Lubuntu 13.04) qui ne dispose que de 250Mo de libre sur le disque…
Pour info, je rappelle que la version beta marchait très bien sur la version 13.04 de Lubuntu : il y a eu qqchose au passage de la 14.04 => version de java ? prise en charge de la 3D au niveau noyau ? autre ?
J'aimerais savoir si d'autres utilisateurs sont confrontés à ce pb (donc test sur leur machine, pas des suppositions)

Hors ligne

#11 Le 08/10/2014, à 14:38

michcauch

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour Domeee
Chez moi GeoGebra5 fonctionne très bien (version des paquets) sur mon portable (Thinkpad E320 -core i3 - CG Intel Sandybridge Mobile - 4 Go de RAM) sous ubuntu 14.04 LTS.
Aucune différence notable de fonctionnement d'avec la 4.4 précédente sinon 1 s de plus à l'ouverture.

As-tu essayé d'installer la version portable toujours disponible ici


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#12 Le 08/10/2014, à 19:00

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour michcauch,
merci pour ton retour : à priori, c'est donc ma machine qui marche mal (celeron D320 2,4GHz, 512Mo de ram, nVidia 6200 avec pilote libre "nouveau")
Pour la version portable, tu l'as aussi en version officielle ici
C'est de là que je l'ai tirée, et testée (voir post #7) avec les ennuis cités plus haut… Et ça ne marche pas mieux… Et ce n'est pas portable du tout !
A titre indicatif, l'écran que j'obtiens :

écran

Dernière modification par Domeee (Le 08/10/2014, à 19:00)

Hors ligne

#13 Le 08/10/2014, à 20:04

michcauch

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Es-tu inscrit sur le forum GeoGebra ?
Peut-être quelqu'un saurait-il te dire si ta configuration est suffisante pour ce logiciel.
À moins que ce soit Lubuntu qui foire quelque part ? et as-tu essayé un pilote Nvidia (s'il existe pour la tienne et si l'installer est sans risque !) ?
Dernière solution, tu reviens à GeoGebra 4.4 (par Synaptic, c'est possible) et tu réinstalles la version de GeoGebra 5 qui marchait bien.

Dernière modification par michcauch (Le 08/10/2014, à 20:04)


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#14 Le 10/10/2014, à 15:00

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour michcauch,
1/ je ne suis pas inscrit sur le forum GGB, mais je vais aller voir les commentaires
2/ ça ne semble pas spéciifique à Lubuntu, j'ai une mint debian sur la même machine, GGB5 a exactement le même comportement.
3/ GGB4.4 marche bien sur ma machine, par contre, je n'ai jamais eu de version 5 qui marchait bien sous 14.04. C'était la 4.9.250 qui tournait bien sous 13.04 (et qui tourne toujours sur mon eeepc en 13.04)
4/ j'ai testé les pilotes Nvidia deux fois sur ce pc, j'ai eu des embrouilles à chaque fois => je passe mon tour !
5/ la version portable ne marche pas mieux, et en plus, elle n'est pas vraiment portable : cf mes posts #7 et #8 : gros pb de propriété de fichiers et d'exécution si on installe ailleurs que dans le "home" (si tu as des tuyaux, je suis preneur...). J'aimerais l'installer sur un support amovible et la tester sur mon eeepc pour voir si elle marche en 13.04 => pas moyen (et plus de place sur mon eeepc (4Go de disque, gloups !))
J'essaye de fouiller dans le forum à la rubrique video et 3D mais je ne trouve pas grand chose...
[Edit] certains utilisateurs sous windows ont un pb de fermeture inopinée de GGB5 quand la souris passe sur la fenêtre 3D. Ca serait dû à un bug qui affecte les puces graphiques intel GMA. J'ai 2 puces graphiques sur mon pc : une intel GMA et une carte nvidia 6200. Normalement, c'est la nvidia qui marche, mais ? Il y aurait un lien ? [/Edit]

Dernière modification par Domeee (Le 10/10/2014, à 15:17)

Hors ligne

#15 Le 10/10/2014, à 15:51

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Je viens de faire le test sur mon eeepc (sous Lubuntu 13.04).
J'avais la 4.9.248.0 pour être précis : je l'ai zippée pour la sauvegarder et retirée de mon home, et j'ai dézippé la version 5.0.13 portable dans mon home.
Eh bé, ça marche : aucun souci d'affichage.
Pour mon pc de bureau, j'avais cru à un pb de RAM (512Mo, + 128Mo sur la nvidia) : ce n'est pas ça, l'eeepc a aussi 512Mo de ram, une puce intel GMA et pas de ram video, et seulement 128Mo de swap contre 512 sur mon pc de bureau.

Bilan : il y a bien un souci au niveau de la version 14.04 pour certaines configs un peu faibles. Je répète que la 4.9.248.0 marchait sur mon pc de bureau du temps où il était en Lubuntu 13.04

Dernière modification par Domeee (Le 10/10/2014, à 15:56)

Hors ligne

#16 Le 10/10/2014, à 17:16

michcauch

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Si tu le veux bien, je transmets ton message sur le forum GeoGebra, le concepteur de GeoGebra5 (Mathieu Blossier) y est très présent et il connait peut-être le problème.


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#17 Le 10/10/2014, à 18:31

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Ok Michel, pas de pb pour que tu transmettes sur le forum GeoGebra, si ça peut permettre de dépanner d'autres utilisateurs…
Par contre, je ne sais pas si le pb vient de GeoGebra ou des *buntu 14.04…
Pour l'instant, vu les retours, le pb semble être réservé à … moi même !!!
Bon week end
Domeee

Hors ligne

#18 Le 12/10/2014, à 08:41

michcauch

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour Domeee,

Le lien vers le message sur ton sujet sur le forum GeoGebra

Une réponse déjà ...

Dernière modification par michcauch (Le 12/10/2014, à 09:56)


Cordialement
Michel
___
Ubuntu 14.04 sur Lenovo ThinkPad Edge E320 et Xubuntu 13.10 sur PC fixe.

Hors ligne

#19 Le 12/10/2014, à 10:47

miir83

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour, c'est moi qui ai mis une réponse sur le forum GeoGebra.
Peut-être peux tu essayer la dernière version de GeoGebra : 5.0.16 peut être moins gourmande en capacités
Michel Iroir

Dernière modification par miir83 (Le 12/10/2014, à 10:48)

Hors ligne

#20 Le 12/10/2014, à 14:37

Domeee

Re : GeoGebra 3D [et aussi nouvelle version 5] : pb d'affichage 3D

Bonjour aux deux Michel, et merci beaucoup pour votre aide !
@ miir83 :
- j'ai fait des tentatives pour installer les pilotes nvidia sur ma machine, j'ai eu des ennuis à chaque fois => je ne recommencerai pas.
- visiblement, c'est la nvidia 6200 qui ne passe pas. C'est bizarre, sur mon eeepc701, j'ai un truc du genre intel GMA 900 ou 950 et ça marche sans pb... C'est vrai que la nvidia est plus ancienne (2005, et c'était les "fins de série" à cette époque, ça équipait les cartes à pas cher)
- le lien que tu donnes pour tester ma 3D ne me permet pas de faire le test : j'ai une image qui me dit qu'il manque un plug in pour afficher le contenu, quand je clique sur "installer le plugin", il me répond qu'il n'y a pas de plug in correspondant... J'ai firefox 32.0.3
- dernière précision : je suis en 32 bits, et j'ai réinstallé la version portable 4.9.248 que j'avais sur mon eeepc et qui marchait sur mon pc de bureau avec Lubuntu 13.04 : elle ne marche plus sur la 14.04 !

=> d'où mon idée qu'il y a sûrement eu un truc qui a changé concernant ma video entre les deux versions de Lubuntu. L'idéal serait que je réinstalle la 13.04 pour voir mais ça me fatigue d'avance...

Quant à la 5.0.16, je n'y crois pas trop, j'ai testé plusieurs versions depuis la 4.9.248 sans succès. Je verrai à l'occasion.

Merci pour votre aide, je surveille le forum GeoGebra...

Domeee

Hors ligne

Haut de page ↑