Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 20/07/2014, à 20:08

jul691

Ouverture session automatique ?[résolu]

Slt smile
je veut ouvrir ma session automatique sans mot de passe ni de valider l'utilisateur .
J'ai réussi a enlever le mot de passe dans paramètre utilisateur ,mais au demarage  je doit quand meme valider l'utilisateur.
Je veux allumer mon PC en quand je reviens tous est lancer .
Est ce que c'est possible Merci smile

Dernière modification par jul691 (Le 24/07/2014, à 13:53)


Lubuntu 14.04

Hors ligne

#2 Le 20/07/2014, à 20:38

Domeee

Re : Ouverture session automatique ?[résolu]

Salut jul691,

alors tout d'abord, il faut savoir que tu as raté une case à cocher quelque part dans ton installation : on te demande si tu veux une ouverture de session automatique, il faut cocher "oui" et donner l'ID de l'utilisateur à ouverture automatique => tu aurais eu le bon comportement sans manip.

2e chose, vu que tu es dans le forum LXDE, je suppose que tu es sous Lubuntu. Je ne sais pas si cette manip marche avec un autre environnement de bureau (Xubuntu, Ubuntu...)

--------------------------------------------------------------------------------------------------------------------------
[Edit 24/07/2014] : NE SURTOUT PAS APPLIQUER LA PROCÉDURE DÉCRITE ICI : c'est celle qui s'appliquait aux versions Lubuntu antérieures à la 12.04. Voir la suite du fil !
--------------------------------------------------------------------------------------------------------------------------

Pour corriger ton pb, c'est très simple :
- tu ouvres une console (ctrl+alt+T)
- tu tapes :

sudo leafpad /etc/lxdm/default.conf

- tu donnes ton mot de passe administrateur
- dans le fichier ouvert suite à ta commande, tu as la première ligne qui doit être du style :

# autologin=domeee

- tu enlèves le # (qui indique que la ligne est un commentaire)
- si tu n'as pas cette ligne, tu la rajoutes en tête de fichier
- évidemment, à la place de "domeee", tu mets ton nom d'utilisateur smile
- tu enregistres le fichier modifié
au prochain boot, ton pc se lance tout seul, tu arrives sur le bureau sans aucune manip

Dernière modification par Domeee (Le 24/07/2014, à 16:06)

Hors ligne

#3 Le 20/07/2014, à 21:23

jul691

Re : Ouverture session automatique ?[résolu]

sa marche pas ,merci de ton aide

autologin=eliza
[base]
## uncomment and set autologin username to enable autologin


## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

Lubuntu 14.04

Hors ligne

#4 Le 20/07/2014, à 21:50

jplemoine

Re : Ouverture session automatique ?[résolu]

Je pense qu'il faut aussi décommenter la ligne timeout.
En effet, il faut que tu es la temps de prendre la main avant l'ouverture automatique.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#5 Le 20/07/2014, à 21:59

Domeee

Re : Ouverture session automatique ?[résolu]

jul691 a écrit :

sa marche pas

Ok, mais ça ne dit pas :
- quel est ton système ?
- tu as rebooté ?
- quelles manips avais-tu faites dans les paramètres utilisateur  : ça peut venir de là.

@ jplemoine : chez moi, c'est commenté et ça marche, et justement, le but est de ne pas à avoir à prendre la main avant la fin du boot

Dernière modification par Domeee (Le 20/07/2014, à 21:59)

Hors ligne

#6 Le 20/07/2014, à 22:03

jplemoine

Re : Ouverture session automatique ?[résolu]

De mémoire, il y a une tempo pour neutraliser l'auto login...  (si on fait rien, ça boote mais au bout de n secondes).
Mais je ne sais pas si c'est obligatoire ou pas.
Si tu me dis que non, c'est que je me suis trompé : j'avais mis "je pense" pour montrer ma "non-certitude".


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#7 Le 20/07/2014, à 22:13

jul691

Re : Ouverture session automatique ?[résolu]

oui je suis sur lubuntu
Dans paramètre utilisateur javais juste cocher la case pas de mot de passe au démarrage.
Que j'ai remis toujours pareil sauf qu'il demande le mdp bien sur.


Lubuntu 14.04

Hors ligne

#8 Le 21/07/2014, à 09:10

Domeee

Re : Ouverture session automatique ?[résolu]

Nul, je suis nul…
Je m'étais déjà fait avoir sur ce truc : l'utilitaire de changement de session avait changé pour la 13.04, c'est lightdm => le fichier que j'ai indiqué ne sert plus à rien (mais que diantre fait-il encore ici ???)
Voir ce fil pour une solution qui marche (enfin, j'espère !)

[Edit 24/07/2014] : ATTENTION : il faut donc modifier le fichier etc/lightdm/lightdm.conf

@ jplemoine : tu avais du tomber sur un truc comme ça et tes souvenirs t'ont donné une piste pas anodine, parce qu'effectivement, il faut paramétrer le timeout comme il faut sinon ça ne marche pas (voir le fil en lien)

Dernière modification par Domeee (Le 24/07/2014, à 16:02)

Hors ligne

#9 Le 21/07/2014, à 13:04

jul691

Re : Ouverture session automatique ?[résolu]

Salut smile
j'ai fait comme sa mais toujours pareil j'ai du louper quelque chose ?

autologin-jul=a151083
autologin-user-timeout=0
pam-service=lightdm-autologin
[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startlubuntu

## uncomment and set to set numlock on your keyboard
# numlock=0

Lubuntu 14.04

Hors ligne

#10 Le 21/07/2014, à 14:01

Domeee

Re : Ouverture session automatique ?[résolu]

Rhââ, on va pas y arriver !

voilà mon fichier etc/lightdm/lightdm.conf :

[SeatDefaults]
autologin-guest=false
autologin-user=domeee
autologin-user-timeout=0
autologin-session=lightdm-autologin

Il a été généré automatiquement à l'installation de ma Lubuntu 14.04, je n'ai rien bidouillé.
Je pense que ton pb vient de ta 1e ligne : tu as "autologin-user=...", il faut pas remplacer "user" par ton nom de user, mais le mettre après le =
Essaye de mettre ton fichier au frais, et remplace le contenu par les lignes du mien en remplaçant juste domeee par ton nom de user.
Si ça marche pas, langue au chat...

Hors ligne

#11 Le 21/07/2014, à 14:54

jul691

Re : Ouverture session automatique ?[résolu]

J'ai fait sa (toujour pareil) Il faut peut-être effacer toute les autre ligne ?

[SeatDefaults]
autologin-guest=false
autologin-user=jul
autologin-user-timeout=0
autologin-session=lightdm-autologin
[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startlubuntu

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

Dernière modification par jul691 (Le 21/07/2014, à 14:55)


Lubuntu 14.04

Hors ligne

#12 Le 21/07/2014, à 17:21

Domeee

Re : Ouverture session automatique ?[résolu]

Ben là…
Je sais que ça avait marché sur mon eeepc en 13.04 avec juste les 4 lignes situées entre [SeatDefaults] et [base]
Essaye en ne gardant que [SeatDefaults] et ces 4 lignes, tu vires tout le reste.
Question : ton user est bon, y'a pas un pb de majuscule des fois ?
Sinon, dans la doc Lubuntu (en anglais), tu as cette commande en plus : "user-session=Lubuntu"
Toi, tu as "session=/usr/bin/startlubuntu" => ça serait ça qui coince ?
Si ça marche pas, je ne sais hélas pas t'aider…

Hors ligne

#13 Le 22/07/2014, à 16:20

jul691

Re : Ouverture session automatique ?[résolu]

non rien ni fait moi login est bon jul.
J'ai remplacer session=/usr/bin/startlubuntu par user-session=Lubuntu
J'ai suprimer toute les autre ligne est j'ai laisser .

[SeatDefaults]
autologin-guest=false
autologin-user=jul
autologin-user-timeout=0
autologin-session=lightdm-autologin

Toujours pareil au démarrage il me demande le mdp .

Dernière modification par jul691 (Le 22/07/2014, à 16:21)


Lubuntu 14.04

Hors ligne

#14 Le 22/07/2014, à 17:11

jplemoine

Re : Ouverture session automatique ?[résolu]

- As-tu essayer avec un timeout >= 5 ? (cf post #11)
- As-tu une sauvegarde du fichier avant modif ? Si oui, peux-tu le poster ?
- dans un terminal, résultat de

whoami

Dernière modification par jplemoine (Le 22/07/2014, à 17:12)


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#15 Le 22/07/2014, à 17:22

jul691

Re : Ouverture session automatique ?[résolu]

Résultat

jul@ubuntu:~$ whoami
jul
jul@ubuntu:~$ 

Avec 5 a la place de zero (toujours pareil)

[SeatDefaults]
autologin-guest=false
autologin-user=jul
autologin-user-timeout=5
autologin-session=lightdm-autologin
[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

Fichier avant modif

[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startlubuntu

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1

[display]
## gtk theme used by greeter
gtk_theme=Clearlooks

## background of the greeter
bg=/usr/share/lubuntu/wallpapers/lubuntu-default-wallpaper.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
theme=Lubuntu

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=

Dernière modification par jul691 (Le 23/07/2014, à 16:59)


Lubuntu 14.04

Hors ligne

#16 Le 23/07/2014, à 17:37

Domeee

Re : Ouverture session automatique ?[résolu]

Et question bête : tu as installé directement un Lubuntu 14.04, ou bien tu es parti d'un Ubuntu (ou Xubuntu ou autre) et rajouté un bureau LXDE après coup ?
Ca pourrait expliquer des choses ?

Hors ligne

#17 Le 23/07/2014, à 17:46

jplemoine

Re : Ouverture session automatique ?[résolu]

Je tente un truc :
Il te faut reprendre le fichier avant modif, le copier (pour garder une sauvegarde) et le modifier comme suit :

[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod
autologin=jul

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10
timeout = 5

## default session or desktop used when no systemwide config
session=/usr/bin/startlubuntu

## uncomment and set to set numlock on your keyboard
# numlock=0
numlock=1

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1

[display]
## gtk theme used by greeter
gtk_theme=Clearlooks

## background of the greeter
bg=/usr/share/lubuntu/wallpapers/lubuntu-default-wallpaper.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
theme=Lubuntu

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=

J'ai mis numlock=1 si tu as un pavé numérique ; supprime la ligne si tu n'en as pas.

Une fois que tu as modifié le fichier. Tu éteins comlètement l'ordinater et tu le rallumes.
Normalement, tu as un décompte de 5 secondes ; à la fin du décompte, ça ouvrira ta session jul de manière automatique.
Si ça fonctionne, tu pourras essayer avec timeout à 0 si tu veux économiser 5 secondes au démarrage.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#18 Le 23/07/2014, à 19:23

jul691

Re : Ouverture session automatique ?[résolu]

Je viens de lubuntu 13.10 domee
J'ai fait copier coller de ton fichier jplemoine
,j'ai éteint l''ordi puis je l'ai rallumer toujours pareil il me demande le mdp mais après bien 30sec d'attente.
Oui j'ai un paver numérique (un clavier d'ordi de maison)


Lubuntu 14.04

Hors ligne

#19 Le 23/07/2014, à 19:29

jplemoine

Re : Ouverture session automatique ?[résolu]

Je vais installer un lubuntu dans une machine virtuelle pour voir ce qui se passe...
Je te tiens au courant dans la journée de demain (jeudi).


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#20 Le 23/07/2014, à 19:41

jul691

Re : Ouverture session automatique ?[résolu]

C'est pas urgent mais je veux trouver wink .
Si tu peut jeter un coup d’œil pour les raccourci sur le bureau vers dd ou dossier . Qui était si simple avec la 13.10
Raccourci bureau
Merci de ton aide smile

Dernière modification par jul691 (Le 23/07/2014, à 19:41)


Lubuntu 14.04

Hors ligne

#21 Le 23/07/2014, à 19:46

Pierrot86

Re : Ouverture session automatique ?[résolu]

Bonjour,

On est bien d'accord, tu modifies bien le fichier "/etc/lightdm/lightdm.conf" ? Parce que j'ai exactement le même contenu que Domee, et je suis bien connecté automatiquement au démarrage.

Hors ligne

#22 Le 24/07/2014, à 00:03

jplemoine

Re : Ouverture session automatique ?[résolu]

J'ai fait le test en Lubuntu 14.04 fresh install
Le fichier est bien /etc/lightdm/lightdm.conf
le contenu est

[SeatDefaults]
autologin-guest=false
autologin-user=<user>
autologin-timeout=0
autologin-session=lightdm-autologin

--> c'est à dire conforme au post #10.


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#23 Le 24/07/2014, à 11:14

jul691

Re : Ouverture session automatique ?[résolu]

Quand je tape /etc/lightdm/lightdm.conf il me mais jusque ici je tapais sudo leafpad /etc/lxdm/default.conf

jul@ubuntu:~$ sudo /etc/lightdm/lightdm.conf
[sudo] password for jul: 
sudo: /etc/lightdm/lightdm.conf: command not found

Mon problème viens peut-être que j'ai fait la mise a niveau de la 13.10.
J'ai lu quelque part qu'il était préférable de faire une installe toute neuve 14.04 directement .
Vu que j'ai 2 ,3 autre problème ??

Dernière modification par jul691 (Le 24/07/2014, à 11:28)


Lubuntu 14.04

Hors ligne

#24 Le 24/07/2014, à 11:48

jplemoine

Re : Ouverture session automatique ?[résolu]

jul691 a écrit :

J'ai lu quelque part qu'il était préférable de faire une installe toute neuve 14.04 directement .

Je suis d'accord avec ça. Pour un ordinateur principal, je préconise :
- des LTS seulement
- un fresh-install lors de la sortie de la LTS.

Pour le fichier, tu peux essayer :

sudo nano /etc/lxdm/default.conf

Peux-tu faire

ls -ld /etc/lxdm/*

et donner le retour entre balises code (<> bleu>


Cordialement, Jean-Philippe.
Sous Ubuntu en système principal depuis 2009
Ubuntu 14.04 desktop (2 postes) & server (1 poste)

Hors ligne

#25 Le 24/07/2014, à 12:31

Pierrot86

Re : Ouverture session automatique ?[résolu]

jul691 a écrit :

Quand je tape /etc/lightdm/lightdm.conf il me mais jusque ici je tapais sudo leafpad /etc/lxdm/default.conf

jul@ubuntu:~$ sudo /etc/lightdm/lightdm.conf
[sudo] password for jul: 
sudo: /etc/lightdm/lightdm.conf: command not found

Mon problème viens peut-être que j'ai fait la mise a niveau de la 13.10.
J'ai lu quelque part qu'il était préférable de faire une installe toute neuve 14.04 directement .
Vu que j'ai 2 ,3 autre problème ??

Bonjour,

Je pense que tu es bien sous LightDM, et qu'il faut donc bien modifier le fichier /etc/lightdm/lightdm.conf.

De façon générale, pour lancer une commande qui vise à modifier un fichier (en mode superutilisateur), la syntaxe est la suivante :

(gk)sudo application fichier

Pour modifier le fichier /etc/lightdm/lightdm.conf avec le logiciel Leafpad, tu dois donc lancer la commande suivante :

gksudo leafpad /etc/lightdm/lightdm.conf

Après avoir entré ton mot de passe, le contenu du fichier va s'afficher dans Leafad. Remplace le contenu existant par le suivant :

[SeatDefaults]
autologin-guest=false
autologin-user=jul
autologin-user-timeout=0
autologin-session=lightdm-autologin

Enregistre le fichier, puis redémarre ton système. Tu devrais être connecté automatiquement.

Hors ligne

Haut de page ↑