Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/08/2014, à 18:53

le Rodoué

PhpmyAdmin #1045 connexion au serveur Mysql non permise

bonsoir,
je viens d'installer Lubuntu14.04 sur un vieil ordi.  Par ailleurs j'installe le serveur  apache2, php5, mysql-server, (ceci par terminal). Sur Firefox, en localhost j'ai "It Works" donc jusque ça va. J'installe phpmyadmin par synaptic, je mets le même mot de passe que sur mysql  je veux me connecter et là "1045 connexion au serveur mysql non permise. J'ai ce problème sur 2 ordi, en fait à chaque fois que j'installe ce phpmyadmin.
J'ai consulté tout ce que j'ai pu trouver comme post sur les forums et il y en a pas mal qui traitent de cette question, j'ai consulté les forums ubuntu traitant de Mysql-server, phpmyadmin...  je n'arrive pas à régler mon problème. Depuis au moins 2 jours j'essaie des trucs mais ça ne marche pas,
Si quelqu'un peut s'intéresser à mon problème j'en serai ravi.
cordialement

Hors ligne

#2 Le 04/08/2014, à 22:18

demeter44

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bonsoir tu as cette erreur lorsque tu entre ton login mot de pas sur phpmyadmin ?

Hors ligne

#3 Le 05/08/2014, à 08:05

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bonjour,
oui c'est cela

Hors ligne

#4 Le 05/08/2014, à 10:40

bruno

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bonjour,

Il faut que tu essaies de redéfinir le mot de passe de l'utilisateur root pour mysql

sudo dpkg-reconfigure mysql-server-5.5

(Cela va te demander de saisir un nouveau mot de passe, puis de le confirmer)

Et ensuite de te connecter sur phpmyadmin avec root et le mot de passe que tu viens de définir.

Hors ligne

#5 Le 08/03/2015, à 00:02

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bonjour,
Je réapparais dans ce post avec la même question. Il y a quelques mois j'avais laissé tomber, bloquant sur ce phpmyadmin et ce mot de passe.
Cette fois j'ai refait l'installation entièrement avec synaptic, intégré les mots de passe, l'ouverture de localhost se fait bien "it works" et quand je veux ouvrir phpmyadmin : http://localhost/phpmyadmin j'ai bien l'invit de connexion, je saisi Root en utilisateur et mon-mot-de-passe et là même réponse :1045 connexion au serveur Mysql non permise. 
j'ai suivi le conseil de Bruno :  "sudo dpkg-reconfigure mysql-server-5.5" , changé de mot de passe voici ce qu'il me donne : $ sudo dpkg-reconfigure mysql-server-5.5
[sudo] password for alain:
mysql stop/waiting
150307 21:11:56 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
mysql start/running, process 2126
Je ne sais plus quoi faire.
Merci de votre aide

Hors ligne

#6 Le 08/03/2015, à 12:46

bruno

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bonjour,

Le nom d'utilisateur c'est root et non Root
Est-ce que tu arrives à te connecter à mysql en ligne de commande :

mysql -u root -p

puis saisir le mot de pase. Tu devrais alors voir l'invite de commandes SQL :

mysql> 

Pour quitter  :

quit

Dernière modification par bruno (Le 08/03/2015, à 12:47)

Hors ligne

#7 Le 08/03/2015, à 13:11

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Merci de ton attention Bruno.
Après mysql -u root -p , il me demande effectivement le mot de passe, réponse  : Access denied for user 'root'@'localhost' (using password :yes)

J'ai refait l'installation par synaptic (Apache2,...)  et une chose m'avait échappé  lors de la configuration de phpmyadmin c'est une erreur dans dbconfig-common, où est signalé  "error 1045 (28000): Acces denied... " en fait le même message cité plus haut.
C'est donc dans l'installation de départ, reste à en comprendre l'origine et résoudre cette erreur ???

Hors ligne

#8 Le 08/03/2015, à 13:43

bruno

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Tu dois forcément faire une erreur en saisissant ton mot de passe… C'est bien le mot de passe que tu as choisi en #5 que tu tapes ?

Hors ligne

#9 Le 08/03/2015, à 14:14

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Salut,

Pourquoi installer phpmyadmin avec synaptic et pas avec le terminal ? Parfois il y a des dialogues qui n'apparaissent pas avec synaptic, et du coup, forcément, il peut y avoir de petites erreurs d'installation, faute de réponse adéquate...

A ta place, je désinstallerais tout, avec

sudo apt-get purge phpmyadmin
sudo apt-get purge mysql-server
sudo apt-get purge php5
sudo apt-get purge apache2

Purge, pour être sûr que tout soit désinstallé y compris les fichiers de configuration

Puis je réinstallerais tout en suivant ceci : http://forum.ubuntu-fr.org/viewtopic.ph … #p19074351


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#10 Le 08/03/2015, à 18:59

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Bruno, non je suis quasiment sûr de ne pas faire d'erreur dans la saisie du mot de passe!
Merci Rufus T Firefly. J'ai suivi la procédure pas à pas comme indiquée.Il se trouve que dans la suppression de phpmyadmin un message m'indique " une erreur s'est produite lors de la suppression de la base de données ; Error 1045 ..." Ce qui fait qu'arrivé au bout de ma procédure de réinstallation je retrouve mon éternel problème. A noter qu'il ne m'a demandé à aucun moment lors de l'installation  de saisir un mot de passe. J'ai fait une copie de toutes mes commandes passées au cas où vous souhaiteriez les avoir, mais je n'ai pas vu la façon de les transmettre.
merci de votre aide

Hors ligne

#11 Le 08/03/2015, à 19:42

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Essaye de renommer provisoirement le répertoire mysql, dans l'espoir de parvenir à supprimer phpmyadmin.

sudo service mysql stop
sudo mv /var/lib/mysql /var/lib/mysql.old
sudo apt-get purge phpmyadmin
sudo mv /var/lib/mysql.old /var/lib/mysql
sudo service mysql start

Si ça fonctionne sans broncher, désinstalle de même le reste (à cause des fichiers de config où il y a probablement des erreurs) et ré-installe.
S'il y a par contre un message d'erreur, envois-le en entier (copier/coller)... Et ce n'est pas la peine de continuer.

Là je viens de faire l'installation complète dans crunchbang (debian wheezy) et pour phpmyadmin, ça m'a demandé :
1) configurer pour apache ? Oui
2) créer  automatiquement la base de données phpmyadmin ? Oui
3) mot de passe de connexion : je donne le même que celui de sudo
4) mot de passe de connexion à mysql : celui défini lors de l'install de mysql (comme je suis en local, je prends aussi celui de sudo)
5) confirmation du mot de passe

Et ça fonctionne !

Dernière modification par Rufus T. Firefly (Le 08/03/2015, à 19:47)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#12 Le 08/03/2015, à 21:06

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Voilà la procédure faite une nouvelle fois, dans l'ordre inverse de la purge en commençant par Apache2 ;  jusqu'à l'install php5-mysql. et voici la copie du terminal à partir de cette étape :
alain@alain-KT400-8235:~$ sudo apt-get install php5-mysql
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
php5-mysql est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
alain@alain-KT400-8235:~$ mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
alain@alain-KT400-8235:~$ mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
alain@alain-KT400-8235:~$
Le problème c'est qu'au cours de l'install, il ne m'a demandé de saisir de mot de passe, donc je ne sais pas lequel il attend, j'en ai essayé 2 pour voir, mais évidemment sans résultat. Décidément c'est très agaçant. Que faire ?

Hors ligne

#13 Le 08/03/2015, à 21:38

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Ce n'est pas normal que l'installation de mysql-server ne t'ait pas demandé un mot de passe pour l'utilisateur root de mysql.
Essaye de le reconfigurer :

sudo dpkg-reconfigure mysql-server

La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#14 Le 08/03/2015, à 21:52

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

sudo dpkg-reconfigure mysql-server
demande le mot de passe for alain
puis retour à l'invit mais ne demande pas de saisir de mot de passe pour mysql!!!!! C'est un résistant !!!! habituellement je les aime mais là !!!

Hors ligne

#15 Le 08/03/2015, à 22:11

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Essaye reconfigure directement sur mysql-server plutôt que sur le métapaquet :

dpkg -l | grep mysql-server

Une fois que tu as repéré la version (probablement 5.5, mais bon il vaut mieux vérifier)

sudo dpkg-reconfigure mysql-server-m.n <= remplacer m et n par les bonnes valeurs

Edit :
Ou alors c'est peut-être que tu n'as de mot de passe root... Pourquoi ? Le diable seul le sait !

mysql -u root

Ça répond quoi ?

Dernière modification par Rufus T. Firefly (Le 08/03/2015, à 22:19)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#16 Le 08/03/2015, à 22:21

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

yes, cette fois mysql répond à "mysql -u root -p
Je poursuis l'install
Merci en attendant

Hors ligne

#17 Le 08/03/2015, à 22:24

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Donc il t'a demandé de donner un mot de passe pour l'utilisateur root de mysql quand tu as fait dpkg-reconfigure ?

Si c'est bien le cas, il se peut que apt-get purge n'efface pas les bases de donnés (ce serait d'ailleurs logique qu'on puisse ré-installer mysql sans perdre toutes les données). Or mysql a sa propre base de données (/var/lib/mysql/mysql) dans laquelle il y a une table user, qui contient, entre autres, les mots de passe (cryptés) des divers utilisateurs, dont root. Si c'est la bonne hypothèse, mysql reprend les bases qui existent, dont la sienne propre.
Et si jamais root a été enregistré sans mot de passe à la première installation, pour une raison quelconque (synaptic qui n'affiche pas la demande de mot de passe ?), il restera sans mot de passe lors des ré-installations ultérieures... Sauf si dpkg-reconfigure remédie à ça...

Dernière modification par Rufus T. Firefly (Le 08/03/2015, à 22:42)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#18 Le 08/03/2015, à 22:32

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Et zut, encore ce maudit message après install de phpmyadmin :
Une erreur s'est produite lors de la création de la base de données.         
│                                                                             
│ ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using         
│ password: YES)                                                               
│                                                                             
│ Vous pouvez soit recommencer soit abandonner l'opération. Si vous           
│ choisissez « Recommencer », la mise à jour sera tentée à nouveau en vous     
│ posant à nouveau les questions de configuration. Avec l'option               
│ « Recommencer avec les mêmes réglages », la mise à jour sera tentée         
│ immédiatement. Avec le choix « Abandonner », la mise à jour échouera et     
│ vous devrez revenir à la version précédente, désinstaller et                 
│ reconfigurer ce paquet, à moins d'effectuer vous-même les opérations         
│ nécessaires pour continuer à l'utiliser. Enfin, le choix « Ignorer »         
│ poursuivra les opérations en ignorant les erreurs ultérieures issues de     
│                                                                             
│                                  <Ok>
C'est le message que j'ai chaque fois,

Hors ligne

#19 Le 08/03/2015, à 22:43

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Est-ce que

mysql -u root -p

fonctionne toujours ?
Si mon hypothèse précédente est exacte, elle vaut aussi pour la base phpmyadmin !

Dernière modification par Rufus T. Firefly (Le 08/03/2015, à 22:45)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#20 Le 08/03/2015, à 22:44

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

je vois qu'il manque la fin du message d'erreur "Enfin, le choix « Ignorer »         
│ poursuivra les opérations en ignorant les erreurs ultérieures issues de dbconfig-common"
C'est bien là que se situe le problème.

Hors ligne

#21 Le 08/03/2015, à 22:46

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Pas de panique ! D'abord vérifier que mysql fonctionne toujours, avec son mot de passe.


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#22 Le 08/03/2015, à 22:46

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

oui "mysql -u root -p" fonctionne toujours

Hors ligne

#23 Le 08/03/2015, à 22:52

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

pardon , j'ai loupé le message 17 et ton hypothèse. Dans mon souvenir lors de 1ere install avec synaptic il m'a demandé un mot de passe que j'ai reproduit à l'identique pour le server et phpmyadmin afin justement de ne pas avoir ces problèmes... Je ne vois vraiment pas où j'ai pu me tromper et pourtant...

Hors ligne

#24 Le 08/03/2015, à 23:06

Rufus T. Firefly

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

On va y arriver.
Commence par désinstaller phpmyadmin (apt-get purge)
Ensuite, on va effacer aussi ses traces dans la base mysql. Evidemment si ça couine, arrête et renvoie ce que ça dit...

mysql -u root -p
mysql> use mysql; <= sélectionne la base mysql
mysql> delete from user where User="phpmyadmin"; <= efface l'utilisateur phpmyadmin
mysql> drop database phpmyadmin; <= supprime la base phpmyadmin
mysql> exit;

Là tu devrais pouvoir ré-installer phpmyadmin comme si tu ne l'avais jamais fait (j'espère qu'il n'y a pas de fourberies ni manigances encore ailleurs...)

Dernière modification par Rufus T. Firefly (Le 08/03/2015, à 23:12)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#25 Le 09/03/2015, à 00:05

le Rodoué

Re : PhpmyAdmin #1045 connexion au serveur Mysql non permise

Merci beaucoup pour la patience.
J'ai fait le nettoyage comme demandé, tout s'est bien passé jusquà la dernière commande : "mysql> use mysql ;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> delete from user where User="phpmyadmin";
Query OK, 1 row affected (0.02 sec)

mysql> drop database phpmyadmin;
ERROR 1008 (HY000): Can't drop database 'phpmyadmin'; database doesn't exist
mysql> exit"

Ensuite j'ai réinstallé phpmyadmin
Voici l'ensemble de l'install :"Une erreur s'est produite lors de la création de la base de données.         
│                                                                             
│ ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using         
│ password: YES)                                                               
│                                                                             
│ Vous pouvez soit recommencer soit abandonner l'opération. Si vous           
│ choisissez « Recommencer », la mise à jour sera tentée à nouveau en vous     
│ posant à nouveau les questions de configuration. Avec l'option               
│ « Recommencer avec les mêmes réglages », la mise à jour sera tentée         
│ immédiatement. Avec le choix « Abandonner », la mise à jour échouera et     
│ vous devrez revenir à la version précédente, désinstaller et                 
│ reconfigurer ce paquet, à moins d'effectuer vous-même les opérations         
│ nécessaires pour continuer à l'utiliser. Enfin, le choix « Ignorer »         
│ poursuivra les opérations en ignorant les erreurs ultérieures issues de     
│                                                                             
│                                  <Ok>
Désolé c'est un peu long. Je pose au moins jusqu'à mardi. Merci encore

Hors ligne