Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 07/08/2014, à 20:43

olnd

affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Bonjour,
Je viens d'installer Ubuntu 14.04 sur un poste précédemment en W7.
Tout fonctionne bien, ou presque.
Je n'ai pas de choix possible dans les résolutions d'affichage: 1024 x 768 ou 800 x 600.
Les paramètres d'affichage m'indiquent "affichage inconnu".
L'écran est un Fujitsu Siemens ScaleoView H22 1WS.
Mes test pour l'instant:
Dans logiciels et mises à jour: aucun pilote additionnel disponible.
Installation par la logithèque de intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb, trouvé sur le site intel (https://01.org/linuxgraphics/downloads) --> par le topic http://forum.ubuntu-fr.org/viewtopic.php?id=1318501.
Recherche d'information sur la carte graphique, voici les données trouvées:

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) 

***************************************

spci -nnk | egrep -iA3 "VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03) 
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000] 
	Kernel driver in use: i915 
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 01) 

***************************************

sudo lshw -c video
  *-display               
       description: VGA compatible controller 
       produit: 4 Series Chipset Integrated Graphics Controller 
       fabriquant: Intel Corporation 
       identifiant matériel: 2 
       information bus: pci@0000:00:02.0 
       version: 03 
       bits: 64 bits 
       horloge: 33MHz 
       fonctionnalités: msi pm vga_controller bus_master cap_list rom 
       configuration: driver=i915 latency=0 
       ressources: irq:43 mémoire:e1000000-e13fffff mémoire:d0000000-dfffffff portE/S:e000(taille=8) 

***************************************

Puis j'ai suivi les informations données sur la page Intel de la doc ubuntu :
Avec la partie « installation des derniers  pilotes Intel ».
Tout semble bien fonctionner !
Ensuring consistent system... OK
Listing packages... OK
Setting up repositories... OK
Installing packages...
    Updating package cache...
    Installing packages... OK
Cleaning up... OK
Listing packages... OK

Mais pour l'instant, aucune amélioration, et je n'ai toujours que mes deux résolutions de proposées.
Auriez-vous d'autres éléments qui pourraient me permettre d'avancer?
Merci par avance.

Hors ligne

#2 Le 07/08/2014, à 21:13

Arnaud16170

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

salut
Etan novice dans le domaine de linux mai je peut peut être t aider
a tu installer les pilotes de ta carte graphique avec les commandes dans un terminal

pour ATI-AMD
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install fglrx

pour Nvidia
sudo apt-get remove nvidia*
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-331 nvidia-331-uvm
sudo reboot

Hors ligne

#3 Le 07/08/2014, à 21:52

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Bonjour Arnaud,
Merci pour ta remarque.
Mais il me semble que les informations remontées par le terminal m'annoncent une carte graphique Intel.
(Intel Corporation 4 Series Chipset Integrated Graphics Controller)
Dans ce cas là, je ne suis pas certain qu'il faille installer de pilotes NVidia ou ATI-AMD...
Non?

Hors ligne

#4 Le 07/08/2014, à 22:46

Arnaud16170

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

oui effectivement je nais pas fait attention, dsl,peut être existe t il un paquetage pour ce chipset graphique regarde dans les dépôts on ne sait jamais smile
sinon une seul solution qui je pence serra la mieux acheter une GC une bonne nvidia gtx650 ou amd 7560hd
prix entre 85 et 115 euros sur le net

EDIT: si tu le veut tu peut installer un petit programme de chez intel qui te mettra a jours les drivers de ta carte (de ton chipset)

dans un terminal tape les commandes suivante:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | sudo apt-key add -

apres sa tu vas telecharger les bon pilotes en fonction de ton architecture (x86 ou x86-64)
https://01.org/linuxgraphics/downloads

puis tu l installe avec cette commande
sudo apt-get install intel-linux-graphics-installer

Dernière modification par Arnaud16170 (Le 07/08/2014, à 22:58)

Hors ligne

#5 Le 07/08/2014, à 23:20

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Merci.
Je vais essayer de conserver cette vieille carte dans la mesure du possible, car elle suffit largement à mes usages.
Pour le lien, j'ai lancé ça dans mes premiers tests:
Mes test pour l'instant:

olnd a écrit :

Dans logiciels et mises à jour: aucun pilote additionnel disponible.
Installation par la logithèque de intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb, trouvé sur le site intel (https://01.org/linuxgraphics/downloads) --> par le topic http://forum.ubuntu-fr.org/viewtopic.php?id=1318501.

Il me semble avoir suivi ça correctement, je vais refaire un test.

Pour l'instant, j'en suis à essayer de créer une résolution supplémentaire, en suivant:
http://doc.ubuntu-fr.org/resolution_ecr … on_d_ecran
Le résultat est pas trop mal. J'ai ajouté 1280x768, mais je ne suis pas bien calé, le lanceur est un "coupé"...
A suivre...

Hors ligne

#6 Le 07/08/2014, à 23:28

Arnaud16170

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

+1 a suivre faut dire que sur n importe quelle distib linux l installation des pilotes c'est toujours quelques chose comparé a windows(oui je sait on ne peut pas comparé mai bon smile)

Dernière modification par Arnaud16170 (Le 07/08/2014, à 23:28)

Hors ligne

#7 Le 07/08/2014, à 23:47

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Voilà donc le script utilisé (cf. autre post cité précédemment, adapté à mon cas):
#!/bin/bash
xrandr --newmode "1152x720_60.00"   66.75  1152 1208 1320 1488  720 723 729 748 -hsync +vsync
xrandr --addmode VGA1 1152x720_60.00
xrandr --output VGA1 --mode 1152x720_60.00

J'ajoute qu'on peut trouver les résolutions adaptées à son écran sur cette page:
http://fr.wikipedia.org/wiki/Définition_d'écran

En éxécutant ce script dans le terminal:

sudo bash MonFichier.sh

La nouvelle résolution est appliquée automatiquement.

Pour le lancer au démarrage:
http://doc.ubuntu-fr.org/tutoriel/application_demarrage
Voir la note: "Si vous désirez lancer un script"

J'ai donc une résolution correcte, et centrée.
Alors on peut mettre "résolu", mais c'est pas encore vraiment le cas! Il me semble qu'il doit y avoir plus simple quand même comme technique... Et surtout avec la possibilité de modifier relativement simplement la résolution de son écran si nécessaire (même si on peut ajouter d'autres résolutions dans le script).

Hors ligne

#8 Le 08/08/2014, à 00:05

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Bon, on n'y est pas encore!
Le script ne se lance pas au démarrage...
Test avec :
sh -c "/home/utilisateur/Documents/SCRIPTS/MaResolutionEcran.sh"
La résolution est proposée dans les paramètres mais non appliquée par défaut
sh -c [home/olivier/Documents/SCRIPTS/MaResolutionEcran.sh]
Rien ne se passe...
sh -c "home/olivier/Documents/SCRIPTS/MaResolutionEcran.sh"
Page d'erreur sur l'accueil "problème d'affichage" et passage étonnant au clavier Qwerty...

La première ligne semble être la bonne, puisque la résolution apparait...
sh -c "/home/utilisateur/Documents/SCRIPTS/MaResolutionEcran.sh"
Mais pourquoi n'est-elle pas automatiquement choisie alors que c'est le cas lorsqu'on exécute le script?

Hors ligne

#9 Le 08/08/2014, à 00:40

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

J'ai essayé également de modifier le fichier /etc/rc.local
Sans succès...
J'y ai ajouté les quelques lignes de mon script

#!/bin/bash
xrandr --newmode "1152x720_60.00"   66.75  1152 1208 1320 1488  720 723 729 748 -hsync +vsync
xrandr --addmode VGA1 1152x720_60.00
xrandr --output VGA1 --mode 1152x720_60.00

Puis (comme ça n'a pas eu l'effet espéré, j'ai remplacé ces quelques lignes par:

sudo bash /home/utilisateur/SCRIPTS/MaResolution.sh

(toujours dans le fichier rc.local)
source: http://www.commentcamarche.net/faq/1864 … t-d-ubuntu

Pour l'un et l'autre, j'ai une page d'erreur sur le bureau --> Impossible d'appliquer la configuration enregistrée pour les écrans. Et j'ai également mon clavier converti en qwerty... Ce qui n'est pas très pratique...
Quelqu'un saurait-il comment arriver à exécuter se script automatiquement à chaque démarrage??? ou même me dire comment installer les pilotes corrects pour ma machin et mon écran (ce qui serait finalement le plus simple!)!?

Hors ligne

#10 Le 08/08/2014, à 09:34

Nicolas St

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Pour remettre ton clavier en azerty ou fr, clique en haut à droite du bureau sur le petit carré (habituellement "Fr") qui doit être en "En"(glish).
Sinon soluce ici (post 28):

http://forum.ubuntu-fr.org/viewtopic.php?id=1397861&p=2


Pour ta carte graphique, je me tâte. Essaie quand même d'ajouter le ppa xorg-edgers (qui ne délivre pas que des drivers nvidia mais aussi ati et peut-être intel)

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

Et ensuite va faire un tour dans le dash du lanceur et tape "pilotes additionnels" et regarde si de nouveaux pilotes te sont proposés.

S'il n'y a rien, enlève le ppa:

sudo add-apt-repository --remove ppa:xorg-edgers/ppa

Si de nouveaux drivers sont disponibles, tu peux en essayer un. Dans tous les cas retire bien le ppa après une install (sinon il te fera des mises à jour pas forcément souhaitables voire instables)


Xubuntu 14.04 - Athlon64 (2 x 2,6 Ghz) - Ram 4 Go - Nvidia Geforce 8500 GT - DD 500 Go

Hors ligne

#11 Le 08/08/2014, à 12:37

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Il ne s'agit pas du petit carré "Fr", qui est bien en français au démarrage.
Je suis obligé d'utiliser:

setxkbmap fr

J'essaie le solution proposée pour le clavier:

ibus-setup

Pas de nouveaux pilotes proposés après l'ajout du ppa, que j'ai donc retiré.
J'ai enlevé mon script de rc.local, ainsi que des programmes au démarrage, mais j'ai maintenant toujours la fenêtre d'erreur au démarrage...
1407494047.png
ça commence à être un brin pénible... Je vais essayer de trouver d'autres façons d'exécuter le script automatiquement au démarrage...

Hors ligne

#12 Le 08/08/2014, à 13:06

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

C'est bon pour le clavier français.
Mais toujours cette fenêtre d'erreur, et rien de neuf pour l'éxécution du script.
Il a bien des droits d'exécution, je l'ai copié dans /etc/init.d/ et ai tapé

sudo update-rc.d nomdemonscript defaults

Il n'a pas pour autant été exécuté au démarrage.
Autre point: j'ai des problèmes d'apparence, avec des fenêtres aspect "années 80", jusqu'à ce que j'arrive à relancer mon script manuellement, puis fermer cette fenêtre d'erreur...
Bon, cette tentative de dual boot W7 - Ubuntu est un peu laborieuse, je cherche un brin ce soir, et sinon on va aller au plus simple.

Hors ligne

#13 Le 08/08/2014, à 13:26

Nicolas St

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600


Xubuntu 14.04 - Athlon64 (2 x 2,6 Ghz) - Ram 4 Go - Nvidia Geforce 8500 GT - DD 500 Go

Hors ligne

#14 Le 08/08/2014, à 14:58

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Merci pour le lien. Ce sont les mêmes manip' que j'ai essayées dans mes premiers tests.
Donc à priori, ça ne suffit.
Le seul point problématique constaté, c'est au moment de l'ajout des clés d'authentification:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | \
sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | \
sudo apt-key add -

Le terminal reste bloqué avec ces informations:
1ère ligne

--2014-08-08 14:48:42--  https://download.01.org/gfx/RPM-GPG-KEY-ilg
[sudo] password for olivier: Résolution de download.01.org (download.01.org)... 23.201.203.111
Connexion vers download.01.org (download.01.org)|23.201.203.111|:443... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Taille : 1753 (1,7K) [text/plain]
Enregistre : «STDOUT»

100%[======================================>] 1 753       --.-K/s   ds 0s      

2014-08-08 14:48:42 (159 MB/s) - envoi vers sortie standard [1753/1753]

2ème ligne:

--2014-08-08 14:51:31--  https://download.01.org/gfx/RPM-GPG-KEY-ilg-2
Résolution de download.01.org (download.01.org)... [sudo] password for olivier: 23.201.203.111
Connexion vers download.01.org (download.01.org)|23.201.203.111|:443... connecté.
requête HTTP transmise, en attente de la réponse... 200 OK
Taille : 3958 (3,9K) [text/plain]
Enregistre : «STDOUT»

100%[======================================>] 3 958       --.-K/s   ds 0s      

2014-08-08 14:51:31 (332 MB/s) - envoi vers sortie standard [3958/3958]

Je peux tout de même lancer l'installation du .deb, dans la logithèque, et lancer l'utilitaire.
Le "report" en fin d'installation m'annonce "No packages were changed on this run of the installer"
Je viens de recommencer les manip', après avoir supprimé les clés et les autres logiciels dans les sources de mises à jour. J'arrive au même résultat.

EDIT: j'ai d'ailleurs une information lors d'un update:

W: Erreur de GPG : https://download.01.org trusty InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY A902DDA375E52366

Ce qui montre qu'il y a visiblement un problème avec les clés en question...

Dernière modification par olnd (Le 08/08/2014, à 15:16)

Hors ligne

#15 Le 17/08/2014, à 19:23

olnd

Re : affichage inconnu / résolutions inadaptées --> 1024 x 768 ou 800 x 600

Quelques nouvelles de mon problème:
J'ai réinstallé Ubuntu 14.04. Et j'ai recommencé les différentes opérations.
J'ai un script qui fonctionne correctement:

#!/bin/bash

# ajout de differentes resolutions d'ecran
xrandr --newmode "1280x800_60"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync 
xrandr --addmode VGA1 1280x800_60
xrandr --newmode "1440x900_60"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync 
xrandr --addmode VGA1 1440x900_60
xrandr --newmode "1680x1050_60"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync 
xrandr --addmode VGA1 1680x1050_60

#choix d'une résolution par défaut
xrandr --output VGA1 --mode 1440x900_60

# configuration du clavier azerty
setxkbmap fr

exit 0

Lui donner les droits d’exécution.
Il me permet donc d'ajouter différentes résolutions et d'en choisir une par défaut. Mais il corrige également le problème de clavier qwerty.
Le scrip est lancé au démarrage (voir applications au démarrage: commande --> sh -c et chemin complet vers le script). Mais cela ne concerne que l'utilisateur en cours, il faut donc refaire la manip' pour les différents utilisateurs.
Il y a peut-être un moyen d’exécuter ce script pour tous les utilisateurs, mais je ne le connais pas. Voir les différentes façons d'éxécuter un escript au démarrage d'Ubuntu.
Le script est donc actif lors de l'authentification. Et donc la page de choix des utilisateurs reste dans une résolution inadaptée (ce qui n'est pas dramatique).

Pour le problème de page d'erreur, j'ai supprimé ce fichier:

rm ~/.config/monitors.xml

(proposition lue ici: http://blog.spyesx.fr/linux-2/ubuntu-im … DcHdZCHtQ)

Si quelqu'un sait comment faire pour que ce script soit actif avant le choix utilisateurs, ce sera parfait, en attendant que je trouve une carte graphique plus adaptée.
J'ai essayé de le copier dans /etc/rc.local mais ça n'a pas fonctionné...

Dernière modification par olnd (Le 17/08/2014, à 22:08)

Hors ligne

Haut de page ↑