Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 16/10/2014, à 15:39

snarf1112

VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

Bonjour,

J'ai un soucis avec VLC.

Depuis la mise à jour d'Ubuntu (version 14.04), je n'arrive plus à lire les vidéos sur VLC. Plus précisément, lorsque j'ouvre un fichier MP4 ou .avi avec VLC, j'ai le son mais aucune image.

D'après quelques recherches que j'ai faites, je pense qu'il s'agit d'un problème de Codecs. Ailleurs sur le forum, quelqu'un avait un problème similaire avec une version antérieur d'Ubuntu et on lui donnait le conseil suivant:

Berserker a écrit :
eme a écrit :

Bonjour Ayral, J'ai désélectionné les vlc de synaptic. J'ai fait un autoremove puis j'ai tapé "sudo apt-get install vlc".  Maintenant j'entends les MP4 mais rien ne bouge et vu que ce sont des video quelque chose doit manquer. Que dois-je rajouter?
Merci pour ton aide.

Salut,
Si tu n'arrive pas à lire les .mp4 avec vlc c'est qu'il doit te manquer des/les codecs, regarde dans ta logithèque si "Greffons vidéo GStreamer pour ffmpeg"(Codecs pour lire les fichiers mpeg, divx, mpeg4, ac3, wmv et asf) sont installés.
Pour vérifier s'ils le sont, ouvre ta logithèque et tape ces 4 premières lettre "gref". S'ils ne le sont pas, installe les et réessaye de lire ta vidéo.mp4 en question.

http://forum.ubuntu-fr.org/ consulté le 16.10.14

Or, avec la nouvelle version d'Ubuntu, les greffons ffmpeg ne sont plus disponibles dans la logithèque. Et pour cause, selon la documentation :

Depuis Ubuntu 14.04 FFmpeg n'est plus dans les dépôts Ubuntu (voir note ci-dessous). Il est remplacé par avconv

et la note de préciser :

2.2 Depuis Ubuntu 14.04
Depuis Ubuntu 14.04 FFmpeg n'est plus dans les dépôts Ubuntu.
Il est remplacé par son fork avconv (présent dans le paquet libav-tools).
Un ppa semble toutefois fonctionnel (voir chapitre suivant).
Voir cette page (en anglais) pour plus d'explications.
Lire la partie suivante pour des explications en français :
Il y a eu une scission entre les développeurs : une partie est sur Libav et une autre partie sur FFmpeg. La version de Libav est celle qui est utilisée sur Ubuntu. Cependant Libav a décidé de ne plus avoir de liens avec ffmpeg, ils ont donc décidé de changer de commande. D'où la création de la commande avconv et un message indiquant l'obsolescence de ffmpeg. La communauté FFmpeg continuera avec la commande ffmpeg.
On peut donc envisager que dans le futur cohabiteront la commande ffmpeg de FFmpeg et la commande avconv de Libav.
Voir des réactions à ce sujet sur LinuxFR.org et un billet de blog un peu plus explicatif.

http://doc.ubuntu-fr.org/ffmpeg consulté le 16.10.14

Je ne comprends pas grand chose à ceci, mais je pense pouvoir en déduire que mon problème provient du changement intervenu avec Ubuntu 14.04.
Si l'on pouvais m'expliquer comment installer le remplaçant de FFmpeg, car en entrant simplement avconv ou libav dans la logithèque, je n'arrive à rien de probant, j'en serais reconnaissant.

Merci d'avance!

Hors ligne

#2 Le 16/10/2014, à 16:18

Ubuntu1988

Re : VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

Oulah, avant d'installer quoique ce soit qui pourrait encore rendre tout ça plus instable, voit pour changer la sortie vidéo dans VLC

Dans VLC, il faut allez dans Outils –> Préférences (cochez "Tous" en bas à gauche) –> Vidéo –> Module de sortie : Sélectionner Sortie vidéo « X11 (XCB) ».

Ou alors, méthode radicale, suppression du dossier de configuration

rm -R ~/.config/vlc

Dernière modification par Ubuntu1988 (Le 16/10/2014, à 16:27)


J'ai perdu ! :(

Hors ligne

#3 Le 19/10/2014, à 16:05

snarf1112

Re : VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

La méthode soft a fonctionné, merci beaucoup!

Hors ligne

#4 Le 19/09/2017, à 08:14

fw13001

Re : VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

Super la sélection de la sortie vidéo X11(XCB) - fonctionne encore en septembre 2017 - avec ubuntu 16.04 (j'avais le même problème avec VLC). Merci !


Intel® Core™ i3-2100 CPU @ 3.10GHz × 8 , GeForce 210, 64 bits, Xubuntu 16.04 en dualboot avec un Windows 7

Hors ligne

#5 Le 12/11/2017, à 00:23

l'aventurier12

Re : VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

Bonsoir à tous
J'ai eu le même problème du son mais plu d'image version 16.04,la solution soft est suffisante tout fonctionne à nouveau merci à tous

Hors ligne

#6 Le 29/11/2017, à 14:56

philboy

Re : VLC : son mais pas d'image sur MP4, avi, etc. depuis MAJ Ubuntu 14.04

salut à tous,
après avoir installer Lubuntu 16.04, puis VLC, celui-ci avait le même pb de lecture d'images.
grâce à X11 tout est rentré ds l'ordre.
merci.


On est bien peu de chose, poussière d'étoiles...

Hors ligne