Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 01/11/2005, à 15:18

Bob Morane

installer Libsane

Bon, alors voilà. J'aimerais essayer de voir si mon scanner ne fonctionne pas avec la dernière version de Sane et le backend genesis qui est dedans. Malheureusement les derniers backends (1.0.16) ne sont pas disponibles dans les dépots de Breezy. Je n'avais pas trop envie d'activer les dépots sarge pour avoir ces backends, la dernière fois que j'ai essayé il a voulu réinstaller plein de trucs et j'ai eu un message comme quoi je risquais de casser complètement mon système si je le faisais hmm

Bref, j'ai téléchargé les .deb via l'interface web des dépôts et j'ai fait un dpkg -i

sudo dpkg --install libsane_1.0.16-5_i386.deb
(Lecture de la base de données... 85352 fichiers et répertoires déjà installés.)
Préparation du remplacement de libsane 1.0.15-9ubuntu6 (en utilisant libsane_1.0.16-5_i386.deb) ...
Dépaquetage de la mise à jour de libsane ...
dpkg : des problèmes de dépendances empêchent la configuration de libsane :
libsane dépend de libgphoto2-2 (>= 2.1.6-5.2) ; cependant :
  La version de libgphoto2-2 sur le système est 2.1.6-1ubuntu6.1.
libsane dépend de libgphoto2-port0 (>= 2.1.6-5.2) ; cependant :
  La version de libgphoto2-port0 sur le système est 2.1.6-1ubuntu6.1.
dpkg : erreur de traitement de libsane (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
libsane

Bon, alors je me demende, est-ce que 2.1.6-5.2 et 2.1.6-1ubuntu6.1 sont des équivalents avec simplement des noms différents car des distribs différentes (auquel cas faudrait vraiment essayer de créer une norme pour les noms) et donc est-ce que je peux sans danger ignorer les dépendances. Si je peux, il faut bien faire "--force depends" pour forcer l'installation en dépit des dépendances.

Hors ligne

#2 Le 02/11/2005, à 20:04

thom83

Re : installer Libsane

Pas sûr que cela marche, mais peut-être qu'en mettant ponctuellement le dépôt Debian de testing sur le fichier /etc/apt/sources.list les dépendances seraient satisfaites. En effet libsane 1.0.16-4 est disponible sur ce site. En revanche, je ne sais pas comment libeller la ligne sur le sources.list. Le lien vers le paquet en question est :
http://packages.debian.org/testing/libs/libsane

Hors ligne

#3 Le 03/11/2005, à 10:54

Bob Morane

Re : installer Libsane

thom83, j'ai déjà essayé avec ma hoary d'activer ponctuellement les dépots Debian, mais cela pose un problème. En effet, j'ai l'impression que Debian n'utilise pas la même numérotation de version qu'Ubuntu (ubutnu ajoute des -ubuntuX.X aux version.) Du coup apt ne s'y retrouve pas bien, me change des fichiers qui étaient à jour en les remplaçant par une version équivalente mais avec un autre nom. C'est pas très grave la plupart du temps, mais un jour j'ai eu un message d'alerte signalant que je risquait de bousiller mon système si je faisais les modif. Ca fait réfléchir hmm
Peut-être ces backends seraient ils sur les dépôts de Daper? Quelqu'un le sait? Qu'est-ce que je dois mettre dans mon source.list pour activer (temporairement, on a beau être un aventurier, y'a des limites lol) les dépots de Daper. J'ai essayer recopiant les lignes des dépots breezy et en mettant "daper" à la place de "breezy", mais çà ne marche pas.

Hors ligne

#4 Le 03/11/2005, à 10:59

Desintegr

Re : installer Libsane

Non, la dernière version de « libsane » c'est pas encore disponible dans Dapper Drake.
Ni en source, ni en paquet.

http://archive.ubuntu.com/ubuntu/pool/main/s/sane-backends/

Tu peux aussi essayer d'installer les paquets Debian de « libgphoto2 » et « libgphoto2-port0 » mais tu peux être encore confronté à des problèmes des dépendances.


Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr

Hors ligne

#5 Le 03/11/2005, à 11:34

Bob Morane

Re : installer Libsane

bon, ben je sens que je vais essayer un --force depends
Au pire libsane ne fonctionnera pas ce qui ne me changera pas beaucoup de la situation actuelle roll
Pas envie de me retrouver avec des versions debian qui foutent le broll dans mes mises à jour hmm

Hors ligne

#6 Le 06/11/2005, à 00:12

thom83

Re : installer Libsane

Bonsoir,
Je viens de mettre à jour libsane vers la version 1.0.16-4 de la façon suivante :
ajout ponctuel, dans /etc/apt/souces.list de la ligne suivante :
deb http://ftp.fr.debian.org/debian testing main contrib non-free
rechargement de synaptic qui s'est plain de l'absence d'une clé publique puis selection pour mise à jour de libsane et xsane. Cela a également entrainé la mise à jour de libgphoto2-2, libgphoto2-port0, sane-utils et xsane-common.
Le scanner a fonctionné sans autre configuration. Merci Ubuntu et Debian

Hors ligne