Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/12/2007, à 18:24

fatahou

proftpd et bind [[Rà‰SOLU]]

Bonjour à  tous,
je dispose d'un serveur ftp (proftpd) tournant sous ubuntu gutsy et administré par gproftpd.
Ma partition systeme ne disposant pas de beaucoup d'espace, je fais habituellement dans mon /etc/fstab un

/media/hdd1/dossierDeMonContenu /var/ftp/ftp-zone none bind 0 0

Le montage de mon dossier  ne se fait plus automatiquement lors du demarrage du systeme.
Je suis obligé de taper la commande de montage pour que le contenu soit visible sur le ftp.

$sudo mount /media/hdd1/dossierDeMonContenu

Quelqu'un aurait une idée d'o๠vient ce problème?

Merci pour votre aide.

ps: comment affiche t'on un demarrage en mode verbose (une touche secrete?) sous ubuntu pour voir les erreurs lors du montage des partions à  la façon Suse, fedora, mandriva...?

Dernière modification par fatahou (Le 05/12/2007, à 17:23)

Hors ligne

#2 Le 04/12/2007, à 18:35

Tha Tawa'S

Re : proftpd et bind [[Rà‰SOLU]]

Salut,
je ne peux que te repondre sur le "ps",
j utilises de mon cote vsftpd,
il y a un paquet qui s appelle StartUp manager que tu trouveras ceertainement dans les depots ou bien sur getdeb.com et en reglage tu n auras qu a cocher Bavard/Verbose
voila ...
bye


Si tu tapes ta tete contre une cruche et que ca sonne creux... ce n est peut-etre pas la cruche qui est creuse....

Hors ligne

#3 Le 04/12/2007, à 19:29

Uggy

Re : proftpd et bind [[Rà‰SOLU]]

Que donne un "mount -a" apres avoir booté... sans avoir lancé ton "sudo mount...." ?

Donne ton fstab.. Il y a une autre ligne avec "/media/hdd1/dossierDeMonContenu" ?

Hors ligne

#4 Le 04/12/2007, à 23:04

fatahou

Re : proftpd et bind [[Rà‰SOLU]]

ReBonsoir,
désolé d'avoir trainé j'ai eu quelques soucis avec mon gutsy.
voilà  mon fstab:

$ cat /etc/fstab
# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/hda3 / ext3 defaults 1 1
proc /proc proc defaults 0 0
/dev/hda4 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/sda /media/floppy0 auto user,atime,noauto,rw,dev,exec,suid 0 0
/media/big1/down2/ftp-zone /var/ftp/down-upload none bind 0 0
/dev/hda1 /media/moyen1 vfat iocharset=utf8,umask=000,uid=0,gid=0,auto,rw,nouser 0 0
/dev/hda2 /media/moyen2 auto nouser,defaults,atime,auto,rw,dev,exec,suid 0 0
/dev/hdc1 /media/petit1 vfat iocharset=utf8,umask=000,uid=0,gid=0,auto,rw,nouser 0 0
/dev/hdc2 /media/petit2 auto nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
/dev/hdd1 /media/big1 ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 2
/dev/hdd2 /media/big2 vfat iocharset=utf8,umask=000,uid=0,gid=0,auto,rw,nouser 0 0
/dev/hdd3 /media/big3 ext3 nouser,defaults,atime,auto,rw,dev,exec,suid 0 0
/dev/hdd4 /media/big4 vfat iocharset=utf8,umask=000,uid=0,gid=0,auto,rw,nouser 0 0
/dev/hdc3 /media/hdc3 swap defaults 0 0

merci pour StartUp manager, ça me dis juste echec sans plus mais ce n'est pas grave.

*mount -me monte bien les systemes de fichiers.
voila le resultat du $mount apres un $mount -a

$ mount
/dev/hda3 on / type ext3 (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.22-14-386/volatile type tmpfs (rw)
/dev/hda1 on /media/moyen1 type vfat (rw,iocharset=utf8,umask=000,uid=0,gid=0)
/dev/hda2 on /media/moyen2 type ext3 (rw)
/dev/hdc1 on /media/petit1 type vfat (rw,iocharset=utf8,umask=000,uid=0,gid=0)
/dev/hdc2 on /media/petit2 type ext3 (rw)
/dev/hdd1 on /media/big1 type ext3 (rw)
/dev/hdd2 on /media/big2 type vfat (rw,iocharset=utf8,umask=000,uid=0,gid=0)
/dev/hdd3 on /media/big3 type ext3 (rw)
/dev/hdd4 on /media/big4 type vfat (rw,iocharset=utf8,umask=000,uid=0,gid=0)
securityfs on /sys/kernel/security type securityfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/media/big1/down2/ftp-zone on /var/ftp/down-upload type none (rw,bind)

la derniere est celle qui nous interresse. Peut etre que j'ai stoppé un service qu'il ne fallait pas au démarrage?

Dernière modification par fatahou (Le 04/12/2007, à 23:08)

Hors ligne

#5 Le 05/12/2007, à 00:42

Uggy

Re : proftpd et bind [[Rà‰SOLU]]

Et su tu met "/dev/hdd1 /media/big1 etc"... avant "/media/big1/down2/ftp-zone /var/ftp/down-upload none bind 0 0" ??

Hors ligne

#6 Le 05/12/2007, à 09:34

fatahou

Re : proftpd et bind [[Rà‰SOLU]]

Bonjour,
Bien vu Uggy. C'était un problème d'ordre. J'essayais de monter un repertoire avant le systeme de fichier.
Merci à  tous.
ps: comment signale t'on résolu?

Dernière modification par fatahou (Le 05/12/2007, à 09:37)

Hors ligne

#7 Le 05/12/2007, à 09:50

michel2652

Re : proftpd et bind [[Rà‰SOLU]]

Bonjour,

fatahou a écrit :

ps: comment signale t'on résolu?

Tu cliques sur Modifier, en bas à  droite de ton 1er message, et tu ajoutes Résolu au titre du post.

A+