Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/02/2015, à 15:02

chrislc

touchpad reconnu mais inactif lenovo s10

Bonjour à tous,

je viens ici en ayant cherché des solutions...
certaines je ne les ai pas comprise et d'autres ont échouée.

Ma machine un vieux maintenant lenovo S10, sauvé en installant lubuntu.
PB : le pad est reconnu id=12 ou 13 je sais plus et impossible de l'activer; Est-il mort ?
J'ai trouvé un post sur l'ajout d'un paramètre au noyau mais là ça me dépasse, la procédure peut expliquer (pas pour novice comme moi certainement) alors je freine des 4 fers avant de faire une bêtise.
clavier en qwerty qui fait des siennes, un coup en azerty malgré commande setxkbmap us et autres touches avec sigles inutilisable !
Wifi pas reconnu et enceinte marche...
Bref, allons si doucement.
le menu déroulant en bas à gauche n'existe pas non plus ? C'est chi... d'aller retrouver les appli...


Est-ce qu'il vaut mieux pas passer directement sur Ubuntu si comme une doc trouver ici dit que lenovoS10 est  bien reconnu ? J'utilise d'habitude un toshiba satellite P300 sous ubuntu alors je suis plus à l'aise avec l'environnement, mais je peux m'adapter si'il vaut mieux rester sur lubuntu !

Merci pour vos réponses

Hors ligne

#2 Le 18/02/2015, à 18:08

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Rebonjour,

donc rectificatif, j'ai récupéré la webcam, le son enceinte.
j'ai fini par trouver l’icône menu pour la barre d'en bas. ouf !
Wifi ok

reste le pad qui ne marche pas
et ce clavier qwerty qui ne marche pas correctement, symboles ou autres signes pas à la bonne place...

Hors ligne

#3 Le 22/02/2015, à 10:45

moko138

Re : touchpad reconnu mais inactif lenovo s10

J'ai aussi un S10 : Xubuntu 12.04, Crunchbang 11 et Antix y tournent bien.

1) Que donne le touchpad, sans aucune manipulation, en session live non persistante ?
2)  Que donne le clavier, sans aucune manipulation, en session live non persistante ?
2.1. En particulier la touche a ?
2.2. Les touches j k l   u i o ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#4 Le 23/02/2015, à 15:35

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Bonjour moko138

Je ne peux pas faire de session live car ce n'est pas moi qui est installé linux sur cette machine !!
Je ne suis pas à l'aise avec les clé usb bootable, j'ai jamais fait ! Donc pas de session live possible pour l'instant !
Celui qui m'a installé lubuntu dessus a eu le mérite de me redémarrer le S10 depuis je suis passé à linux, mais il m'avait dit : wifi, enceinte et pad fichus. Or j'ai réussit à refaire fonctionné le wifi et les enceintes donc j’espérais faire pareil pour le pad !

une autre idée ou j'essaye de faire cette usb bootable ?

Hors ligne

#5 Le 23/02/2015, à 16:34

moko138

Re : touchpad reconnu mais inactif lenovo s10

Fais une clef live : la Doc est bien faite.

Tu peux aussi dire déjà ce que donne le clavier, sans aucune manipulation, en session normale.
1. En particulier la touche a ?
2. Les touches j k l   u i o ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#6 Le 23/02/2015, à 16:42

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Bon alors je vais faire une clé live mais pas tout de suite tout de suite...

touche a    il dit q
touches jkl uio          normales
touches m,.          ,;:

donc généralement pour pouvoir écrire je fais dans le terminal  setxkbmap us mais du coup tous les sigles sont en vrac !! J'ai au moins les lettres au bon endroit !!

Dernière modification par chrislc (Le 23/02/2015, à 16:51)

Hors ligne

#7 Le 23/02/2015, à 20:06

moko138

Re : touchpad reconnu mais inactif lenovo s10

Tu es en qwerty ; la commande pour passer en azerty est

setxkb,qp fr

(soit, en azerty :   setxkbmap fr).


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#8 Le 24/02/2015, à 13:08

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Merci moko138

mais j'ai un clavier qwerty !
du coup il se remet en azerty !
mais les touches ne correspond pas exactement en faisant setxkbmap us pour les signes, doit y avoir une autre astuce pour les clavier de portable...

Hors ligne

#9 Le 24/02/2015, à 13:59

moko138

Re : touchpad reconnu mais inactif lenovo s10

mais j'ai un clavier qwerty !

Désolé, j'avais compris de travers.
Donne

uname -mr
cat /etc/environment
cat /etc/default/locale
cat /etc/default/keyboard

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#10 Le 24/02/2015, à 15:02

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Pas de pb

Voilà

christelle@christelle-Lenovo:~$ uname -mr
3.13.0-45-generic i686
christelle@christelle-Lenovo:~$ cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
christelle-Lenovo:~$ cat /etc/default/locale
LANG="fr_FR.UTF-8"
christelle@christelle-Lenovo:~$ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="oss"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Hors ligne

#11 Le 24/02/2015, à 23:53

moko138

Re : touchpad reconnu mais inactif lenovo s10

Désolé, ma connexion est particulièrement mauvaise ce soir.

Intéressant !
1) L'usage et le règlement du forum veulent qu'on mette les retours de commandes entre balises-code  - et je te prie de lire Retour utilisable de commande et de l'appliquer à l'avenir - pour obtenir cette mise en forme :

christelle@christelle-Lenovo:~$ uname -mr
3.13.0-45-generic i686
christelle@christelle-Lenovo:~$

  qui montre que tu utilises le noyau 32 bits de la 14.04 LTS, apparemment à jour : c'est bien !

christelle@christelle-Lenovo:~$ cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
christelle-Lenovo:~$
cat /etc/default/locale
LANG="fr_FR.UTF-8"
christelle@christelle-Lenovo:~$

  qui montre que langue et encodage sont corrects.

christelle@christelle-Lenovo:~$ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="oss"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

2) C'est ce dernier retour de commande qui est révélateur smile
  Puisque tu es inscrite de fraîche date -

Bienvenue, au fait ! -

je t'explique :
2.1. Le # sert à dire au système "Ne t'occupe pas de ce qui est à droite de ce symbole, ce n'est que du commentaire".
Ainsi tu peux rajouter dans ce fichier-système

XKBMODEL="pc105"# j'y nik samer au noyau Linux
#Vive windows et mac
# XKBLAYOUT="farNçAais, mais l' vrai, çui de Ménilmuche"

et cela ne perturbera pas le moins du monde ton système.
  Alors à quoi ça sert ?
À ce que tu veux :
  En l'occurrence les deux premières lignes te disent qu'il y a un fichier-mode d'emploi et où le trouver ! smile
  Tu peux y rajouter tes propres commentaires, pour mémoire :

#ci-dessous la ligne originelle, (le "#" en plus) :
#XKBLAYOUT="fr"
XKBLAYOUT="us"# modif faite le 23/2/2015

  Tu rencontreras aussi des explications intermédiaires dans tel long fichier touffu

# Réglage de ceci :
(...)

# Réglage de cela :
(...)
etc., ad libitum.

2.2. la cause et le remède

j'ai un clavier qwerty !

Bien, donc la ligne à corriger est  :

XKBLAYOUT="fr" # <--"KB" est mis pour "keyboard", "clavier"

qu'il faut bien sûr changer en :

XKBLAYOUT="us"# "us" <--> clavier qwerty (modif du 23/2/2015)

  Concrètement
C'est un fichier-système, que ce /etc/default/keyboard.
Donc pour l'éditer, il te faut deux choses :
- tu dois prendre momentanément les droits-administrateur, et dans Lubuntu 14.04, c'est probablement pkexec (ou sinon : gksudo).
- utiliser un éditeur de texte (je crois que tu as leafpad, non ?)
  Ouvre un "émulateur de terminal" (Ctrl T ou Menu Principal>Accessoires, je crois) et tente :

pkexec leafpad /etc/default/keyboard

  Si mes 2 premières commandes sont exactes, ton mot de passe te sera demandé.
N.B. : dans le terminal, on le tape à l'aveugle, pas le moindre astérisque.
  Puis leafpad s'ouvrira avec les droits-administrateur (on dit aussi "droits root" ou "en root").
Attention, ce n'est pas le moment de toucher à tes fichiers habituels, car ils deviendraient eux aussi propriété de root !
  Simplement tu colles

XKBLAYOUT="us"

(avec les commentaires de ton choix smile )
à la place de

XKBLAYOUT="fr"

J'espère, sans en être certain, que cette correction, sans ou avec redémarrage, suffira.
  Tu nous diras.

3) P.S. : sur ton Dell comme sur ton Lenovo, lance

sudo apt-get install smartmontools

et sans ajouter de chiffre :

sudo smartctl -a /dev/sda

parce que sur les ordinosaures, si le disque est moribond, sauvegarder est la seule priorité (oui je sais, tu l'as déjà fait).
  Et dans ton cas, fixboot, qui répare ou rétablit dans le mbr un amorçage windowsien, est inutile puisque c'est par grub

Grub2 (v2.00) is installed in the MBR of /dev/sda

que tu accédais à XP et que grub était encore fonctionnel puisque tu accédais à Lubuntu.
  Donc si XP ne démarrait plus, c'est que le problème gît dans C:\ et non dans le mbr !

Démarre en tapotant le touche Majuscule, pour faire apparaître le menu grub des choix, et tu auras de nouveau accès à Lubuntu.

  Après quoi tu peux sauvegarder la partition de réinstallation en la copiant avec gparted. En vue de la dupliquer - toujours avec gparted - sur un DDE puis sur un disque neuf ou en bon état... si, financièrement, ça vaut le coup.

  Mais si tu veux parler du Dell, ouvre un fil séparé et mets le lien ici.

Et dans l'immédiat, fais au Lenovo la réparation indiquée en §2.2 et donne l'état smart du §3.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#12 Le 25/02/2015, à 15:27

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Merci moko138 pour ce long message et merci pour la bienvenue !

Je vais m’atteler à ce que tu me dis mais avant juste une précision :
en fait je m'étonnais que les signes ne correspondent pas non plus quand je me mettais en us par setxkbmap
et j'ai cherché grâce à ça : http://fr.wikipedia.org/wiki/Dispositio … 3.A9ricain
je sais que j'ai un clavier britannique !
Donc c'est pas us qu'il va falloir que je tape mais UK peut-être ?

Hors ligne

#13 Le 25/02/2015, à 18:10

moko138

Re : touchpad reconnu mais inactif lenovo s10

uk ? ou en ? Essaye et surtout donne les résultats, que ça profite à d'autres !

Je viens de chercher sur en.wikipedia.org, mais je n'ai pas encore vu la réponse.
Peut-être que cette page en.wikipedia.org/wiki/British_and_American_keyboards te parlera plus qu'à moi.

En parallèle, je vais contacter un forumeur qui bosse en Angleterre et qui a peut-être le même clavier que le tien.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#14 Le 26/02/2015, à 17:52

αjet

Re : touchpad reconnu mais inactif lenovo s10

Je suis le "forumeur qui bosse en Angleterre" auquel faisait référence moko138 wink

Je suis actuellement sur mon pc du bureau (windows) mais j'ai un accès distant sur mon vps (debian serveur configuré en en-uk) et ça me donne ceci:

~/ cat /etc/default/locale
#  File generated by update-locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB
~/ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Je compare avec mon pc perso sur ubuntu rapidement.


αjet: ça se prononce alfajet, bordel ! | GMT+1 | Viens poueter avec moi, bordel ! | Mes photos | Shaarli | Fluidbuntu-fr

Hors ligne

#15 Le 26/02/2015, à 18:46

moko138

Re : touchpad reconnu mais inactif lenovo s10

merci αjet !
Mais avec ces réglages, as-tu un clavier britannique comme celui que chrislc mentionne en #12 ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#16 Le 26/02/2015, à 20:34

αjet

Re : touchpad reconnu mais inactif lenovo s10

Voila ce que j'ai sur mon pc perso, et oui je confirme que c'est bien un clavier britannique (en_gb / en-uk).

~/ cat /etc/default/locale
LANG="en_GB.UTF-8"
LANGUAGE="en_GB:en"
~/ cat /etc/default/keyboard
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

Je pense que c'est cette configuration que devrait prendre Christelle. Je suppose que n'est pas correctement configuré XKBLAYOUT sur mon VPS mais cela ne m'impacte pas dans la mesure où je me sers pas du serveur graphique à distance.


αjet: ça se prononce alfajet, bordel ! | GMT+1 | Viens poueter avec moi, bordel ! | Mes photos | Shaarli | Fluidbuntu-fr

Hors ligne

#17 Le 01/03/2015, à 20:43

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Merci beaucoup αjet
et merci beaucoup moko138

donc ça marche maintenant quasiment parfait à part deux touches inversées
pour info donc c'était gksudo plutot que pkexec
et gb ou uk ça change rien, j'ai essayé les deux, igual les mêmes !

bon pas eu le temps de faire la clé live pour tester le pad mais je reviens pour vous tenir évidemment au courant de cet essai et la suite de mon aventure...

Hors ligne

#18 Le 01/03/2015, à 22:24

moko138

Re : touchpad reconnu mais inactif lenovo s10

smile
Merci pour ce retour d'info !
Et merci αjet !

Quelles sont les deux touches inversées ?


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#19 Le 02/03/2015, à 11:46

αjet

Re : touchpad reconnu mais inactif lenovo s10

Content que ça marche un peu mieux. Pareil, je suis curieux de savoir quelles sont les touches inversées. smile


αjet: ça se prononce alfajet, bordel ! | GMT+1 | Viens poueter avec moi, bordel ! | Mes photos | Shaarli | Fluidbuntu-fr

Hors ligne

#20 Le 05/03/2015, à 14:49

chrislc

Re : touchpad reconnu mais inactif lenovo s10

Bonjour moko138

Bien j'ai testé le pad de mon S10 en session live
pas de réponse hmm
À bientôt

Hors ligne

#21 Le 05/03/2015, à 18:08

αjet

Re : touchpad reconnu mais inactif lenovo s10

Il y a de fortes chances que ce soit un problème matériel.

J'ai eu le cas il y a longtemps (~9-10 ans) avec un portable acer. Le touchpad est tombe en panne du jour au lendemain. A l’époque j’étais en dual boot GNU/Linux / Windows. Même comportement quelque soit OS.

Le touchpad n'a pas fonctionné pendant des années, ce qui me condamnait a utiliser une souris externe, du coup pas pratique en utilisation nomade.

Peu après avoir fait l'acquisition d'un nouveau portable, le touchpad de l'ancien s'est remis à fonctionner comme par enchantement!


αjet: ça se prononce alfajet, bordel ! | GMT+1 | Viens poueter avec moi, bordel ! | Mes photos | Shaarli | Fluidbuntu-fr

Hors ligne

#22 Le 07/03/2015, à 18:06

chrislc

Re : touchpad reconnu mais inactif lenovo s10

bon, alors il faut continuer avec la souris...
Merci pour votre retour d'expérience
Bonne continuation

Hors ligne