Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 13/11/2005, à 16:35

racoon97

[Résolu] Enorme occupation processeur > 85 % (Breezy)

Depuis quelques jours ma breezy n'arrete pas de ramer et je ne sais pas d'ou ca vient exactement.
Voici une capture de mon htop :
[img=http://img450.imageshack.us/img450/7994/tree16za.th.png]
[img=http://img120.imageshack.us/img120/9820/tree29ew.th.png]

Si quelqu'un peut m'aider à voir d'ou vient ce probleme. Comme vous le verrez ce processus a démarrer il y a 5 h environ, or à cette heure je dormais.

Inutile de vous dire que ma machine est inutilisable dans ces conditions

Merci.


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#2 Le 13/11/2005, à 16:53

Tao

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

racoon97 a écrit :

Depuis quelques jours ma breezy n'arrete pas de ramer et je ne sais pas d'ou ca vient exactement.
Voici une capture de mon htop :

http://img103.imageshack.us/img103/8759/capture11gj.png

Si quelqu'un peut m'aider à voir d'ou vient ce probleme. Comme vous le verrez ce processus a démarrer il y a 5 h environ, or à cette heure je dormais.

Inutile de vous dire que ma machine est inutilisable dans ces conditions

Merci.

Je ne vais peut-être pas faire beaucoup avancer le problème, mais je vais quand même préciser quelque chose : il se peut que ce processus soit démarré depuis bien plus de 5H. En effet le temps indiqué dans la colonne TIME+ est le temps "équivalent pour une occupation à 100% du cpu". Donc il se peut que le processus tournait normalement à un faible pourcentage cpu depuis plusieurs jours puis ensuite un bug lui a fait perdre la tête.

EDIT : dans ton cas, ce processus, c'est Xorg, donc c'est probablement ce qui s'est passé, mais je ne connais pas le pourquoi.

Dernière modification par Tao (Le 13/11/2005, à 16:55)

Hors ligne

#3 Le 13/11/2005, à 16:59

Tao

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Je complète ma pensé :
Il se peut qu'en fait jusqu'à ce que tu reviennes à ton ordi tout à l'heure xorg tournait normalement et avait tout simplement totalisé une charge équivalente à 5H de calcul cpu. Là tu arrives et tu fais quelque chose qui surcharge ton serveur X avec un programme qui a buggé, et tu aurais exactement ce résultat avec top.

Tout ça pour dire que ça vient peut-être de se passer, il ne faut pas chercher quelque chose qui se serait passé tout seul pendant que tu dormais.

EDIT : extrait de man top :

l: TIME  --  CPU Time
          Total CPU time the task has used since it started.  When ’Cumulative
          mode’  is  On,  each process is listed with the cpu time that it and
          its dead children has used.  You toggle ’Cumulative mode’ with  ’S’,
          which  is a command-line option and an interactive command.  See the
          ’S’ interactive command for additional  information  regarding  this
          mode.

       m: TIME+  --  CPU Time, hundredths
          The  same  as  ’TIME’,  but reflecting more granularity through hun‐
          dredths of a second.

Ce n'est pas exactement ce que je disais, mais presque. Ça correspond au temps où le processus à eu la main sur le cpu.

Dernière modification par Tao (Le 13/11/2005, à 17:04)

Hors ligne

#4 Le 13/11/2005, à 17:22

racoon97

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Merci pour ta réponse. N'empêche que la ca me le faisais hier, j'ai rebooté, et ca à recommencé. En outre j'ai une machine sous Breezy au bureau qui faisais quasiment la meme chose cette semaine, j'ai du rebooté également ...
Donc, ce n'est pas lié à ma machine mais à Breezy, donc si quelqu'un à eu ce même probleme qu'il se manifeste.


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#5 Le 13/11/2005, à 17:31

Tao

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Y a-t-il un programme qui était lancé à chaque fois et qui aurait pu donner du fil à retordre à xorg ? La version 1.5 de firefox ?

EDIT : maintenant que j'y pense, ça peut être gdesklet ou une applet qui fasse mal à xorg. Essaye durant quelques jours sans ces trucs là pour voir si ça arrange les choses. Ce n'est qu'une hypothèse bien sur...

Dernière modification par Tao (Le 13/11/2005, à 17:37)

Hors ligne

#6 Le 13/11/2005, à 17:51

racoon97

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Non c'est une breezy "standard" avec Firefox 1.07 et pas de desklets installé.
J'ai rebooté et je surveille avec un tail -f /var/log/messages , on verras bien hmm


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#7 Le 13/11/2005, à 17:54

racoon97

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Bin j'ai ca toutes les minutes semble t'il :

Nov 13 12:51:30 localhost kernel: [4295913.856000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:30 localhost kernel: [4295913.856000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
Nov 13 12:51:31 localhost kernel: [4295914.901000] atkbd.c: Unknown key released (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:31 localhost kernel: [4295914.901000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
Nov 13 12:51:32 localhost kernel: [4295915.190000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:32 localhost kernel: [4295915.190000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
Nov 13 12:51:32 localhost kernel: [4295915.280000] atkbd.c: Unknown key released (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:32 localhost kernel: [4295915.280000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
Nov 13 12:51:32 localhost kernel: [4295915.568000] atkbd.c: Unknown key pressed (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:32 localhost kernel: [4295915.568000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.
Nov 13 12:51:32 localhost kernel: [4295915.658000] atkbd.c: Unknown key released (translated set 2, code 0xaa on isa0060/serio0).
Nov 13 12:51:32 localhost kernel: [4295915.658000] atkbd.c: Use 'setkeycodes e02a <keycode>' to make it known.

C'est arrivé 15 mn après le reboot.


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#8 Le 14/11/2005, à 02:43

racoon97

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Bon, ca n'avance pas trop sad
Voici la première ligne d'un top apres quelques heures d'utilisation de la machine :

20723 root      24   0  357m  98m  11m R 85.1  9.7  10:57.86 Xorg

Comme vous pouvez le constater Xorg bouffe en permanence 85 % (minimum) de ressources processeur et je ne sais pas pourquoi.
La souris devient très lente à manipuler et l'affichage général est complementement au ralenti. Il y a peu d'applications ouvertes, pas plus que d'habitude en tout cas.

Je suis obligé de rebooter toutes les 6 heures pour que la machine reste utilisable.


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#9 Le 14/11/2005, à 03:35

racoon97

Re : [Résolu] Enorme occupation processeur > 85 % (Breezy)

Bon j'ai trouvé ça :
http://ubuntuforums.org/archive/index.php/t-76271.html

On a effectivement ces messages quand on appuie sur les touches fléchées .... hmm
Il faut donc faire :

sudo /etc/init.d/hotkey-setup stop

Pour désactiver le service définitivement :

sudo apt-get install rcconf
sudo update-rcconf-guide
sudo rcconf

Puis désactiver hotkey-setup


Ca a l'air d'avoir calmé Xorg ... je laisse tourné pendant la nuit mais je pense que c'est résolu.


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

  • Accueil
  • » Forum
  • » Unity
  • » [Résolu] Enorme occupation processeur > 85 % (Breezy)

Haut de page ↑