Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/01/2008, à 16:18

kristoff-974

Pas de WPA dans la dernière version d'Ubuntu

Bonjour à  tous,

Je n'ai pas (ou je n'ai plus... je développerais) l'option WPA dans l'interface graphique de configuration de réseau (network manager). J'utilise Ubuntu depuis très peu de temps et sous linux, on peut dire que je suis un newbie, donc je ne sais pas vraiment o๠vérifier que le WPA est bien installé et encore moins comment le rendre visible dans l'interface graphique.

Après quelques recherches sur internet, et notamment sur ce forum et dans la documentation d'Ubuntu, j'ai procédé à  la réinstallation de wpasupplicant par l'intermédiaire du gestionnaire de paquets synaptic, ce qui n'a rien changé à  mon problème.

Ma carte Wifi est une Trendnet avec un chipset acx111. Je ne pense pas qu'elle soit incompatible avec le WPA puisque je me souviens avoir déjà  vu cette option sur mon pc lorsque j'avais testé ubuntu sans l'installé et je crois (j'en suis pas sur) après l'installation d'ubuntu.

Par ailleurs, j'ai essayer aircrack pour tester la sécurité de mon réseau (et j'ai rapidement abandonné vu mon niveau). Cela aurait-il une conséquence sur mon problème ?

Enfin j'aimerais savoir s'il y a un moyen de réinitialliser Ubuntu (restaurer toutes la configuration par défaut) sans avoir à  tout réinstaller.

Par avance, Merci

Hors ligne

#2 Le 01/02/2008, à 03:19

Dude_zi'flo

Re : Pas de WPA dans la dernière version d'Ubuntu

Bonjour,
Peux tu poster le retour de ces commandes {une ligne= une commande}.

cat /etc/lsb-release
lsusb
lspci
lsmod
sudo lshw -C network && ip link show
iwconfig
ifconfig
iwlist scan
cat  /etc/network/interfaces

Retire les protections de ton routeur...Pour tester, l'idéal est de retirer les protections (WEP/WPA/Mac).

A/ Purger le fichier 'interfaces' pour que les outils fonctionnent:

sudo /etc/init.d/networking stop
echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces

Cela modifie ton fichier 'interfaces' et ne laisse que la boucle système 'Lo'
B/Graver dans le dur tes DNS

1/ Méthode préconisée:
http://www.opendns.com/start/ubuntu.php
Méthode employée

echo -e 'nameserver 127.0.0.1\nnameserver 0.0.0.0\nnameserver 192.168.0.1\nnameserver 208.67.222.222\nnameserver 208.67.220.220\n' | sudo tee /etc/resolv.conf && sudo chattr +i /etc/resolv.conf

C/Installer WICD
pour Feisty

echo 'deb http://wicd.longren.org feisty extras' | sudo tee -a /etc/apt/sources.list

pour Gutsy

echo 'deb http://wicd.longren.org gutsy extras' | sudo tee -a /etc/apt/sources.list
sudo aptitude update
sudo aptitude install wicd     #au passage il désinstalle n-m

Pour lancer wicd

/opt/wicd/tray.py

Redémarre ton ordi et essaye de te connecter avec WICD.

NB: Attention à  cette commande,

echo -e 'nameserver 127.0.0.1\nnameserver 0.0.0.0\nnameserver 192.168.0.1\nnameserver 208.67.222.222\nnameserver 208.67.220.220\n' | sudo tee /etc/resolv.conf && sudo chattr +i /etc/resolv.conf

elle va fixer dans le dur la route à  suivre,  L'adresse qui est en gras est sensée être le routeur. Adapte selon ton architecture.
si tu as le net par cà¢ble, profite en pour taper ces commandes
[Mise à  jour de tout]

sudo -s
aptitude update && aptitude upgrade
aptitude dist-upgrade
aptitude autoclean && update-pciids && update-usbids
exit

Bon courage et @ ++ ت
NB: Utilise les balises de mise en page pour tes futurs msg...sinon c'est illisible. (elles sont au dessus des smileys quand tu rédiges un post).