Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/11/2005, à 18:53

max-fx

[Résolu] Problème avec la résolution 1280*800 [Résolu]

Salut à tous,

après de nombreuses recherches, j'ai mondifié mon xorg.conf comme ceci :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"Intel Corporation 82852/855GM Integrated Graphics Device"
	Driver		"i810"
	BusID		"PCI:0:2:0"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
        HorizSync   30-70
        VertRefresh 50-150
	Option		"DPMS"
	Modeline "1280x800@75" 111.50 1280 1312 1728 1760 800 815 825 841
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation 82852/855GM Integrated Graphics Device"
	Monitor		"Écran générique"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

J'ai aussi fais les changements avec le programme 855resolution, mais pour arriver a avoir cette résolution, je dois faire un "sudo dpkg-reconfigure xserver-xorg" après chaque démarrage.
C'est assez contraingnant, même si ça marche.

C'est un des derniers problèmes qui une fois résolu me permettrais de me passer de windows alors si quelqu'un peut m'aider je lui en serait très reconnaissant.

Merci d'avance

Dernière modification par max-fx (Le 20/12/2005, à 23:13)

Hors ligne

#2 Le 22/11/2005, à 17:53

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

sad

Hors ligne

#3 Le 22/11/2005, à 21:02

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

ton xorg.conf a l'air configuré pour du 1280x800, je vois pas pourquoi ça ne fonctionne pas.

n'utilise pas de programme auxiliaire pour modifier ta résolution, désinstalle-le au besoin...

redémarre et donne-moi ton nouveau xorg.conf pour voir s'il se change tout seul wink

Hors ligne

#4 Le 22/11/2005, à 22:27

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

j'ai désinstallé 855resolution mais ça ne fonctionne pas mieux car sur tout les tutos que j'ai trouvé il est nécessaire avec ce type de carte graphique.

sinon xorg ne sait pas gérer le 1280*800.

donc j'ai redémarré, refait un reconfigure x-server-xorg.

le nouveau xorg.conf semble s'être bien configuré, comme celui d'avant sauf que je ne peut toujours mettre qu'en 1024*768 dans le menu.

je pense donc que 855resolution est vraiment nécessaire pour avoir cette résolution

affaire à suivre

Hors ligne

#5 Le 22/11/2005, à 22:34

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

il faut que tu me passes ton xorg.cong juste quand tu viens de redémarrer...

Hors ligne

#6 Le 22/11/2005, à 22:46

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

voila celui d'origine :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/CID"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"Intel Corporation 82852/855GM Integrated Graphics Device"
	Driver		"i810"
	BusID		"PCI:0:2:0"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation 82852/855GM Integrated Graphics Device"
	Monitor		"Écran générique"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Hors ligne

#7 Le 22/11/2005, à 23:02

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

sur ce xorg, on voit que tu utilises un pilote intel et que la seule résolution possible est 1280x800, et tu es toujours en 1024x768?
tu es sur que ce xorg.conf est celui quand tu viens de démarrer ton ordi et que tu es en 1024x768

Hors ligne

#8 Le 22/11/2005, à 23:07

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

oui, sur à 100%, dans le menu "résolution de l'écran je n'ai que 1024*768" comme choix sad

Hors ligne

#9 Le 22/11/2005, à 23:16

fraide

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

Peut être idiot, mais à ta place; je réinstall en tapant au boot :
linux vga=771 et àa devarit rouler... big_smile

Hors ligne

#10 Le 22/11/2005, à 23:44

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

pourquoi cette option?

Hors ligne

#11 Le 23/11/2005, à 00:16

fraide

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

Parce que la réso 1280 x 800 n'est pas prise en charge par le noyau par défaut... Fais moi confiance big_smile

Hors ligne

#12 Le 23/11/2005, à 00:27

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

ouai mais bon ça va à l'encontre de la philosophie linux de résintaller pour ça ^^

Hors ligne

#13 Le 23/11/2005, à 01:37

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

moi je suis sur mon portable en 1280x800 et je n'ai pas eu ce problème. A la config de xorg j'ai choisi 1280x800 et je n'ai pas eu à changer le VGA

Hors ligne

#14 Le 23/11/2005, à 08:14

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

tu a la même carte graphique?

Hors ligne

#15 Le 24/11/2005, à 19:30

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

snif sad

Hors ligne

#16 Le 24/11/2005, à 21:12

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

non moi j'ai un controleur graphique SIS

essaie juste ça :
dans =>    Section "Device"
               Driver        "i810"

remplace i810 par vesa... et redémarre

tu comptes mettre l'accélération 3D ou pas ?

Hors ligne

#17 Le 24/11/2005, à 21:46

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

ok je vais essayer ça.

l'accélération 3d non pour le moment j'en ai pas besoin, le principal c'est de résoudre ce problème de résolutions

edit : arf ça fait pareil

Dernière modification par max-fx (Le 24/11/2005, à 21:53)

Hors ligne

#18 Le 24/11/2005, à 23:14

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

vraiment bizarre sachant qu'on met un pilote disons un peu fourre-tout !

Hors ligne

#19 Le 29/11/2005, à 13:48

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

up svp

Hors ligne

#20 Le 29/11/2005, à 18:24

racoon97

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

sudo dpkg-reconfigure xserver-xorg

tu sélectionnnes 1280*800 (avec la touche espace) puis ok a toutes les autres options puis redémarrage de la session.
Tu devrais voir ta résolution apparaitre dans Système > Préférences > Résolution de l'écran


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#21 Le 30/11/2005, à 10:48

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

j'ai sélectionné avec espace cette résolution mais je ne vois pas comment mettre ok à toutes les autres options

Hors ligne

#22 Le 01/12/2005, à 17:53

Rustre

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

T'as essayé de vérifier ton xorg.conf? Je vois que tu déclare un modeline "1280x1024@75" et tu met dans tes modes "1280x1024" en oubliant le "@75".

Rustre

#23 Le 02/12/2005, à 13:50

max-fx

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

ok merci j'essaierai ça quand je serai chez moi, on sait jamais

Hors ligne

#24 Le 04/12/2005, à 19:43

wilfried

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

excuser moi salut a tout les utilisateurs de ce forum j'ai un probleme un peu pareil moi j'ai installé ubuntu mais au démarage tout a coup mon écran devient noir.
mais je crois que c'est un problème de résolution alors je vous en pris aidez moi en me donnant soit les codes a taper ou en tout cas faites quelques choses pour moi.
je vous remercie d'avance.


Vive le Logiciel Libre en Afrique

Hors ligne

#25 Le 05/12/2005, à 00:09

k-nine

Re : [Résolu] Problème avec la résolution 1280*800 [Résolu]

Il faudrait que tu nous donnes un peu d'informations sur ton matériel...
portable ?
carte graphique ?
....

Hors ligne

Haut de page ↑