Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/11/2015, à 12:43

fazpedro

Epson XP-530 Scanner

Bonjour,

je viens d'acheter une imprimante Epson XP-530, et j'arrive à faire fonctionner l'imprimante mais pas le scanner :
J'ai essayé plusieurs méthodes trouvés sur le forum mais je n'arrive toujours pas à faire reconnaître le scanner...
Merci de votre aide.

Liens déjà utilisés :

https://doc.ubuntu-fr.org/scanner_epson … nner_epson
https://doc.ubuntu-fr.org/tutoriel/inst … ante_epson

http://download.ebz.epson.net/dsc/du/02 … a067e1b189

Erreurs :
E: Impossible de trouver le paquet libboost-filesystem1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-filesystem1.54.0 »
E: Impossible de trouver le paquet libboost-program-options1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-program-options1.54.0 »
E: Impossible de trouver le paquet libboost-regex1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-regex1.54.0 »
E: Impossible de trouver le paquet libboost-system1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-system1.54.0 »
E: Impossible de trouver le paquet libboost-thread1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-thread1.54.0 »

Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/11/2015, à 13:26)

Hors ligne

#2 Le 28/11/2015, à 13:29

sylvain3800

Re : Epson XP-530 Scanner

Bonjour fazpedro

peut tu nous donner de plus amples info sur ton systeme :
pour cela donne nous le retour de ces commandes :

cat /etc/*release && uname -m
dpkg -l | grep iscan

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#3 Le 28/11/2015, à 13:59

fazpedro

Re : Epson XP-530 Scanner

Bonjour sylvain3800,

Voici le résultat :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu 15.04"
NAME="Ubuntu"
VERSION="15.04 (Vivid Vervet)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 15.04"
VERSION_ID="15.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
x86_64

Modération - Rappel : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/11/2015, à 15:47)

Hors ligne

#4 Le 28/11/2015, à 14:17

sylvain3800

Re : Epson XP-530 Scanner

okay merci !
c'est plus claire maintenant ... mais j'ai encore besoin du resultat de la 2nde commande tongue


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#5 Le 28/11/2015, à 15:24

fazpedro

Re : Epson XP-530 Scanner

en fait, après la deuxième commande, il ne se passe rien :

$ dpkg -l | grep iscan
$
ou
$ sudo dpkg -l | grep iscan
$

voici aussi une autre commande :

$ sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04b8, product=0x110c) at libusb:004:003
found USB scanner (vendor=0x0bda [Generic], product=0x0129 [USB2.0-CRW]) at libusb:003:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Modération - Rappel : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/11/2015, à 15:48)

Hors ligne

#6 Le 28/11/2015, à 15:41

sylvain3800

Re : Epson XP-530 Scanner

Okay si il ne se passe rien c'est déjà une réponse ça veux dire que tes pilotes ne sont pas installé .

pour les installer il va falloir télecharger les pilotes depuis le site d'epson et lancer le script d'installation depuis le terminal pour ce faire ouvre un terminal et rentre ces commandes (copie-colle)dans l'ordre :
etape 1) telecharge les pilotes

wget https://download2.ebz.epson.net/imagescanv3/ubuntu/lts1/deb/x64/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz

etape 2) décompresse le fichier

tar -xvf imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz 

etape 3) rend toi dans le dossier ainsi crée

cd imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/

etape 4) lance le script

sudo ./install.sh

ton scanner devrait être fonctionnel depuis le logiciel image scann


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#7 Le 28/11/2015, à 15:45

fazpedro

Re : Epson XP-530 Scanner

Voici le résultat :

$ sudo wget [url]https://download2.ebz.epson.net/imagescanv3/ubuntu/lts1/deb/x64/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz[/url]
--2015-11-28 14:43:15--  [url]https://download2.ebz.epson.net/imagescanv3/ubuntu/lts1/deb/x64/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz[/url]
Résolution de download2.ebz.epson.net (download2.ebz.epson.net)… 104.85.85.252
Connexion à download2.ebz.epson.net (download2.ebz.epson.net)|104.85.85.252|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 1434041 (1,4M) [application/x-gzip]
Enregistre : «imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz»
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz                  100%[====================================================================================================================================================================>]   1,37M  1,09MB/s   ds 1,3s   
2015-11-28 14:43:17 (1,09 MB/s) - «imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz» enregistré [1434041/1434041]
$ sudo tar -xvf imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb.tar.gz 
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core/
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core/imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/README.rst
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/install.sh
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/plugins/
imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/plugins/imagescan-plugin-networkscan_1.1.0-1epson4ubuntu14.04_amd64.deb
$ cd imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/
$ sudo ./install.sh
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid InRelease
Atteint [url]http://archive.canonical.com[/url] vivid InRelease                                       
Réception de : 1 [url]http://fr.archive.ubuntu.com[/url] vivid-updates InRelease [64,4 kB]               
Réception de : 2 [url]http://security.ubuntu.com[/url] vivid-security InRelease [64,4 kB]                  
Atteint [url]http://archive.canonical.com[/url] vivid/partner Sources                                              
Atteint [url]http://archive.canonical.com[/url] vivid/partner amd64 Packages                                                                                 
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/main Sources                                                  
Atteint [url]http://archive.canonical.com[/url] vivid/partner i386 Packages                                                       
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/restricted Sources                                                          
Atteint [url]http://archive.canonical.com[/url] vivid/partner Translation-en                                                      
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/universe Sources                               
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/multiverse Sources                             
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/main amd64 Packages                              
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/restricted amd64 Packages                         
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/universe amd64 Packages                    
Réception de : 3 [url]http://security.ubuntu.com[/url] vivid-security/main Sources [53,6 kB]     
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/multiverse amd64 Packages              
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/main i386 Packages                     
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/restricted i386 Packages
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/universe i386 Packages                                           
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/multiverse i386 Packages                                         
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/main Translation-fr                        
Réception de : 4 [url]http://security.ubuntu.com[/url] vivid-security/restricted Sources [3 418 B]
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/main Translation-en                                              
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/multiverse Translation-fr                  
Réception de : 5 [url]http://security.ubuntu.com[/url] vivid-security/universe Sources [20,3 kB]     
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/multiverse Translation-en                                            
Réception de : 6 [url]http://security.ubuntu.com[/url] vivid-security/multiverse Sources [1 937 B]                         
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/restricted Translation-fr                                            
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/restricted Translation-en                      
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/universe Translation-fr                        
Réception de : 7 [url]http://security.ubuntu.com[/url] vivid-security/main amd64 Packages [162 kB]   
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid/universe Translation-en                    
Réception de : 8 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/main Sources [106 kB]     
Réception de : 9 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/restricted Sources [4 351 B]                         
Réception de : 10 [url]http://security.ubuntu.com[/url] vivid-security/restricted amd64 Packages [11,2 kB]                  
Réception de : 11 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/universe Sources [47,3 kB]                           
Réception de : 12 [url]http://security.ubuntu.com[/url] vivid-security/universe amd64 Packages [66,1 kB]
Réception de : 13 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/multiverse Sources [1 937 B]                           
Réception de : 14 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/main amd64 Packages [254 kB]                           
Réception de : 15 [url]http://security.ubuntu.com[/url] vivid-security/multiverse amd64 Packages [6 045 B]
Réception de : 16 [url]http://security.ubuntu.com[/url] vivid-security/main i386 Packages [161 kB]                          
Réception de : 17 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/restricted amd64 Packages [13,6 kB]                   
Réception de : 18 [url]http://security.ubuntu.com[/url] vivid-security/restricted i386 Packages [10,9 kB]                     
Réception de : 19 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/universe amd64 Packages [126 kB]                      
Réception de : 20 [url]http://security.ubuntu.com[/url] vivid-security/universe i386 Packages [66,1 kB]                       
Réception de : 21 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/multiverse amd64 Packages [6 045 B]
Réception de : 22 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/main i386 Packages [251 kB]                           
Réception de : 23 [url]http://security.ubuntu.com[/url] vivid-security/multiverse i386 Packages [6 198 B]                   
Atteint [url]http://security.ubuntu.com[/url] vivid-security/main Translation-en                                         
Atteint [url]http://security.ubuntu.com[/url] vivid-security/multiverse Translation-en           
Atteint [url]http://security.ubuntu.com[/url] vivid-security/restricted Translation-en          
Atteint [url]http://security.ubuntu.com[/url] vivid-security/universe Translation-en            
Réception de : 24 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/restricted i386 Packages [13,3 kB]
Réception de : 25 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/universe i386 Packages [126 kB]
Réception de : 26 [url]http://fr.archive.ubuntu.com[/url] vivid-updates/multiverse i386 Packages [6 198 B]
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid-updates/main Translation-en           
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid-updates/multiverse Translation-en
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid-updates/restricted Translation-en
Atteint [url]http://fr.archive.ubuntu.com[/url] vivid-updates/universe Translation-en
1 653 ko réceptionnés en 7s (209 ko/s)                                                                                                                                                                                                                                        
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libboost-filesystem1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-filesystem1.54.0 »
E: Impossible de trouver le paquet libboost-program-options1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-program-options1.54.0 »
E: Impossible de trouver le paquet libboost-regex1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-regex1.54.0 »
E: Impossible de trouver le paquet libboost-system1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-system1.54.0 »
E: Impossible de trouver le paquet libboost-thread1.54.0
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libboost-thread1.54.0 »
$ 

Modération - Rappel : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/11/2015, à 15:49)

Hors ligne

#8 Le 28/11/2015, à 15:52

sylvain3800

Re : Epson XP-530 Scanner

okay ... le probleme c'est que ces paquets sont ecrit pour ubuntu 14.04 et que visiblement ca pose un probleme avec ton ubuntu 15.04
... le prob c'est que les paquet pour ubuntu 15.04 ne sont pas accessible ...
essaye ceci

cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core
sudo dpkg -i imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb 

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#9 Le 28/11/2015, à 16:00

fazpedro

Re : Epson XP-530 Scanner

Résultat :

$ cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core
$ sudo dpkg -i imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb 
Sélection du paquet imagescan précédemment désélectionné.
(Lecture de la base de données... 585706 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb ...
Dépaquetage de imagescan (3.13.0-1epson4ubuntu14.04) ...
dpkg: des problèmes de dépendances empêchent la configuration de imagescan :
 imagescan dépend de libboost-filesystem1.54.0 ; cependant :
  Le paquet libboost-filesystem1.54.0 n'est pas installé.
 imagescan dépend de libboost-program-options1.54.0 ; cependant :
  Le paquet libboost-program-options1.54.0 n'est pas installé.
 imagescan dépend de libboost-regex1.54.0 ; cependant :
  Le paquet libboost-regex1.54.0 n'est pas installé.
 imagescan dépend de libboost-system1.54.0 ; cependant :
  Le paquet libboost-system1.54.0 n'est pas installé.
 imagescan dépend de libboost-thread1.54.0 ; cependant :
  Le paquet libboost-thread1.54.0 n'est pas installé.
 imagescan dépend de libgraphicsmagick++3 ; cependant :
  Le paquet libgraphicsmagick++3 n'est pas installé.
 imagescan dépend de graphicsmagick ; cependant :
  Le paquet graphicsmagick n'est pas installé.
dpkg: erreur de traitement du paquet imagescan (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 imagescan

Hors ligne

#10 Le 28/11/2015, à 16:04

sylvain3800

Re : Epson XP-530 Scanner

apt-cache search libboost

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#11 Le 28/11/2015, à 16:10

fazpedro

Re : Epson XP-530 Scanner

$ sudo apt-cache search libboost
libboost-atomic1.55-dev - types de données, opérations et contraintes d'ordonnancement de mémoire pour atomic
libboost-atomic1.55.0 - types de données, opérations et contraintes d'ordonnancement de mémoire pour atomic
libboost-chrono1.55-dev - Représentation C++ d'une durée de temps, d'un point temporel, et d'horloges
libboost-chrono1.55.0 - Représentation C++ d'une durée de temps, d'un point temporel, et d'horloges
libboost-date-time-dev - Ensemble de bibliothèques d'horodatage basées sur des concepts génériques de programmation (version par défaut)
libboost-date-time1.55-dev - Ensemble de bibliothèques d'horodatage basées sur des concepts génériques de programmation
libboost-date-time1.55.0 - Ensemble de bibliothèques d'horodatage basées sur des concepts génériques de programmation
libboost-dbg - Bibliothèques boost C++ avec les symboles de débogage (version par défaut)
libboost-dev - Fichiers de développement de bibliothèques Boost C++ (version par défaut)
libboost-doc - Documentation des bibliothèques Boost.org (version par défaut)
libboost-filesystem-dev - opérations de système de fichiers (chemins portables, itération sur les répertoires, etc) en C++ (version par défaut)
libboost-filesystem1.55-dev - opérations de système de fichiers (chemins portables, itération sur les répertoires, etc) en C++
libboost-filesystem1.55.0 - opérations de système de fichiers (chemins portables, itération sur les répertoires, etc) en C++
libboost-iostreams-dev - Fichiers de développement de la bibliothèque Boost.Iostreams (version par défaut)
libboost-iostreams1.55-dev - Fichiers de développement de la bibliothèque Boost.Iostreams
libboost-iostreams1.55.0 - bibliothèque Boost.Iostreams
libboost-log-dev - C++ logging library (default version)
libboost-log1.55-dev - C++ logging library
libboost-log1.55.0 - C++ logging library
libboost-program-options-dev - Bibliothèque d'options de programme pour C++ (version par défaut)
libboost-program-options1.55-dev - Bibliothèque d'options de programme pour C++
libboost-program-options1.55.0 - Bibliothèque d'options de programme pour C++
libboost-python-dev - Fichiers de développement de la bibliothèque Boost.Python (version par défaut)
libboost-python1.55-dev - Boost.Python Fichiers de développement de la bibliothèque
libboost-python1.55.0 - Bibliothèque Boost.Python
libboost-regex-dev - Bibliothèque d'expressions régulières pour C++ (version par défaut)
libboost-regex1.55-dev - Bibliothèque d'expressions régulières pour C++
libboost-regex1.55.0 - Bibliothèque d'expressions régulières pour C++
libboost-serialization-dev - Bibliothèque de sérialisation pour C++ (version par défaut)
libboost-serialization1.55-dev - bibliothèque de sérialisation pour C++
libboost-serialization1.55.0 - bibliothèque de sérialisation pour C++
libboost-system-dev - Bibliothèque de Système d'exploitation (par exemple, prise en charge des diagnostics) - (version par défaut)
libboost-system1.55-dev - Bibliothèque de Système d'exploitation (par exemple, prise en charge des diagnostics)
libboost-system1.55.0 - Bibliothèque de Système d'exploitation (par exemple, prise en charge des diagnostics)
libboost-test-dev - Composants pour l'écriture et l'exécution de suites de tests (version par défaut)
libboost-test1.55-dev - Composants pour l'écriture et l'exécution de suites de tests
libboost-test1.55.0 - Composants pour l'écriture et l'exécution de suites de tests
libboost-thread-dev - Unités d'exécution multiples C++ portable (version par défaut)
libboost-thread1.55-dev - Unités d'exécution multiples C++ portable
libboost-thread1.55.0 - Unités d'exécution multiples C++ portable
libboost1.55-dbg - Bibliothèques Boost C++ avec symboles de débogage
libboost1.55-dev - Fichiers de développement pour les bibliothèques Boost C++
libboost1.55-doc - Documentation de la bibliothèque Boost.org
libboost1.55-tools-dev - Outils de développement pour les bibliothèques C++ Boost
libboost-geometry-utils-perl - Perl module providing bindings to the Boost Geometry library
libboost-all-dev - Boost C++ Libraries development files (ALL) (default version)
libboost-atomic-dev - atomic data types, operations, and memory ordering constraints (default version)
libboost-chrono-dev - C++ representation of time duration, time point, and clocks (default version)
libboost-context-dev - fournit une sorte de multitâche coopératif sur un seul fil d'exécution (version par défaut)
libboost-context1.55-dev - fournit une sorte de multitâche coopératif sur un seul fil d'exécution
libboost-context1.55.0 - fournit une sorte de multitâche coopératif sur un seul fil d'exécution
libboost-coroutine-dev - fournit une sorte de multitâche coopératif sur un seul fil d'exécution (version par défaut)
libboost-coroutine1.55-dev - fournit une sorte de multitâche coopératif sur un seul fil d'exécution
libboost-exception-dev - library to help write exceptions and handlers (default version)
libboost-exception1.55-dev - library to help write exceptions and handlers
libboost-graph-dev - generic graph components and algorithms in C++ (default version)
libboost-graph-parallel-dev - generic graph components and algorithms in C++ (default version)
libboost-graph-parallel1.55-dev - Composants de graphes et algorithmes génériques en C++
libboost-graph-parallel1.55.0 - Composants de graphes et algorithmes génériques en C++
libboost-graph1.55-dev - Composants de graphes et algorithmes génériques en C++
libboost-graph1.55.0 - Composants de graphes et algorithmes génériques en C++
libboost-locale-dev - C++ facilities for localization (default version)
libboost-locale1.55-dev - Utilitaires C++ pour la localisation
libboost-locale1.55.0 - Utilitaires C++ pour la localisation
libboost-math-dev - Boost.Math Library development files (default version)
libboost-math1.55-dev - Fichiers de développement de la bibliothèque Boost.Math
libboost-math1.55.0 - Bibliothèque Boost.Math
libboost-mpi-dev - C++ interface to the Message Passing Interface (MPI) (default version)
libboost-mpi-python-dev - C++ interface to the Message Passing Interface (MPI), Python Bindings (default version)
libboost-mpi-python1.55-dev - C++ interface to the Message Passing Interface (MPI), Python Bindings
libboost-mpi-python1.55.0 - C++ interface to the Message Passing Interface (MPI), Python Bindings
libboost-mpi1.55-dev - C++ interface to the Message Passing Interface (MPI)
libboost-mpi1.55.0 - C++ interface to the Message Passing Interface (MPI)
libboost-random-dev - Boost Random Number Library (default version)
libboost-random1.55-dev - Boost Random Number Library
libboost-random1.55.0 - Boost Random Number Library
libboost-signals-dev - managed signals and slots library for C++ (default version)
libboost-signals1.55-dev - Bibliothèque de signaux et récepteurs gérés pour C++
libboost-signals1.55.0 - Bibliothèque de signaux et récepteurs gérés pour C++
libboost-timer-dev - C++ wall clock and CPU process timers (default version)
libboost-timer1.55-dev - C++ wall clock and CPU process timers
libboost-timer1.55.0 - C++ wall clock and CPU process timers
libboost-tools-dev - Boost C++ Libraries development tools (default version)
libboost-wave-dev - C99/C++ preprocessor library (default version)
libboost-wave1.55-dev - Bibliothèque du préprocesseur C99/C++
libboost-wave1.55.0 - Bibliothèque du préprocesseur C99/C++
libboost1.55-all-dev - bibliothèques Boost C++, fichiers de développement (ALL)

Hors ligne

#12 Le 28/11/2015, à 16:21

sylvain3800

Re : Epson XP-530 Scanner

okay va falloir mettre à jour les pilotes donc car ta version est la 1.55 et celle demandé est la 1.54

cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core
sudo dpkg-deb -x imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp
sudo dpkg-deb --control imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp/DEBIAN

tu ouvre le fichier de controle :

sudo xdg-open fichiertemp/DEBIAN/control

tu devrai obtenir ceci :

Package: imagescan
Version: 3.13.0-1epson4ubuntu14.04
Architecture: amd64
Maintainer: SEIKO EPSON CORPORATION <linux-scanner@epson.jp>
Installed-Size: 8156
Depends: libatkmm-1.6-1 (>= 2.22.1), libboost-filesystem1.54.0, libboost-program-options1.54.0, libboost-regex1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.12.0), libglibmm-2.4-1c2a (>= 2.36.2), libgraphicsmagick++3, libgraphicsmagick3 (>= 1.3.11), libgtkmm-2.4-1c2a (>= 1:2.24.0), libjpeg8 (>= 8c), libltdl7 (>= 2.4.2), libsigc++-2.0-0c2a (>= 2.0.2), libstdc++6 (>= 4.6), libtiff5 (>= 4.0.3), libudev1 (>= 183), libusb-1.0-0 (>= 2:1.0.12), graphicsmagick
Recommends: sane-utils
Section: graphics
Priority: optional
Description: next generation image acquisition utilities
This software provides applications to easily turn hard-copy
documents and imagery into formats that are more amenable to
computer processing.
.
Included are a native driver for a number of EPSON scanners
and a compatibility driver to interface with software built
around the SANE standard.
.
The current package supports the
  - DS-40
  - DS-510
  - DS-520
  - DS-560
  - DS-760
  - DS-860
  - DS-5500
  - DS-6500
  - DS-7500
  - DS-50000
  - DS-60000
  - DS-70000
  - EP-10VA Series
  - EP-808A Series
  - EP-978A3 Series
  - ET-2500 Series
  - ET-2550 Series
  - ET-4500 Series
  - ET-4550 Series
  - L220/L360 Series
  - L365/L366 Series
  - L455 Series
  - L565/L566 Series
  - L655 Series
  - PX-M840FX
  - PX-M860F
  - PX-M7050 Series
  - PX-M7050FX Series
  - WF-6590 Series
  - WF-8510/8590 Series
  - WF-R8590 Series
  - XP-220 Series
  - XP-230 Series
  - XP-235 Series
  - XP-332 335 Series
  - XP-430 Series
  - XP-432 435 Series
  - XP-530 Series
  - XP-630 Series
  - XP-830 Series
  - XP-960 Series

dans les lignes dependances tu remplace tout les libboost* 1.54.0 par libboost 1-55.0
(il suffit de remplacer 54 par 55)
tu enregistre et quite
tu crée ta version du paquet

dpkg -b fichiertemp imagescan.deb

tu installe ta version

dpkg -i imagescan.deb

et tu verifie que c'est bien installé

dpkg -l | grep imagescan

Dernière modification par sylvain3800 (Le 28/11/2015, à 16:23)


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#13 Le 28/11/2015, à 16:23

fazpedro

Re : Epson XP-530 Scanner

J'ai redémarré, et là il fonctionne mais il est hyper lent ( au moins deux minutes avant de numériser...) c'est à cause de ce libboost ?
Merci.

$ scanimage -L
device `epson:libusb:004:003' is a Epson PID flatbed scanner

Hors ligne

#14 Le 28/11/2015, à 16:26

sylvain3800

Re : Epson XP-530 Scanner

c'est etonnant qu'il fonctionne quand même le script d'installation à peut être installé une version generique ou incomplete
donne le retour de cette commande :

dpkg -l | grep imagescan

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#15 Le 28/11/2015, à 16:29

fazpedro

Re : Epson XP-530 Scanner

Résultat :

$ cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg-deb -x imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg-deb --control imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp/DEBIAN
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo xdg-open fichiertemp/DEBIAN/control
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo xdg-open fichiertemp/DEBIAN/control
(gedit:2098): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
(gedit:2098): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ dpkg -b fichiertemp imagescan.deb
dpkg-deb : construction du paquet « imagescan » dans « imagescan.deb ».
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg -i imagescan.deb
Sélection du paquet imagescan précédemment désélectionné.
(Lecture de la base de données... 555537 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de imagescan.deb ...
Dépaquetage de imagescan (3.13.0-1epson4ubuntu14.04) ...
dpkg: des problèmes de dépendances empêchent la configuration de imagescan :
 imagescan dépend de libboost-program-options1.55.0 ; cependant :
  Le paquet libboost-program-options1.55.0 n'est pas installé.
 imagescan dépend de libboost-regex1.55.0 ; cependant :
  Le paquet libboost-regex1.55.0 n'est pas installé.
 imagescan dépend de libgraphicsmagick++3 ; cependant :
  Le paquet libgraphicsmagick++3 n'est pas installé.
 imagescan dépend de graphicsmagick ; cependant :
  Le paquet graphicsmagick n'est pas installé.
dpkg: erreur de traitement du paquet imagescan (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 imagescan
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ dpkg -l | grep imagescan
iU  imagescan                                   3.13.0-1epson4ubuntu14.04                  amd64        next generation image acquisition utilities

Hors ligne

#16 Le 28/11/2015, à 16:34

sylvain3800

Re : Epson XP-530 Scanner

okay il est donc installé mais pas configuré
c'est vrai que dpkg gere pas les dépendences :

sudo apt-get install libboost-program-options1.55.0 libboost-regex1.55.0 libgraphicsmagick++3 graphicsmagick

puis

sudo dpkg -i imagescan.deb

Dernière modification par sylvain3800 (Le 28/11/2015, à 16:36)


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#17 Le 28/11/2015, à 16:45

fazpedro

Re : Epson XP-530 Scanner

Résultat ci-dessous : il est toujours aussi lent à démarrer ...

$ sudo apt-get install libboost-program-options1.55.0 libboost-regex1.55.0 libgraphicsmagick++3 graphicsmagick
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libboost-program-options1.55.0 est déjà la plus récente version disponible.
libboost-program-options1.55.0 passé en « installé manuellement ».
libboost-regex1.55.0 est déjà la plus récente version disponible.
libboost-regex1.55.0 passé en « installé manuellement ».
graphicsmagick est déjà la plus récente version disponible.
graphicsmagick passé en « installé manuellement ».
libgraphicsmagick++3 est déjà la plus récente version disponible.
libgraphicsmagick++3 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
$ sudo dpkg -i imagescan.deb
dpkg: erreur de traitement de l'archive imagescan.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 imagescan.deb
$ dpkg -b fichiertemp imagescan.deb
dpkg-deb : erreur : la lecture du fichier « info » « fichiertemp/DEBIAN/control » du paquet a échoué: Aucun fichier ou dossier de ce type
$ sudo xdg-open fichiertemp/DEBIAN/control
xdg-open: file 'fichiertemp/DEBIAN/control' does not exist
$ cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg-deb -x imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg-deb --control imagescan_3.13.0-1epson4ubuntu14.04_amd64.deb fichiertemp/DEBIAN
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo xdg-open fichiertemp/DEBIAN/control
(gedit:1761): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
(gedit:1761): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ dpkg -b fichiertemp imagescan.deb
dpkg-deb : construction du paquet « imagescan » dans « imagescan.deb ».
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg -i imagescan.deb
(Lecture de la base de données... 555723 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de imagescan.deb ...
Dépaquetage de imagescan (3.13.0-1epson4ubuntu14.04) sur (3.13.0-1epson4ubuntu14.04) ...
Paramétrage de imagescan (3.13.0-1epson4ubuntu14.04) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.21-0ubuntu4) ...
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ dpkg -l | grep imagescan
ii  imagescan                                   3.13.0-1epson4ubuntu14.04                  amd64        next generation image acquisition utilities
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo apt-get install libboost-program-options1.55.0 libboost-regex1.55.0 libgraphicsmagick++3 graphicsmagick
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libboost-program-options1.55.0 est déjà la plus récente version disponible.
libboost-regex1.55.0 est déjà la plus récente version disponible.
graphicsmagick est déjà la plus récente version disponible.
libgraphicsmagick++3 est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/core$ sudo dpkg -i imagescan.deb
(Lecture de la base de données... 555723 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de imagescan.deb ...
Dépaquetage de imagescan (3.13.0-1epson4ubuntu14.04) sur (3.13.0-1epson4ubuntu14.04) ...
Paramétrage de imagescan (3.13.0-1epson4ubuntu14.04) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.10.1-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.58ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.21-0ubuntu4) ...

dpkg -l | grep imagescan
ii  imagescan                                   3.13.0-1epson4ubuntu14.04                  amd64        next generation image acquisition utilities

Hors ligne

#18 Le 28/11/2015, à 16:53

sylvain3800

Re : Epson XP-530 Scanner

bon maintenant que c'est installé et configuré essaye ceci

cd ~/imagescan-bundle-ubuntu-14.04-1.0.3.x64.deb/plugins
dpkg -i imagescan-plugin-networkscan_1.1.0-1epson4ubuntu14.04_amd64.deb 

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#19 Le 28/11/2015, à 17:00

fazpedro

Re : Epson XP-530 Scanner

Résultat ci-dessous mais il est toujours aussi lent à démarrer ...


$ sudo dpkg -i imagescan-plugin-networkscan_1.1.0-1epson4ubuntu14.04_amd64.deb 
Sélection du paquet imagescan-plugin-networkscan précédemment désélectionné.
(Lecture de la base de données... 555723 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de imagescan-plugin-networkscan_1.1.0-1epson4ubuntu14.04_amd64.deb ...
Dépaquetage de imagescan-plugin-networkscan (1.1.0-1epson4ubuntu14.04) ...
Paramétrage de imagescan-plugin-networkscan (1.1.0-1epson4ubuntu14.04) ...

Hors ligne

#20 Le 28/11/2015, à 17:01

sylvain3800

Re : Epson XP-530 Scanner

dpkg -l | grep imagescan

Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#21 Le 28/11/2015, à 17:02

fazpedro

Re : Epson XP-530 Scanner

$ dpkg -l | grep imagescan
ii  imagescan                                   3.13.0-1epson4ubuntu14.04                  amd64        next generation image acquisition utilities
ii  imagescan-plugin-networkscan                1.1.0-1epson4ubuntu14.04                   amd64        Network scan plugin

Hors ligne

#22 Le 28/11/2015, à 17:08

sylvain3800

Re : Epson XP-530 Scanner

okay c'est installé , lorsque tu lance le scanner tu passe par image scann ?


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#23 Le 28/11/2015, à 17:10

fazpedro

Re : Epson XP-530 Scanner

j'ai simple scan

Hors ligne

#24 Le 28/11/2015, à 17:11

sylvain3800

Re : Epson XP-530 Scanner

utilise le programme  image scann est dit moi si c'est plus rapide
ou si c'est la même chose ?


Cogito ergo sum = je consome donc je suis : je pense, donc je suis !
Les anes ont soif
Les chiens de garde
Rwanda

Hors ligne

#25 Le 28/11/2015, à 17:34

fazpedro

Re : Epson XP-530 Scanner

j'ai pas trouvé "image scann" mais "Skanlite" je l'ai installé, il est hyper long au démarrage "Recherche de périphérique en cours..."...
une fois mon epson trouvée, la numérisation est rapide mais du coup autant utiliser "Simple scan" qui est aussi long...
il existe un moyen d'accélérer la reconnaissance de l'epson ?
merci.

Dernière modification par fazpedro (Le 28/11/2015, à 17:35)

Hors ligne