Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 27/04/2016, à 17:25

Li@nel

[TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour tout le monde,

J'ouvre ce topic afin de fournir une aide à la communauté francophone linuxienne dans l'installation d'Ubuntu sur une tablette ASUS T100 TA/TAF/CHI etc..
J'espère que ce sujet se trouve dans la bonne catégorie, auquel cas je laisserai les modérateurs de ce forum oeuvrer.

Toutes les informations renseignées sur ce sujet proviennent d'une communauté anglophone très active, présente sur Google+, qui mettent tout en oeuvre pour bénéficier d'Ubuntu sur ce genre de machine, et je salue leur travail !

Au fur et à mesure de l'état d'avancement de ce projet, je viendrai mettre à jour ce post wink

Si vous rencontrez le moindre soucis, n'hésitez pas à en faire part ici ou à contacter en anglais uniquement le créateur de cet installateur à brainwreck80@gmail.com

------------------------------------------------------------------
27.04.2016

Je tiens à signaler que compte tenu de certaines difficultés rencontrées sur le kernel 4.5.2 et en attendant le retour d'utilisation pour le kernel 4.4.8-1, il n'est pas prévu de créer un nouvel installateur pour la version 16.04 LTS, il faudra encore un peu attendre !
Pour ceux qui veulent, le kernel 4.5.2 est fonctionnel, sauf pour le son qui n'est pas reconnu sur l'appareil.
Toute installation de kernel linux d'origine n'est pas contraire, néanmoins les versions proposées par la communauté ont été patchées et permettent une meilleure intégration des différents composants du système (luminosité, batterie, son, wifi etc..).

Dernière modification par Li@nel (Le 27/04/2016, à 17:50)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#2 Le 27/04/2016, à 17:37

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Installation d'Ubuntu 15.10 sur l'ASUS T100, kernel 4.4.0.1

Ce qui fonctionne :

Luminosité
Bluetooth, s'il ne marche pas, copier le .hcd file de /lib/firmware/brcm à /lib/firmware 
Wifi
SDCard
Touches spéciales
Sound, pour la version TAF le kernel 4.5 devrait corriger un bug éventuel
Accéléromètre (nécessaire d'installer les scripts pour la rotation après l'installation, sauf utilisation d'un kernel personnalisé "aufs")
Capteur lumineux (nécessaire d'ajouter les scripts de réglage de la luminosité après l'installation, sauf utilisation d'un kernel personnalisé "aufs")

Voici juste un installateur basique d'Ubuntu 15.10 sur l'ASUS T00, il fonctionne avec les kernels personnalisés pour les modèles TAF/CHI etc...
Par ailleurs, vous pouvez faire une installation depuis les image ISO officielle d'Ubuntu, et ensuite remplacer votre kernel par défaut par un personnalisé afin de profiter pleinement de la compatibilité périphérique.

Les ISO de cet installateur pour la version I386 (32 bit) et X86_64 (64 bit)
Dernier kernel récent opérationnel : 4.4.8.1

Dernière modification par Li@nel (Le 27/04/2016, à 17:51)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#3 Le 01/05/2016, à 19:40

tuxrouge

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Sur une T100 TAM
Sur une carte SD séparée (une partition boot en uefi et un pour le système en ext4)

boot sur la clef seulement avec la version 64 (avec la version 32, la clef est reconnue mais impossible de booter dessus)
installation sans problème
mais impossible de booter dessus. Ubuntu apparait comme option de boot dans le bios (c'est déjà ça)
quand je sélectionne, je boote sur un grub vide. Juste accès à la commande grub>

quand j'essaye de réinstaller grub via la clef j'obtiens

grub-install: warning: File system 'fat' doesn support embedding...

Hors ligne

#4 Le 01/05/2016, à 21:07

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Comme spécifié sur de nombreux forums, le BIOS de l'ASUS T100 ne reconnait par le port MicroSD comme un périphérique capable d'être utilisé comme périphérique d'amorcage au démmarrage de la machine.
J'avais déjà essayé ta manipulation et j'arrivais au même problème, même si le BIOS reconnait grosso modo l'existence de l'entrée au démarrage.
Le GRUB n'arrive pas à lancer le kernel car il est sur la carte microSD qui n'est pas reconnue au démarrage, c'est embêtant, mais c'est comme ça hmm

Tu n'as pas un disque dur en plus sur ce modèle ? Il sera plus simple pour toi de directement installer Ubuntu sur la mémoire eMMC de l'appareil wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#5 Le 07/05/2016, à 20:03

tuxrouge

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

c'est ce que j'ai fais. J'ai viré les partitions windows et je suis maintenant full linux
en utilisant un iso spécifique https://drive.google.com/folderview?id= … sp=sharing et en bidouillant ensuite grub (bidouille de grub) je peux démarrer sur la mchine et tout semble fonctionner
existe t'il un moyen de récupérer les options passées au kernel afin que je ne les perde pas lors de la mise à jour ?

Hors ligne

#6 Le 07/05/2016, à 20:25

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

tuxrouge a écrit :

existe t'il un moyen de récupérer les options passées au kernel afin que je ne les perde pas lors de la mise à jour ?

Je ne peux que te conseiller d'utiliser principalement les kernels patchés spécialement par la communauté pour profiter au maximum de ton installation.
Si tu te sens capable, voici les patchs utilisés sur les kernels officiels, tu peux toujours tenter de compiler ton propre noyau.
Le dernier noyau stable de la communauté est le 4.4.9 quand même


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#7 Le 08/05/2016, à 09:58

tuxrouge

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

ok vu pour les kernels patchés, je connaissais pas cette ressource.
du coup je vais essayer de réinstaller à partir de la dernière ubuntu et je passerai au noyau spécifique ensuite.
Par contre pour l'instant je ne peux pas booter directement sur mon linux. Je dois passer des options à grub
dans mon cas (doc ici):

linux (hd0,gpt2)/vmlinuz-4.4.0 root=/dev/mmcblk0p3
initrd (hd0,gpt2)/initrd-4.4.0
boot

comment puis-je faire pour que ce soit automatique ?

Hors ligne

#8 Le 08/05/2016, à 10:09

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Si tu comtpes réinstaller Ubuntu, je te conseille d'installer la version 15.04 avec le Magic Stick, comme va ton problème de GRUB sera réglé.
Ensuite, fait les mies à jour, puis la migration vers 15.10, les mises à jours de la 15.10, puis la migration vers la 16.04 et enfin les mises à jours de la 16.04.

Cela te facilitera la vie et tu auras beaucoup moins de soucis pour le GRUB.
Sinon t'as besoin de te créer un fichier grub.cfg mais c'est un peu galère juste.


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#9 Le 09/05/2016, à 00:39

tuxrouge

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

je reviens de faire une installation avec la magic stick (qui est actuellement en 15.10) et j'ai toujours le même pb de boot alors que je n'ai aucun pb quand je le fais avec une manjaro (bon là par contre, pas de wifi, pas de son ...)

Dernière modification par tuxrouge (Le 09/05/2016, à 00:46)

Hors ligne

#10 Le 09/05/2016, à 02:35

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Petite rectification, le Magic Stick est en version 15.04 d'Ubuntu.
As-tu essayé en formatant ton disque entier et en laissant Ubuntu le partitionner comme bon lui semble ?


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#11 Le 09/05/2016, à 08:40

tuxrouge

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

on ne parle pas de la même alors. Moi je fais avec celle là: https://plus.google.com/communities/117 … 4346186936
l'image est appelée T100-4.4.0-Ubuntu-15.10-x86_64-bootable
et non j'ai partitionné à la main pour garder un /home séparé.

Hors ligne

#12 Le 09/05/2016, à 08:42

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Ah ouais d'accord, tu parles des ISO de la communauté toi.
Pour ne plus avoir de soucis, je te conseil de réinstaller Ubuntu avec le Magic Stick, il y a des soucis avec l'installation du GRUB pour ces ISO hmm
Ça marche nickel avec le Magic Stick


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#13 Le 11/05/2016, à 12:41

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bonjour à tous.

Alors en fait, n'ayant pas vu ce post, j'avais posté la mienne ici : https://forum.ubuntu-fr.org/viewtopic.php?id=1989941

Bref, j'ai testé vraiment pas mal de choses, car difficile d'éviter les freeze quasi répétitif pour le peu que l'on veuille regarder un tant soit peu youtube, ou utiliser VLC fréquemment (cela dit quelques fois dés le démarrage bing freeze alors que rien n'est lancé !) !

Donc en clair on a des freeze indépendant de la charge sur le système (qui peut encaisser pas mal quand même cela dit) !

Sinon, tout marche, sauf la caméra (problème connu avec ce type de matériel et à la limite ça... je ne m'en sert pas).
Niveau mise en veille ça marche assez bien aussi avec le kernel proposé (4.4.0-21/22 generic).

J'ai tenté de faire un upgrade sur la dernière version stable du kernel => 4.5.3, et beaucoup beaucoup moins de freeze (1 seul en quelques jours)... par contre, problème identifié sur ce dernier également, en effet la carte son n'est plus reconnue...

J'ai donc tenté de rebooter sur l'ancien Kernel proposé en standard et là, la carte son est à nouveau reconnue et est fonctionnelle, mais le système instable... donc finalement j'ai tenté le Kernel 4.4.9 où la carte son est bien reconnue mais la stabilité toujours pas là.

Comme j'ai l'impression que le problème est lié à l'affichage, j'ai tenté une petite session mate avec le kernel 4.4.9, j'ai aussi eu un plantage (sans composition ni rien (marco sans comp)).

J'ai bien tenté de modifier le fichier /etc/default/grub en ajoutant intel_idle.max_cstate=0 (http://www.jfwhome.com/2016/01/04/lates … us-t100ta/), mais ça n'a pas résolu le problème.

En fait, j'essaie de vraiment comprendre ce problème qui n'est en fait pas forcément lié à l'affichage (en attendant un Kernel 4.5.x qui résolve "nativement" ce problème), mais on a l'impression que c'est quand même cela qui plante complètement.

Je tiens à préciser que j'ai fait tous les tests en buildant moi-même les kernel, ce qui m'a pris une paire d'heure à chaque fois.

Pour les kernels patchés, est-ce que quelqu'un a essayé ceci ? https://github.com/Asus-T100/kernel (c'est peut-être la même chose que le lien que j'ai vu passé dans un réponse précédente).

Pour info, je n'ai plus trace de W8 sur le système, j'ai complètement rincé le disque.

Grâce à vous, je viens enfin de comprendre pourquoi je n'arrive pas à booter autrement que sur une clé et en tapant les commandes à la main (bon j'ai quand même modifié le fichier de grub pour ne plus justement avoir à les retaper à chaque fois)... Cependant il semble quelqu'un ici a réussi, donc tout trouve une solution.

Est-ce que quelqu'un a réussi à avoir une mise en veille qui fonctionne bien avec un patché (qui éteint aussi au passage l'éclairage de l'écran ?), qui élimine les freeze et nous rend une carte son fonctionnelle ?. Si oui, à la limite le boot devient secondaire pour moi (je ne compte vraiment pas le maj souvent ni le redémarrer, c'est quoi ces habitudes de windowsien là!!)

Sinon, donc là je suis sur une session mate, et c'est très réactif !! ça fait plaisir.

Bonne journée à vous.

Hors ligne

#14 Le 11/05/2016, à 14:37

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Salut flouub,

J'avoue que j'ai aussi beaucoup de freeze sur mon T100TA, et grosso modo dans les mêmes conditions que toi (au démarrage, en plein milieu de la rédaction d'un mail sur GMail ou en audio sur Skype).
Je vais de ce pas signaler cela sur la communauté Google+ afin que les autres membres tiennent ça en compte dans leurs travaux futurs sur le prochain kernel patché.
Le T100 est une machine assez robuste je l'avoue^^'.

Concernant le problème de la caméra, je n'aime pas créer des rumeurs ou ébruiter la foule, mais je tiens à annoncer que ce problème pour être résolu dans les semaines à venir, la solution est tout proche !
Pour la mise en veille, je l'ai surtout testée avec les kernels de la communauté et elle fonctionne grosso modo correctement (le problème de l'écran allumé mais noir est toujours présent, tout comme la diode de la caméra), sinon j'utilise la commande pm-suspend-hybrid pour l'hibernation, commande qui fonctionne à merveille.

Le problème de la carte son sur les kernels supérieurs à 4.4.x a déjà été signalés par mes soins, et notre demande est pour le moment analysée par les développeurs de chez Intel.
Je n'exclus pas que ce problème pourrait être corrigé avec les nouveaux kernels 4.6.x ou corrigé prochainement dans un prochain kernel patché 4.5.x.

As-tu essayée avec le kernel 4.4.0 pour l'ASUS T100 ? De mémoire je le pense plus stable et avec beaucoup moins de freeze que le 4.4.9 qui est toujours en version beta test.

Qu'est-ce qui te fait dire que les freezes sont liés à l'affichage ?
Aurais-tu des logs afin d' appuyer des propos, logs que je transmettrai à John pour le développement ?

Je salue ton travail pour avoir patché les kernels, mais je te conseille de ne pas trop perdre de temps sur ça vu qu' il y a déjà une équipe active de développeurs qui y travaillent régulièrement.
Voudrais-tu te joindre à eux sur la communauté ? Ton travail et tes remarques pourraient nous faire progresser, il y a pas de doutes !

Je te souhaite bon courage sur ton ASUS T100 et au plaisir d'avoir de tes nouvelles wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#15 Le 11/05/2016, à 16:29

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Salut Li@nel.

Merci pour ton retour.

Non, je n'ai pas encore pris du temps pour tester le Kernel patché qui semble allait très bien avec nos machines, j'essaierai de trouver un peu de temps en fin de soirée pour faire ça.

En effet, j'ai constaté quelques rapports de bug (bugzilla) évoquant des problèmes avec les kernel 4.5.x/cartes son de certains netbook.

Tu as raison, je ne suis pas sûre que le problème est vraiment lié à l'affichage (j'avoue que je n'ai pas non plus chercher à avoir des logs), mais maintenant que tu en parles, ça pourrait se vérifier facilement en passant runlevel 3 par exemple, si le système finit par freezer, et bien on sera fixé !

D'ailleurs j'en suis de moins en moins convaincu, le test avec maté m'a laissé un déconvenue, je pensais que le problème était peut être lié à unity, mais même là avec Gnome 2, qui pourtant est d'une stabilité à toute épreuve...

En essayant d'analyser ce problème de freeze, la difficulté principale est qu'il est difficile de factoriser les faits qui permettent de le reproduire, et par conséquent pas évident de trouver une explication (surtout dans le cas où le freeze apparait juste après l'ouverture d'une session graphique), ça semble lié à un service schedulé ?! Il me semble qu'en utilisant synaptic le problème apparait également assez souvent.

Bref il y a une opération qui se lance de façon randomatique (schedulée probablement) et qui fait planter le système, laquelle... j'essaierai d'en savoir plus après avoir testé le Kernel patché si les résultats ne sont pas concluants.

Sinon, autant ubuntu mate est bien (nostalgie de gnome 2 où on peut remettre du compiz lol), autant unity tient bien la route aussi (pas testé kubuntu tient ! ça doit faire 9 ans que je n'ai pas lancé un KDE)...

Affaire à suivre.

Encore merci pour ton message !

Dernière modification par flouub (Le 11/05/2016, à 16:30)

Hors ligne

#16 Le 11/05/2016, à 23:06

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Bon.

Finalement j'ai pu jeter un oeil sur les kernels patchés 4.4.0 et 4.4.9, je dois admettre que ces derniers n'ont pas améliorés la stabilité sur ma machine (par contre la gestion de la luminosité de l'écran était fonctionnelle).

J'en suis donc revenue à ma version 4.5.3 qui est la plus stable sur ma machine (un seul freeze à ce jour) (manque juste le son smile).

Hors ligne

#17 Le 12/05/2016, à 07:20

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Salut flouub,

Merci pour ton retour d'expérience sur l' ASUS T100.

Comme annoncé hier, j'ai transmis tes remarques à la communauté anglophone, et j'ai eu une réponse d'un développeur à propos de cela.

La mise en veille fonctionne sur la version CHI avec les kernels appropriés de la communauté.
Cependant, on peut vérifier que l'argument reboot=pci,force soit présent dans les options du GRUB et l'ajouter s'il est manquant, cela pourra aider mais la mise en veille prendra quelques secondes en plus néanmoins.
Le paquet pm-utils est très pratique pour la gestion de la mise en veille et de l'hibernation n'empêche wink

Concernant les freezes sur les kernels patchés, leurs sources est variées et il est difficile de trouver la cause exacte.
Cela peut déprendre du matériel, de l'utilisation, du processeur, bref il est difficile de trouver une solution "universelle".
Pourrais-tu continuer tes recherches sur ton opération schedulée qui pourrait être à l'origine de ses freezes ? Peut-être que tu tiens une piste, mais il est bon de ne pas la négliger même si elle s'avérera fausse wink

Dés que le problème de son sera réglé sur les version 4.5.x du kernel, ce sera un plaisir d' utiliser Ubuntu sur l' ASUS T100^^'
Peut-être que ses freezes sont liés aux version 4.4.x et qu'avec les nouvelles version, Canoncial a résolus ce problème grâce à ses développeurs.


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#18 Le 12/05/2016, à 11:27

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

@flouub : Bonne nouvelle pour toi, je viens de tester le kernel 4.5.4 généric et il reconnait nativement les périphériques audios^^'
En bidouillant un peu, je suis arrivé à trouver une config temporaire pour utiliser le son avec alsamixer.
Si ça t'intéresse, voici les commandes à tester :

Alsamixer settings for headphone
HP R(ight) --> open
HP L(eft) --> open
HP0 MIX DAC1 --> open
HPO MIX DAC 2 --> open
Alsamixer settings for speaker : 
Speaker --> open
Speaker channel --> open
Speaker L(eft) --> open
Speaker R(ight)--> open

J'espère qu'une version patchée (afs) arrivera bientôt pour que tout soit parfaitement opérationnel et stable, enfin ça dépend du point de vue ça ! wink

Dernière modification par Li@nel (Le 12/05/2016, à 11:28)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#19 Le 12/05/2016, à 13:59

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Salut Li@nel !

En effet, je n'avais pas vu que la 4.5.4 était sortie, bon je vais le récupérer sur https://cdn.kernel.org/pub/linux/kernel/v4.x/, faire un build, une install et tester (comme j'ai fait pour mon 4.5.3 actuel), si le son est fonctionnel, comme ça semble être le cas, on sera bon niveau stabilité !!

To be continued

Hors ligne

#20 Le 12/05/2016, à 14:05

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Tu le patches avec les patches de la communauté ?
Une fois ton kernel buildé, y aurait moyen que tu le fasses partager stp ? wink

J'ai quand même eu quelques freezes avec ce kernel ^^'
4 en une heure, ce qui est plus que la 4.4.9 pour moi là !


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#21 Le 12/05/2016, à 17:25

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Salut.

J'ai simplement suivi ce lien pour builder l'ensemble des kernels, je n'applique aucun patch en particulier post build : http://www.cyberciti.biz/faq/debian-ubu … ux-kernel/

C'est avec cette méthode que j'ai eu un 4.5.3 quasi stable.
Pas de soucis, je pourrai partager les .deb générés pour que tu testes (sauf si ça freeze aussi tous les 15 mn !).

Hors ligne

#22 Le 12/05/2016, à 17:29

flouub

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Mais il est vrai qu'il y a les fichiers de patch aussi dans la librairie, ça pourrait aller plus vite certainement smile

Hors ligne

#23 Le 12/05/2016, à 18:37

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Merci pour le lien wink
Je pense pas que j'aurai le courage de le suivre par contre ^^

As-tu déjà testé ton kernel patche ?
Si oui j'attends avec impatience les liens de téléchargements wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#24 Le 12/05/2016, à 21:23

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

@flouub : Serait-ce possible de te demander de tester les paramètres sonores que je t'ai conseillé afin de savoir si cela fonctionne correctement sur ta machine ?
Je tiens à préciser qu'au cours de ses tests, je te conseille de ne pas augmenter trop fort le volume de tes hauts parleurs, au risque de les abimer, voir de les rendre inutilisables !
Par le passé, certains membres avaient testés un mauvais fichier de configuration de Pulseaudio et ils se sont retrouvés avec des hauts parleurs pétés, mais ça fait quelques mois que ça n'est plus arrivé, je te rassure^^

Tiens moi au courant et dis moi ce que t'as changé pour que le son soit le plus audible possible ! wink


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#25 Le 13/05/2016, à 12:01

Li@nel

Re : [TUTORIEL] Installation d'Ubuntu sur l'ASUS T100

Voilà le lien pour installer une version plus récente du driver audio wink
Un tuto est disponible dans le dossier et vous permettra d'installer correctement les fichiers de configuration.

Néanmoins, comme ce pilote n'a pas encore été énormément testé, je vous conseille de rester sur vos gardes si vous tenez à vos hauts parleurs !

EDIT : Le son marche sur le kernel 4.5.2.afs avec ce fichier ! Ca génère un nouveau fichier asound.state qui permet d'avoir la bonne config pour utiliser le système audio !! On finit la semaine en beauté là wink

Dernière modification par Li@nel (Le 13/05/2016, à 12:16)


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne