Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 03/05/2016, à 16:39

M.DURIX

Impossible Installer le paquet giac (pour Xcas)

Bonjour
Je veux installer Xcas sous UBUNTU 16.04.
J'ai téléchargé le paquet et l'installateur me dit "Ce logiciel provient d'une tierce partie et est susceptible de contenir des éléments non libres"
J'ai fouillé et trouvé qu'il fallait installer gdebi, mais ça n'a pas résolu mon problème;
Merci d'avance à ceux qui pourront m'aider.
M. DURIX

Hors ligne

#2 Le 03/05/2016, à 20:07

jvallois

Re : Impossible Installer le paquet giac (pour Xcas)

J'ai également un problème pour l'installer, mais j'ai le message :

giac : Dépend: libgsl0ldbl (>= 1.9) mais il n'est pas installable

Comment faire ?

Merci d'avance.


Jacques VALLOIS
http://vallois.nom.fr
http://www.laprovidence02.fr
"Notre science est primitive et enfantine, mais c'est notre bien le plus précieux." (Albert Einstein)

Hors ligne

#3 Le 04/05/2016, à 10:11

gl38

Re : Impossible Installer le paquet giac (pour Xcas)

Le paquet libgsl0ldbl n'est plus dans la distribution d'ubuntu. En attendant que les auteurs résolvent le problème, tu peux essayer d'utiliser les librairies de la version précédente.
Le contenu du paquet était :

/usr/lib/x86_64-linux-gnu/libgsl.so.0
/usr/lib/x86_64-linux-gnu/libgsl.so.0.17.0
/usr/lib/x86_64-linux-gnu/libgslcblas.so.0
/usr/lib/x86_64-linux-gnu/libgslcblas.so.0.0.0
/usr/share/doc/libgsl0ldbl/AUTHORS
/usr/share/doc/libgsl0ldbl/BUGS.gz
/usr/share/doc/libgsl0ldbl/NEWS.gz
/usr/share/doc/libgsl0ldbl/README
/usr/share/doc/libgsl0ldbl/README.Debian
/usr/share/doc/libgsl0ldbl/THANKS.gz
/usr/share/doc/libgsl0ldbl/TODO.gz
/usr/share/doc/libgsl0ldbl/changelog.Debian.gz
/usr/share/doc/libgsl0ldbl/copyright
/usr/share/lintian/overrides/libgsl0ldbl

En copiant les .so dans la nouvelle arborescence et en forçant l’installation du paquet avec un peu de chance ça va marcher.
Pour le moment je ne peux pas essayer chez moi.
Cordialement,
Guy

Hors ligne

#4 Le 12/05/2016, à 14:09

nil-p-sud

Re : Impossible Installer le paquet giac (pour Xcas)

Une autre méthode, un peu crade, est d'ajouter le dépôt "trusty" à vos sources de paquets. Cela ne devrait pas poser de problème dans la mesure où les paquets proposés sont normalement plus anciens et donc de moindre priorité. Jouer avec les dépôts peut cependant être dangereux pour le système. Donc il vaut mieux avoir vraiment besoin d'Xcas, et tester sur un système qu'on peut casser.

Par exemple, ajouter cette ligne à /etc/apt/sources.list :

deb http://fr.archive.ubuntu.com/ubuntu/ trusty main amd64

(à adapter si par exemple vous êtes en 32 bits). Puis update et install, comme d'hab.

Dernière modification par nil-p-sud (Le 12/05/2016, à 14:12)

Hors ligne

#5 Le 13/05/2016, à 20:14

gl38

Re : Impossible Installer le paquet giac (pour Xcas)

Il suffit de télécharger et d'installer le paquet libgsl0ldbl pour wily ici : http://packages.ubuntu.com/wily/libgsl0ldbl
Puis de télécharger le paquet de xcas ici : http://www-fourier.ujf-grenoble.fr/~par … r#packages en choisissant le paquet Debian tout en un
et de l'installer avec gdebi.
Et voilà, ça marche sans toucher au fichier sources.list
Cordialement,
Guy

Hors ligne

#6 Le 07/08/2016, à 14:42

TheLiar

Re : Impossible Installer le paquet giac (pour Xcas)

La méthode indiquée sur le message précédent ne fonctionne pas chez moi.
En lançant Xcas dans un terminal, j'obtiens :

GSL error handler off
bug in PARI or calling program.
Erreur de segmentation

Impossile d'utiliser Xcas, mais Giac fonctionne lui.

Hors ligne

#7 Le 07/08/2016, à 15:47

gl38

Re : Impossible Installer le paquet giac (pour Xcas)

J'ai aussi le message "GSL error handler off" mais ça n'a pas l'air bien grave.
Le message d'erreur a l'air de concerner pari, est-ce que pari fonctionne ?
Cordialement,
Guy

Hors ligne

#8 Le 07/08/2016, à 22:26

TheLiar

Re : Impossible Installer le paquet giac (pour Xcas)

.Merci pour votre réponse
Je ne sais pas ce qu'est pari!

Hors ligne

#9 Le 08/08/2016, à 05:49

gl38

Re : Impossible Installer le paquet giac (pour Xcas)

Pour pari, voir iicii.
On le lance dans un terminal en tapant

gp

on peut demander

exp(1)

on sort avec

quit

Cordialement,
Guy

Hors ligne

#10 Le 13/08/2016, à 17:54

TheLiar

Re : Impossible Installer le paquet giac (pour Xcas)

J'ai  installé PARI et il fonctionne; xcas toujours pas!

Ce doit être un problème lié à l'affichage puisque GIAC fonctionne dans le terminal.

Dernière modification par TheLiar (Le 13/08/2016, à 17:54)

Hors ligne

#11 Le 13/08/2016, à 18:31

gl38

Re : Impossible Installer le paquet giac (pour Xcas)

Chez moi ça fonctionne avec Ubuntu-mate sur une installation neuve, donc je n'ai pas de traces d'installations précédentes.
Est-ce que tu as le même problème avec un utilisateur que tu créerais juste pour voir ?
Cordialement,
Guy

Hors ligne

#12 Le 18/08/2016, à 20:57

TheLiar

Re : Impossible Installer le paquet giac (pour Xcas)

J'ai finalement réussi à le faire fonctionner en suivant la méthode indiquée dans le lien suivant:

xcas et ubuntu 16.04



Je suis sur Gnome Ubuntu fraîchement installé (pas une mise à jour)

Merci pour tes réponses.

Hors ligne