Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 25/05/2016, à 08:26

Jeanmarc05

Accent circonflexe

Bonjour,
Je viens d'installer Mate 16.04 et en suis ma foi très satisfait hormis quelques petits bogues mineurs mais agaçants.
Je commence par l'accent circonflexe :
Habituellement je paramètre mon clavier pour « Français latin-9 » et ça va très bien.
Mais ici non, si le reste des caractères semble s'afficher normalement, il n'en est pas de m^eme (!) pour l'accent circonflexe et le tréma.
Bien entendu j'ai testé d'autres configurations de clavier français mais avec toujours ce résultat.
Y a-t-il une astuce pour cela ?
Merci

Hors ligne

#2 Le 25/05/2016, à 08:48

gl38

Re : Accent circonflexe

Avec le clavier Français (Variante), tout marche bien chez moi : ô ö œ æ...
Cordialement,
Guy

Hors ligne

#3 Le 25/05/2016, à 09:05

Li@nel

Re : Accent circonflexe

Salut

C'est un problème de locale m.
Rajoute LC_ALL="fr_FR.UTF-8" dans /etc/environnment et ça marche wink

Ou tu peux aussi essayer en tapant cette commande

sudo update-locale LANG=fr_FR.UTF-8

MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#4 Le 25/05/2016, à 09:52

Jeanmarc05

Re : Accent circonflexe

J'avais déjà essayé Français variante mais sans succès.
La commande indiquée n'est pas suivie d'effets.
La modification manuelle de /etc/environment fonctionne pour Pluma mais pas pour Firefox ni libre-office. O_o
Je redémarre l'ordi ça ne marche m^eme plus pour Pluma.
Je vérifie le fichier environment, la modification est toujours là !

Hors ligne

#5 Le 25/05/2016, à 09:56

Li@nel

Re : Accent circonflexe

Si tu ouvres un terminal et que tu tapes setxkbmap fr oss, ça donne quoi ?


MS 7641-760gm P23 (FX) ↱ AMD FX 8120 (3.1 GHz) ↱ RAM : 8 Go DDR3 ↱ AMD Radeon HD 3000 ↱SSD Samsung 840 EVO 500 Go ↱ Moniteurs Philips 196VLA en DVI & Philips 170 S4 en VGA ↬ Windows 7 Pro SP1 ↬ Ubuntu 16.04.1 LTS
ASUS T100TA 32Gb ↱ MicroSD SanDisk 16 Go Classe 10 ↱ RAM : 2Go ↱ Intel HD Graphics ↬ Ubuntu 16.04.1 LTS
iPhone SE 64GB ↱ iOS 10.2

Hors ligne

#6 Le 25/05/2016, à 10:02

Jeanmarc05

Re : Accent circonflexe

Rien !
Mais tiens, l'accent circonflexe est de retour sur pluma mais pas sur la console ni firefox.

Hors ligne

#7 Le 25/05/2016, à 11:10

erresse

Re : Accent circonflexe

Bonjour,

D'abord, dans le menu "Système -> Préférences -> Claviers", tu affiches l'onglet "Agencements" et tu choisis bien "Français Français (variante)". Dans la liste "Modèle de clavier", tu choisis "PC générique 105 touches (intl)".
Ensuite tu ouvres la liste "Options" et, dans la rubrique "Disposition du pavé numérique", tu coches "Obsolète".
Dans "Diverses options de compatibilité", tu coches "Touches du pavé numérique par défaut".
Enfin, dans "Séquence de touches pour tuer le serveur X", tu coches "Ctrl+Alt+Eff.arrière".

Chez moi, avec ces réglages, j'ai accès à toutes les combinaisons de touches, y compris les majuscules accentuées et les signes spéciaux, j'ai la reconnaissance automatique de la virgule ou du point avec la touche du pavé numérique selon les applications utilisées.

Pour la francisation de Firefox et de LibreOffice, vérifie si les paquets spéciaux de "locale" sont bien installés pour ces deux applications (contrairement au reste du système, la francisation de FF et LO nécessite l'installation de paquets spécifiques).

Voilà, après ça, normalement, tu ne devrais plus rencontrer de problème, sauf si tu disposes d'un matériel exotique bien sûr...


Plus de 50 ans d'informatique, ça en fait des lignes de commandes en console, mais on n'avait pas le choix...
Excellente raison pour, aujourd'hui qu'on le peut, utiliser au maximum les INTERFACES GRAPHIQUES !
Important : Une fois résolu, pensez à clore votre sujet en ajoutant [Résolu] devant le titre du 1er message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Hors ligne

#8 Le 25/05/2016, à 12:24

Jeanmarc05

Re : Accent circonflexe

Salut,
Ces réglages étaient déjà ainsi (sauf le pavé numérique) ; donc pas de changement.
Oui, les paquets locale-fr sont bien installés pour LO et FF.
Quant au clavier, c'est le m^eme depuis pas mal d'années et je n'avais aucun problème de caractères avec Ubuntu 16.04
Les autres caractères spéciaux sortent bien :
œ æ Æ Œ @ À Ç € ù
mais ^a ^u ¨u ¨e

Hors ligne

#9 Le 06/07/2016, à 10:45

Jeanmarc05

Re : Accent circonflexe

Bonjour,
Le problème n'est toujours pas résolu et s'épaissit.
Je récapitule :
Je suis apparemment la seule victime, donc ce n'est pas un bogue de Mate 16.04.
Le problème persiste si j'utilise le clavier virtuel, ce n'est donc pas un problème d^u au matériel.
Le problème n'apparait pas sous Ubuntu 16.04 (dual-boot mais m^eme répertoire home), ça ne viendrait donc pas de mes fichiers de configuration. Pourtant, si je crée un autre utilisateur, il n'a pas ce problème. :-/
C'est déjà pour le moins curieux mais le pire est à venir : si je lance Mate en live depuis le cédé d'installation le problème est encore là o_O !!!!
Serais-je maudit ?

Hors ligne

#10 Le 06/07/2016, à 10:54

gl38

Re : Accent circonflexe

Sous mate-ubuntu 16.04 installé, le clavier "Français Français (variante)" marche parfaitement chez moi.
Il me semble qu'avec le live-Cd, j'ai eu des difficultés à avoir un clavier complètement opérationnel.
Cordialement,
Guy

Hors ligne

#11 Le 06/07/2016, à 11:07

Jeanmarc05

Re : Accent circonflexe

Quand j'ai créé le nouvel utilisateur j'ai laissé tous les paramètres par défaut et tout va bien.
Comme dit plus haut, Ubuntu 16.04 avec mes propres paramètres (les m^emes que ceux utilisés pour Mate) ne me pose aucun souci.
Est-ce que ça n'arriverait qu'à l'utilisateur principal (ID 1000) ?
Cordialement,
Jean-Marc

Hors ligne

#12 Le 06/07/2016, à 11:34

gl38

Re : Accent circonflexe

Mon identité est 1000 et je n'ai pas de problème.
Cordialement,
Guy

Hors ligne

#13 Le 02/09/2016, à 01:13

Coeur Noir

Re : Accent circonflexe

Effacer le fichier ~/.xinputrc peut-être ?

Hors ligne

#14 Le 04/09/2016, à 12:34

Coeur Noir

Re : Accent circonflexe

Vérifier la méthode de saisie dans prise en charge des langues ( ibus ou autre )
Cette manip' ré-écrit le fichier .xinputrc
Attention : relancer la session voire redémarrer le pc pour appliquer

Si ibus actif, voir aussi :

ibus-setup

s'assurer que dans l'onglet avancé, est coché :
- utiliser la disposition clavier système

Hors ligne