Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 17/08/2016, à 16:46

krodelabestiole

Re : En finir avec Mint ?

donut a écrit :

Vos sources ce sont des blogueurs qui donnent leur avis, ils ont tout à fait le droit, mais ce ne sont pas des experts en sécurité.
Je dirais qu'au contraire l'amateurisme c'est penser que ton OS est sécurisé parce que tu fais un apt-get upgrade tous les jours.

les seules sources que j'ai citées sont le blog officiel de mint, mon experience propre, et Adrian Glaubitz qui est un développeur de debian, qui s'y connait mieux que moi en gestion des dépôts et trouve visiblement, et avec argumentaire, que le travail chez mint est de l'amateurisme.

en matière de sécurité il n'y rien de blanc ni de noir, mais un debian à jour est probablement largement plus safe qu'un mint qui a un peu tourné et a update ce qu'il a bien voulu par défaut.
ceci dit il serait idiot d'utiliser mint pour un serveur web, et tant que ça reste pour une station de travail, on s'en fout relativement de la sécurité (à moins peut-être d'être pétri de backdoors, de keyloggers ou d'être journaliste).

là où ça me pose un souci personnellement c'est au niveau de la fiabilité dans le temps des mises à jour. j'ai pas envie de perdre du temps à réparer un système cassé :

Secondly, they are mixing their own binary packages with binary packages from Debian and Ubuntu without rebuilding the latter. This creates something that we in Debian call a "FrankenDebian" which results in system updates becoming unpredictable [2]. With the result, that the Mint developers simply decided to blacklist certain packages from upgrades by default thus putting their users at risk because important security updates may not be installed.

là je t'avoue que je pige pas tout les tenants et aboutissants. j'imagine que ça correspond à ces updates invisibles par défaut, et il ne s'agit apparemment pas que de sécurité, mais aussi de stabilité et de fiabilité.

en gros j'ai besoin de faire confiance à une distro. c'est bien cet amateurisme dénoncé par Adrian Glaubitz (peut-être à tord, mais il reste à le démontrer), et que j'ai personnellement observé dans la gestion de leur site (absolument catastrophique) qui me fait douter et me détourner de mint.

Hors ligne

#27 Le 17/08/2016, à 17:02

PileOuFace

Re : En finir avec Mint ?

krodelabestiole a écrit :

là où ça me pose un souci personnellement c'est au niveau de la fiabilité dans le temps des mises à jour. j'ai pas envie de perdre du temps à réparer un système cassé :

Ça n'arrive pas souvent en pratique. Mon PC de bureau est toujours sur l'ancienne Mint 17.3 (Ubuntu 14.04) et un netbook sur LMDE, ce n'est jamais arrivé.
Oui je sais, j'ai mis plus haut que j'avais compris les problèmes de Mint, mais pour le moment j'ai la flemme de tout réinstaller. Ça sera pour plus tard.

freechelmi a écrit :
PileOuFace a écrit :

En revanche, je les trouve bien meilleurs qu'ubuntu en ce qui concerne les attentes de pas mal d'utilisateurs concernant l'ergonomie et l'environnement de travail, c'est d'ailleurs grâce à ça qu'ils ont percé et trouvé leur public.

L'idéal n'aurait il pas été de faire un Cinabuntu ? et donc se concentrer sur les paquets du bureau cinammon ?

Je me suis fait la même réflexion. Ils ont peut-être voulu tout prendre en main pour proposer un produit fini à leur idée, je ne sais pas.
En tout cas, on peut installer Mate ou Cinnamon sur Ubuntu et Debian, même si je suppose qu'il faut configurer un peu derrière pour obtenir la même chose.

Dernière modification par PileOuFace (Le 17/08/2016, à 17:03)

Hors ligne

#28 Le 17/08/2016, à 19:42

CM63

Re : En finir avec Mint ?

Bonjour,

CercleEuclidien a écrit :

Je viens de lancer Writer et j'ai vu du vrai noir sur blanc. Je ne me souviens pas d'avoir eu autre chose, même en 12.04. Tu es sûr que ça ne venait pas de ton matériel ? Les polices sont très bien chez moi.

De toute façon, Mint est presque identique à Ubuntu, ça devait pas être plus compliqué à corriger qu'installer un paquet et changer une option.

Peux-tu faire un méga zoom de façon à ce que les traits des caractères fassent plusieurs centaines de pixels, faire une copie d'écran et regarder dans un logiciel d'édition d'image si tu as bien 000 comme couleur? Merci de ton aide.


D'sous n'a mis, est-elle avare, frivole ou tellurique?

Hors ligne

#29 Le 18/08/2016, à 10:27

krodelabestiole

Re : En finir avec Mint ?

donut a écrit :

Même le forum de Steam s'est fait pirater.... et ce moment, le PSN.

et du coup est-ce que l'attaquant a pu glisser une backdoor dans les jeux steam ?
je prends même pas la peine de vérifier...

c'est un boulot différent de sécuriser un forum et de sécuriser une bête plate-forme de téléchargement (va attaquer un site statique).
mais forcément si tu mets phpbb, wordpress et les images de ta distro sur le même serveur, le tout en 777, tu t'exposes, et tu montres par le même coup que tu ne prends pas en compte le b.a.-ba de la sécurité informatique.
c'est extrêmement gênant de la part d'une structure qui propose un os, tu crois pas ?

Hors ligne

#30 Le 18/08/2016, à 11:02

Compte anonymisé

Re : En finir avec Mint ?

CM63 a écrit :

Peux-tu faire un méga zoom de façon à ce que les traits des caractères fassent plusieurs centaines de pixels, faire une copie d'écran et regarder dans un logiciel d'édition d'image si tu as bien 000 comme couleur? Merci de ton aide.

J'ai bien du 000. J'ai sélectionné le noir du "T" dans GIMP.
Edit : le lien n'était pas bon.

donut a écrit :

Vos sources ce sont des blogueurs qui donnent leur avis, ils ont tout à fait le droit, mais ce ne sont pas des experts en sécurité.
Je dirais qu'au contraire l'amateurisme c'est penser que ton OS est sécurisé parce que tu fais un apt-get upgrade tous les jours.

Le seul facteur plus important que l'utilisateur dans la sécurité, c'est d'avoir un système maintenu à jour pour échapper aux failles. Autant dire tout de suite que tu te moques de la sécurité sur ton PC, tu as le droit. Mais je trouve ça irresponsable de fournir une sécurité trouée à des utilisateurs, même s'ils ne feront qu'aller sur le Web et stocker des photos avec (ou payer par Internet ? Se connecter à leurs comptes en banque ?).

Quant à ces blogueurs, ils s'y connaissent largement assez pour donner un avis éclairé. Tu n'es pas un expert en sécurité non plus. On n'a pas besoin d'un expert en sécurité. Mint ne s'intéresse que peu à la sécurité, c'est évident.

maxire a écrit :

Si cela avait été le cas vous vous seriez aperçu que Mint utilise les dépôts de Canaonical et que donc tout ce qui est mise à jour est pris en compte.

Pas exactement vrai. Mint utilise des dépôts quasiment identiques, mais pour éviter de casser certaines choses, a blacklisté des mises à jour de sécurité. Ce qui donne des paquets troués. Tous les articles cités en parlent, justement. Au-delà des paquets affectés, ça montre que la sécurité n'est pas la priorité de l'équipe de Mint.

maxire a écrit :

Mint n'est pas un  fork de Ubuntu, c'est une distribution dérivée de Ubuntu avec quelques paquets spécifiques comme Cinnamon et des réglages spécifiques de Apt portant essentiellement sur les priorités de versions à appliquer pour certains paquets.

C'est justement ce qui me gêne (entre autres). Ces règles empêchent des patchs de sécurité d'arriver aux utilisateurs.

EDIT : OK, en relisant mes sources j'ai appris que le gestionnaire de mises à jour graphique (celui que tout le monde utilise donc) ne mettait pas à jour le kernel, et qu'il fallait passer par la ligne de commande pour ça. Là, c'est du foutage de gueule caractérisé.

maxire a écrit :

Je crois que les attaques contre Mint sont d'assez mauvaise foi bien qu'en partie justifiées (sujet secondaire comme mdm).

Je crois que cette phrase n'est pas logique. "De mauvaise foi" est le contraire de "justifiées".

donut a écrit :
krodelabestiole a écrit :
donut a écrit :

Est-ce que leur site était insuffisamment sécurisé ?

un site suffisamment sécurisé ne tombe pas, ou très partiellement.

Même le forum de Steam s'est fait pirater.... et ce moment, le PSN.

Sony n'est pas un modèle de sécurité. Je crois qu'ils ont annoncé après le premier hack du PSN qu'ils allaient engager un responsable de la sécurité. Ce qui implique qu'il n'y en avait pas avant.

"Y'a pire ailleurs", c'est l'excuse la plus idiote qu'on peut inventer. Quand on fournit un OS, on le fait correctement.

maxire a écrit :

À tous les critiques je voudrais rappeler que la qualité du noyau Linux est également fortement critiquée par les dévelopeurs de Unix Like comme BSD.
Il est vrai que la lecture des sources de Linux fait peur quant à la faible qualité, à la lisibilité du code (les développeurs système vivent réellement dans un autre monde que nous!).

Les devs de Linux savent ce qu'ils font. Ils peuvent prendre des décisions qui ne plaisent pas à BSD, mais Linux est utilisé et patché par des entreprises énormes ; on ne peut pas comparer le professionnalisme des devs Linux avec la petite équipe de Mint. Les failles de Linux sont corrigées rapidement, les patchs arrivent aux utilisateurs, les développeurs font attention à la qualité de leur code.

En parlant du code, justement, ce n'est pas parce que ttu as du mal à le lire qu'il est mal écrit. Si tu n'es pas un dev système avec beaucoup d'expérience (comme ceux qui ont écrit ce code justement), tu n'es pas qualifié pour critiquer. Moi non plus.

De mémoire, les attaques sur Linux portaient surtout sur des options de compilation et des mécanismes permettant de mitiger les failles, qui auraient (d'après Linux) un gros impact sur les performances. On est loin des quelques paquets à "dé-casser" que Mint voulait éviter, et c'est un choix qui se tient, d'autant plus que les utilisateurs du kernel (les distributions dans notre cas) peuvent toujours ajouter ces fonctionnalités à la compilation, et distribuer un noyau renforcé à leurs utilisateurs.

En ce moment, les ransomwares sont à la mode, les hacks sont de plus en plus nombreux, on trouve des malwares créés par des services de renseignement avec des équipes de centaines de personnes et des moyens illimités. Dans le contexte, une distribution qui évite des patchs parce que "c'est pas trop grave puis on veut pas bosser" et qui fournit un système d'exploitation qui se veut sérieux sur un site WordPress qu'ils ont la flemme de sécuriser, ça fait tache.

Dernière modification par Compte anonymisé (Le 18/08/2016, à 15:33)

#31 Le 18/08/2016, à 11:04

donut

Re : En finir avec Mint ?

krodelabestiole a écrit :
donut a écrit :

Même le forum de Steam s'est fait pirater.... et ce moment, le PSN.

et du coup est-ce que l'attaquant a pu glisser une backdoor dans les jeux steam ?
je prends même pas la peine de vérifier...

c'est un boulot différent de sécuriser un forum et de sécuriser une bête plate-forme de téléchargement (va attaquer un site statique).
mais forcément si tu mets phpbb, wordpress et les images de ta distro sur le même serveur, le tout en 777, tu t'exposes, et tu montres par le même coup que tu ne prends pas en compte le b.a.-ba de la sécurité informatique.
c'est extrêmement gênant de la part d'une structure qui propose un os, tu crois pas ?

Dans le cas de Steam a part les adresses e-mail et mots de passe (ce qui est déjà pas mal) en effet l'impact fut limité.
Mais il y a eu beaucoup de cas de piratages où ce sont des données bancaires qui sont dérobées, exemple le PSN chez Sony.

Je ne suis pas admin chez Mint, je ne peux donc pas te dire s'ils bossent avec du chmod777 ou pas (j'espère pas).
Mais je me doute qu'ils ont certainement moins de moyens qu'Amazon, Steam ou même Debian.

Dernière modification par donut (Le 18/08/2016, à 11:05)


https://utux.fr (blog perso)

Hors ligne

#32 Le 18/08/2016, à 11:29

PileOuFace

Re : En finir avec Mint ?

CercleEuclidien a écrit :

EDIT : OK, en relisant mes sources j'ai appris que le gestionnaire de mises à jour graphique (celui que tout le monde utilise donc) ne mettait pas à jour le kernel, et qu'il fallait passer par la ligne de commande pour ça. Là, c'est du foutage de gueule caractérisé.

Cette information me semble inexacte. Je viens de ressortir le netbook de voyages qui n'a pas été allumé depuis quelques semaines, pas mal de mises à jour proposées, y compris au niveau du kernel :

Par contre, ce qui est vrai, c'est que les mises à jour du Kernel sont dans la catégorie 5, donc désactivée par défaut :
1471512353.png

Il y a même une section dédiée au kernel : menu Vue => Noyaux Linux
1471512360.png

1471512364.png

Je viens aussi de tester la mise à jour en ligne de commande, il n'y a rien de plus. L'applet de mise à jour semble donc complète, la question porte plutôt sur les catégories, activées ou non par défaut.

Dernière modification par PileOuFace (Le 18/08/2016, à 12:03)

Hors ligne

#33 Le 18/08/2016, à 12:23

Rufus T. Firefly

Re : En finir avec Mint ?

PileOuFace a écrit :

Par contre, ce qui est vrai, c'est que les mises à jour du Kernel sont dans la catégorie 5, donc désactivée par défaut

Apparemment c'est du 3.13 qui pourrait passer à 3.19
Ça ressemble plutôt à ça : https://doc.ubuntu-fr.org/ltsenablementstack


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

En ligne

#34 Le 18/08/2016, à 12:35

PileOuFace

Re : En finir avec Mint ?

Rufus T. Firefly a écrit :
PileOuFace a écrit :

Par contre, ce qui est vrai, c'est que les mises à jour du Kernel sont dans la catégorie 5, donc désactivée par défaut

Apparemment c'est du 3.13 qui pourrait passer à 3.19
Ça ressemble plutôt à ça : https://doc.ubuntu-fr.org/ltsenablementstack

Alors justement, maintenant le Kernel est en 3.19 suite à cette mise à jour.
Je vois que les dépôts (qui sont ceux d'Ubuntu) offrent d'autres Kernels jusqu'en 4.4, mais ce n'est pas proposé automatiquement dans l'utilitaire de mise à jour ni apt-get upgrade.

Dernière modification par PileOuFace (Le 18/08/2016, à 12:48)

Hors ligne

#35 Le 18/08/2016, à 13:05

krodelabestiole

Re : En finir avec Mint ?

donut a écrit :

je ne peux donc pas te dire s'ils bossent avec du chmod777 ou pas (j'espère pas).

That said, there were already PHP backdoors on the forums and we think we had lax file permissions too.

c'est sur cette page : http://blog.linuxmint.com/?p=2994

Hors ligne

#36 Le 18/08/2016, à 14:03

Compte anonymisé

Re : En finir avec Mint ?

PileOuFace a écrit :
CercleEuclidien a écrit :

EDIT : OK, en relisant mes sources j'ai appris que le gestionnaire de mises à jour graphique (celui que tout le monde utilise donc) ne mettait pas à jour le kernel, et qu'il fallait passer par la ligne de commande pour ça. Là, c'est du foutage de gueule caractérisé.

Cette information me semble inexacte. Je viens de ressortir le netbook de voyages qui n'a pas été allumé depuis quelques semaines, pas mal de mises à jour proposées, y compris au niveau du kernel :

Par contre, ce qui est vrai, c'est que les mises à jour du Kernel sont dans la catégorie 5, donc désactivée par défaut :
http://pix.toile-libre.org/upload/thumb/1471512353.png

Il y a même une section dédiée au kernel : menu Vue => Noyaux Linux
http://pix.toile-libre.org/upload/thumb/1471512360.png

http://pix.toile-libre.org/upload/thumb/1471512364.png

Je viens aussi de tester la mise à jour en ligne de commande, il n'y a rien de plus. L'applet de mise à jour semble donc complète, la question porte plutôt sur les catégories, activées ou non par défaut.

D'accord. En re-relisant l'article de TechRepublic, c'est apt-get dist-upgrade qui met à jour le kernel.

On parle quand même d'un système qui s'adresse aux gens normaux, qui n'iront jamais activer les mises à jour facultatives. Ça reste à peu près le même problème : les mises à jour sont installables mais rien n'est fait par défaut. Je maintiens que c'est se moquer des utilisateurs, d'autant plus que la cible de Mint est la même qu'Ubuntu (les débutants). Une faille non patchée dans le kernel est catastrophique.

Si on continue de recommander Mint, il faudrait au moins informer à chaque fois que ça revient à abandonner la sécurité pour éviter la maintenance. Ça marche, mais ça finira par retomber sur la tête de quelqu'un (ça l'a déjà fait en fait).

Dernière modification par Compte anonymisé (Le 18/08/2016, à 14:04)

#37 Le 18/08/2016, à 14:25

PileOuFace

Re : En finir avec Mint ?

CercleEuclidien a écrit :

Si on continue de recommander Mint, il faudrait au moins informer à chaque fois que ça revient à abandonner la sécurité pour éviter la maintenance.

Concernant les catégories, ceux qui recommandent Mint peuvent peut-être préciser d'activer les 5 catégories des mises à jour dans l'applet, ça deviendra comme sur Ubuntu. Ça passe juste par : clique-droit sur l'icône des mises à jours => menu Préférences => onglet Niveau => cocher les 4 cases manquantes des niveau 4 et 5
Du coup, les maj de sécurité d'une version de kernel seront également incluses, comme indiqué dans mes copies d'écran ci-dessus.

Alors oui, il faut le faire, mais je ne trouve pas ça pire que la bidouille qu'il fallait mettre en oeuvre avec Ubuntu pour désactiver l'envoie à Amazon des résultats de recherche du Dash, bonjour la confidentialité. Il fallait aussi entrer dans un menu de préférences et décocher une option.

Après installation :
1471524378.jpg

Après modification :
1471524384.jpg

Voici la liste des dépôts "upstream" :

deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

Dernière modification par PileOuFace (Le 18/08/2016, à 14:55)

Hors ligne

#38 Le 18/08/2016, à 15:08

Rufus T. Firefly

Re : En finir avec Mint ?

Il y a un truc que je ne comprends pas très bien.
Chez Debian stable, le noyau est un 3.16 et il le restera jusqu'à la fin du support (2020). Mais il y a régulièrement des mises à jour (correction de bugs et sécurité).
Si j'en juge par ceci :
1471512360.png

c'est pareil : le 3.13, noyau de base de 14.04 et 14.04.1, est régulièrement mis à jour.
En revanche ça ne change pas de version du noyau... Ce que même la doc ubuntu recommande, même si ubuntu ne suit pas la recommandation, si par exemple on a installé 14.04.2 par mégarde...

Sur du matériel déjà reconnu le passage à une étape de version LTS ( HWE Hardware Enablement Stack) a peu d’intérêt (les dépôts restent les mêmes) et est même déconseillé pour des machines virtuelles.

Donc sur ce point ça me semble un mauvais procès fait à mint et de plus un mauvais conseil que d'activer les mises à jour du noyau (qui sont non pas des mises à jour, mais des changements de version).


Sur Toile Libre, choisir le lien « Insérer la miniature dans un forum : » 1469894479.png

Dernière modification par cqfd93 (Le 18/08/2016, à 20:26)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

En ligne

#39 Le 18/08/2016, à 15:17

PileOuFace

Re : En finir avec Mint ?

Rufus T. Firefly a écrit :

Donc sur ce point ça me semble un mauvais procès fait à mint et de plus un mauvais conseil que d'activer les mises à jour du noyau (qui sont non pas des mises à jour, mais des changements de version).

Du coup, il faudrait clarifier si on peut faire des mises à jour de sécurité du kernel mais sans changer de branche principale, sans activer le niveau 5 des maj dans Mint.

Dernière modification par PileOuFace (Le 18/08/2016, à 15:19)

Hors ligne

#40 Le 18/08/2016, à 15:24

Rufus T. Firefly

Re : En finir avec Mint ?

J'ai cité une de tes captures d'écran : tu vois bien qu'il y a plusieurs 3.13. Donc des mises à jour ont bien été faites.
Je suppose que les les "mises à jour" du noyau étaient inactivées puisque tu relèves que ça ne t'a pas proposé le 3.19.


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

En ligne

#41 Le 18/08/2016, à 15:30

Compte anonymisé

Re : En finir avec Mint ?

Les captures d'écran ne sont pas claires. Est-ce que des mises à jour du kernel sont bien faites quand ce "niveau 5" est désactivé ? Ce lien ne dit pas ça.

#42 Le 18/08/2016, à 15:36

Rufus T. Firefly

Re : En finir avec Mint ?

CercleEuclidien a écrit :

Les captures d'écran ne sont pas claires. Est-ce que des mises à jour du kernel sont bien faites quand ce "niveau 5" est désactivé ? Ce lien ne dit pas ça.

Mais il dit que ça ne lui propose pas la mise jour vers 3.19... Alors que ça passe une fois que ça a été activé. Ce qui suppose que c'était désactivé avant. Alors qu'il y a quand même eu des mises à jour de 3.13 !

Dernière modification par Rufus T. Firefly (Le 18/08/2016, à 15:39)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

En ligne

#43 Le 18/08/2016, à 15:36

PileOuFace

Re : En finir avec Mint ?

Rufus T. Firefly a écrit :

J'ai cité une de tes captures d'écran : tu vois bien qu'il y a plusieurs 3.13. Donc des mises à jour ont bien été faites.

Alors justement, je vois qu'elles sont "disponibles" mais je ne vois pas le marqueur "installé". Du coup, j'aimerais comprendre quel niveau correspond à quoi :
- mises à jour de sécurité pour une même branche de kernel
- passage à la branche supérieur, comme ici 3.13 -> 3.19, ça c'est bien la mise à jour de niveau 5

Dernière modification par PileOuFace (Le 18/08/2016, à 15:37)

Hors ligne

#44 Le 18/08/2016, à 15:44

Compte anonymisé

Re : En finir avec Mint ?

J'ai du mal à comprendre maintenant.

Je comprends déjà que le changement de branche (3.19) est désactivé par défaut. Aucun problème avec ça.

Maintenant, puisque tu as une Mint sous la main, peux-tu essayer d'installer les mises à jour (avec les paramètres par défaut, donc niveau 5 désactivé) et vérifier si les révisions du kernel (mises à jour sans changement de branche) sont faites ?

Si les révisions sont installées par défaut, aucun problème. Si elles ne le sont pas, l'applet de mises à jour est très malhonnête en nommant l'option les désactivant "Don't break my computer !". On sait parfaitement que c'est celle qui sera sélectionnée par les débutants. Les révisions de kernel ne cassent rien et sont indispensables pour la sécurité.

Plus généralement, un programme qui me propose un choix entre "Ne pas casser mon ordinateur" et "Rester en sécurité" me ferait fuir immédiatement.

#45 Le 18/08/2016, à 15:44

Rufus T. Firefly

Re : En finir avec Mint ?

PileOuFace a écrit :
Rufus T. Firefly a écrit :

J'ai cité une de tes captures d'écran : tu vois bien qu'il y a plusieurs 3.13. Donc des mises à jour ont bien été faites.

Alors justement, je vois qu'elles sont "disponibles" mais je ne vois pas le marqueur "installé".

Oui, je n'avais pas remarqué... Désolé.

(n'empêche que je suis bien content d'être sous Debian, où tous ces trucs sont réglés : j'ai un noyau 4.6 dans les dépôts stable backports, si vraiment le matériel n'était pas géré avec 3.16).

Dernière modification par Rufus T. Firefly (Le 18/08/2016, à 15:48)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

En ligne

#46 Le 18/08/2016, à 17:19

PileOuFace

Re : En finir avec Mint ?

CercleEuclidien a écrit :

Maintenant, puisque tu as une Mint sous la main, peux-tu essayer d'installer les mises à jour (avec les paramètres par défaut, donc niveau 5 désactivé) et vérifier si les révisions du kernel (mises à jour sans changement de branche) sont faites ?

C'est un peu trop tard pour le PC principal (car déjà à jour), mais je viens de retrouver mon second netbook équipé d'un vieux Mint 17 Mate, je peux donc tester avec celui-là.

=> Mises à jour par défaut : niveaux 1, 2 et 3
Kernel 3.13.24, la mise à jour par défaut conserve cette version. Le menu "noyau Linux" qui liste tous les kernels disponible conseille de passer en 3.19, on peut le faire à partir de là.

=> Mises à jour de niveau 4 : ça inclut des composants comme le grub...

=> Mises à jour niveau 5 :
Tout est listé et coché, on passe au 3.19

Bref, le menu "noyaux Linux" permet de changer de version à la carte et recommande actuellement le 3.19, mais la mise à jour niveaux 1, 2 et 3 ne change pas le kernel, tandis que le niveau 5 passe au 3.19. Les kernels 4.2 et 4.4 sont aussi disponibles, mais pas proposés dans la mise à jour en niveau 5.

Dernière modification par PileOuFace (Le 18/08/2016, à 17:29)

Hors ligne

#47 Le 18/08/2016, à 17:41

Compte anonymisé

Re : En finir avec Mint ?

Si le kernel ne change vraiment pas par défaut, je crois qu'on a trouvé LE point qui devrait interdire à n'importe qui de conseiller cette distro.

Une Ubuntu + Cinnamon/MATE donne la même chose. Conseillez ça à la place !

#48 Le 18/08/2016, à 17:54

PileOuFace

Re : En finir avec Mint ?

CercleEuclidien a écrit :

Si le kernel ne change vraiment pas par défaut, je crois qu'on a trouvé LE point qui devrait interdire à n'importe qui de conseiller cette distro.

Une Ubuntu + Cinnamon/MATE donne la même chose. Conseillez ça à la place !

Oui, ou alors on insiste bien pour activer les niveaux 4 et 5 après juste installation, on a alors les mêmes mises à jours que sous Ubuntu, fin de l'histoire.
Exactement comme sous Ubuntu récemment, on insistait bien pour désactiver l'envoie par défaut à Amazon des recherches du dash.

Hors ligne

#49 Le 18/08/2016, à 17:56

Compte anonymisé

Re : En finir avec Mint ?

Mouais, comme j'ai dit plus haut l'attitude générale de la distribution me gêne. D'autres mises à jour n'arrivent jamais aux utilisateurs quel que soit le niveau choisi. J'ose espérer par contre que le site a été bien renforcé, il ne devrait plus y avoir de problème de ce côté.

#50 Le 18/08/2016, à 18:11

PileOuFace

Re : En finir avec Mint ?

D'après le site LinuxMint, si on coche tout alors on a les mêmes mises à jours que la distrib de base. As-tu un exemple de maj qui n'arrive jamais?

Voici ma situation en ce moment :
- Mint est connecté directement aux dépôts d'Ubuntu
- j'ai tout mis à jour en avec l'applet en niveaux 4&5
- j'ai testé les maj avec apt-get upgrade : rien de plus
- pour la science, j'ai testé les maj avec apt-get dist-upgrade : rien de plus
- avec Synaptic : rien de plus

Donc ça voudrait dire que le blacklistage toucherait la base du système de package? Il serait intéressant d'avoir un exemple précis pour que je puisse me pencher dessus. je peux vérifier sur Mint 17 ou LMDE.

L'idéal serait peut-être d'installer la dernière Ubuntu 14.04.5 via Virtualbox ou une clé USB pour que je puisse comparer de près.

Dernière modification par PileOuFace (Le 18/08/2016, à 18:15)

Hors ligne