Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/10/2016, à 22:59

abelthorne

Impossible de lancer Steam sur Ubuntu 16.10

Bon, d'habitude c'est plutôt moi qui réponds à ce genre de problème mais là, je suis dépassé.

J'ai fait la mise à niveau vers Ubuntu (Mate) 16.10 cet après-midi et depuis, impossible de lancer Steam, je me retrouve avec les conflits de biblis habituels entre Mesa et la runtime (RadeonHD 7770 avec Mesa/RadeonSi) :

Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: radeonsi_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: radeonsi
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Le problème, c'est qu'en supprimant les biblis en question de la runtime comme je fais d'habitude, ça ne change rien. Une idée ?

EDIT : je peux au moins le lancer en préchargeant les biblis 32 bits comme ça :
env LD_PRELOAD='/usr/lib/i386-linux-gnu/libstdc++.so.6 /lib/i386-linux-gnu/libgcc_s.so.1 /usr/lib/i386-linux-gnu/libxcb.so.1 /lib/i386-linux-gnu/libgpg-error.so.0' steam
(Version plus propre :)

env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /$LIB/libgpg-error.so.0' steam

Mais il y a plusieurs problèmes qui en découlent :
1) Je suppose que ça va m'empêcher de lancer des jeux en 64 bits ? (J'ai essayé de mettre les deux versions des biblis dans le LD_PRELOAD mais ça n'a pas l'air de changer grand chose, je ne sais pas si c'est censé fonctionner, je connais mal.)
2) J'ai des tas de messages d'erreur signalant une mauvaise archi pour les biblis (wrong ELF class).
3) J'ai une fenêtre xterm qui s'ouvre à chaque démarrage pour tenter d'installer les biblis graphiques 32 bits au niveau système alors qu'elles le sont déjà, ce qui semble confirmer qu'il est paumé dans les versions des biblis.

Je continue à chercher une solution propre et viable...

EDIT 2 : avec le bon LD_PRELOAD, le point 2 est réglé, plus des tonnes de messages à propos de la mauvaise archi. J'ai pu éliminer le point 1 aussi : j'ai testé The Talos Principle en 64 bit et il fonctionne sans problème.
Reste le point 3.

Dernière modification par abelthorne (Le 14/10/2016, à 17:03)

Hors ligne

#2 Le 14/10/2016, à 09:26

Blakesnake

Re : Impossible de lancer Steam sur Ubuntu 16.10

Bonjour,

as-tu réinstallé tes drivers graphiques proprement par le gestionnaire de pilotes propriétaires ?

Perso je suis passé à la 16.10 Mate il y a quelques jours, je n'ai pas eu de soucis avec Steam, par contre j'ai fait une réinstall complète et j'utilise une CG nVidia.

A+


Blakesnake, le laborantin fou

Hors ligne

#3 Le 14/10/2016, à 10:30

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Alors justement, tu n'es pas concerné par le problème, il ne touche que les gens qui utilisent Mesa (GPUs AMD & Intel). C'est un problème bien spécifique qui traîne depuis un bout de temps et qui se comporte différemment sur la 16.10. En gros, Steam inclut un paquet de biblis (la runtime) qui permet aux développeurs d'avoir une base pour leurs jeux. Problème : les biblis de la runtime en question sont en conflit avec celles du pilote graphique libre (Mesa) alors qu'il n'y a aucun souci avec le pilote proprio (donc les gens avec une CG nVidia ne sont pas concernés − idem avec Catalyst pour AMD à l'époque où il existait encore). Jusqu'à Ubuntu 16.04, il y avait une solution très simple : on supprime les biblis concernées de la runtime pour forcer Steam à utiliser celles du système et tout va pour le mieux. Sauf que depuis Ubuntu 16.10, cette solution ne fonctionne plus, d'où mon embarras et l'ouverture de ce sujet.

J'ai un peu avancé, j'ai une variable LD_PRELOAD un peu plus propre qui permet de lancer Steam et les jeux (mais je n'ai pas encore testé certains cas un peu particuliers qui me posaient problème il y a quelques mois avec cette méthode) :

env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /$LIB/libgpg-error.so.0' steam

Mais j'ai toujours la fenêtre xterm qui s'ouvre pour essayer d'installer les paquets déjà installés, donc je suppose qu'il y a encore un couac quelque part.

Dernière modification par abelthorne (Le 14/10/2016, à 13:28)

Hors ligne

#4 Le 14/10/2016, à 17:13

sergei_ruskof

Re : Impossible de lancer Steam sur Ubuntu 16.10

Bonjour,

Tu devrais essayer de le désinstaller puis de le réinstaller, ou bien faire un steam --reset

Hors ligne

#5 Le 14/10/2016, à 17:38

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Oh, c'est déjà fait, j'ai testé pas mal de choses. On est vraiment sur un cas particulier lié à Ubuntu 16.10. Pour ce qui est de la fenêtre xterm qui veut m'installer des paquets, c'est possible que ça vienne du fait que je sois passé par le paquet de Valve plutôt que la version des dépôts. Je dis ça parce que ça me fait penser à un problème très vaguement similaire d'il y a quelques mois qui touchait une version et pas l'autre. Je vais faire un essai en ce sens.

Hors ligne

#6 Le 14/10/2016, à 18:53

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Bon, problème potentiellement réglé : j'ai viré le Steam du paquet de Valve, j'ai installé la version des dépôts Ubuntu à la place et tout semble fonctionner comme par magie, sans bidouille d'aucune sorte. Je ne pige absolument pas pourquoi. Quelqu'un a une idée de ce qui diffère exactement entre les deux versions ? Mon hypothèse est que la version des dépôts bypasse complètement la runtime mais ça me semble curieux.

J'ai encore quelques tests à faire sur des jeux spécifiques avant de passer en résolu mais pour l'instant, ça a l'air bien parti.

Dernière modification par abelthorne (Le 14/10/2016, à 19:44)

Hors ligne

#7 Le 14/10/2016, à 22:00

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai testé Faeria, qui plante... mais qui fonctionne si je lance Steam avec LD_PRELOAD. Non mais quel foutoir.

Hors ligne

#8 Le 14/10/2016, à 23:39

Gatsu

Re : Impossible de lancer Steam sur Ubuntu 16.10

Salut abelthorne

J'ai suivi un peu tes déboires ici et sur reddit. Ça m'a l'air d'être un beau bordel. big_smile

Pour Faeria, va dans le dossier et lance un ldd histoire de voir s'il n'y a pas une bibliothèque qui manque dans ton système.

ldd Faeria.x86_64

J'ai regardé dans le script de démarrage de Steam pour la version sur Ubuntu 16.10, et il n'y a guère que 3 passages qui résolvent des bugs. Et je pense que tu les connais tous. Ensuite il ne fait que lancer le script de démarrage habituel de Steam.

# use C locale (bug #764311)
export LANG=C

# remove steam-runtime's libstdc++ files, which are incompatible with
# newer mesa drivers (https://bugs.freedesktop.org/78242)
find $runtime -name libstdc++.so\* -delete

# remove steam-runtime's libgpg-error files for the same reason
find $runtime -name libgpg-error.so\* -delete

Bref il n'y a pas beaucoup de magie là-dedans.

Dernière modification par Gatsu (Le 14/10/2016, à 23:40)

Hors ligne

#9 Le 15/10/2016, à 00:00

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Pour Faeria, voilà ce que ça donne mais je ne sais pas vraiment interpréter le résultat :

linux-vdso.so.1 =>  (0x00007ffd465c7000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd1f48a4000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd1f4686000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fd1f447e000)
libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007fd1f420a000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fd1f3ed1000)
libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007fd1f3cc5000)
libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007fd1f3aba000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd1f3732000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd1f3429000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd1f3212000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd1f2e4b000)
/lib64/ld-linux-x86-64.so.2 (0x0000557ab7af8000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fd1f2c1f000)
libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007fd1f2a1c000)
libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007fd1f2819000)
libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007fd1f2612000)
libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007fd1f240f000)
libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007fd1f21e0000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fd1f1fcc000)
libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007fd1f1dc9000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fd1f1bc3000)
libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007fd1f19c1000)
libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007fd1f17a8000)
libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007fd1f15a3000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fd1f137f000)
libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007fd1f1179000)
libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007fd1f0f6a000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007fd1f0d60000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fd1f0b5c000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fd1f0954000)

Pour le script de démarrage, c'est intéressant, je ne pensais pas qu'il était différent de celui de la version officielle. Donc il vire des bouts de la runtime à la volée... Par contre, il ne touche pas à libgcc ni libxcb. Je me demande si ça a un rapport avec le plantage de Faeria et/ou si ça peut impacter certains jeux, sachant que certains ont des problèmes si on fait un LD_PRELOAD juste sur libstdc++.

EDIT : tiens, si je lance Faeria directement depuis son dossier, sans Steam, il m'affiche l'écran de chargement qui va jusqu'à 90 % environ, puis va un peu plus loin : il arrive sur le menu principal et me dit "connexion Steam requise" avant de planter avec un core dump. Donc je me demande si avec Steam il bloque effectivement sur l'écran de connexion ou si c'est au moment du passage au menu principal que ça déconne (je me fiais à l'état de la jauge).

Dernière modification par abelthorne (Le 15/10/2016, à 00:10)

Hors ligne

#10 Le 15/10/2016, à 11:01

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Bon, j'ai modifié le script de démarrage de Steam pour qu'il supprime les deux autres biblis habituelles à chaque démarrage. Ça règle le problème de Faeria et probablement les autres problèmes potentiels.
À rajouter avant la dernière ligne :

find $runtime -name libgcc_s.so\* -delete
find $runtime -name libxcb.so\* -delete

Hors ligne

#11 Le 15/10/2016, à 11:55

Gatsu

Re : Impossible de lancer Steam sur Ubuntu 16.10

Ton ldd m'a l'air parfait. S'il y avait eu un problème, tu l'aurais tout de suite remarqué. Il indique "not found" en face de la bibliothèque manquante (voir ici pour un exemple). Accessoirement tu peux voir également l'emplacement des bibliothèques utilisées.

Les 2 scripts de démarrage des dépôts Ubuntu et de Steam sont complètement différents. Celui de Steam est beaucoup trop compliqué pour moi, je ne sais pas trop ce qu'il fait (bootstrap et tout le tralala). J'avais eu une discussion à ce sujet avec GrumD il y a quelques semaines.

Pour ma part je conseille le paquet des dépôts contrairement à ce qui est indiqué dans la doc ubuntu, car plus adapté à l'environnement spécifique d'Ubuntu. D'autre part Valve ne devrait pas se soucier de fournir un paquet .deb, ils ne sont pas capables de gérer tous les problèmes internes à chaque distribution. Et vu les problèmes que tu as rencontré, ça me conforte dans ce choix.

Concernant Faeria, si tu te sens le courage, tu peux faire un rapport de bug.
http://packages.ubuntu.com/yakkety/steam

Hors ligne

#12 Le 15/10/2016, à 12:08

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Gatsu a écrit :

Ton ldd m'a l'air parfait. S'il y avait eu un problème, tu l'aurais tout de suite remarqué. Il indique "not found" en face de la bibliothèque manquante (voir ici pour un exemple). Accessoirement tu peux voir également l'emplacement des bibliothèques utilisées.

J'avais un doute sur la première ligne vu qu'il n'y a rien en face de linux-vdso.so.1, je me disais qu'il manquait peut-être quelque chose. Mais comme je n'ai aucune idée de ce que c'est...

Pour ma part je conseille le paquet des dépôts contrairement à ce qui est indiqué dans la doc ubuntu, car plus adapté à l'environnement spécifique d'Ubuntu. D'autre part Valve ne devrait pas se soucier de fournir un paquet .deb, ils ne sont pas capables de gérer tous les problèmes internes à chaque distribution. Et vu les problèmes que tu as rencontré, ça me conforte dans ce choix.

J'ai toujours cru que le paquet de Valve était préférable parce que j'avais l'impression que celui d'Ubuntu correspondait à une vieille version de Steam (à cause du stockage des données dans .steam au lieu de .local/share/Steam) et que Valve était sans doute mieux placé pour savoir packager son propre logiciel.

Concernant Faeria, si tu te sens le courage, tu peux faire un rapport de bug.
http://packages.ubuntu.com/yakkety/steam

Ah, merci, je cherchais justement où signaler le problème, je ne savais pas si c'était du côté de Valve ou d'Ubuntu qu'il fallait le faire.

Hors ligne

#13 Le 15/10/2016, à 13:07

Gatsu

Re : Impossible de lancer Steam sur Ubuntu 16.10

Pour le ldd, tu peux voir qu'il y a des bibliothèques sans emplacement, et des emplacements sans bibliothèque. big_smile
Je t'avouerais que je ne sais pas trop à quoi ça correspond (ld-linux-x86-64.so.2 concerne probablement ldd lui-même), mais les seuls problèmes que j'ai rencontrés jusqu'à maintenant, étaient tous liés à des bibliothèques qualifiées de "not found".

Concernant le paquet .deb de Valve, je les vois mal corriger l'ensemble des problèmes pour chaque distribution et chaque version de distribution. Rien qu'Ubuntu en a 4 en cours, 12.04, 14.04, 16.04, 16.10, chacune ayant potentiellement ses problèmes spécifiques et ses solutions créant des problèmes pour d'autres versions. Et c'est sans compter les autres distributions qui utilisent les paquets deb.

Pour ma part, je pense que Valve devrait se contenter de livrer un .tar.gz avec leur installateur (le fameux binaire "/usr/games/steam.real" dans le deb des dépôts 16.04, et "/lib/games/steam/steam" dans ceux de la 16.10) accompagné d'une documentation sur son utilisation. Charge ensuite pour les mainteneurs des distribs, d'empaqueter le logiciel, de faire un suivi des bugs et de dialoguer avec Valve sur les possibles améliorations.
Ça me fait penser à un journal sur linuxfr.org qui est passé la semaine dernière : Comment distribuer un logiciel pour GNU/Linux ?

Il y a aussi le problème de la steam-runtime. Là on en est à 4 ans de dette technologique (ubuntu12_32) et toujours coincé sur un architecture 32 bits pour Steam lui-même. Mais là Valve à créer un problème bien trop complexe dont la transition va être très difficile à négocier.

Pour le rapport de bug, comme tu ne peux tester et confirmer son existence que sur Ubuntu, je pense que c'est la meilleure façon de le remonter pour toi. Ensuite je pense que les mainteneurs des autres distribs sont également inscrits sur cette liste de discussion, donc ça devrait pouvoir essaimer un peu partout. Apparemment les mainteneurs Ubuntu et Debian sont la même personne.

Hors ligne

#14 Le 15/10/2016, à 13:11

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai fait un rapport de bug sur Launchpad, on verra bien ce que ça donne. J'avais aussi posé la question sur GitHub mais comme c'est le week-end, il y a moins d'activité ; je verrai s'il faut le faire aussi ailleurs.

Hors ligne

#15 Le 16/10/2016, à 21:59

bug-in

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai le même problème depuis mon passage en 16.10. mon message d'erreur est légèrement différent :

steam
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1474415843)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

j'ai aussi tenté ta commande que tu indique plus haut. Steam a réussi a se lancer, mais je sais pas dans quelle mesure ça fonctionnerai.

 env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /$LIB/libgpg-error.so.0' steam
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
Installing breakpad exception handler for appid(steam)/version(1474415843)
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-10-16 21:59:54] Startup - updater built Mar 29 2016 17:40:06
[2016-10-16 21:59:54] uninstalled manifest found in /home/bugin/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2016-10-16 21:59:54] Found pending update
[2016-10-16 21:59:54] Applying update...
[2016-10-16 21:59:55] Extracting package...
[2016-10-16 22:00:16] Installing update...
[2016-10-16 22:00:16] Cleaning up...
[2016-10-16 22:00:17] Update complete, launching...
[2016-10-16 22:00:17] Shutdown
Restarting Steam by request...
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME has been set by the user to: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime
Error: You are missing the following 32-bit libraries, and Steam may not run:
libv8.so
libXtst.so.6
libavcodec.so.56
libavformat.so.56
libavresample.so.2
libavutil.so.54
libswscale.so.3
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-10-16 22:00:32] Startup - updater built Oct 13 2016 00:47:16
[2016-10-16 22:00:32] Verifying installation...
[2016-10-16 22:00:32] Unable to read and verify install manifest /home/bugin/.local/share/Steam/package/steam_client_ubuntu12.installed
[2016-10-16 22:00:32] Verification complete
[2016-10-16 22:00:32] Downloading Update...
[2016-10-16 22:00:32] Checking for available update...
[2016-10-16 22:00:34] Download Complete.
[2016-10-16 22:00:34] uninstalled manifest found in /home/bugin/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2016-10-16 22:00:34] Extracting package...
[2016-10-16 22:00:54] Installing update...
[2016-10-16 22:00:55] Cleaning up...
[2016-10-16 22:00:55] Update complete, launching...
[2016-10-16 22:00:55] Shutdown
Restarting Steam by request...
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME has been set by the user to: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
/bin/bash: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
Gtk-Message: Failed to load module "unity-gtk-module"
Installing breakpad exception handler for appid(steam)/version(1476379980)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 72: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 72: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 80: saw unknown, expected number
[1016/220118:ERROR:main_delegate.cc(779)] Could not load cef_extensions.pak
[1016/220118:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
Installing breakpad exception handler for appid(steamwebhelper)/version(20161013004706)
Installing breakpad exception handler for appid(steamwebhelper)/version(1476319626)
[1016/220118:ERROR:main_delegate.cc(779)] Could not load cef_extensions.pak
Installing breakpad exception handler for appid(steamwebhelper)/version(20161013004706)
Installing breakpad exception handler for appid(steamwebhelper)/version(1476379980)
Installing breakpad exception handler for appid(steamwebhelper)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Created shared memory when not owner SteamController_Shared_mem
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 72: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 72: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 80: saw unknown, expected number
Generating new string page texture 12: 48x256, total string texture memory is 49,15 KB
Generating new string page texture 13: 256x256, total string texture memory is 311,30 KB
Generating new string page texture 14: 128x256, total string texture memory is 442,37 KB
Generating new string page texture 20: 64x256, total string texture memory is 507,90 KB
Generating new string page texture 21: 8x256, total string texture memory is 516,10 KB
Generating new string page texture 22: 16x256, total string texture memory is 532,48 KB
Generating new string page texture 23: 24x256, total string texture memory is 557,06 KB
Generating new string page texture 24: 32x256, total string texture memory is 589,82 KB
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
roaming config store loaded successfully - 1081 bytes.
migrating temporary roaming config store
Installing breakpad exception handler for appid(steam)/version(1476379980)
Failed to init SteamVR because it isn't installed
ExecCommandLine: ""/home/bugin/.local/share/Steam/ubuntu12_32/steam" "
Installing breakpad exception handler for appid(steam)/version(1476379980)
System startup time: 79,27 seconds
Generating new string page texture 95: 1024x256, total string texture memory is 1,64 MB
Generating new string page texture 96: 128x256, total string texture memory is 131,07 KB
Generating new string page texture 101: 128x256, total string texture memory is 1,77 MB
Generating new string page texture 102: 256x256, total string texture memory is 2,03 MB
Generating new string page texture 103: 128x256, total string texture memory is 2,16 MB
Installing breakpad exception handler for appid(steam)/version(1476379980)
bash: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by bash)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
dpkg: symbol lookup error: dpkg: undefined symbol: setexecfilecon
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Traceback (most recent call last):
  File "/usr/bin/gnome-terminal", line 9, in <module>
    from gi.repository import GLib, Gio
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: /usr/lib/x86_64-linux-gnu/libgirepository-1.0.so.1: undefined symbol: g_type_class_adjust_private_offset
Package curl needs to be installed
Package python-apt needs to be installed
Package xterm needs to be installed
Package xz-utils needs to be installed
Package zenity needs to be installed
Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Package libc6:i386 needs to be installed
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME has been set by the user to: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime
/bin/bash: /home/bugin/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
grep: symbol lookup error: grep: undefined symbol: pcre_jit_stack_alloc
/usr/bin/ldd: ligne 119 : printf: erreur d'écriture : Relais brisé (pipe)
ExecCommandLine: "/home/bugin/.local/share/Steam/ubuntu12_32/steam steam://open/driverhelperready"
ExecSteamURL: "steam://open/driverhelperready"
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)
Generating new string page texture 597: 256x256, total string texture memory is 2,42 MB
Installing breakpad exception handler for appid(steam)/version(1476379980)
Installing breakpad exception handler for appid(steam)/version(1476379980)

Dernière modification par bug-in (Le 16/10/2016, à 22:06)

Hors ligne

#16 Le 16/10/2016, à 22:05

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Steam installé depuis le paquet de Valve ou les dépôts Ubuntu ?

Hors ligne

#17 Le 16/10/2016, à 22:07

bug-in

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai modifié mon message et ajouter des infos.
C'est une bonne question. Il me semble qu'a une époque c'était le paquet valve puis ensuite j'avais essayé ubuntu. Je t'avoue ne plus trop savoir ou j'en suis.

Hors ligne

#18 Le 16/10/2016, à 22:09

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Si tu as un doute, donne le retour de apt-cache policy steam* mais je pense que c'est la version Valve.

Hors ligne

#19 Le 16/10/2016, à 22:16

bug-in

Re : Impossible de lancer Steam sur Ubuntu 16.10

En tout cas en faisant ta commande, j'ai réussi à le lancer et j'ai testé en lançant la vision d'une partie DOTA, a part que tout est en anglais (ce qui n'étais pas originellement le cas) ça a l'air ok.

J'ai ça :

apt-cache policy steam*
steam-launcher:
  Installé : 1.0.0.52
  Candidat : 1.0.0.52
 Table de version :
 *** 1.0.0.52 100
        100 /var/lib/dpkg/status
steamcmd:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
steam:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
steam-devices:
  Installé : (aucun)
  Candidat : 1:1.0.0.52-5ubuntu1
 Table de version :
     1:1.0.0.52-5ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu yakkety/multiverse amd64 Packages
        500 http://fr.archive.ubuntu.com/ubuntu yakkety/multiverse i386 Packages
steam64:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :

par contre sans ta commande, ça ne marche toujours pas.

Dernière modification par bug-in (Le 16/10/2016, à 22:27)

Hors ligne

#20 Le 16/10/2016, à 22:30

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Ouais, c'est bien la version de Valve. Avec la commande LD_PRELOAD, ça devrait fonctionner mais ça peut déconner avec certains jeux. Tu peux aussi virer les biblis de la runtime mais il faut le refaire à chaque mise à jour de Steam. Troisième possibilité : passer à la version des dépôts Ubuntu et modifier le script comme je l'ai fait, c'est probablement la solution la plus pérenne. Si ça t'intéresse :
1) déplace les dossiers steamapps et userdata qui sont dans ~/.local/share/Steam sur le bureau (pour les garder et t'éviter de devoir réinstaller tes jeux)
2) désinstalle le paquet : sudo apt-get remove --purge steam-launcher
3) supprime le dépôt s'il ne l'a pas fait : sudo rm /etc/apt/sources.list.d/steam.list
4) recharge les sources : sudo apt-get update
5) supprime le dossier "Steam" qui est dans ~/.local/share ainsi que le dossier ".steam" qui est dans ton dossier perso
6) installe Steam depuis les dépôts : sudo apt-get install steam
7) lance-le, connecte-toi et quitte-le
8) va dans ~/.steam/steam (~/.steam sera le nouveau dossier pour Steam, plus de ~/.local/share/Steam), supprime les dossiers steamapps et userdata qui sont dedans puis mets ceux que tu avais gardé sur le bureau à la place
9) modifie le script de lancement (sudo gedit /usr/games/steam) pour rajouter les deux lignes suivantes avant la commande test de la dernière ligne :

find $runtime -name libgcc_s.so\* -delete
find $runtime -name libxcb.so\* -delete

Le script complet devrait alors ressembler à ça :

#!/bin/sh -e
# Copyright (C) 2013-2016 Michael Gilbert <mgilbert@debian.org>
# License: MIT

config=$HOME/.steam
ubuntu32=$config/ubuntu12_32
steam=$ubuntu32/steam
runtime=$ubuntu32/steam-runtime

real=/usr/lib/games/steam/steam

# use C locale (bug #764311)
test -n "$LANG" || export LANG=C

# do an initial update when expected pieces are missing
test ! -d $config && rm -rf $config && mkdir -p $config || true
test ! -x $config/steam.sh && rm -rf $config/package $steam || true
test ! -d $ubuntu32 && rm -rf $ubuntu32 && mkdir -p $ubuntu32 || true
test ! -x $steam && rm -rf $steam && cp $real $steam && $steam || true
test ! -e $runtime.tar.xz && cat $runtime.tar.xz.part* > $runtime.tar.xz || true
test ! -d $runtime && cd $ubuntu32 && tar xf steam-runtime.tar.xz && \
    md5sum steam-runtime.tar.xz > steam-runtime/checksum || true

# remove steam-runtime's libstdc++ files, which are incompatible with
# newer mesa drivers (https://bugs.freedesktop.org/78242)
find $runtime -name libstdc++.so\* -delete

# remove steam-runtime's libgpg-error files for the same reason
find $runtime -name libgpg-error.so\* -delete

# remove other steam-runtime's files
find $runtime -name libgcc_s.so\* -delete
find $runtime -name libxcb.so\* -delete

# launch the Valve run script
test -x $config/steam.sh && $config/steam.sh "$@" 2>$config/error.log

Une fois que tout ça est fait, tu peux lancer Steam normalement, le problème devrait être définitivement réglé.

Pour ce qui est de Dota 2 en anglais, va faire un tour dans ses propriétés, il devrait y avoir le choix de la langue dans un onglet. Si le français est déjà sélectionné mais que le jeu est en anglais, essaie de faire une vérification du cahe du jeu.

Hors ligne

#21 Le 17/10/2016, à 20:15

DjDeViL

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai une AMD HD 7950 et j'ai le même pépin sous la 16.10 j'ai chipoté en faisant rm par ci par là une fois installation via le site de valve avec un . deb

et une autre via

sudo apt-get install steam

Donc voilà, ne trouvant pas de solution, j'aimerais supprimer tout ce qui concerne steam

Quelle cmd faut-il faire (Ubuntu Gnome 64bits)  ?

J'espère que tu trouveras une solution big_smile

Hors ligne

#22 Le 17/10/2016, à 20:23

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Tu peux suivre ce que j'ai écrit juste au-dessus. Si tu as installé les deux Steam (le paquet Valve + la version des dépôts) en même temps, il faudra peut-être forcer la réinstallation du paquet Ubuntu au point 6 :

sudo apt-get install --reinstall steam

Dernière modification par abelthorne (Le 17/10/2016, à 23:22)

Hors ligne

#23 Le 17/10/2016, à 23:07

DjDeViL

Re : Impossible de lancer Steam sur Ubuntu 16.10

J'ai réussi à installer steam mais je ne sais pas comment exactement:

J'ai fait les points suivant:

2) désinstalle le paquet : sudo apt-get remove --purge steam-launcher
3) supprime le dépôt s'il ne l'a pas fait : sudo rm /etc/apt/sources.list.d/steam.list
4) recharge les sources : sudo apt-get update
5) supprime le dossier "Steam" qui est dans ~/.local/share ainsi que le dossier ".steam" qui est dans ton dossier perso

puis j'ai lancé steam via le terminal

Il a retéléchargé les paquets et il s'est lancé, une fois la connexion établi, j'ai pu le mettre en français.

Cependant, je ne peux que le lancer via le terminal mais plus via le launcher sad

Hors ligne

#24 Le 17/10/2016, à 23:20

abelthorne

Re : Impossible de lancer Steam sur Ubuntu 16.10

Suis tous les points, c'est important. Notamment parce que la version de Valve et la version des dépôts n'utilisent pas les mêmes dossiers pour stocker les données. Et que si j'ai dit de forcer la réinstallation du paquet, c'est justement pour réinstaller le lanceur qui ne doit plus correspondre à rien.

Là, je ne sais pas trop où tu en es, je te propose de recommencer proprement :
- déplace tes dossiers steamapps et userdata sur le bureau (ça sert uniquement à garder les jeux installés, si tu es sur une installation neuve sans jeux, c'est inutile)
- vire tout façon Attila :

sudo apt-get remove --purge steam-launcher steam
sudo rm /etc/apt/sources.list.d/steam.list
sudo rm /usr/share/applications/steam.desktop
rm ~/.local/share/applications/steam.desktop

C'est possible/probable que certaines commandes ne donnent rien (comme celle qui efface steam.desktop dans ~/.local/share/applications), j'ai juste essayé de couvrir tous les cas de figure.
- recharge les sources :

sudo apt-get update

- supprime le dossier Steam dans ~/.local/share et le dossier .steam dans ton dossier perso
- réinstall Steam :

sudo apt-get install --reinstall steam

À partir de là tu peux suivre les points 7, 8 et 9 d'au-dessus.

Dernière modification par abelthorne (Le 17/10/2016, à 23:21)

Hors ligne

#25 Le 18/10/2016, à 11:03

DjDeViL

Re : Impossible de lancer Steam sur Ubuntu 16.10

Merci abelthorne cela fonctionne smile

Hors ligne