Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/12/2016, à 20:50

Eric Bl

[Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Bonjour,

J'ai beau explorer les pages sur le verrouillage majuscule au démarrage de kubuntu, aucune solution ne semble marcher.
J'ai bien numlockxx. J'ai essayé de passer par la configuration du clavier. Ni "activé", ni "laisser en l'état" ne fonctionne.
J'ai mis dans le fichier /usr/share/lightdm/lightdm.conf.d/40-kde-plasma-kf5.conf une ligne greeter-setup-script=/usr/bin/numlockx on, dans la section [SeatDefaults]
Je trouve aussi un /usr/share/lightdm/lightdm.conf.d/99-numlockx.conf qui contient aussi cette ligne greeter-setup-script=/usr/bin/numlockx on (également dans une section [SeatDefaults]).

C'est vrai que, sur un post, il est écrit : tu n'as qu'à appuyer sur "Verr num". Ce n'est pas faux, mais je n'aime pas que l'informatique ne marche pas comme elle devrait !

N.B. Au post 6 apparaît une distinction entre démarrage de session avant saisie du mot de passe ou après saisie du mot de passe.

Dernière modification par Eric Bl (Le 29/12/2016, à 10:13)

Hors ligne

#2 Le 18/12/2016, à 10:48

bruno

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Bonjour,


Attention il ne faut pas modifier les fichiers situés dans /usr/share !
La configuration se fait toujours dans /etc/

En principe avec KDE c'est Sddm qui est utilisé comme gestionnaire de connexion. Dans ce cas il suffit de créer ou modifier le fichier /etc/sddm.conf pour y mettre :

[General]
numlock=on

Dernière modification par bruno (Le 18/12/2016, à 10:49)

Hors ligne

#3 Le 18/12/2016, à 11:51

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Merci Bruno, pour ta suggestion. Mais je n'ai pas rencontré le succès.

Je précise que je n'ai pas trouvé le fichier tout-à-fait à l'endroit espéré, mais dans /etc/init/
et que son contenu ne ressemble pas à du code qui accueillerait facilement une section telle que celle proposée.

# SDDM
#
# The display manager service manages the X servers running on the
# system, providing login and auto-login services
#
# based on lightdm upstart script

description     "SDDM"
author          "Rohan Garg <rohangarg@kubuntu.org>"

start on ((filesystem
           and runlevel [!06]
           and started dbus
           )
          or runlevel PREVLEVEL=S)

stop on runlevel [016]

respawn
respawn limit 2 15

emits login-session-start
emits desktop-session-start
emits desktop-shutdown


script
    if [ -n "$UPSTART_EVENTS" ]
    then
        # Check kernel command-line for inhibitors, unless we are being called
        # manually
        for ARG in $(cat /proc/cmdline); do
            if [ "$ARG" = "text" ]; then
		plymouth quit || : 
                stop
		exit 0
            fi
        done

        [ ! -f /etc/X11/default-display-manager -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/sddm" -o "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/sddm" ] || { stop; exit 0; }
        plymouth quit
        clear >/dev/tty7
    fi
    exec sddm
end script

post-start script
    sleep 5
    clear > /dev/tty7
end script

post-stop script
        clear > /dev/tty7
        sleep 1
        if [ "$UPSTART_STOP_EVENTS" = runlevel ]; then
                initctl emit desktop-shutdown
        fi
end script
Bruno a écrit :

Attention il ne faut pas modifier les fichiers situés dans /usr/share !

Du coup, j'ai supprimé les lignes numlockxx des fichiers que j'avais modifiés en suivant pourtant la doc ubuntu numlockxx
Quand je coche ou décoche l'option "numérique au démarrage", de l'écran de configuration du clavier, d'ailleurs, ça ne change rien à ces fichiers.
Ca donne un peu l'impression qu'il s'agit de fichiers créés par un processus de type compilation.
Ca me fait penser à ce qui se passe avec le fichier de configuration de grub. Et pour grub, il y a bien une phase de compliation.

Est-ce qu'avec sddm il n'y a pas un processus analogue ?

Hors ligne

#4 Le 18/12/2016, à 15:21

bruno

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Eric Bl a écrit :

Je précise que je n'ai pas trouvé le fichier tout-à-fait à l'endroit espéré, mais dans /etc/init/

Comme je l'ai dit si le fichier /etc/sddm.conf n’existe pas il faut le créer :

kdesudo kate /etc/sddm.conf

Il ne faut pas toucher aux fichiers sous /etc/init !

P.S. : merci de modifier le titre de ton premier message pour écrire numlock plutôt que nomlock wink

Dernière modification par bruno (Le 18/12/2016, à 16:12)

Hors ligne

#5 Le 18/12/2016, à 21:33

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Merci de cette mise au point.

J'ai fait exactement ce qui est indiqué. J'ai donc maintenant un fichier sddm.conf dans /etc/ qui contient :
[General]
numlock=on

Mais le pavé numérique n'est toujours pas actif au moment de saisir mon mot de passe.

Pour rappel, je n'ai plus :
greeter-setup-script=/usr/bin/numlockx on
dans les fichiers
/usr/share/lightdm/lightdm.conf.d/40-kde-plasma-kf5.conf
/usr/share/lightdm/lightdm.conf.d/99-numlockx.conf

Mais mon écran de configuration du clavier est toujours coché "Activé" pour la fonction "Verrouillage clavier numérique au démarrage de KDE".

C'est quand même étonnant que cette fonction prévue, que j'avais activée facilement en 12.04 (ma version précédente, sauf erreur), soit si difficile à activer en 16.04.
Tout comme je suis surpris que la fonction coller du clic droit de la souris soit en anglais dans dolphin (paste clipboard contents), mais c'est un autre débat.

Hors ligne

#6 Le 18/12/2016, à 22:16

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

En écrivant mon dernier post, j'ai réalisé tout à coup qu'il pouvait y avoir 2 choses différentes :
* l'activation du clavier numérique avant saisie du mot de passe
* l'activation du clavier numérique après saisie du mot de passe.

Comme j'ai un mot de passe avec des chiffres, ce qui m'intéresse c'est que le pavé numérique soit activé avant la saisie du mot de passe.
Et comme j'ai un mot de passe avec des chiffres, j'ai toujours verrouillé mon pavé numérique avant de saisir mon mot de passe, tout en regrettant qu'il ne soit pas activé de lui-même. Et je n'ai jamais cherché à savoir ce qui se passait après. Puisque Bruno semble maîtriser son sujet, je viens de regarder ce qui se passe après. Effectivement, n'ayant pas activé moi-même le pavé numérique, cette fois, j'ai vu qu'il s'activait tout seul.

En 12.04, mon voyant numérique s'activait avant la saisie du mot de passe. Alors je n'avais pas fait cette distinction.

Quelqu'un sait-il comment activer le pavé numérique avant la saisie du mot de passe ?

Hors ligne

#7 Le 19/12/2016, à 11:05

bruno

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Là je ne comprends plus ton problème…
La manipulation que je t'ai proposée verrouille le pavé numérique pour le gestionnaire de connexion SDDM et donc avant la saisie du mot de passe !

Hors ligne

#8 Le 26/12/2016, à 10:27

porcnoz

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Juste une proposition à la con.

Cotnrairement à toi, ma session s'ouvre automatiquement au démarrage, donc je suis pas sûr que ça marche pour toi ET je ne suis pas non plus convaincu d'avoir compris toutes les manipulations que tu as faites.

Bref, ça m'a gonflé aussi d'avoir "perdu" le verrouillage du pavé numérique donc j'ai fouillé un moment et puis, dans le panneau de configuration du système, dans épériphérique d'entrée", je suis (miraculeusement) tombé sur "Verrouillage numérique au démarrage de KDE". Est-ce que ça ne règlerait pas le problème ?


Kubuntu 16.04 64 bits
Asus P7P55D / i5 750 / 2*2Go DDR2 1333MHz / Radeon HD 5400

Hors ligne

#9 Le 26/12/2016, à 22:53

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Merci de la proposition, mais je suis déjà en "Verrouillage numérique au démarrage de KDE".
Sans effet, malheureusement.

Hors ligne

#10 Le 26/12/2016, à 23:02

Alex10336

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Eric Bl a écrit :

Merci de la proposition, mais je suis déjà en "Verrouillage numérique au démarrage de KDE".
Sans effet, malheureusement.

Normal, c'est une option « au démarrage de KDE » et ton problème est avant le démarrage de KDE.

Vous avez visiblement fait pas mal de bidouilles.
Le retour de cette commande ?

which numlockx

Dernière modification par Alex10336 (Le 26/12/2016, à 23:07)


« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne

#11 Le 27/12/2016, à 21:42

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Voici la réponse

parents@Grillo:~$ which numlockx
/usr/bin/numlockx

Merci

Hors ligne

#12 Le 28/12/2016, à 12:57

Alex10336

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Ok, et ceux là:

cat /etc/sddm.conf
service sddm status
service lightdm status

« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne

#13 Le 28/12/2016, à 18:32

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Voilà les résultats

parents@Grillo:~$ cat /etc/sddm.conf
[General]
numlock=on
parents@Grillo:~$ service sddm status
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
   Active: active (running) since mer. 2016-12-28 17:02:45 CET; 27min ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
 Main PID: 1062 (sddm)
   CGroup: /system.slice/sddm.service
           ├─1062 /usr/bin/sddm
           └─1093 /usr/lib/xorg/Xorg -nolisten tcp -auth /var/run/sddm/{07e67490-8a08-4bc4-b4dd-ec092c35e615} -background none -noreset -displayfd 17 vt7

déc. 28 17:14:35 Grillo sddm-helper[24874]: pam_kwallet(sddm:auth): (null): pam_sm_authenticate
déc. 28 17:14:35 Grillo sddm-helper[24874]: pam_kwallet5(sddm:auth): (null): pam_sm_authenticate
déc. 28 17:14:35 Grillo sddm[1062]: Oops, secure memory pool already initialized
déc. 28 17:14:35 Grillo sddm-helper[24874]: [PAM] returning.
déc. 28 17:14:35 Grillo sddm[1062]: Authenticated successfully
déc. 28 17:14:35 Grillo sddm-helper[24874]: pam_kwallet(sddm:setcred): pam_kwallet: pam_sm_setcred
déc. 28 17:14:35 Grillo sddm-helper[24874]: pam_kwallet5(sddm:setcred): pam_kwallet5: pam_sm_setcred
déc. 28 17:14:35 Grillo sddm[1062]: Auth: sddm-helper exited successfully
déc. 28 17:14:35 Grillo sddm[1062]: Greeter stopped.
déc. 28 17:14:35 Grillo sddm[1062]: Session started
parents@Grillo:~$ service lightdm status
● lightdm.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
parents@Grillo:~$ 

Hors ligne

#14 Le 28/12/2016, à 18:52

Alex10336

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Et avec une majuscule sur le N de Numlock ?


« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne

#15 Le 29/12/2016, à 10:13

Eric Bl

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

Ouaaaah !
J'avoue que je n'y croyais pas. J'ai même éteint et fait le test une deuxième fois, telle était mon incrédulité.
Bravo à Alex10336 !

Hors ligne

#16 Le 29/12/2016, à 12:13

Alex10336

Re : [Résolu] Verrouillage majuscule avant démarrage -kubuntu 16.04

^^

Tu peux également supprimer numlockx, il n'en a pas besoin.


« On ne répond pas à une question par une autre question. » (moi ;-) )

Hors ligne