Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 07/01/2017, à 13:07

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Voilà. J'ai débranché l'imprimante et passé le petit module bluetooth du clavier/souris de l'avant de ma tour à l'arrière.
Et maintenant je vais tester (ça peut être long ...)


Merci à tous

Hors ligne

#27 Le 07/01/2017, à 13:44

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Maintenant je numérote les reboots. Le premiers essai imprimante débranché est le N°6.
Reboot N°6 : Plantage comme les autres, c'est à dire écran du #1 à 4'20
Reboot N°7 : Plantage comme les autres, c'est à dire écran du #1 à 4'20
Reboot N°8 : Plantage avec timing un peu diffrent (écran Xubuntu avec sablier tournant pendant quelques temps).
Reboot N°9 : Plantage comme les autres, c'est à dire écran du #1 à 4'20
Bref, je n'arrive plus à rebooter.
J'ai enregistré le dmesg-6 si ça a un intérêt.?.
Pour le 10 je vais essayer de rebooter en désactivant le swap comme ça semblait faire marcher.


Merci à tous

Hors ligne

#28 Le 07/01/2017, à 13:51

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Reboot 10 : Désactiver le swap n'a rien changé, écran XUBUNTU à 55", écran du #1 à 3'50.


Merci à tous

Hors ligne

#29 Le 07/01/2017, à 14:59

nam1962

Re : [Résolu] Problème de démarrage xubuntu16.04

Débranche ton module bluetooth souris et rebranche l'imprimante.


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux)  Et vous ?
57 convertis  IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#30 Le 07/01/2017, à 15:10

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Ok, je fais ça.

Entre temps, comme ça ne pouvais plus rebooter, et que je faisais des reboot H/W (en coupant le courant sur le switch on/off derrière), je me suis dit que peut-être il n'aimait pas ça.
Alors j'ai fait des reboots en lignes de commande (après ctrl alt F1), et ça s'est mis à rebooter immédiatement et 4 x d'affilé. C'est peut-être un hasard, mais bon ...


Merci à tous

Hors ligne

#31 Le 07/01/2017, à 15:20

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Reboot 15 : (après reboot S/W) Avec imprimante branché et clavier/souris BT rébranchés
idem : plantage à 4'20


Merci à tous

Hors ligne

#32 Le 07/01/2017, à 15:20

nam1962

Re : [Résolu] Problème de démarrage xubuntu16.04

Ben le reboot à l'interrupteur ne fait plaisir à aucun OS sur aucun ordi !

Dernière modification par nam1962 (Le 07/01/2017, à 15:21)


Almanet doLys de l'open source : mon tuto pour optimiser / finaliser une install
Xubuntu devel - Manjaro unstable - OpenSUSE tumbleweed (GeckoLinux)  Et vous ?
57 convertis  IRL (leur ai pas donné le choix, aussi...).
Un jeune site que j'aime bien, le top du T-shirt homme ...bio et éthique en plus : https://goudronblanc.com

Hors ligne

#33 Le 07/01/2017, à 15:29

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

C'est sûr, tu as bien raison. Donc dorénavant pour la suite des tests, je vais éviter.
Ici le problème est ailleurs. En #31, c'était un S/W reboot. Et actuellement, je suis encore planté après un S/W reboot.

Dernière modification par Crestey (Le 07/01/2017, à 19:38)


Merci à tous

Hors ligne

#34 Le 08/01/2017, à 12:52

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Pour investiguer j'ai retiré les options "quiet splash" du démarrage, ce qui permet de voir tous les messages. on voit donc où ça plante.
Il y un problème avec le login service :
p1050057_imagesia-com_1cgr6_small.JPG
Ce dysfonctionnement est reproductible (quand ça plante, c'est toujours ces lignes qui s'affichent)
J'ai aussi remarqué un fait très étrange : Sur ce PC, il y a 2 noyaux : 4.4.0-31 et 4.4.0-57
Si je re-démarre sur l'autre noyau, ça ne plante jamais ! Dès que je re-démarre sur le même noyau ça plante ! Sur une quinzaine de ré-démarage, ça se vérifie


Merci à tous

Hors ligne

#35 Le 09/01/2017, à 10:01

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Là je suis un peu sur le cul.
Mon "/" est sur sda5, une partition logique (à l'intérieur d'une partition étendue). Elle mettait 2'15 (+/-2secondes) à booter.
Dans une soucis de test, j'ai refait une autre install sur sda4, une partition principale, tout à fait à droite quand on la visionne avec Gparted.
Et là, j'obtiens 40s de boot sans rien installer d'autre que xubuntu + faire une mise à jour. Si j'installe tout ce que j'utilise d'habitude ça passe à 53s.
Du coup, j'ai (encore) reformaté la partition sda5 de ma première installe, et refait exactement la même chose: install avec mise à jour. Et là, je boot en 1'42" ! à comparer aux 40" de sda4

Pourquoi une install (toute fraîche) boot 2,5 fois plus vite que l'autre (toute fraîche aussi) sur le même disque dur. ?!? hmm
Je soupçonne que c'est lié à mon problème de démarrage.

Auriez-vous une idée ? (DD endommagé ? , "/" qui n'aime pas les partitions logique, autre chose)
Je suis en train de tester mon DD avec gnome-disk-utility mais je ne suis pas sûr que c'est le mieux (il reste figé sur "test : 10%" depuis 1/h !)
A vous lire

Dernière modification par Crestey (Le 09/01/2017, à 10:59)


Merci à tous

Hors ligne

#36 Le 09/01/2017, à 15:12

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Le self test de mon DD est K.O. : selftest_imagesia-com_1chib_small.png
Ceci peut-il expliquer cela ? Comment puis-je en savoir plus sur mon DD suite au résultat de ce test ?
En fait tout est indiqué OK dans la colonne de droite, donc je ne sais pas trop comment interpréter ce résultat.

Dernière modification par Crestey (Le 09/01/2017, à 15:13)


Merci à tous

Hors ligne

#37 Le 09/01/2017, à 16:00

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Bonjour
J'ai parcouru très rapidement tous tes tests
Dans une de tes traces j'ai que le démarrage était un peut long a cause de cela

[   78.106043] usblp 1-2:1.0: usblp1: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0262
[  125.998242] IPv6: ADDRCONF(NETDEV_UP): enp2s5: link is not ready
[  126.008655] r8169 0000:02:05.0 enp2s5: link down
[  126.008664] r8169 0000:02:05.0 enp2s5: link down
[  126.008701] IPv6: ADDRCONF(NETDEV_UP): enp2s5: link is not ready
[  127.670268] r8169 0000:02:05.0 enp2s5: link up
[  127.670282] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s5: link becomes ready
[  157.966253] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[  157.970385] NFSD: starting 90-second grace period (net c1b61100)
[  157.998896] FS-Cache: Loaded
[  158.067804] FS-Cache: Netfs 'nfs' registered for caching

c'est typiquement réseau et connexion fichiers distants. Mais ce n'est pas lié au plantage

Tu parles de deux noyaux
4.4.0-31 et 4.4.0-57
J'ai cru comprendre que tes tests semblent indiquer que l'un plante systématiquement  et que l'autre ne plante pas,
Il serait bon que tu le lances et que tu postes  le résultat des commandes

sudo apt update
sudo apt ugrade

J'ai regardé l'état du disque.    Il n'est pas évident d'en déduire qu'il est responsable.
si le problème survient de nouveau, lorsque tu auras booté,  tu donneras le contenu des fichiers suivants

tail -500    /var/log/kern.log
tail -500    /var/log/syslog
tail -500    /var/log/kern.log.1
tail -500    /var/log/syslog.1

J'ai mis une valeur de 500 au hasard au cas où l'un des fichiers serait énorme et ce n'est peut-être pas à la fin des fichiers qu'on trouvera des infos

Dernière modification par Bougron (Le 09/01/2017, à 16:01)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#38 Le 09/01/2017, à 16:20

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Crestey a écrit :

Bonjour à tous,
Une fois sur 2, mon PC ne démarre pas et affiche cela :
http://pimg.imagesia.com/fichiers/1ca/bug-demarrage_imagesia-com_1capx_small.JPG
Il affiche ça pendant quelques 10aines de secondes puis affiche un écran noir pendant quelques 10aines de secondes puis reviens sur cet affichage, etc ...
Et une fois sur 2 il démarre correctement.
Auriez-vous une piste SVP ?
A vous lire

Bonjour.
La seconde ligne est en jaune, C'est un problème d'avertissement. Comme j'ai un petit écran, J'ai du mal à lire
cependant, cela m'a permit de tomber sur cette discussion https://bugzilla.redhat.com/show_bug.cgi?id=1088665
que je comprends mal.    Cela pourrait être plus qu'un message d'information mais la cause du problème.
C'est une piste à creuser.   ===> Arrêtes de monter en automatique les partitions RESEAU pour confirmer cet axe de recherche.
Je dois m'absenter quelques heures.

Dernière modification par Bougron (Le 09/01/2017, à 16:21)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#39 Le 09/01/2017, à 17:23

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Bougron a écrit :

Tu parles de deux noyaux
4.4.0-31 et 4.4.0-57
J'ai cru comprendre que tes tests semblent indiquer que l'un plante systématiquement  et que l'autre ne plante pas,

Non, en fait ils merdaient tous les 2 de la même manière.
Mais ce qui était très bizarre, c'est qu'ils pouvaient planter 10 fois de suite et que, face à une longue série de plantage comme ça, il suffisait de booter sur l'autre noyau pour sortir de l'impasse ! De même, je n'ai jamais planté en passant d'un noyau à l'autre, sur plusieurs dizaines de fois.

Bougron a écrit :

Arrêtes de monter en automatique les partitions RESEAU

Quand j'ai fait mes tests, j'ai fini par faire une config minimal (pas d'usb, pas d'imprimante, j'ai même débranché le lecteur CD!, pas de nas monté a démarrage, etc, ...). Mais ça plantait toujours pareil quoi que je fasse.

Je parle au passé, et je ne peux pas trop faire les tests que tu demandes car depuis, j'ai réinstallé sda5 qui merdait. Il ne merde plus, mais boot en 2 fois plus de temps, et je suspecte mon DD. J'hésite à continuer avec lui.

Voici la situation actuelle pour résumer :

mes partitions :gp_imagesia-com_1chmv_small.png

1) sda5 est la partition logique qui merdait et qui maintenant boot bien mais 2 fois plus lentement que sda4 (partition primaire que j'ai installé pour tester). sda4 mets 50s à booter, et sda5 mets 1mn40.
2) Les 2 partitions ont exactement la même install minimal (xubuntu16.04 + mise à jour + nemo + gparted)
3) j'ai 2 DD dans ce pc. un sda et un sdb. sda ne passe pas l'autotest smart. sdb oui.

Donc, ça fait beaucoup d'incohérences, et je soupçonne mon DD d'être sur sa fin. Qu'en penses-tu ?
Ne penses-tu pas qu'avant de chercher du coté d'ubuntu, je doive régler le problème de l'autotest qui ne passe pas ?
Y a-t-il d'autres tests que smart qui viendraient confirmer/infirmer la chose ?

Dernière modification par Crestey (Le 09/01/2017, à 17:27)


Merci à tous

Hors ligne

#40 Le 09/01/2017, à 17:28

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Refais la commande

sudo smartctl -s on -a /dev/sda

Cela permettra de comparer avec les  valeurs précédentes.

ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   100   100   051    Pre-fail  Always       -       0
  5 Reallocated_Sector_Ct   0x0033   253   253   010    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   253   253   051    Pre-fail  Always       -       0
 13 Read_Soft_Error_Rate    0x000e   100   100   000    Old_age   Always       -       1159493
188 Command_Timeout         0x0032   253   253   000    Old_age   Always       -       0
196 Reallocated_Event_Count 0x0032   253   253   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   253   253   000    Old_age   Always       -       0
SMART Error Log Version: 1
No Errors Logged

en fait  le code 13 pourrait être inquiétant
"Taux d’erreurs non corrigées transmises au système d’exploitation".
Si on comprend que le disque décide de transmettre n'importe quoi.        Mais L'OS devrait être capable de refuser.
On y verra certainement la trace du test qui a foiré.
J'ai vu un truc avec plein de valeurs

Four SAMSUNG SpinPoint T166 series, HD501LJ and more than 4 years in a 8-core server, here are the raw error rates:
    13 Read_Soft_Error_Rate 0×000e 100 100 000 479105152
    13 Read_Soft_Error_Rate 0×000e 100 100 000 633936205
    13 Read_Soft_Error_Rate 0×000e 100 100 000 494533244
    13 Read_Soft_Error_Rate 0×000e 100 100 000 844820954

Dernière modification par Bougron (Le 09/01/2017, à 19:57)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#41 Le 09/01/2017, à 17:50

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Voilà, je ne sais pas trop interpréter, mais il y a des lignes d'erreur à SMART Self-test log structure revision number 1, qu'il n'y a pas dans mon 2ème DD.

crestey@PC4:~$ sudo smartctl -s on -a /dev/sda
[sudo] Mot de passe de crestey : 
smartctl 6.5 2016-01-24 r4214 [i686-linux-4.4.0-57-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Device Model:     SAMSUNG HD161HJ
Serial Number:    S0V3J9DQ929211
LU WWN Device Id: 5 0000f0 09b929211
Firmware Version: JF100-19
User Capacity:    160 041 885 696 bytes [160 GB]
Sector Size:      512 bytes logical/physical
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ATA/ATAPI-7, ATA8-ACS T13/1699-D revision 3b
Local Time is:    Mon Jan  9 16:43:40 2017 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
SMART Enabled.

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x82)	Offline data collection activity
					was completed without error.
					Auto Offline Data Collection: Enabled.
Self-test execution status:      ( 121)	The previous self-test completed having
					the read element of the test failed.
Total time to complete Offline 
data collection: 		( 3002) seconds.
Offline data collection
capabilities: 			 (0x5b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  51) minutes.
SCT capabilities: 	       (0x003f)	SCT Status supported.
					SCT Error Recovery Control supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   100   100   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0007   253   253   025    Pre-fail  Always       -       4416
  4 Start_Stop_Count        0x0032   094   094   000    Old_age   Always       -       6747
  5 Reallocated_Sector_Ct   0x0033   253   253   010    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   253   253   051    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0025   253   253   015    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       22425
 10 Spin_Retry_Count        0x0033   253   253   051    Pre-fail  Always       -       0
 11 Calibration_Retry_Count 0x0012   253   253   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   000    Old_age   Always       -       4029
 13 Read_Soft_Error_Rate    0x000e   100   100   000    Old_age   Always       -       67011096
184 End-to-End_Error        0x0033   253   253   099    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   253   253   000    Old_age   Always       -       0
188 Command_Timeout         0x0032   253   253   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   166   127   000    Old_age   Always       -       24 (Min/Max 3/37)
194 Temperature_Celsius     0x0022   166   127   000    Old_age   Always       -       24 (Min/Max 3/37)
195 Hardware_ECC_Recovered  0x001a   100   100   000    Old_age   Always       -       67011096
196 Reallocated_Event_Count 0x0032   253   253   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       1
198 Offline_Uncorrectable   0x0030   253   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x000a   100   100   000    Old_age   Always       -       0
201 Soft_Read_Error_Rate    0x000a   100   100   000    Old_age   Always       -       0
202 Data_Address_Mark_Errs  0x0032   253   253   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed: read failure       90%     22422         245081735
# 2  Extended offline    Completed: read failure       90%     22422         245081735
# 3  Short offline       Completed: read failure       90%     22420         245081735
# 4  Extended offline    Completed: read failure       20%     22419         245081735
# 5  Abort offline test  Aborted by host               90%     22417         -
# 6  Abort offline test  Aborted by host               90%     22417         -

SMART Selective self-test log data structure revision number 0
Note: revision number not 1 implies that no selective self-test has ever been run
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

crestey@PC4:~$ 

Merci à tous

Hors ligne

#42 Le 09/01/2017, à 18:06

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Crestey a écrit :

Voilà, je ne sais pas trop interpréter, mais il y a des lignes d'erreur à SMART Self-test log structure revision number 1, qu'il n'y a pas dans mon 2ème DD.

crestey@PC4:~$ sudo smartctl -s on -a /dev/sda
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   100   100   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0007   253   253   025    Pre-fail  Always       -       4416
  7 Seek_Error_Rate         0x000f   253   253   051    Pre-fail  Always       -       0
 13 Read_Soft_Error_Rate    0x000e   100   100   000    Old_age   Always       -       67011096
188 Command_Timeout         0x0032   253   253   000    Old_age   Always       -       0
196 Reallocated_Event_Count 0x0032   253   253   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       1

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed: read failure       90%     22422         245081735
# 2  Extended offline    Completed: read failure       90%     22422         245081735
# 3  Short offline       Completed: read failure       90%     22420         245081735
# 4  Extended offline    Completed: read failure       20%     22419         245081735

Un seul secteur non lisible dans 78%  de l'espace  pour un  disque qui a plus de 22422 heures de fonctionnement, je pense que c'est très très peu.   245081735  / ( 160 041 885 696 /512)
De plus , il est maintenant répertorié (compteur 197).  On peut donc affirmer que, si dans passé, il y avait eu une telle situation, elle aurait été enregistrée.
A noter que lorsque cette situation se produit, il y a un message très parlant....

En revanche ce fichu compteur 13 a  grimpé en flèche. Et je ne trouve rien sur internet de satisfaisant pour indiquer à quoi cela sert.

Dernière modification par Bougron (Le 09/01/2017, à 18:19)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#43 Le 09/01/2017, à 18:30

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Tu peux tenter de lire le secteur fichu.   Je me fais toujours avoir avec le positionnement

sudo    dd   if=/dev/sda    bs=512   count=1      skip=2450817354
sudo    dd   if=/dev/sda    bs=512   count=1      skip=2450817355

Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#44 Le 09/01/2017, à 18:43

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Je comprends pas tout, mais je suis très discipliné :

crestey@PC4:~$ sudo    dd   if=/dev/sda    bs=512   count=1      skip=2450817354
[sudo] Mot de passe de crestey : 
dd: /dev/sda : impossible d'ignorer: Argument invalide
0+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 0,000132239 s, 0,0 kB/s
crestey@PC4:~$ sudo    dd   if=/dev/sda    bs=512   count=1      skip=2450817355
dd: /dev/sda : impossible d'ignorer: Argument invalide
0+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 0,000483238 s, 0,0 kB/s
crestey@PC4:~$

Dernière modification par Crestey (Le 09/01/2017, à 18:44)


Merci à tous

Hors ligne

#45 Le 09/01/2017, à 20:20

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Cela devrait mieux aller

sudo    dd      if=/dev/sda    bs=512   count=1      skip=245081734
sudo    dd      if=/dev/sda    bs=512   count=1      skip=245081735

Le but est de lire le secteur illisible détecté.  Pour l'identifier avec certitude, on aura un retour disant que ce n'est pas lisible.
Après on pourra écrire..... sur le secteur de remplacement. On vérifiera par smartctl que c'est OK, et tu pourras reprendre ton test de qualité.
Si on en trouve un autre, même action

Dernière modification par Bougron (Le 09/01/2017, à 20:23)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#46 Le 09/01/2017, à 23:56

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Je viens d'avoir deux événements sur sda5 (pas trop rassurant) :
1) Un popup me disant "Hard disk health warning: the hd health has changed. this could mean that hard drive failure is imminent"
2) Le clic sur les icones inopérant. Et sur le clavier aussi. sinon j'aurais fait une copie d'écran pour vous montrer le popup.
Réponse à tes commandes :

root@PC4:~# dd      if=/dev/sda    bs=512   count=1      skip=245081734
dd: erreur de lecture '/dev/sda': Erreur d'entrée/sortie
0+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 8,24587 s, 0,0 kB/s
root@PC4:~# dd      if=/dev/sda    bs=512   count=1      skip=245081735
dd: erreur de lecture '/dev/sda': Erreur d'entrée/sortie
0+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 4,43916 s, 0,0 kB/s
root@PC4:~#

P.S. : S'il faut changer le DD, franchement c'est pas le prix que ça coûte, d'autant qu'il y en a un autre de sain dans ce même pc. Mais par contre, je n'ai jamais eu ce cas de figure d'une panne pas franche comme ça. Alors, ça m'intéresse d'investiguer pour savoir diagnostiquer un DD pour mes autres PC et tous ceux que j'ai installé à mes amis. Ceci dit, s'il est viable, pourquoi pas le garder, mais là, quand même, j'ai des doutes. Ça fait la 3ème réinstall, et il merdoit toujours, et toujours sur sda5. Merci à vous en tout cas pour le temps passé à m'aider.

Dernière modification par Crestey (Le 09/01/2017, à 23:56)


Merci à tous

Hors ligne

#47 Le 10/01/2017, à 00:31

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Je n'ai toujours pas compris le code 13......

En revanche, je suis très surpris des retours des deux commandes. " Erreur d'entrée/sortie"
Je n'en attendais qu'une seule!!!!!!
On corrige

   sudo      dd       if=/dev/zero     of=/dev/sda    bs=512   count=1      seek=245081734
   sudo      dd       if=/dev/zero     of=/dev/sda    bs=512   count=1      seek=245081735

On vérifie par une commande allégée

sudo smartctl   -A   /dev/sda

AJOUT Je viens de trouver un truc qui semble vouloir dire  que la mécanique du disque est en parfaite santé car cela provient d'un SSD

 13 Read_Soft_Error_Rate    0x0032   049   049   000    Old_age   Always       -       73027548545186

Read Soft Error Rate - should be Soft Read Error Rate. Similar to Raw Read Error Rate but this one depends on logical level, such as error occured in the hdd buffer, etc.

Uncorrected read errors reported to the operating system.

Cela vaut ce que cela vaut
"Les erreurs logicielles sont des erreurs qui ont disparu lorsque votre disque a réessayé une opération. Un petit nombre pourrait être causé par de légers problèmes électriques et n'est pas une source directe de souci"
ALIM????
une autre contradictoire
Although this parameter is not considered critical by the most hardware vendors, degradation of this parameter may indicate electromechanical problems of the disk.

Dernière modification par Bougron (Le 11/01/2017, à 01:26)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#48 Le 10/01/2017, à 02:16

Bougron

Re : [Résolu] Problème de démarrage xubuntu16.04

Bonsoir
Je vais abandonner ma recherche.
Mais si la cause de l'erreur 13 est un problème mécanique, tu devrais entendre grincer ce disque....


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
fournir le rapport bisnext pour une aide. https://doc.ubuntu-fr.org/bisnext

Hors ligne

#49 Le 10/01/2017, à 11:11

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Merci Bougron,

crestey@PC4:~$    sudo      dd       if=/dev/zero     of=/dev/sda    bs=512   count=1      seek=245081734
[sudo] Mot de passe de crestey : 
dd: erreur d'écriture de '/dev/sda': Erreur d'entrée/sortie
1+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 3,16614 s, 0,0 kB/s
crestey@PC4:~$    sudo      dd       if=/dev/zero     of=/dev/sda    bs=512   count=1      seek=245081735
dd: erreur d'écriture de '/dev/sda': Erreur d'entrée/sortie
1+0 enregistrements lus
0+0 enregistrements écrits
0 bytes copied, 2,49607 s, 0,0 kB/s
crestey@PC4:~$
crestey@PC4:~$ sudo smartctl   -A   /dev/sda
smartctl 6.5 2016-01-24 r4214 [i686-linux-4.4.0-57-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   100   100   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0007   253   253   025    Pre-fail  Always       -       4352
  4 Start_Stop_Count        0x0032   094   094   000    Old_age   Always       -       6750
  5 Reallocated_Sector_Ct   0x0033   253   253   010    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   253   253   051    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0025   253   253   015    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       22428
 10 Spin_Retry_Count        0x0033   253   253   051    Pre-fail  Always       -       0
 11 Calibration_Retry_Count 0x0012   253   253   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   097   097   000    Old_age   Always       -       4031
 13 Read_Soft_Error_Rate    0x000e   100   100   000    Old_age   Always       -       167422
184 End-to-End_Error        0x0033   253   253   099    Pre-fail  Always       -       0
187 Reported_Uncorrect      0x0032   092   092   000    Old_age   Always       -       9
188 Command_Timeout         0x0032   253   253   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   193   127   000    Old_age   Always       -       15 (Min/Max 3/37)
194 Temperature_Celsius     0x0022   184   127   000    Old_age   Always       -       18 (Min/Max 3/37)
195 Hardware_ECC_Recovered  0x001a   100   100   000    Old_age   Always       -       167422
196 Reallocated_Event_Count 0x0032   253   253   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       1
198 Offline_Uncorrectable   0x0030   253   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x000a   253   100   000    Old_age   Always       -       0
201 Soft_Read_Error_Rate    0x000a   253   100   000    Old_age   Always       -       0
202 Data_Address_Mark_Errs  0x0032   253   253   000    Old_age   Always       -       0

crestey@PC4:~$

Merci à tous

Hors ligne

#50 Le 10/01/2017, à 11:19

Crestey

Re : [Résolu] Problème de démarrage xubuntu16.04

Bougron a écrit :

Le but est de lire le secteur illisible détecté.  Pour l'identifier avec certitude, on aura un retour disant que ce n'est pas lisible.
Après on pourra écrire..... sur le secteur de remplacement. On vérifiera par smartctl que c'est OK, et tu pourras reprendre ton test de qualité.

A priori, ce n'est toujours pas bon : le test smart est toujours K.O.
J'ai une question : En fait je pensais avoir compris que les DD savait détecter et exclure tout seul les secteurs défaillants.
Si c'est le cas, pourquoi on doit ici l'exclure nous même ?


Merci à tous

Hors ligne