Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Appel à contributeurs pour la doc.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 05/01/2017, à 02:01

Creditabricole

[Résolu]Réseau filaire non géré

Bonjour et bonne année à tous les Ubuntiens (& tiennes bien sur !)
Pardon d'avance pour mes boulettes mais je suis un "rookie" sur Ubuntu.
Suite à la mise à jour d'Ubuntu de 16.04 vers 16.10 j'ai perdu ma connexion filaire (Network manager -> périphérique non géré)
Quelques infos pour démarrer: je suis en dual boot Win7/Ubuntu et sous Win je n'ai pas de soucis de connexion. De plus ayant dans mes tiroirs un vieux LiveCD d'Ubuntu (12.10) je me reconnecte sans soucis lors d'une session live.
Coté hardware je pense donc que tous est OK.
J'ai mis à jour le driver du chip réseau (Realtek RTL8111/8168/8411) avec le driver du R8168 Rev 8.043.02 (déclaré comme 100% compatible sur le site de Realtek) sans succès ...
Pour aider au diagnostique du problème, voici le résultat de quelques commandes trouvées en cherchant dans le forum et/ou sur AskUbuntu:

lspci:
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS880 Host Bridge
00:01.0 PCI bridge: ASUSTeK Computer Inc. AMD RS780/RS880 PCI to PCI bridge (int gfx)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880 [Radeon HD 4200]
01:05.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
03:08.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0)

Puis le contenu du fichier /etc/network/interfaces:
auto lo
iface lo inet loopback

Résultat de ifconfig:
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 26012  bytes 1565200 (1.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 26012  bytes 1565200 (1.5 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Ou encore:
sudo lshw -C network
  *-network DÉSACTIVÉ       
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: eth0
       version: 03
       numéro de série: 20:cf:30:8d:9a:98
       taille: 100Mbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.043.02-NAPI duplex=full latency=0 link=no multicast=yes port=twisted pair speed=100Mbit/s
       ressources: irq:25 portE/S:d800(taille=256) mémoire:fdfff000-fdffffff mémoire:fdff8000-fdffbfff mémoire:feaf0000-feafffff


J'ai également essayé:
sudo service network-manager stop
puis
sudo service network-manager start

Toujours sans succès . . . Maintenant je sèche sérieusement et m'en remets donc à la sagacité des experts smile
Désolé d'avoir été si long en espérant déjà avoir posté au bon endroit.
Merci d'avance !
Creditabricole

Dernière modification par Creditabricole (Le 01/02/2017, à 01:41)


Postulat de base : je suis une bille !

Hors ligne

#2 Le 05/01/2017, à 16:56

ikoula

Re : [Résolu]Réseau filaire non géré

Bonjour,

Une autre personne a rencontré un problème du même genre https://forum.ubuntu-fr.org/viewtopic.php?id=2002549 du coup je te le demande n'aurais tu pas la possibilité de brancher une clée wifi le temps de lancer une maj ou alors il faudrait reinstaller  la carte réseau (supprimer la conf) pour pouvoir lancer une maj et ne plus être embêté.


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#3 Le 05/01/2017, à 19:27

Creditabricole

Re : [Résolu]Réseau filaire non géré

Bonjour Ikoula,
Merci pour ta réponse. Malheureusement, non, je n'ai pas de clé Wifi.
Par contre on peut imaginer que je grave une iso de la 16.10 et réinstaller la carte réseau à partir du CD/DVD ? A noter que j'ai déjà fait une mise à jour du driver, j'ai conservé les sources en local sur mon HD, peut être est-ce suffisant.
Mais pour commencer, je ne sais pas comment on supprime la conf d'un périphérique précis.... Comme indiqué dans ma signature, je suis vraiment un débutant !:D


Postulat de base : je suis une bille !

Hors ligne

#4 Le 06/01/2017, à 11:28

ikoula

Re : [Résolu]Réseau filaire non géré

C'est simple il faut supprimer le fichier /etc/udev/rules.d/70-persistent-net.rules et rebooter si cela ne fonctionne pas il faudra peu être effectivement passer par une reinstall.


Thomas | Community manager | ikoula Serveurs dédiés, VPS et Cloud Public
Contactez-nous | Suivez-nous sur Twitter | Likez nous sur Facebook

Hors ligne

#5 Le 07/01/2017, à 13:34

Creditabricole

Re : [Résolu]Réseau filaire non géré

Ok.
Je vais essayer une suppression dans un premier temps.
Merci.


Postulat de base : je suis une bille !

Hors ligne

#6 Le 08/01/2017, à 17:55

Creditabricole

Re : [Résolu]Réseau filaire non géré

Hello,
Avant de ré-installer la carte réseau j'ai tenté d'y aller "à l'arrache":
Dans le fichier /etc/network/interfaces j'ai ajouté :

iface eth0 inet dhcp

Du coup j'ai enfin une connexion fonctionnelle même si "péripherique non géré" apparait toujours dans le network manager. De même quand je clique sur "Information sur la connexion" j'ai le retour: Aucun connexion valide active trouvée ....
Y'a encore du boulot.
Petit indice supplémentaire:
En faisant :

sudo lshw -class network

Depuis une session live d'Ubuntu 16.04 je vois driver=r8169 tandis depuis mon install actuelle (16.10) j'ai driver=r8168.
Ce ne sont pas les mêmes drivers qui sont utilisés.
J'embraye sur la manip recommandée par Ikoula et reviendrai ici vous ce qu'il en est !


Postulat de base : je suis une bille !

Hors ligne

#7 Le 20/01/2017, à 01:53

Creditabricole

Re : [Résolu]Réseau filaire non géré

Pffff, quelle galère !
En suivant ce fil https://forum.ubuntu-fr.org/viewtopic.php?id=209578 j'ai tenté de remplacer le pilote de ma carte Realtek r8168 par un pilote r8169: impossible yikes
J'ai tellement bidouillé dans tout les sens que maintenant je n'arrive même plus à reactiver ma connexion en passant par le fichier /etc/network/interfaces...
Je tente la manip de la dernière chance recommandée par Ikoula avec une re-install via le dvd de la 16.10.
Si ca ne marche pas, il me reste toujours la possibilité de revenir en 16.04: avant les mises à jour, je fais toujours une sauvegarde de ma partition Linux avec Clonezilla.


Postulat de base : je suis une bille !

Hors ligne

#8 Le 01/02/2017, à 01:51

Creditabricole

Re : [Résolu]Réseau filaire non géré

Voila,
Après plusieurs jours de galère j'ai fini par la méthode "bourrin": gravure d'une iso d'Ubuntu 16.10 et réinstallation grâce à la documentation: https://doc.ubuntu-fr.org/reinstallation_ubuntu
J'ai enfin pu récupérer une interface Ethernet pleine et entière.
A noter que le pilote installé est bien le r8169 ce qui confirme bien mes soupçons de départ.
Pourquoi la mise à jour OTA a installé un pilote différent de l'installation via Live DVD . . . mystère !
Je passe donc le sujet en "Résolu" même si la solution n'est pas à 100% satisfaisante.


Postulat de base : je suis une bille !

Hors ligne