Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/01/2017, à 00:35

harlock59

lecture BluRay libssl dépendance non satisfaite aacskeys

Bonjour, j'ai voulu installer aacskeys depuis ce site http://deb-multimedia.org/pool/main/a/a … cskeys.php car depuis les dépots que j'ai dans sources.list il était introuvable. quel dépot doi-je ajouter pour pouvoir installer aacskeys depuis la commande "sudo apt install ..." ? merci.


HP EliteBook 840 G1 - Dual Boot Windobe7 x64 +XUBUNTU Bionic Beaver 18.04 x64
Ne soyez pas raciste, soyez comme Mario !

Hors ligne

#2 Le 08/01/2017, à 00:49

harlock59

Re : lecture BluRay libssl dépendance non satisfaite aacskeys

Bon, pour résumer, j'ai réussi à installer aacskeys 0.4.0e-dmo2, dmo5 mais pas dmo7


HP EliteBook 840 G1 - Dual Boot Windobe7 x64 +XUBUNTU Bionic Beaver 18.04 x64
Ne soyez pas raciste, soyez comme Mario !

Hors ligne

#3 Le 08/01/2017, à 02:54

Coeur Noir

Re : lecture BluRay libssl dépendance non satisfaite aacskeys

Sans vouloir décourager, la lecture de BluRay « commerciaux » protégés n'est pas une mince affaire :
https://wiki.archlinux.org/index.php/Blu-ray
https://doc.ubuntu-fr.org/blu-ray
https://doc.ubuntu-fr.org/lxbdplayer

aacskeys n'est plus dans les dépôts ubuntu depuis la 12.04.
Il est par là comme tu l'as vu http://deb-multimedia.org/dists/testing … e/aacskeys
Les adresses de dépôts ici http://deb-multimedia.org/ mais c'est une mauvaise idée d'ajouter un dépôt typiquement debian à ubuntu - gros risques de casse du système…

Hors ligne

#4 Le 08/01/2017, à 10:50

Compte anonymisé

Re : lecture BluRay libssl dépendance non satisfaite aacskeys

au dernière nouvelle, la seul façon qui marche avec tout les films était MakeMKV. Bon ça fait quelque temps que je me suis pas renseigné.

Mon script qui te télécharge/met à jour/génère paquet debian/fournit la clé logiciel pour utiliser MakeMKV gratuitement :

#!/bin/sh

cd /tmp
curr_version=$(wget -qO- http://www.makemkv.com/download/|grep -m 1 "MakeMKV v" | sed -e "s/.*MakeMKV v//;s/ (.*//")
inst_version=$(apt-cache show makemkv-bin|grep Version|cut -f2 -d" ")

echo "Scraped the MakeMKV download page and found the latest version as" $curr_version

if [ "${curr_version}" != "${inst_version%-1}" ]
then
   sudo apt-get -f -q -y install checkinstall build-essential libc6-dev libssl-dev libexpat1-dev libavcodec-dev libgl1-mesa-dev libqt4-dev
   sudo apt-mark auto libc6-dev libssl-dev libexpat1-dev libavcodec-dev libgl1-mesa-dev libqt4-dev > /dev/null

   bin_zip=makemkv-bin-$curr_version oss_zip=makemkv-oss-$curr_version

   wget -q http://www.makemkv.com/download/${bin_zip}.tar.gz http://www.makemkv.com/download/${oss_zip}.tar.gz

   tar -xzvf ${bin_zip}.tar.gz 
   tar -xzvf ${oss_zip}.tar.gz

   cd $oss_zip
   ./configure
   make&&sudo checkinstall -y

   cd ../$bin_zip
   make&&sudo checkinstall -y

  cd ..
  rm -rf $bin_zip.tar.gz $oss_zip.tar.gz $oss_zip $bin_zip

#this for use of libmmbd on VLC
#sudo apt-get -f -q remove libaacs0
#sudo apt-get -f -q install libbluray1 libbluray-bin libbluray-bdj
#cd /usr/lib
#sudo ln -s libmmbd.so.0 libaacs.so.0
#sudo ln -s libmmbd.so.0 x86_64-linux-gnu/libbdplus.so.0

else
  echo "This version is already installed"

fi

echo "current free key is : "
echo "$(curl "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053" -s | awk 'FNR == 243 {print $57}' | cut -c 21-88
)"

EDIT : j'en profite pour le simplifier
EDIT2 : la bibliothèque libmmbd semble fonctionner, en enlevant les #, on peut lire les blu-ray avec vlc

Dernière modification par Compte anonymisé (Le 08/01/2017, à 11:27)

#5 Le 02/03/2017, à 22:16

harlock59

Re : lecture BluRay libssl dépendance non satisfaite aacskeys

merci !


HP EliteBook 840 G1 - Dual Boot Windobe7 x64 +XUBUNTU Bionic Beaver 18.04 x64
Ne soyez pas raciste, soyez comme Mario !

Hors ligne

#6 Le 02/03/2017, à 22:38

harlock59

Re : lecture BluRay libssl dépendance non satisfaite aacskeys

j'ai un problème de son avec vlc


HP EliteBook 840 G1 - Dual Boot Windobe7 x64 +XUBUNTU Bionic Beaver 18.04 x64
Ne soyez pas raciste, soyez comme Mario !

Hors ligne