Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Appel à contributeurs. Réunion pour la refonte du wiki lundi 26 juin

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 09/01/2017, à 00:08

fgi

[Résolu] [16.04]Pb d'install Adobe Flash Plugin

Bonsoir,

Je cherche à faire une install propre de flash pour FF et Chromium.

J'ai suivi le post suivant : https://forum.ubuntu-fr.org/viewtopic.p … #p21504956

Après les nettoyages préconisés par Coeur Noir, lors de l'install de adobe-flashplugin depuis Synaptic, j'ai l'erreur suivante :

E: /var/cache/apt/archives/adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb: tentative de remplacement de « /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png », qui appartient aussi au paquet flash-plugin 11.2.202.644-1
E: /var/cache/apt/archives/adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb: tentative de remplacement de « /usr/share/applications/flash-player-properties.desktop », qui appartient aussi au paquet flash-plugin 11.2.202.644-1

et lors que Synaptic me propose les infos détaillées, j'ai une popup avec une "pseudo" fenêtre d'émulateur terminal dans laquelle j'ai ces éléments :

(Lecture de la base de données... 226439 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flashplugin (1:20161213.1-0ubuntu0.16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png », qui appartient aussi au paquet flash-plugin 11.2.202.644-1
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Préparation du dépaquetage de .../adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flash-properties-gtk (1:20161213.1-0ubuntu0.16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/applications/flash-player-properties.desktop », qui appartient aussi au paquet flash-plugin 11.2.202.644-1
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb
 /var/cache/apt/archives/adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :

Merci pour vos avis.

Dernière modification par fgi (Le 09/01/2017, à 22:18)


L'homme ne recherche pas La Vérité. Il n'est qu'avide de certitude ... [Cornélius Castoriadis]

~ Xubuntu 16.04 64 bits ~

Hors ligne

#2 Le 09/01/2017, à 00:25

abelthorne

Re : [Résolu] [16.04]Pb d'install Adobe Flash Plugin

Désinstalle flashplugin-installer avant : adobe-flashplugin ne peut pas s'installer parce qu'il a des fichiers communs avec.

sudo apt-get remove --purge flashplugin-installer
sudo apt-get install adobe-flashplugin

Hors ligne

#3 Le 09/01/2017, à 00:48

fgi

Re : [Résolu] [16.04]Pb d'install Adobe Flash Plugin

Je pensais l'avoir enlevé, j'ai donc recommencé, mais ce n'est pas encore ça :

francis@xubuntu:~$ sudo apt-get remove --purge flashplugin-installer
[sudo] Mot de passe de francis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  flashplugin-installer*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 226437 fichiers et répertoires déjà installés.)
Suppression de flashplugin-installer (24.0.0.186ubuntu0.16.04.1) ...
Purge des fichiers de configuration de flashplugin-installer (24.0.0.186ubuntu0.16.04.1) ...
francis@xubuntu:~$ sudo apt-get install adobe-flashplugin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  adobe-flash-properties-gtk
Paquets suggérés :
  x-ttcidfont-conf msttcorefonts ttf-bitstream-vera | ttf-dejavu
  ttf-xfree86-nonfree xfs libnspr4-0d libnss3-1d
Les NOUVEAUX paquets suivants seront installés :
  adobe-flash-properties-gtk adobe-flashplugin
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/10,4 Mo dans les archives.
Après cette opération, 37,8 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 226439 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flashplugin (1:20161213.1-0ubuntu0.16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/icons/hicolor/32x32/apps/flash-player-properties.png », qui appartient aussi au paquet flash-plugin 11.2.202.644-1
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Préparation du dépaquetage de .../adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flash-properties-gtk (1:20161213.1-0ubuntu0.16.04.1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/share/applications/flash-player-properties.desktop », qui appartient aussi au paquet flash-plugin 11.2.202.644-1
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb
 /var/cache/apt/archives/adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
francis@xubuntu:~$ 

L'homme ne recherche pas La Vérité. Il n'est qu'avide de certitude ... [Cornélius Castoriadis]

~ Xubuntu 16.04 64 bits ~

Hors ligne

#4 Le 09/01/2017, à 01:10

abelthorne

Re : [Résolu] [16.04]Pb d'install Adobe Flash Plugin

Oups, j'avais mal lu, ce n'était pas flashplugin-installer (qui était déjà déinstallé ?) mais il est question d'un paquet flash-plugin (?). Qu'est-ce que ça donne si tu le supprimes ?

sudo apt-get install flash-plugin

Hors ligne

#5 Le 09/01/2017, à 22:18

fgi

Re : [Résolu] [16.04]Pb d'install Adobe Flash Plugin

francis@xubuntu:~$ sudo apt-get remove --purge flash-plugin
[sudo] Mot de passe de francis : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  flash-plugin*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 20,5 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 226437 fichiers et répertoires déjà installés.)
Suppression de flash-plugin (11.2.202.644-1) ...
dpkg : avertissement : lors de la suppression de flash-plugin, le répertoire « /usr/lib64 » n'était pas vide, donc il n'a pas été supprimé
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
francis@xubuntu:~$ sudo apt-get install adobe-flashplugin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  adobe-flash-properties-gtk
Paquets suggérés :
  x-ttcidfont-conf msttcorefonts ttf-bitstream-vera | ttf-dejavu ttf-xfree86-nonfree xfs libnspr4-0d libnss3-1d
Les NOUVEAUX paquets suivants seront installés :
  adobe-flash-properties-gtk adobe-flashplugin
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/10,4 Mo dans les archives.
Après cette opération, 37,8 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 226415 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../adobe-flashplugin_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flashplugin (1:20161213.1-0ubuntu0.16.04.1) ...
Préparation du dépaquetage de .../adobe-flash-properties-gtk_1%3a20161213.1-0ubuntu0.16.04.1_amd64.deb ...
Dépaquetage de adobe-flash-properties-gtk (1:20161213.1-0ubuntu0.16.04.1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.15-0ubuntu1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Paramétrage de adobe-flashplugin (1:20161213.1-0ubuntu0.16.04.1) ...
update-alternatives: utilisation de « /usr/lib/adobe-flashplugin/libflashplayer.so » pour fournir « /usr/lib/mozilla/plugins/flashplugin-alternative.so » (mozilla-flashplugin) en mode automatique
Paramétrage de adobe-flash-properties-gtk (1:20161213.1-0ubuntu0.16.04.1) ...
francis@xubuntu:~$ 

Et ça semble marcher : Deezer (qui ne sert de test) fonctionne sur Chromium et sur FF smile

Merci !

smile

Dernière modification par fgi (Le 09/01/2017, à 22:18)


L'homme ne recherche pas La Vérité. Il n'est qu'avide de certitude ... [Cornélius Castoriadis]

~ Xubuntu 16.04 64 bits ~

Hors ligne